Personal Toolbar Folder labels overflow the window borders

RESOLVED FIXED

Status

SeaMonkey
Themes
--
trivial
RESOLVED FIXED
16 years ago
9 years ago

People

(Reporter: Luciano Giustini, Assigned: Joe Hewitt (gone))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:0.9.7+) Gecko/20020124
BuildID:    

I noticed the labels of the Personal Toolbar Folder go above the window borders.

For example, consider the item "WebMail" that may show on the far right on the
window (tipical if you set some new items on the left)

[] WebMail
  ---------

Well, right part of the "WebMail" string will be "over" the border of the
Mozilla window . In Ascii it's difficult to render this concept, :) hope may be
comprensible. In case, I can send a gif to display it graphically.
--l.

Reproducible: Always
Steps to Reproduce:
1.Set some new PTF items on Personal Toolbar
2.You will notice that the right visible item goes onto the window border till
to the right limit of the display/monitor

Comment 1

16 years ago
I'm not seeing this, could you describe exactly how to reproduce it, and perhaps
include an image?

Comment 2

16 years ago
received private email showing this on classic skin only, ->themes
Assignee: trudelle → hewitt
Component: XP Apps → Themes
QA Contact: sairuh → pmac

Comment 3

16 years ago
Created attachment 74733 [details]
Illustration of personal toolbar text overflowing its container.

Comment 4

16 years ago
I attach an illustration of what I think is the same problem exhibited in Linux
(build 2002031008).  Notive that the letters of "AllTheWeb" oferflow the
personal tookbar and appear above the frame of the window.

This problem can be fixed by adding 

style="overflow:hidden" 

to 

hbox id="innermostBox"

in 

navigator.xul (which is not part of any theme in particular)?

Comment 5

16 years ago
Ok - a better fix is a minor change to toolbar.css in the classic theme.

Either drop the right-border style setting in the toolbox style or add the
overflow:hidden here.  The modern theme does not have a right border and it is
this right-border that is causing the problem with the overflowing text in the
classic theme (just set the right border to 10px and you'll see what I mean).

I know this may not appear to be an important bug, but it is the first one where
I have a suggested fix that :-).

Comment 6

16 years ago
"More haste less speed".

Remove right border from toolbox works and adding overflow:hidden to *toolbar*
(not toolbox !) works.

Comment 7

16 years ago
Reporter, are you still seeing this in Mozilla 1.0?

Comment 8

16 years ago
Problem is still visible in Moz 1.0 (Linux).

Comment 9

16 years ago
Thank you for your patience. Confirming on Mozilla 1.1 alpha, 2002060704,
Windows 98, classic skin.

The problem is that with the classic skin, fill up personal toolbar folder so it
overflows. Text and graphics in the folder overflows onto the window border.
Changing the window's horizontal size shows the problem as well.

The fix is easy. See comment 4 and comment 5.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla1.0.1, nsbeta1
Summary: Personal Toolbar Folder labels go above the window borders → Personal Toolbar Folder labels overflow the window borders

Comment 10

16 years ago
Nav triage team: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 11

15 years ago
*** Bug 150286 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
*** Bug 136159 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
Informations from duped bug 136159:
- Also seen on Linux, so: Platform/OS = All/All
- Seems to occur also with Modern theme, only less visible because of the
different borders.
- timeless changed its component to Bookmarks: "it's a XUL bug" (don't know if
that's appropriate)

Comment 14

15 years ago
Geraint wrote in a personal e-mail that his solution does not work anymore.

I did some further investigation and found that adding:

.toolbar-holder {
  overflow: auto !important;
}

to userChrome.css fixes this bug on Classic and Modern (yes, it *is* also a bug
on Modern, see screenshot in bug 136159). Adding the overflow-value to any other
element in the hierarchy (toolbar, toolbox, toolbarbutton, bookmark-item) does
not work, adding "-moz-scrollbars-none" instead of "auto" *does* work.

I have no idea why "overflow:hidden" does not work, but "auto". Maybe some CSS
guru can help me with this question. I searched bugzilla quite a while for
possible "overflow"-bugs, but found none:
bug 109927, bug 151351, bug 47710 and bug 158633 sound close, but they cannot be
the cause.
It's still not clear to me at which level something overflows...

While this can fix it, the underlying problem might be something different: bug
120702 is about the same problem in the sidebar. It is not fixed by my CSS rule;
however, that does not necessarily mean that it has another root. Maybe timeless
was right with his reassignment of duplicate bug 136159 to Bookmarks, saying it
was a XUL bug.
The question is if fixing it via CSS is also ok.
I'm also not sure if "auto" is a good way: I don't like the idea of scrollbars
suddenly appearing in the toolbar...

-> all/all and ->trivial
Severity: normal → trivial
OS: Windows ME → All
Hardware: PC → All

Comment 15

15 years ago
#PersonalToolbar > .toolbar-holder {
  overflow: auto !important;
}  

Would be a better solution for userChrome.css since the previous one affects all
Toolbars, which leads to scrollbars in chatzilla windows' channel topic pane
when a channel has a quite long topic.
So only the personal toolbar is affected by this rule. The main question stays
the same: WHY AUTO???

Comment 16

15 years ago
*** Bug 192528 has been marked as a duplicate of this bug. ***

Comment 17

15 years ago
*** Bug 194900 has been marked as a duplicate of this bug. ***

Comment 18

15 years ago
This has been fixed a few hours ago by bug 66919.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED

Comment 19

15 years ago
http://bugzilla.mozilla.org/show_bug.cgi?id=192528 was marked as a duplicate of
this bug (which, at the time, I didn't really think it was a dup, but I just
kept my mouth shut as I didnt know if there would prove to be some subtle
connection). This fix has not affected 192528 - should that bug now be reopened?
Thx.
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.