Open Bug 1339439 Opened 6 years ago Updated 2 years ago

Device permission prompts overlay other programs opened on Linux

Categories

(Firefox :: Site Permissions, defect, P3)

Unspecified
Linux
defect

Tracking

()

REOPENED
Tracking Status
firefox52 --- unaffected
firefox-esr68 --- wontfix
firefox53 --- wontfix
firefox54 --- wontfix
firefox55 --- wontfix
firefox72 --- wontfix
firefox73 --- wontfix
firefox74 --- wontfix
firefox75 --- wontfix
firefox76 --- fix-optional

People

(Reporter: hani.yacoub, Unassigned)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: regression)

Attachments

(1 file)

[Affected versions]: 
Nightly 54.0a1, Nightly 53.0a1

[Affected platforms]:
All platforms: Ubuntu 16.04 x64

[Steps to reproduce]:
1. Go to https://mozilla.github.io/webrtc-landing/gum_test.html and click on "Screen".
2. Open another program or a folder.
3. Minimize it and drag it to the device permission.

[Expected result]:
Device permission pop-up shouldn't overlay other programs opened.

[Actual result]:
Device permission overlay other programs opened.
Attached image overlay.png
Sounds like a dupe of bug 1320361
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320361
Actually, even though there's probably no extra work required once bug 1320361 is solved, I'd like to un-dupe this and make it dependent on that bug, because the other bug is a bit too concerned with the technical details and we should track this important issue.

All this is in the end depending on bug 545265, but I don't really have high hopes for that one. :(
Status: RESOLVED → REOPENED
Depends on: 1320361
Resolution: DUPLICATE → ---
Summary: Device permission overlay other programs opened → Device permission overlay other programs opened on Linux
Summary: Device permission overlay other programs opened on Linux → Device permission prompts overlay other programs opened on Linux
Duplicate of this bug: 1373255
Duplicate of this bug: 1411135
Duplicate of this bug: 1413726
Duplicate of this bug: 1410830
See Also: → 1412846
Duplicate of this bug: 1501242
Component: Site Identity → Site Permissions
Duplicate of this bug: 1599204

Hi,

I was able to reproduce this issue on Ubuntu 18 with Firefox version Nightly 76.0a1 (2020-03-16) (64-bit). Marking that flag as affected.

Version: 54 Branch → Trunk

Bugbug thinks this bug is a regression, but please revert this change in case of error.

Keywords: regression
Duplicate of this bug: 1686171
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.