Device permission prompts overlay other programs opened on Linux

REOPENED
Unassigned

Status

()

P3
normal
REOPENED
2 years ago
21 days ago

People

(Reporter: hani.yacoub, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

54 Branch
Unspecified
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox52 unaffected, firefox53 fix-optional, firefox54 fix-optional, firefox55 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
[Affected versions]: 
Nightly 54.0a1, Nightly 53.0a1

[Affected platforms]:
All platforms: Ubuntu 16.04 x64

[Steps to reproduce]:
1. Go to https://mozilla.github.io/webrtc-landing/gum_test.html and click on "Screen".
2. Open another program or a folder.
3. Minimize it and drag it to the device permission.

[Expected result]:
Device permission pop-up shouldn't overlay other programs opened.

[Actual result]:
Device permission overlay other programs opened.
(Reporter)

Updated

2 years ago
Blocks: 1188147
status-firefox53: --- → affected
(Reporter)

Comment 1

2 years ago
Created attachment 8839405 [details]
overlay.png
Sounds like a dupe of bug 1320361
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1320361
Actually, even though there's probably no extra work required once bug 1320361 is solved, I'd like to un-dupe this and make it dependent on that bug, because the other bug is a bit too concerned with the technical details and we should track this important issue.

All this is in the end depending on bug 545265, but I don't really have high hopes for that one. :(
Status: RESOLVED → REOPENED
status-firefox52: --- → unaffected
status-firefox53: affected → fix-optional
status-firefox55: --- → affected
Depends on: 1320361
Resolution: DUPLICATE → ---
Summary: Device permission overlay other programs opened → Device permission overlay other programs opened on Linux
Summary: Device permission overlay other programs opened on Linux → Device permission prompts overlay other programs opened on Linux
status-firefox54: affected → fix-optional
Priority: -- → P3
Duplicate of this bug: 1373255
Duplicate of this bug: 1411135
Duplicate of this bug: 1413726
Duplicate of this bug: 1410830
See Also: → bug 1412846
Duplicate of this bug: 1501242
You need to log in before you can comment on or make changes to this bug.