Clicking on a Combobox sends a modal dialog behind its parent window.

RESOLVED FIXED in mozilla1.0

Status

()

--
major
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: kinmoz, Assigned: danm.moz)

Tracking

({regression})

Trunk
mozilla1.0
x86
Windows NT
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt1])

(Reporter)

Description

17 years ago
If you pulldown the menu of a combobox (select) in a modal dialog, the dialog is
placed behind it's parent window, after the menu displays itself. If the dialog
is directly over the parent window, this gives the appearance that the dialog
disappeared.

I'm seeing this in my Win32 Trunk debug build from today, but I think it's been
a problem for at least a couple of days.

Some examples of this problem can be seen in Composer by bringing up the dialogs
from these menu items:

    Edit -> Check Spelling
    Insert -> Link
    Insert -> Table
(Reporter)

Updated

17 years ago
Keywords: mozilla1.0, nsbeta1, regression

Comment 1

17 years ago
I can't reproduce this on win2k with either this morning's commercial build or 
with my own trunk cvs build, for any of Insert->Link, Insert->Table, 
Edit->Check Spelling (or in the Fill Form dialog of wallet which was mentioned 
in another bug). Tested with classic and modern skins.

But, obviously it's happening to kin (and the wallet bug reporter). So what's 
the missing piece of config info.

Comment 2

17 years ago
I was seeing this problem in builds during the past 2 days, but I don't in my
debug build today.

Comment 3

17 years ago
another example is in Publish tab for publishing, pulling down 
a sitename causes this problem as well..

Charley and I saw this yesterday.

Comment 4

17 years ago
*** Bug 135519 has been marked as a duplicate of this bug. ***

Comment 5

17 years ago
The Mail compose window is affected by this too.  This is bad regression and
very annoying to have the Compose window go to the back as soon as you start
typing in the addressing pane.  Sometimes it will have added an address that you
didn't want just because you clicked at the time the autocomplete list was
coming up.  Marking 135195 as  dup of this and adding putterman & gayatri to cc
list.

Comment 6

17 years ago
*** Bug 135195 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
Marking nsbeta1+ and adt1 on behalf of the ADT.  I'm about to mark a couple of
mail bugs as dups of this as well.
Keywords: nsbeta1 → nsbeta1+
Whiteboard: [adt1]

Comment 8

17 years ago
*** Bug 135047 has been marked as a duplicate of this bug. ***

Comment 9

17 years ago
*** Bug 134968 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Severity: normal → major

Comment 10

17 years ago
*** Bug 135742 has been marked as a duplicate of this bug. ***

Comment 11

17 years ago
any ETA on this?  I'm starting to see a lot of dups.

Comment 12

17 years ago
marking mozilla1.0+. We really need to get this for 1.0 and if the fix is large
then we need to get it into RC1 (next week).  
Keywords: mozilla1.0 → mozilla1.0+

Comment 13

17 years ago
*** Bug 135556 has been marked as a duplicate of this bug. ***

Comment 14

17 years ago
*** Bug 135652 has been marked as a duplicate of this bug. ***

Comment 15

17 years ago
I can't reproduce this on my win32 (win2k) system (kin and I don't know why my 
system would be unaffected while others are). 

Can someone who can reproduce this bug take the time to go back back through 
prior builds and figure out when this bug began to appear. It would go a long 
way towards getting this bug resolved quickly if we can determine which 
checkin(s) resulted in this bug.

Comment 16

17 years ago
John,
for my duped bug, bug 135047, I saw this problem
only in Mail/Newsgroup Account settings pref panel with any
combo box(drop down menu list). And even then only
on 98 or Win NT 4.0. Worked fine on 2k for me.

I regressed back and for my paticular bug using commercial builds:
2002-03-28-10-trunk/  Thu Mar 28 11:31:00 2002 was Ok
2002-03-29-18-trunk/ Fri Mar 29 20:09:00 2002 was when I saw my problem

I didn't try the 2002-03-28-06-trunk/ due to the numerous problems
with that build.

I installed the 2002-03-29-18-trunk on win 2k and I don't see my problem
But on NT 4.0, i do. Hope this helps.

Comment 17

17 years ago
esther will go through her scenario in comment 5 to find the build date that
this started with.

She tells me that putterman cannot see this problem on his system either.  It is
strange.

Comment 18

17 years ago
Let's look at checkins from around 3-28 to 3-29 to see if anything in this
particular area was checked in and which bug it was for.  That may help in
determining the fix needed to get this high profile bug addressed.

Comment 19

17 years ago
I just got duped to this by the mail filter dialog.  Adding a new mail filter
and clicking on anyof the combo boxes causes this behavior where the rest of the
box disappears.

Comment 20

17 years ago
confirmed for mail compose window:
this was not broke with the 2002032810
couldn't test it with 2002032906 build, couldn't open mail folders
broke with with the 2002032918 build.  

Comment 21

17 years ago
doing a cvs query for the timeframes, hewitt looks like a good possibility...

hewitt--should this be your bug?

Comment 23

17 years ago
I've put two builds at http://jrgm.mcom.com/temp/ as 'win32-brand-X.zip' and
'win32-brand-Y.zip' which differ by one checkin. Can people who have systems 
that reproduce this bug download them and see if they have different behaviour
w.r.t this bug.

Sorry #1: that is an internal link and I don't have a place to make those 
publicly available because ... Sorry #2: those are MOZ_PROFILE builds, so they 
are about 117MB each in uncompressed size :-/.

Comment 24

17 years ago
For my particular problem (bug 135047) testing on NT 4.0:
 win32-brand-X.zip - still see the problem
 win32-brand-Y.zip - problem is gone. works as expected

Comment 25

17 years ago
*** Bug 134855 has been marked as a duplicate of this bug. ***

Comment 26

17 years ago
Okay, so 'brand-X' is with rev 3.409 of widget/src/windows/nsWindow.cpp in the 
tree, and 'brand-Y' is with it reverted.

-> danm

see also bug 134317
Assignee: jaggernaut → danm

Comment 27

17 years ago
Note that right-clicking to bring out a context menu (on textfields for example)
also sends it behind the parent window. (Bookmark properties demonstrate this
behaviour). So the summary needs some updating.

Comment 28

17 years ago
*** Bug 135650 has been marked as a duplicate of this bug. ***

Comment 29

17 years ago
*** Bug 135649 has been marked as a duplicate of this bug. ***

Comment 30

17 years ago
*** Bug 135093 has been marked as a duplicate of this bug. ***

Comment 31

17 years ago
The "Open Web Location" window (CTRL+SHIFT+L) is affected as well.

Comment 32

17 years ago
*** Bug 136147 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Summary: Clicking on a Combobox sends a modal dialog behind it's parent window. → Clicking on a Combobox sends a modal dialog behind its parent window.
Target Milestone: --- → mozilla1.0

Comment 33

17 years ago
can't ship RC1 with this.
Blocks: 134771

Updated

17 years ago
Blocks: 136384
This bug was most likely caused by the check in to fix:
bug 120155 - See attachment 75659 [details] [diff] [review].
(Assignee)

Comment 35

17 years ago
backed out fix for bug 120155. this will go away now.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 36

17 years ago
*** Bug 136547 has been marked as a duplicate of this bug. ***

Comment 37

17 years ago
adding branch resolution keyword. 
04/09/2002 21:36danm%netscape.com mozilla/ widget/ src/ windows/ nsWindow.cpp
3.410.2.2 MOZILLA_1_0_0_BRANCH  3/2
Keywords: fixed1.0.0
You need to log in before you can comment on or make changes to this bug.