[DOGFOOD] popups not working in modal dialogs (comboboxes, colorpicker)

VERIFIED FIXED in M12

Status

()

defect
P1
blocker
VERIFIED FIXED
20 years ago
20 years ago

People

(Reporter: mcafee, Assigned: blizzard)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

linux, apprunner.
Edit|Preferences|Colors
comboboxes post Ok but you can't select any colors.
This works on Win95 Ok.
OS: other → Linux
Hardware: Sun → PC
Assignee: pavlov → danm
popups don't work in modal dialogs.  reassigning to danm
QA Contact: beppe → claudius
Ahah! Here is this bug! I've been looking for this.
On Linux and mac, you cannot select items in combo boxes in modal dialogs.

This is preventing mail from being even the slightest bit usable on these
platforms. Upgrading to blocker, dogfood, pp
adding trudelle to CC for some traction.
possibly a dupe of #15476?
Whiteboard: [PDT+]
Priority: P3 → P1
Target Milestone: M11
targetting m11, P1.
*** Bug 17035 has been marked as a duplicate of this bug. ***
*** Bug 17036 has been marked as a duplicate of this bug. ***
OS: Linux → All
Summary: [DOGFOOD][PP]Linux: popups not working in modal dialogs (combo boxes and colorpicker) → [DOGFOOD] popups not working in modal dialogs (combo boxes and colorpicker)
this isn't working for me on windows nt either.

removing the PP and changing platform to all.
Hardware: PC → All
Summary: [DOGFOOD] popups not working in modal dialogs (combo boxes and colorpicker) → [DOGFOOD] popups not working in modal dialogs (comboboxes, colorpicker)
shorter title
*** Bug 17737 has been marked as a duplicate of this bug. ***
as of 1999110108 builds this works on WinNT
but not on MacOS 8.5 or Linux RH6. This blocks the use of several preferences as well.
Blocks: 17907
is there ANY progress on this at all?
This is rediculous. Mac users have not been able to create IMAP or News servers,
and Linux users now can't even use the keyboard either.
A workaround might be to un-modalize the pref dialog,
I can make this a pref if we can't fix modal stuff
fast enough.
Status: NEW → ASSIGNED
Blocks: 15476
this is blocking other things besides the pref dialog
*** Bug 17477 has been marked as a duplicate of this bug. ***
Blocks: 18471
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
particial fix applied to m11 branch by danm.  marking fixed so it falls
on the testing radar.

Regarding bug  Bugzilla bug 14131 , I have a partial fix that I'd like to put on
the branch. This is all I want to do for the branch: I'm still
investigating a real fix for the trunk. (But even when I find one,  I'd like to
leave M11 with just the fix I'm proposing.)

It's a code change which will be included in the full fix. Current behaviour
goes like this:

Windows: popups in modal dialogs work fine (except that for some kinds of popup,
like the color picker, you can't actually make a selection,
probably because of  Bugzilla bug 17851 . But that's the worst that happens.)

Mac: popups in modal dialogs go mouse-dead: you can dismiss them by clicking
outside the popup, but you can't make a selection using the
mouse. I can't double-check this right now because my Mac will be in build hell
for several hours more, but I believe you can select using the
keyboard. But only for comboboxes. The color picker is useless, though not
dangerous.

Linux: if you're foolish enough to bring up a popup in a modal dialog, your
whole UI goes mouse-dead. You must log in from another terminal
and kill the process to regain control.

I propose a gtk-specific M11 checkin that will bring it into line with the Mac:
popups are useless to the mouse yet navigable using the
keyboard, and not dangerous. It's safe; I've checked both possible paths to the
affected code and found no worries.
Status: RESOLVED → REOPENED
It is dangerous to mark partial fixes as "fixed".
If you want to put it on the testing radar, send mail.
Reopening.  If partial-fix gets us past m11-status, then
mark this m12.
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.  All agreed - move to M12?
Target Milestone: M11 → M12
targetting m12
Status: REOPENED → ASSIGNED
Whiteboard: [PDT+] → [PDT+] workable, somewhat clunky fix ready for review then checkin
*** Bug 15476 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Whiteboard: [PDT+] workable, somewhat clunky fix ready for review then checkin → [PDT+]
Hey, how has this been RESOLVED FIXED? Has just the partial fix been checked in?
If so, like mcafee says, that's not a permanent fix -- so you should leave the
bug open. Put its priority and/or severity down, if necessary.
Status: RESOLVED → REOPENED
reopening, looking for why-this-is-fixed comment so we
don't let this one slip out of our hands...
Resolution: FIXED → ---
Clearing FIXED resolution due to reopen.
Mail&News: This has gotten worse in the last m11 windows build (using NT 4.0):
When using the account settings dialog to set up new accounts, the server type
is no longer selectable (or so it appears -- it actually selects the correct
type of server, but doesn't reflect it in the widget) and the workaround (ref
bug #15476) to use the arrow keys to select doesn't work at all.  This was not
the case in the past several m11 builds.
Response from mailnews: It's out of our hands now, this is toolkit bug that has
been open for 4 weeks. M11 is thus unusable for mail now on Linux and mac.
Wonderful.
Status: REOPENED → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
Made gtk case much more complicated to handle popup control windows on top of a *stack* of modal dialogs,
as happens in the case mentioned by Laurel just above. Not a problem on Windows or Mac. Other platforms will,
unfortunately, need to find their own solutions.
thanks dan, today's build seems to be working pretty well for me.
Status: RESOLVED → VERIFIED
Looks good to me. i checked the color-picker, not all of the mail/news
ramifications. marking VERIFIED with 1999111708 builds.
Sorry to be such a nuisance, but it hasn't been made clear: has a permanent
solution for this bug been donated by someone, for all platforms; or has just
danm's partial fix been checked in?
Status: VERIFIED → REOPENED
guess what, it's broken again.
Resolution: FIXED → ---
I should add that I noticed this on friday of last week (11/19) and thought
maybe it was just my build...but it wasn't.
I think blizzard is testing a fix for this, linux/gtk
Status: REOPENED → ASSIGNED
I do have a fix for this.  I don't have a place to check it in, though.  akkana
+ mcafee have a copy of it, though.  It looked ok to me, akkana had a suggestion
that I agreed might be good to implement but it should work as is.
*** Bug 19287 has been marked as a duplicate of this bug. ***
Assignee: danm → blizzard
Status: ASSIGNED → NEW
Fix checked in.
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
Resolution: --- → FIXED
fix in?  marking fixed!
*** Bug 19994 has been marked as a duplicate of this bug. ***
Status: RESOLVED → VERIFIED
I am very tentatively marking this bug as VERIFIED. I've checked on all paltforms
with the 1999112909 builds. I've looked at the color picker, prefs panels, mail account setup
and the addressbook. There are/were several dupes so I checked those testcases too.
I hesitate because the html:select in the addressbook isn't working properly, but only there.
If anyone thinks otherwise don't hesitate to reopen.
we should file a separate bug for the address book problem.
mail/news QA will take care of filing the bugs on the address book for this.
Thanks.
FYI: Build 1999112909M12: NT4, Linux, Mac
Selection (using the mouse or arrow keys) for IMAP, POP, and News holds in the
Account Wizard.
Huh?  What does "holds" mean?
Linux Redhat 6.0 (1999-12-01-09 M12)
Win_nt 4.0 (1999-12-01-09 M12)
Mac (1999-12-01-08 M12)
Yes. The selection for copies and folders holds in the Account Setup. To check
this, i did the following steps
1. From Messenger, I select Edit|Account Setup and select my account.
2. Select Copies and Folders from my account
3. Place a check on the "Place a copy in" text area and select a folder. (folder
named Mark).
4. click OK to close the Account Setup.
5. Now send a message out to any account.
6. Go to the folder named Mark. It does place a copy in the folder that I
selected in step 3.
This is in response to the question "What does 'holds' mean?"

Sorry if my statement was confusing or appeared to be a problem. Everything
is working as expected.

Using the Account Wizard, on the Server Information dialog, I can see and select
POP, IMAP or News for the Server Type. This can be done using the mouse or the
arrow keys. Once I've made the selection then the Server Type combo box reflects
the selection I made. This is what I meant by the term "holds" which was meant
to be a good thing.
Please ignore the spam.  Changing address.
Assignee: blizzard → blizzard
Status: VERIFIED → NEW
busted when I reassigned
Status: NEW → RESOLVED
Closed: 20 years ago20 years ago
busted when I reassigned
Status: RESOLVED → VERIFIED
No longer blocks: 17907
No longer blocks: 18471
You need to log in before you can comment on or make changes to this bug.