No scroll bar on Attachmets window and the first attachment disappear

VERIFIED DUPLICATE of bug 122180

Status

MailNews Core
Attachments
--
major
VERIFIED DUPLICATE of bug 122180
16 years ago
10 years ago

People

(Reporter: Pedro Fernando, Assigned: Yuedong Du)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [need info])

Attachments

(5 attachments)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.0rc2) Gecko/20020510
BuildID:    2002051006

When I recieve an email with three files attached, in the attachement window, I
am only abled to see the two first and the top of the thirth, no scloll bar
appear. (Figure1)

When I select first, and go down with the down key, the first file disappear.
(Figure2)

When I see an email with more than three files attached, and go back to the
first message, the scroll bars appears. (Figure3)

Reproducible: Always
Steps to Reproduce:
1.Recieve an email with three files attached (any files).
2.Close mail window.
3.Open mail window
4.Look this email first.

Actual Results:  No scrollbar appear in the Attachment window
(Reporter)

Comment 1

16 years ago
Created attachment 83884 [details]
Figure1 (No scrollbar in Attachment window
(Reporter)

Comment 2

16 years ago
Created attachment 83885 [details]
Figure 2 (First attached file disappear)
(Reporter)

Comment 3

16 years ago
Created attachment 83886 [details]
Figure 3 (And now scroll bar appear)
Confirmed on Win2k/2002051406.
->NEW
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

16 years ago
*** Bug 150427 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
*** Bug 138574 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

16 years ago
The bug is so common and very bad. Upgrade to normal.
Severity: trivial → normal
(Assignee)

Comment 8

16 years ago
reassign to self
Assignee: mscott → yuedong.du
(Reporter)

Updated

16 years ago
Summary: No scroll bar on Attachmets window and the firs attachment disappear → No scroll bar on Attachmets window and the first attachment disappear

Comment 9

16 years ago
Comment out the line below in msghdrviewoverlay.js, thus remove the icon in
attachment.
function displayAttachmentsForExpandedView()
{
   ... ...
   setApplicationIconForAttachment(attachment, item);
}

So maybe the problem is related to icon's size.


(Assignee)

Comment 10

16 years ago
A intereting find: 
1. When view the message with problem, first time we fail to scoll out the last
element. But if now  switch to another email, view it. 
2 Then switch back to view the message with attachment.
3. The last attachment can be scroll out!!!

Seems something do not initialized properly the first time. Any idea?
(Assignee)

Comment 11

16 years ago
See the code about scroll below, the function is called when you click the
scroll bar,

NS_IMETHODIMP nsScrollPortView::ScrollTo(nscoord aX, nscoord aY, PRUint32
aUpdateFlags)
{
        ... ... ...
 	nsView* scrolledView = GetScrolledView();

	if (!scrolledView) return NS_ERROR_FAILURE;
	scrolledView->GetDimensions(scrolledSize);
        ... ... ...   
}

After view another message, the returned scrolledSize is changed! Do not know why.

Comment 12

16 years ago
*** Bug 160812 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
I didn't have a scroll bar in the attachment window too
but no pieces disappeared when I scrooled the window
with the 'up' and 'down' keys.

Updated

16 years ago
QA Contact: trix → yulian

Comment 14

16 years ago
*** Bug 140012 has been marked as a duplicate of this bug. ***
QA Contact: yulian → stephend
I see this as well with build 2003-01-09-08, Windows 2000.  Nominating for Buffy.
Severity: normal → major
Keywords: nsbeta1

Comment 16

16 years ago
Created attachment 112377 [details]
Scrollbar at the bottom

Comment 17

16 years ago
Probably related, I have a message with 4 attachments. The scrollbar doesn't
permit to reach the last one.
See figure 4.

Comment 18

15 years ago
Trunk build 2003-01-05: WinMe, Win2k
I've attached up to 6 files to a message and the scrollbar in the attachment box
always appear. 

Reporter: What happens in a more recent build. Does this occur in existing
profiles only? What happens in a new profile?

Comment 19

15 years ago
Using trunk build 20030205 on winxp and linux in both modern and classic themes
I can't reproduce this either.   I have 6 attachments, scrolling up and down in
the attachment area is OK.  I also opened a stand alone mail window and the
attachment window is OK in that window too.  What are we missing in trying to
reproduce this.
(Reporter)

Comment 20

15 years ago
It seems that now works, but there is still a small thing:

1. Receive an email with for example 6 files attached
2. Close and open the email window
3. Select this email the first
4. Click on the attachmet window (don't use scroll bars)
5. Click on the down keyboard button
6. When you reach the last attachment, the one at the top disappear
7. If you go up again it will appear again

Not critical, but why this happen?
winXp 20021130 

Comment 21

15 years ago
are bug 182585 (and bug 187980 and bug 188928) dups of this?

Comment 22

15 years ago
to reproduce: see http://bugzilla.mozilla.org/show_bug.cgi?id=138574#c4
The screenshot in bug 188928, attachment 111410 [details], tells the same story.

Comment 23

15 years ago
*** Bug 192719 has been marked as a duplicate of this bug. ***

Comment 24

15 years ago
*** Bug 182585 has been marked as a duplicate of this bug. ***

Comment 25

15 years ago
*** Bug 193127 has been marked as a duplicate of this bug. ***
Mail Triage Team: need info
Whiteboard: [need info]

Comment 27

15 years ago
Created attachment 114664 [details]
Picture 5: last attachment completely invisible

Sometimes the last mail-attachment is completely invisible,
and there is no scrollbar.
See Picture 5: 3 attachments, but only 2 are visible.

Comment 28

15 years ago
I use Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210.
I use 'large fonts' 120 dpi.

Comment 29

15 years ago
*** Bug 142483 has been marked as a duplicate of this bug. ***

Comment 30

15 years ago
Testing on Mozilla 1.3b under Win98SE:

No scroll bar and disappearing first attachement happens here ONLY with EXACTLY
3 attachments. In the preview pane ONLY the first time a 3-attachment message is
previewed, but ALWAYS in a full-message window when such message is displayed.
Icon/font size settings in windows do not affect this behavior for me as someone
has suggested. Hope this helps.
This is looking fine for me so far with 3 attachments, and more than 3
attachments, on the trunk 2003-03-12-04 build on Windows XP (IMAP).

Comment 32

15 years ago
Does not work in Mozilla 1.4b under Win XP (but changed a bit)

This does not work now:
Attachment window has space for 2 attachments. The mail contains
4 attachment: I get a scrollbar, but I can scoll only to the first
3 attachments. The last attachment is completely invisible and 
unreachable.

This works now (did not work before):
Attachment window has space for 2 attachments. The mail contains
3 attachments: Now I get a scrollbar and can reach all 3 attachments.

The first attachment does not disappear any more.

Updated

15 years ago
Depends on: 195355

Comment 33

15 years ago
adt: nsbeta1-
Keywords: nsbeta1 → nsbeta1-

Comment 34

15 years ago
Correction to comment #32:

The last attachment is always invisible und unreachable, no matter if
there are 3 or 4 (or more).

This is always true for a message in an new window.
In the preview pane, it is only true for the first time. If I visit a
message a second time, I can see all attachments.

*** This bug has been marked as a duplicate of 122180 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 36

15 years ago
v
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.