Closed Bug 1471687 (remove-arc) Opened 3 years ago Closed 3 months ago

Remove local dependency on Arcanist from new Phabricator command-line app

Categories

(Conduit :: moz-phab, enhancement, P2)

Production
enhancement

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: mcote, Assigned: zeid)

References

(Depends on 1 open bug, Blocks 2 open bugs)

Details

(Keywords: conduit-triaged)

Attachments

(4 files)

A better solution for commit-series support in Phabricator, once we have finished bug 1471678, is to write a command-line app that does not require Arcanist.  Rather, it will transmit all relevant information to a remote server, which will itself wrap Arcanist (continue to use Arcanist underneath lessens the chance of a Phabricator upgrade breaking our functionality).  The main benefit here is that users will no longer require a local Arcanist installation.  We can also do away with the git-cinnabar fork of Arcanist, as the client or server could do the commit-hash translations before invoking Arcanist.
Assignee: nobody → glob
Assignee: glob → nobody
This bug is still relevant and part of the moz-phab performance-improvement plan (https://docs.google.com/document/d/14v33dMrAvs9KlhYVdbN7yYqJpubs8XFpnrDlsZTPBW0/edit#); however, we will be simplifying this and not using a separate server-side component.  moz-phab will instead talk directly to Phabricator via Conduit APIs (extending them if necessary).
Duplicate of this bug: 1515125
Component: Phabricator → Review Wrapper
Blocks: 1517247
Keywords: conduit-story
Priority: -- → P2
Depends on: 1537990
Blocks: 1494697
Assignee: nobody → pzalewa
Duplicate of this bug: 1498171
Depends on: 1555267
Depends on: 1555269
Depends on: 1555270
Depends on: 1576603
Blocks: 1594496
Duplicate of this bug: 1600601
Depends on: 1600696
Depends on: 1646060
Depends on: 1646831
Severity: normal → S1
Assignee: pzalewa → nobody
Depends on: 1675648, 1639564, 1674310
Depends on: 1676540
Severity: S1 → --
Depends on: 1697160
Alias: remove-arc

WIP, DO NOT MERGE.

  • remove --no-arc configuration flag and support
  • remove tests that test with --no-arc
  • do not checkout revisions when submitting patches
Attachment #9221355 - Attachment description: WIP: Bug 1471687: remove arcanist support → WIP: Bug 1471687: Remove arcanist support
Assignee: nobody → zeid
Attachment #9221355 - Attachment description: WIP: Bug 1471687: Remove arcanist support → Bug 1471687: Remove arcanist support r=sheehan,dkl
Status: NEW → ASSIGNED
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.