Closed Bug 1552007 Opened 3 months ago Closed Last month

[meta] Support mc-only workflow for local development of newtab component

Categories

(Firefox :: Messaging System, task, P1)

task

Tracking

()

RESOLVED FIXED
Firefox 69

People

(Reporter: k88hudson, Unassigned)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

(Keywords: meta)

In order to support other teams being able to more easily work on newtab component code, we'd like to support a workflow that allows us to build, run, lint and test all code without the use of our GitHub repository.

The intention for the scope of this group of bugs is not to replace the Github workflow or completely replicate it, but rather to make it optional. This means being able to:

  • change source files and build code (npm run bundle)
  • import locale changes from pontoon (npm run strings-import)
  • run and debug unit tests (npm test)
  • catch any linting errors with ./mach lint
  • look up our the development workflow in Mozilla central docs
Type: defect → task
Keywords: meta
Depends on: 1552009
Depends on: 1552011

(moved comment to top)

Summary: Support mc-only workflow for newtab component → [meta] Support mc-only workflow for newtab component
Depends on: 1552013
Blocks: bugzy-epic
No longer blocks: 1433315
Priority: -- → P1
Depends on: 1553375
Depends on: 1553917
Depends on: 1553919
Depends on: 1553926
Depends on: 1553931
No longer blocks: bugzy-epic
Summary: [meta] Support mc-only workflow for newtab component → [meta] Support mc-only workflow for local development of newtab component
No longer depends on: 1553375
Depends on: 1559479
Component: Activity Streams: Newtab → Messaging System
Duplicate of this bug: as-mc
Status: NEW → RESOLVED
Closed: Last month
Resolution: --- → FIXED
Target Milestone: --- → Firefox 69
No longer depends on: 1553931
Depends on: 1572515
You need to log in before you can comment on or make changes to this bug.