Closed Bug 1558982 Opened 2 years ago Closed 2 months ago

[meta] Remove XUL about:addons

Categories

(Toolkit :: Add-ons Manager, task, P2)

task

Tracking

()

RESOLVED FIXED
Tracking Status
firefox75 --- wontfix
firefox76 --- fixed
firefox77 --- fixed

People

(Reporter: robwu, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: meta)

When the whole about:addons is fully HTML, we can rip out the XUL parts and the tests.

See Also: → 1558109

I'm not sure we need to wait until everything has been converted. Once we're sure we won't be using the old views, we can rip out a bunch of xbl even if extensions.xul is still lingering around.

No longer depends on: 1559392
Priority: -- → P2
Depends on: 1337627
Blocks: 1565606
No longer blocks: 1555361
Depends on: 1569669
No longer blocks: war-on-xbl
No longer blocks: burn-xul-grids
Duplicate of this bug: 1625007
Depends on: 1674890
Depends on: 1525179
No longer depends on: 1569669
Depends on: 1676292
Depends on: 1677571
No longer depends on: 1674890
Depends on: 1678173

Completed by bug 1525179.

Status: NEW → RESOLVED
Closed: 2 months ago
Keywords: meta
Resolution: --- → FIXED
Summary: Remove XUL about:addons → [meta] Remove XUL about:addons
You need to log in before you can comment on or make changes to this bug.