Closed Bug 1564808 Opened 2 months ago Closed 2 months ago

Unable to drag and drop images or URLs from browser to desktop when running Windows as Administrator with UAC disabled

Categories

(Firefox :: General, defect)

68 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
relnote-firefox --- 68+

People

(Reporter: callahad, Unassigned)

References

Details

A user on Twitter reports that Firefox 68 "just killed drag and drop images from browser to desktop. No longer works."

The user is on 64-bit Windows 7 Pro.

I do not have a Win7 box available to attempt to reproduce this bug.

See Also: → 1563681

Same here. Drag and drop does not work at all in Firefox 68 on Windows 10 64-bit, whether it's images or URLs. Cursor immediately turns into "not allowed" as soon as I try dragging anything. Tried this on a brand new profile and with WebRender disabled (out of troubleshooting curiosity) and it's still broken. Worked fine in 67.

(In reply to gracz542 from comment #1)

Same here. Drag and drop does not work at all in Firefox 68 on Windows 10 64-bit, whether it's images or URLs. Cursor immediately turns into "not allowed" as soon as I try dragging anything. Tried this on a brand new profile and with WebRender disabled (out of troubleshooting curiosity) and it's still broken. Worked fine in 67.

Update: I tried downgrading to 67, and now it still doesn't work for some reason. Not even on a new profile.

Some related reports on forums. Safe mode and new profile not helpful. Save Image As still works.

Are there particular issues to ask users about?

This has now fixed itself for me. No clue what could have caused it or fixed it, but everything seems fine again.

Another affected user reported no longer being able to drag from the site info area to the desktop to create a shortcut. Is there any obvious connection?

https://support.mozilla.org/questions/1264292#answer-1236353

I am willing to bet that all of these users are running Windows as Administrator with UAC disabled.

This is a security feature that we tested in 67 and released at 100% in 68. Please see this SUMO article for more information.

Status: UNCONFIRMED → RESOLVED
Closed: 2 months ago
Component: Untriaged → General
Resolution: --- → WONTFIX

Release Note Request
[Why is this notable]: The issue is coming up a couple of times in support channels after the 68 release and we already have a sumo article explaining workarounds, so it might be helpful adding this as a known issue to the release notes.
[Affects Firefox for Android]: no
[Suggested wording]: Windows administrator users with UAC turned off may no longer be able to drag content out of Firefox. To learn more and how to fix this see <sumo article>
[Links (documentation, blog post, etc)]: https://support.mozilla.org/kb/windows-administrator-launcher-process-error-fix

relnote-firefox: --- → ?

Added as a known issue.

(In reply to Aaron Klotz [:aklotz] from comment #6)

I am willing to bet that all of these users are running Windows as Administrator with UAC disabled.

This is a security feature that we tested in 67 and released at 100% in 68. Please see this SUMO article for more information.

This is indeed the case for me. I'll add the -no-deelevate command to my Firefox shortcuts.

Duplicate of this bug: 1565519
Duplicate of this bug: 1565856

(In reply to gracz542 from comment #9)

(In reply to Aaron Klotz [:aklotz] from comment #6)

I am willing to bet that all of these users are running Windows as Administrator with UAC disabled.

This is a security feature that we tested in 67 and released at 100% in 68. Please see this SUMO article for more information.

This is indeed the case for me. I'll add the -no-deelevate command to my Firefox shortcuts.

That command worked but sometimes I've found with it sometimes links created won't either auto open with Firefox or if you drag it onto an already open Firefox nothing works.

Summary: Unable to drag and drop images from browser to desktop → Unable to drag and drop images or URLs from browser to desktop

(In reply to Ste from comment #12)

That command worked but sometimes I've found with it sometimes links created won't either auto open with Firefox or if you drag it onto an already open Firefox nothing works.

If you are still having problems, please file a new bug with specific steps illustrating how to reproduce the problem.

(In reply to Ste from comment #12)

(In reply to gracz542 from comment #9)

(In reply to Aaron Klotz [:aklotz] from comment #6)

I am willing to bet that all of these users are running Windows as Administrator with UAC disabled.

This is a security feature that we tested in 67 and released at 100% in 68. Please see this SUMO article for more information.

This is indeed the case for me. I'll add the -no-deelevate command to my Firefox shortcuts.

That command worked but sometimes I've found with it sometimes links created won't either auto open with Firefox or if you drag it onto an already open Firefox nothing works.

You can't drag and drop from from lower to higher privilege, so it sounds as though the link/shortcut is running in a less privileged context than Firefox (with -no-deelevate, Firefox presumably is running as a high integrity process).

Can you re-enable UAC instead? It's not like the bad old Vista days, at least on Windows 10.

Duplicate of this bug: 1566326
Duplicate of this bug: 1564872
Duplicate of this bug: 1578322
Summary: Unable to drag and drop images or URLs from browser to desktop → Unable to drag and drop images or URLs from browser to desktop when running Windows as Administrator with UAC disabled
You need to log in before you can comment on or make changes to this bug.