implement restore previous page/tabs on restart

VERIFIED DUPLICATE of bug 159357

Status

()

Firefox
Preferences
--
enhancement
VERIFIED DUPLICATE of bug 159357
16 years ago
12 years ago

People

(Reporter: dave, Assigned: Blake Ross)

Tracking

unspecified
Future
x86
All
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
Opera has a really nifty option that makes the pain of windows crashing your
browser for you (or miscelaneous bugs -- hey, it happens) a lot less frustrating
-- an option to remember the last pages you had open so that you can pick up
where you were so rudely dropped off.

This makes the usage (especially of a product in development) a lot nicer -- i
can handle the fact that things will crash (often, especially under windows):
it's just really frustrating when you have to go dig up all the /. urls you had
open and stuff  ;p

Comment 1

16 years ago
user_pref("browser.startup.page", 2); works for me.

Comment 2

16 years ago
That pref works for me too. I guess the General panel is getting a little
crowded with various buttons related to this, but nontheless I'm turning this
into a bug about adding UI for this pref.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Summary: Remember last open page urls → Remember last open page urls (UI for user_pref("browser.startup.page", 2);)
(Reporter)

Comment 3

16 years ago
I think we're missing something here: that preference setting (well, at elast on
the win32 port of 31/10/2002) *only opens up the url that last had focus*. What
i was requesting was that all tabs open at the time of program termination would
be opened when the browser is re-started. This is also really useful for the
case where i get the latest nightly build, but i have to make sure that i'm
finished with (or have bookmarked) all of the pages i have open in tabs in the
browser when i quit.

To reiterate: i don't just want to restart the last page that i had open and
focussed: i want to restart all of the pages that i had open (or at least have
the option to do so)

thx
dave

Updated

16 years ago
Summary: Remember last open page urls (UI for user_pref("browser.startup.page", 2);) → implement restore previous page/tabs on restart
(Reporter)

Comment 4

16 years ago
ok, i've received about 3 mails that tell me that i should add the line:
user_pref("browser.startup.page", 2);
to my prefs.js

Guys, i did this *ages* ago, and, if you check my posting, i noted that this
_only retrives the *last* page that i had open_. Whilst this is fine and dandy,
the feature request i made was for something like Opera's ability to rmember
*all* of the pages i had open in tabs, so that if i, for instance, had an
instance of phoenix open with 3 tabs:
www.planetquake.com
slashdot.org
www.little-gamers.com
and i closed down phoenix, i would *really* like it to, upon reopening, open all
3 of those sites, in tabs, as i had them before the program termination (or at
least give me the option). 

Abnormal program termination is not really a problem any more (thx, guys, the
nightly releases of phoenix are getting better and better, and i really believe
that this is an excellent project: i promote it to everyone i know, and am
always fed back lines like "wow, it's so INCREDIBLY fast!". Phoenix is, i
believe, set to be a common browser in the furture). The main reason i'm
requesting this feature now is for the occasion where i choose to close down
Phoenix, normally because i want to install the latest nightly build  (:

Please, Please, Please (wow, i sound like a Deftones cover here...) don't tell
me again that i can add that little line above into my prefs.js. I know. I have
it. O yeah, maybe the confusion is being brought in by someone running the Linux
distro (although, i would have expected that the browser, being java-based,
should have the same code-base across the platforms) -- although i have the
linux distro, i haven't actually installed it at home (and i'm not online at
home anyway, so it would only be for the viewing of static documents like hel
pand such). In case it makes a difference, i'm running on Win32 (not out of
choice: out of company policy)

Thx to all the team working on this project. Keep up the good work!

-dave

Comment 5

16 years ago
Agree 100% with Dave.  Opera has this feature.  Galeon has it.  I can live 
without mouse jestures (sigh) but need to not loose my tabs.




Thanks!


(Assignee)

Updated

15 years ago
Target Milestone: --- → After Firebird 1.0
taking QA contact, sorry about the bugspam
QA Contact: asa → mconnor

Comment 7

15 years ago
*** Bug 219518 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 226726 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 19454

Comment 9

15 years ago
You may have a look at Pike's Session Saver: http://www.pikey.me.uk/mozilla/#ss
Not exactly the same as the one in Opera, but it's close, nice and works
perfectly in Fb.

Comment 10

15 years ago
It is not just a metter of retrieving a session (i.e. windwos+tabs+ (possibly)
forms) in case of a crash.... Which is obviuously very helpful (crashes,
particularly in windo$ are out of control...)

But sometimes (quite often for me) you might want to restore the last session
EVEN IF YOU HAD A CLEAN EXIT... 

So you should really keep TWO stored sessions (buffers) at any time. 

1) A "current session" (stored at runtime and not when you close the browser),
which is not directly accessible. Just as a buffer to store current
windows/tabs/forms.

2) A "last session" which is directly accessible at any time. This is basically
the previous current session. 

It is quite simple: when you OPEN the browser, the last saved "current session",
will replace the "last session". 

In this way the "last session" is available also when the browser is already
opened and until you close it and reopen it (when a new "last session" will
replace the old one). 

If you had only one "buffer" you could only open the "last session" when you
first start up the browser, but not afterwards.

This is a slight modification from the original plan that should make it much
more flexible. 

Some nice add ons.

A) In case of a non-clean exit, just pop-up a window asking if you want to
restart from last time. 

B) Make the last session available somewhere (either under history, or
bookmarks, or wherever you like) with the following options:
-restore all windows in last session
-restore specific window > submenu with list of windows

Thanks and kudos for the excellent job so far

Updated

14 years ago
Whiteboard: parity-opera
Parity with Opera is not a stated goal of the Firebird project and the presence
of features in Opera has zero impact on the decisions made here.  Please don't
add information to the status whiteboard unless it is one of the standard status
flags.
Whiteboard: parity-opera

Updated

14 years ago
Flags: blocking1.0?

Comment 12

14 years ago
The comment by Mike Connor on 3/29 seems specious.  Paraphrasing, "don't ever
mention any other browser when commenting on a desireable thing to do in Moz."

If comments about useful features observed elsewhere will be perforce ignored,
let's all forget about it and go do something useful.
-ing, feature. We will likely do something like this after 1.0. 
Flags: blocking1.0? → blocking1.0-
*** Bug 243110 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
Sorry for the dup Bug 243110, I did infact search before, but seem to have
missed this one... (couldn't believe nobody had reported this anyway;).

However postponing to after 1.0 seems a bit late IMHO (for such a now-standard
feature) - couldn't you add an UI for the "user_pref("browser.startup.page",
2);" in 0.9, without all the fancy (restore after crash, restore framesets etc.) ?

Thanks and keep up the great work!

Comment 16

14 years ago
*** Bug 244229 has been marked as a duplicate of this bug. ***

Comment 17

14 years ago
I want you all to know that I dropped Firefox because of this lack of feature. 
I find Mike Connor's comment rude in the extreme.  I'm a long time Opera user
who tried Firefox due to my geek friends telling me that it was the best open
source option right now.


I leave ~12-15 browser tabs open at any given time.  Generally things I want to
come back and read later. Having to manually open them on restart is totally
unacceptable to me.  Losing them on a crash is much, much worse, and is a total
deal breaker.

Just thought you all would want to know.

-Robin; robin@teddyb.org

Comment 18

14 years ago
(In reply to comment #17)
Well I can live with the following trick *for now*, but considering what
killer-features (RSS-Bookmarks, total redesign of Find and Popup-Blocking etc.)
where added for 1.0PR, I find it hard to believe this one can't make it into 1.0...

As for the trick, you can either set the startup-page in the Options with "Use
Current Pages" checked, or you file all open pages as a Bookmark on your
Personal Toolbar-folder... not really foxy, but works,-)
I get the feeling that my comment was taken well out of context, but hey, that's
prone to happen sometimes to people who don't know Bugzilla.  I was removing a
"parity-opera" status whiteboard entry, and by way of explanation noted that
we're not trying for feature parity with Opera.  Although I'm sure some people
want a built in user style that emulates the Commodore 64...

All joking aside, nothing I was saying was meant to be interpreted as "we're not
going to do this" or "this is a stupid feature" but was solely relating to the
bogus status whiteboard entry.  I don't know if I'd use this feature, since I'm
task oriented and finish with tabs before closing the app, but it does open up
new possibilities for a large number of users.

Comment 20

14 years ago
*** Bug 262392 has been marked as a duplicate of this bug. ***

Comment 21

14 years ago
That's an excellent explanation.  Thank you.

In addition, as it turns out, Session Saver implements the "save your tabs"
feature, and it stood up pretty well to forced crash testing (although not
perfectly).  I've started a page on migrating from Opera to Firefox, as I
couldn't find one myself; see
http://www.teddyb.org/~rlpowell/hobbies/opera_to_firefox.html

It lists Session Saver as one of the plugins to install.

-Robin
*** Bug 261908 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
*** Bug 257685 has been marked as a duplicate of this bug. ***
*** Bug 266187 has been marked as a duplicate of this bug. ***

Comment 25

14 years ago
*** Bug 266761 has been marked as a duplicate of this bug. ***
*** Bug 270412 has been marked as a duplicate of this bug. ***
*** Bug 270633 has been marked as a duplicate of this bug. ***

Comment 28

14 years ago
*** Bug 273230 has been marked as a duplicate of this bug. ***

Comment 29

14 years ago
*** Bug 275263 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 30

14 years ago

*** This bug has been marked as a duplicate of 159357 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE

Updated

14 years ago
No longer blocks: 19454
*** Bug 278480 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Status: RESOLVED → VERIFIED

Comment 32

13 years ago
*** Bug 284820 has been marked as a duplicate of this bug. ***
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs,
filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → preferences
You need to log in before you can comment on or make changes to this bug.