Closed Bug 1854646 Opened 9 months ago Closed 8 months ago

Temporarily disable some Tier 2 a11y_checks for Add-ons Manager

Categories

(Toolkit :: Add-ons Manager, task, P3)

task

Tracking

()

RESOLVED FIXED
120 Branch
Tracking Status
firefox120 --- fixed

People

(Reporter: ayeddi, Assigned: ayeddi)

References

(Blocks 1 open bug)

Details

(Keywords: access)

Attachments

(1 file)

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved. A separate task to investigate the failed Tier 2 a11y_checks will be filed for an appropriate component.

Tests affected:

Result	Path	Error	Element ID	Element tagName	Element className
FAIL	toolkit/mozapps/extensions/test/browser/browser_addon_list_reordering.js	Node is not accessible via accessibility API		H1	header-name
FAIL	toolkit/mozapps/extensions/test/browser/browser_colorwaybuiltins_migration.js	Node is not accessible via accessibility API		ADDON-CARD	
FAIL	toolkit/mozapps/extensions/test/browser/browser_globalwarnings.js	Node is not accessible via accessibility API		DIV	addon-name-container
FAIL	toolkit/mozapps/extensions/test/browser/browser_globalwarnings.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_gmpProvider.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_gmpProvider.js	Node is not accessible via accessibility API		DIV	addon-name-container
FAIL	toolkit/mozapps/extensions/test/browser/browser_gmpProvider.js	Node is not accessible via accessibility API		DIV	card addon
FAIL	toolkit/mozapps/extensions/test/browser/browser_gmpProvider.js	Node is not accessible via accessibility API		DIV	container
FAIL	toolkit/mozapps/extensions/test/browser/browser_history_navigation.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_history_navigation.js	Node is not accessible via accessibility API		ADDON-CARD	
FAIL	toolkit/mozapps/extensions/test/browser/browser_history_navigation.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_detail_permissions.js	Node is not focusable via the accessibility API	details-deck-button-permissions	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_detail_view.js	Node is not accessible via accessibility API		DIV	addon-name-container
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_detail_view.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_discover_view_clientid.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_list_view_recommendations.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_list_view.js	Node is not accessible via accessibility API		H1	header-name
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_list_view.js	Node is not accessible via accessibility API		PANEL-ITEM	
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_list_view.js	Node is not accessible via accessibility API		DIV	main-search
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js	Node is not focusable via the accessibility API	details-deck-button-details	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_options_ui.js	Node is not focusable via the accessibility API	details-deck-button-preferences	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_pending_updates.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_pending_updates.js	Node is not accessible via accessibility API		DIV	text-container
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_scroll_restoration.js	Node is not accessible via accessibility API		ADDON-CARD	
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_scroll_restoration.js	Node is not focusable via the accessibility API	details-deck-button-permissions	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_updates.js	Node is not accessible via accessibility API		DIV	
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_updates.js	Node is not focusable via the accessibility API	details-deck-button-release-notes	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_updates.js	Node is not focusable via the accessibility API	details-deck-button-details	BUTTON	tab-button ghost-button
FAIL	toolkit/mozapps/extensions/test/browser/browser_html_updates.js	Node is not focusable via the accessibility API		BUTTON	category
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_doorhanger_installs.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_relative.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button

Jobs affected:

  1. test-linux1804-64-qr/opt-mochitest-browser-chrome-swr-a11y-checks-${1-7} (Try run)

Some Tier 2 accessibility checks for click events fired on controls that should be keyboard accessible and have valid labels were failing for this component. They were captured by testing/mochitest/tests/SimpleTest/AccessibilityUtils.js via bug 1692110. These failing tests should be temporarily skipped in the directory's browser.ini file while we investigate these failures. For all confirmed bugs individual defects should be filed.

When the individual test failures are resolved and the individual bugs are closed, remove the fail-if condition for a11y_checks from the appropriate files/sections to ensure better test coverage and to avoid regressions in a11y of these components.

Blocks: 1854647

We are working on enabling Tier 2 a11y-checks to ensure our products have basic accessibility built-in (bug 1692110) and before that, we need to prepare the existing code base. While we triage and investigate existent tests that would fail once the a11y-checks are enabled in the CI, we are going to skip the failing tests altogether and then handle each one of them individually.

This task is to skip with fail-if condition of the failing tests while we continue investigation into the reasons these tests failed and to be able to backtrack these tests once they're resolved.

Related bugs:

  • Disabling tests: meta bug 1848402
  • Investigation and remediation for components with disabled tests: meta bugs 1848394 and 1854227, Add-ons Manager-specific meta bug 1854647
  • Explore capturing click events for a11y_checks: bug 1692110

Depends on D188991

The following tests passed on Try (job):

  1. toolkit/mozapps/extensions/test/browser/browser_html_list_view_recommendations.js
  2. toolkit/mozapps/extensions/test/xpinstall/browser_doorhanger_installs.js
  3. toolkit/mozapps/extensions/test/xpinstall/browser_relative.js

New failing tests (Try):

FAIL	toolkit/mozapps/extensions/test/browser/browser_html_list_view_recommendations.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button panel-footer-button	
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_relative.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button panel-footer-button	
Attachment #9354621 - Attachment description: WIP: Bug 1854646 - Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=scaraveo,rpl,Jamie → Bug 1854646 - Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy,rpl,Jamie
Attachment #9354621 - Attachment description: Bug 1854646 - Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy,rpl,Jamie → Bug 1854646 - Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy,Jamie
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/76d2a8ae9c19
Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy
Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
Attachment #9354621 - Attachment description: Bug 1854646 - Temporarily disable some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy,Jamie → Bug 1854646 - Temporarily fail-if some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy,Jamie

New test results (Try):

FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_amosigned_trigger_iframe.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_auth4.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_bug540558.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_doorhanger_installs.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_httphash4.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
PASS	toolkit/mozapps/extensions/test/xpinstall/browser_installchrome.js	We expect at least one assertion to fail because this test file is marked as fail-if in the manifest			
FAIL	toolkit/mozapps/extensions/test/xpinstall/browser_unsigned_url.js	Node is not focusable via the accessibility API		button	popup-notification-primary-button primary panel-footer-button
Flags: needinfo?(ayeddi)
Pushed by ayeddi@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ad49a7e7665
Temporarily fail-if some Tier 2 a11y_checks for Add-ons Manager. r=mixedpuppy
Blocks: 1858037
Status: REOPENED → RESOLVED
Closed: 8 months ago8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 120 Branch
See Also: → 1868568
See Also: → 1873255
See Also: → 1873279
See Also: → 1873299
See Also: → 1873304
See Also: → 1876618
See Also: → 1877049
See Also: → 1877051
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: