junk filter moves mail only when i open the folder with junk mail

RESOLVED DUPLICATE of bug 329569

Status

defect
RESOLVED DUPLICATE of bug 329569
17 years ago
11 years ago

People

(Reporter: kriskelvin, Assigned: sspitzer)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3; MultiZilla v1.4.0.3f) Gecko/20030312
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3; MultiZilla v1.4.0.3f) Gecko/20030312

I filter incoming mail of account 1 to a folder within account 2.
Both accounts have their junk-filter turned on. For both accounts the
junk-folder to drop messages marked as junk automatically is set to "junk" of
account 2 (for both accounts it is this one).

When i receive a junk-mail for account 1 my filter moves it to a folder of
account 2 and obiously it is correctly marked as junk. Also it will be moved to
the correct junk folder, _but_:

I will have to open the folder where the junk mail was stored to have the
junk-mail-funtion move it.



Reproducible: Always

Steps to Reproduce:
see above
Actual Results:  
junk-mail moved to junk folder on opening its original folder 

Expected Results:  
junk-mail moved to junk folder as soon as marked as junk by the filter
Confirming on Windows 2000 and XP with Mozilla 1.3 and 1.4RC1 respectively.

Build ID of Mozilla 1.4RC1 on Windows XP: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030529
This looks to be the same as bug 204483.  Kris Kelvin, if you agree, please mark
this bug as a duplicate of that one.
*** Bug 204483 has been marked as a duplicate of this bug. ***
I looked (for bug 219975) in the code and it seems thgat this behaviour depends
on the spam filter concept. Junk filtering is done after the message filter, for
new messages and only for the inbox folder and the selected folder. The junk
classification for the new messages in you destination folder is done when you
move to that folder. So your expected results is the actual result.

I don't know if this behaviour is part of the spam filter concept (in that case
the resolution would be WONTFIX). Marking as NEW, so one of the mail developers
should make this decision.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Keywords: mail3
*** Bug 193313 has been marked as a duplicate of this bug. ***
A solution to this bug as well as bug 193625 will prevent the "my folder view
tells me I have lots of new unread mail but when I actually click to see what it
is all the mail turns out to be junk".

Also, regarding Daniel's comment, regardless of whether bayesian junk filtering
is done before or after rule-based message filtering, I think it is more
reasonable for it to be done when a message arrives, not when a user views a
folder. As for the filter concept: I always thought the concept was that at the
entrance to your message repository/database/set-of-folders/whatever there's a
filter that prevents spam from entering - like a filter on a water tap - and it
doesn't need any sort of intervention from you (e.g. opening some folder) for
the filter to work.
Blocks: 233930
Blocks: 233933
No longer blocks: 233933
Another detail of this bug that I'm seeing:

Some mail is filtered from POP Inbox of account Alpha to Inbox of account Beta
(Beta never connects to a server, it just receives mail filtered to it).

If Beta's Inbox is already selected when Moz filters mail into it, the Junk mail
filter never activates.

And, as reported above, if Beta's Inbox is NOT selected when Moz filters mail
into it, Junk filter doesn't activate until I select Beta's Inbox.



Reassiging to proper owner:

was: naving@formerly-netscape.com.tld
now: sspitzer@mozilla.org
Assignee: naving → sspitzer
How do those of us who are Thunderbird or Mozilla MailNews users, not developers
with plenty of time to figure out these systems, indicate something is very
annoying and should be fixed ASAP?  It is troubling to see this and the numerous
defects related to IMAP offline folder corruption, the compact folders feature
(e.g. bug 133996) and spurious errors users can do little about (e.g. bug 163892
or bug 202426) remain "NEW" for months at a time while the not
ready-for-prime-time (at least for Thunderbird) new Extension Manager gets
rolled out.  Yes, this defect is an example of a more general issue of matching
developer productivity to user community satisfaction.
Is it an idea to add the junkfilter option to the message filters?
(In reply to comment #9)
> Is it an idea to add the junkfilter option to the message filters?

Like bug 196036 or bug 202605?
Blocks: 234044
Product: MailNews → Core
*** Bug 310542 has been marked as a duplicate of this bug. ***
Blocks: 66425
*** Bug 318979 has been marked as a duplicate of this bug. ***
i switched from evolution to thunderbird....and i miss the evolution way to find junk mails.
 
evolution says: "always check for junk, because, even restrictive filters *may* be bypassed"

so it always checks for junk, and after it applies filters.
my filters are something like: move to ZZZ folder if subject contains "hello". but hello can be in many spam mails.

infact when i access that folder many mails go to the junk folder.

please change the filter/junk sequence.
Patch in progress at bug 329569.  Why that bug simply wasn't duped here in the first place, I don't understand.
As I see it, this bug is the wrong approach.  There should not be a distinction made between junk filters and other filters; they should be in the same list and work the same in every way (bug 202605).  That way, whatever criteria you choose to use for determining junk/non-junk status, you can choose whether to apply those criteria before, after, or even in between your other filtering rules.

Mozilla's workings should not be hidden from its users.  Making junk filtering rules (including those generated by "adaptive filter" logic) part of the regular filter list will give users better control over the process -- which they ought to have.
*** Bug 338276 has been marked as a duplicate of this bug. ***
OK, that other bug is fixed.  Junk will now be detected, and moved if that's how you're configured, after filtering without having to open the folder.  However, you'll still get a notification if the only incoming messages were junk; bug 233930 is for that problem.

*** This bug has been marked as a duplicate of 329569 ***
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.