Vertical & horizontal scrollbars disappear if window too small (narrow, short)mostfreq

VERIFIED DUPLICATE of bug 55368

Status

SeaMonkey
General
P3
minor
VERIFIED DUPLICATE of bug 55368
19 years ago
14 years ago

People

(Reporter: Biswapesh Chatterjee, Assigned: Dan M)

Tracking

({helpwanted})

Trunk
Future
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
System: Build 1999112908 on WinNT SP5 (PII with 64 MB RAM)
Overview: If the browser window is made small enough so that the mozilla icon
at the top-right corner starts to hide itself, then the vertical scrollbar
disappears though there is enough space to display it.
Test Case: Go to http://mozilla.org/ . Start reducing the window size by
dragging the top right corner towards the bottom-left corner. As the Mozilla
icon starts to disappear, so does the scrollbar.
Ecpected Result: The scrollbar should be visible.
Other info: This problem was not present in M11 build.

Updated

19 years ago
Assignee: shuang → leger
Component: UE/UI → Browser-General

Comment 1

19 years ago
reassign it to browser general category. It is not a UI design bug for now.
The cause of this bug is quite simple: the scrollbars appear within the content
area as specified by the XUL, not at the window edge. And the minimum size of
the XUL sets where the scrollbars will be.

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

19 years ago
Yes.  Marking Bug Verified/Invalid
Whiteboard: REOPEN?
leger: I'm not sure that the bug _is_ invalid. If the window is too small for
the chrome, shouldn't we still be able to see the scroll bars for the content?
Or at least have a _minimum_ window size so that this problem never occurs?

Updated

19 years ago
Status: RESOLVED → REOPENED
OS: Windows NT → All
Hardware: PC → All

Comment 5

19 years ago
I concur. reopening. The behavior is the same on all platforms. On Mac there is a minimum
width but the vertical scrollbar disappears even before you reach it. This is basically a limitation
in the design. cc'ing trudelle so maybe a xul type can take a look.

Updated

19 years ago
Resolution: INVALID → ---

Comment 6

19 years ago
Clearing INVALID resolution due to reopen.

Updated

19 years ago
Assignee: leger → danm
Status: REOPENED → NEW
Target Milestone: M16

Comment 7

19 years ago
Yes, there needs to be a minimum size where the window still has all it's basic
controls visible and working. reassigning to danm as p3 for m16

Comment 8

18 years ago
Mass-moving all M16 non-feature bugs to M17, which we still consider to be 
part of beta2
Target Milestone: M16 → M17

Comment 9

18 years ago
moving to m30, helpwanted
Keywords: helpwanted
Target Milestone: M17 → M30

Comment 10

18 years ago
Mass-moving all M20-M30 XPToolkit bugs to Future
Target Milestone: M30 → Future

Comment 11

18 years ago
*** Bug 39738 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
Testing with 2000-09-12-08-M18 on WinNT, the exact point at which the scrollbars
no longer (completely) display varies by theme, but beyond a theme-specific
minimum content-area size, the scrollbars get clipped. Very odd to see half
or one-eighth of a scrollbar.

Quoting from bug 39738,
  ------- Additional Comments From Jesse Ruderman 2000-05-28 14:29 -------
  This isn't just about the vertical scrollbars -- the entire content area has a 
  minimum width.  If you reduce the width of the browser window beyond the point 
  where the vertical scrollbar disappears, you'll notice that you can drag the 
  horizontal scrollbar farther than it looks like you can.
From the discussion here, the proposed fix - enforcing a minimum size where all 
the controls are visible - should fix that problem too.

Setting severity to minor: there is always an obvious and easy workaround
(unless the display is too small to contain a Mozilla window sized to show
all controls...but that's beyond the scope of this bug).
Severity: normal → minor
Summary: Scrollbar disappears if window is made small enough → Vertical & horizontal scrollbars disappear if window too small (narrow, short)
Whiteboard: REOPEN?
*** Bug 52070 has been marked as a duplicate of this bug. ***
couldn't this be solved by not making the toolbars and the browser window in 
the same xul box. It seems to me that just making sure that no box wrapps both 
the toolbar and the browserbox would solve this...

Comment 15

18 years ago
*** Bug 52735 has been marked as a duplicate of this bug. ***

Comment 16

18 years ago
*** Bug 55530 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
*** Bug 56949 has been marked as a duplicate of this bug. ***
*** Bug 50405 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
*** Bug 58902 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
*** Bug 58902 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
dup bug 39738 had 3 dups itself:
bug 41432, bug 44441, bug 52378
In addition 6 other bugs are marked dup directly of this one:
bug 52070, bug 52735, bug 55530, bug 56949, bug 50405, bug 58902.

10 indepedant dups in all. Adding mostfreq keyword.
Keywords: mostfreq
Summary: Vertical & horizontal scrollbars disappear if window too small (narrow, short) → Vertical & horizontal scrollbars disappear if window too small (narrow, short)mostfreq

Comment 22

18 years ago
I recommend reading bug 55368 for instructions on how to fix this one.
It seems fairly easy.
Fabian.
(Assignee)

Comment 23

18 years ago


*** This bug has been marked as a duplicate of 55368 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 24

18 years ago
verified duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.