Running filters on folder doesn't update the unread mail indicator in folders pane.

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: matt, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [comments 6 thru 15 are irrelevant to the original report])

Attachments

(3 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.6.1 StumbleUpon/1.79
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031007 Firebird/0.6.1 StumbleUpon/1.79

When I run a filter which removes unread mail from a folder, the folder's
"unread messages" indicator is not updated on the folders pane.  This indicator
should be refreshed after each filter execution. Just to be clear, the "unread
mail" indicator is the bolding and counter of the folder name in the folders pane.

Reproducible: Always

Steps to Reproduce:
1.When you get new mail in inbox, don't read it.
2.Instead run a filter that moves all of it to another folder.


Actual Results:  
The "unread mail" indicator now remains, even though unread mail no longer
exists in the inbox.

Expected Results:  
The "unread mail" indicator should turn off.

Comment 1

15 years ago
I also observe similar behavior using the same build on Windows XP Professional.
In my case I run the filters automatically. Sometimes some folders will show new
mail on their own accord. Most folders will not show any updates until I click
on them to view their comments.

Comment 2

15 years ago
Also confirmed on Red Hat 9 using Thunderbird 0.7
(thunderbird-0.7-i686-linux-gtk2+xft.tar.gz). I have a filter which moves mail
to/cc an address into another folder and marks the message read. The filter
appears to work, but the folder which the mail has been moved into still shows
bold with an unread count.

Comment 3

14 years ago
related to Bug 116181 (and Bug 222068)

Comment 4

14 years ago
Confirmed on Thunderbird "version 0.8 (20040913)".
I have several filters that distribute incoming (unread) email into different
folders; for folders that receive unread messages the icon changes to show there
are unread messages (an asterisk is overlayed) but the unread message count is
not updated.

Comment 5

14 years ago
Reporter (Matt), and Paul Walker: POP or IMAP mail?
In both cases, you appear to state that the Inbox bold/count status does not 
turn off/decrement.  Does the destination folder turn bold / increment the 
count?

Paul Walker, it is not clear whether your filter is being automatically run on 
the incoming messages, or run manually after the fact.

I attempted to reproduce the original problem on a POP account, but when I tried 
to manually a filter that removed unread messages, the source folder node 
(Inbox) was unbolded and the count cleared.


(In reply to comment #4)
> I have several filters that distribute incoming (unread) email into different
> folders; for folders that receive unread messages the icon changes to show
> there are unread messages (an asterisk is overlayed) but the unread message
> count is not updated.

This is possibly bug 261201.


This bug is not related to bug 116181 nor bug 222068, which are about the New 
flag on the account, not the unread/count state of the folder display.

Comment 6

14 years ago
Created attachment 168212 [details]
Screenshot

Comment 7

14 years ago
I'm used to bcc all messages to myself, therefore I've created a filter which
marks all messages from myself as read. However, since 1.0RC1 the message is
marked as read, but the folder and message icons don't change.

The part of marking as read which goes correctly:
- The notifier in the systray doesn't show up
- The subject/sender/date text is not shown in bold

Screenshot attached. It is about the most upper message, subject "test"

Regards,
Cornelis 

Comment 8

14 years ago
(In reply to comment #7)

This is about Thunderbird, sorry ...

Comment 9

14 years ago
(In reply to comment #5)
> This bug is not related to bug 116181 nor bug 222068, which are about the New 
> flag on the account, not the unread/count state of the folder display.

Those bugs are for the "Suite" (This one is for Thunderbird). There seems to be
a whole bunch of bugs that essentially all want the same thing. Would it make
sense (for someone who can) to dupe all these bugs into one and make it
"Product: Core"?

Suggested new Summary:
Unread mail indicator (red star / green arrow) on (Account) folder icon and the
New Mail Icon in the Windows Taskbar are not updated/removed when all mails are
read or moved/deleted via (junk)filters.

Comment 10

14 years ago
Created attachment 181397 [details]
Screenshot - Missing Unread Flags on Inbox and Account Folders

Comment 11

14 years ago
Created attachment 181398 [details]
Screenshot - Incorrect Read Flag on Account Folder

The Mail Notification Icon in the Windows taskbar is also incorrectly being
displayed.

Comment 12

14 years ago
Those two previous screenshots are from my IMAP account. I'm using Thunderbird
version 1.0+ (20050420) (trunk nightly build).

Comment 13

14 years ago
The reason why this bug is so annoying (and why it should be fixed) is that I
receive far more junk mail than regular mail, and it is (usually) correctly
filtered (moved to "Junk" folder on "Local Folfers") by Thunderbird's junk
filter. However, I am constantly being notified of new mail (New Mail Notifier &
flag on account folder) which makes me fequently switch from my work to
Thunderbird to look for new (important) mail that isn't there.

I hope mozilla.org will agree. Requesting "blocking-aviary1.1".
Flags: blocking-aviary1.1?

Comment 14

14 years ago
I agree with Peter completely.  I have no need to know that Junk mail has come
into my accounts.  

A great solution would be to be allowed to select folders that you do not want
to be notified that mail has arrived.  

For example:

Bugzilla mail is not as important as work email.  I would rather browse this
mail at my leisure than be told that mail is in my inbox and have to go to the
client to find out I don't want to read it yet.

Any comments

Comment 15

14 years ago
Peter Lairo, you have misappropriated this bug.  I am sorry that the issues of 
new vs. unread, flagged vs. bold, 'new' on folder vs. 'new' on account is so 
confusing -- which it is -- but you have made everything much more confusing by 
not reading and understanding this bug nor the referenced bugs, and posting a 
bunch of noise here.  I am clearing your blocking request.

Your first screenshot (attachment 181397 [details]) shows *correct* behavior.  The flag 
that appears on a folder is *not* an indicator of unread messages, it is an 
indicator of *new* messages.  There is a difference.  Note that the original bug 
report explicitly states [emphasis mine]:
> Just to be clear, the "unread mail" indicator is the *bolding and counter*
> of the folder name in the folders pane.

Also note that the New flag on a folder has a different meaning than the New 
flag on an account.  Which leads to:

Your second screenshot (attachment 181398 [details]) does show a bug, and that is the same 
as bug 116181.  Bug 283388 is about this same issue but filed for TB.  You are 
correct that this is probably a Core issue.

> junk mail [...] is (usually) correctly filtered (moved to "Junk" folder on
> "Local Folfers") by Thunderbird's junk filter.  However, I am constantly
> being notified of new mail (New Mail Notifier & flag on account folder)

By "New Mail Notifier" do you mean the tray icon, or the alert (sound and/or 
slide-up window)?  If the symptom is that the tray icon is not disappearing 
after you've read your new mail, that's the same problem.

On the other hand, if you are getting new mail alerts on the receipt of (only) 
junk mail, that would be a new bug.  I cannot test that specifically, because my 
IMAP account doesn't get any junk.  I did some new testing trying to figure this 
out, and discovered bug 291454 -- it's possible that junk filtering is causing 
the same symptom.


Cornelis van Bemmel: your screenshots *also* are not related to this bug.  There 
does seem to be a bug there: the 'test' message has a New flag, but it is not 
supposed to because it has been marked Read.  If you can determine a consistent 
means of duplicating that new flag, please open a new bug for it.

The bolding of the Inbox occurs because the 'New' message triggers a style rule 
present in the default TB theme (also in the Classic theme in Mozilla), as 
detailed at bug 201917 comment 14.
Flags: blocking-aviary1.1?
Whiteboard: [comments 6 thru 15 are irrelevant to the original report]

Comment 16

14 years ago
The original bug report looks similar to but not the same as bug 179556; that 
bug refers to bug 222112 and bug 94215 as related or possible dupes.  If 
reporter (Matt) is paying any attention to this bug (he never responded to 
comment 5) he might look into those bugs for insight, and perhaps mark this as a 
dupe.

Comment 17

14 years ago
(In reply to comment #15)
> Cornelis van Bemmel: [...]  If you can determine a consistent 
> means of duplicating that new flag, please open a new bug for it.

You don't have to open a bug, I've reproduced it: bug 291465.

Comment 18

13 years ago
I've the same problem than this bug, but the filter didn't remove unread mail,
but move it to a subfolder


I've TB and 6 pop account
Each pop has its own inbox, but i've a lot of filter on each account to move the
message in one of subfolder below Local Folders ...
But when i receive a mail for account x which is filtered, and i've read the
filtered mail, i've to click on the originating inbox account to remove the red
star (similar to the green arrow of seamonkey) on the inbox and the account (and
to remove the notification icon in the tray box)

--> Does somebody know if this bug is already open for TB?
I've found it for mozilla suite (
https://bugzilla.mozilla.org/show_bug.cgi?id=116181 and
https://bugzilla.mozilla.org/show_bug.cgi?id=222068 ), but not for TB and this
bug seems related to filter which remove unread mail, what is not exactly the
same ...

thanks

Comment 19

13 years ago
can we update the summary of this bug to enlarge its scope:
It is the same bug when the filter don't remove the message but move it from a
folder of a pop account (typically inbox) to a subfolder of the local folder and
then remove the mail after having read it ... 

Comment 20

13 years ago
I am running Thunderbird version 1.5 (20051025) and am experiencing the same issue as comment #1 (Bill Zumach).  Several comments seem to indicate that this bug either a duplicate or a symptom of seveal bugs.  (I am having serious issues caused by not noticing that auto-filtered mail is "hiding" in folders.)

I'd be happy to explain more or be told to which bug I should add more info (and apologies if this is not helpful).

Problem description:
- I have a pop mail box with many (over 30) mail filters set to run automatically.
- Mail filter moves messages to local machine into a (often) deep folder heirarchy.
- Local folders show no sign of new messages until they are clicked.
- Once clicked, the folder is updated and new messages "appear" (unred count, bold-ing of the folder in the tree pane)
- Unless I click on all my folders individually (maybe 100 variously nested folders), new mail in my local folder heirarchy is unknown

(I thought that running a complicated "find x/y/z in message body" search would update the folders, but this does not seem to cause any change in the "bold" state of the folder)



Comment 21

12 years ago
I first reported this bug (on Mozilla) in 2003, having had the problem since 2001 and watched the lack of resolution for a couple of years.

STILL the little leaping dolphin to the left of each mailbox has a red nose
when there's been mail, even if I read the mail days ago.   It seems the "new
mail" flag doesn't know about mailfilters.

It's not a "problem" - but it's a heck of an annoyance.   Is there any hope that it can be fixed, or is the problem too deep in the core of Mozilla/Thunderbird?   If so, shouldn't it be marked "unfixable" and closed?

Comment 22

12 years ago
> Is there any hope that it can be fixed,

There's always "hope". What we need is someone writing a patch. ;-)
But copying almost the same (useless) comment to several bugs just annoys people.

Comment 23

12 years ago
(In reply to comment #21)
> STILL the little leaping dolphin to the left of each mailbox has a red nose
> when there's been mail, even if I read the mail days ago.   It seems the 
> "new mail" flag doesn't know about mailfilters.

That's not this bug, it's bug 222068.  Original report states explicitly:
> the "unread mail" indicator is the bolding and counter of the folder name
> in the folders pane.

Comment 24

12 years ago
Similar bugs, probably duplicates:

Bug 179556
Bug 275561

Comment 25

12 years ago
Has this been fixed by the checkin for Bug 275561 ?

Comment 26

12 years ago
my change only affects filters that run when new pop3 mail is retrieved, and it really only affects the mail icon on the system notification tray. But I've made other changes for filters that mark messages read...
QA Contact: front-end

Comment 27

12 years ago
The problem is still present in Thunderbird 2.0.0.4.

Comment 28

11 years ago
This WFM following the original STR on TB trunk 2008-04-17

Comment 29

11 years ago
WFM also per mike 2007-01-12 bug 202783 comment 8

=> WFM
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.