[RFE] delete mail from pop server when moved to trash (separate preference from moved out of inbox)

RESOLVED FIXED

Status

enhancement
RESOLVED FIXED
16 years ago
7 years ago

People

(Reporter: mohr.42, Assigned: Bienvenu)

Tracking

({fixed1.8.1})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Option to "delete messages from server when moved to trash" as well as "delete
messages from server when deleted or moved from inbox".
but delete is a move to the trash. Why do you want to move messages to the trash
instead of using delete?
The current option is to delete messages from the server when they are moved
from the inbox.  I'm requesting an option to delete messages from the server
when the message is moved to the trash or deleted.  I'm not understanding your
question.
Severity: normal → enhancement
the current option is to leave messages on server "until I delete them or move
them from the Inbox". If you delete a message, it will get removed from the
server. Please try a 1.6b build. Thx.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → INVALID
Yes, deleting the message or moving it from the inbox deletes it from the server.  

However, I am requesting an option so that moving a message to a folder other
than the trash does not delete it from the server.  Hence "Option to 'delete
messages from server when moved to trash'" from comment 0.  It would not be an
option to use in conjunction with "until I delete them or move them from the
Inbox".  

This is not invalid.  Feel free to resolve wontfix or duplicate though (I
searched for dupes but didn't find any--you might).
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
ah, so you want an option to delete from server *only* when deleted, not when
moved out of the inbox. That makes sense. The main impediment to implementing
this is that this pref dialog is already extremely complicated and adding this
option might make it overflow the dialog box.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: MailNews → Core
Clearing up summary according to comment #5

Prog.
Summary: [RFE] option to delete mail from server when mail is moved to trash → [RFE] option to delete mail from server when mail is moved to trash (only when deleted, not when moved out of the inbox)
Summary: [RFE] option to delete mail from server when mail is moved to trash (only when deleted, not when moved out of the inbox) → [RFE] option to delete mail from pop server when mail is moved to trash (only when deleted, not when moved out of the inbox)
*** Bug 306536 has been marked as a duplicate of this bug. ***
*** Bug 288268 has been marked as a duplicate of this bug. ***
*** Bug 257676 has been marked as a duplicate of this bug. ***
*** Bug 231614 has been marked as a duplicate of this bug. ***
Recap: there were at least a half dozen different requests for the following UI change (and accompanying backend work) to Account Settings -> Server Settings

[ ] Leave messages on server
  [ ] For at most ___ days
  [ ] Until I delete them
  [ ] Until I move them from Inbox

See also superset bug 47297
QA Contact: esther
Summary: [RFE] option to delete mail from pop server when mail is moved to trash (only when deleted, not when moved out of the inbox) → [RFE] delete mail from pop server when moved to trash (separate preference from moved out of inbox)
Having these two options separated is the ONLY WAY for someone to read (all his) mail at work and at home, use sub folders, and be able to delete mail from server when deleted in Thunderbird.

Think about this scenario - which is quite normal. This separation is a MUST, isn't it?
*** Bug 321369 has been marked as a duplicate of this bug. ***
Please promote from enhancement request to major, since this is required functionality for an email client.
David Bienvenu, to whom this bug was assigned has not posted a reply here for over 2 years, which i think explains why this fundamental bug hasn't been touched even though it has been known for so long.

What can be done about this?
(In reply to comment #15)
> David Bienvenu, to whom this bug was assigned has not posted a reply here for
> over 2 years, which i think explains why this fundamental bug hasn't been
> touched even though it has been known for so long.
> 
> What can be done about this?
> 

Maybe we should make a noise on Mozillazine? Here is the relevant thread:
http://forums.mozillazine.org/viewtopic.php?t=330689&highlight=delete+server
I looked at Thunderbird 3 alpha 1 and couldn't believe my eyes: the mostly unuseable double option "Until I delete them or move from Inbox" is still in there!

It seems, these reports aren't really looked at (or at least not thought about seriously). Anyhow - probably no one will hear this cry in the dark.


[can someone maybe assign this to someone who can get things going?]
[can someone (Robert?) with enough rights take some time to understand this and set severity to major?]
The "Until I delete them" functionality (as opposed to the only current similar option "Until I delete or move them from Inbox") was already implemented once in an earlier Mozilla release.  In Netscape 6.2.3 (which is a version of Mozilla Application Suite - although I do not know which version) implemented "Delete messages on server when they are deleted locally" -- and this feature seemed to work correctly in my limited testing.  Could someone just copy this code to Thunderbird to enable this "Until I delete them" setting (as shown in Comment #11 from Frankie)?

I would second the proposal to promote this enhancement request to Major.
This is an important feature. If the only impediment is that it will add too many options to the pref dialog, then the option of deleting mail from the server when mail is deleted or moved should be eliminated. I use filters to sort my mail as I download it, and to save time, I don't download the headers on most mail. If I selected the option of deleting mail on the server when it is deleted or moved, some legitimate mail would be deleted from the server before I had the opportunity to download it.
(In reply to comment #19)
> I use filters to sort my mail as I download it, and to save time, I don't 
> download the headers on most mail.

I meant to say that I don't download the body on most mail, which is to say that I download only the headers on most mail. Any option that would delete legitimate mail from the server before I could download the body is useless to me.
(In reply to comment #20)
> (In reply to comment #19)
> > I use filters to sort my mail as I download it, and to save time, I don't 
> > download the headers on most mail.
> 
> I meant to say that I don't download the body on most mail, which is to say
> that I download only the headers on most mail. Any option that would delete
> legitimate mail from the server before I could download the body is useless to
> me.
> 

So is anything going to be done about this?  If it is a space problem get rid of the "delete from server if deleted or moved from inbox".  Does anyone actually use that on purpose?

This should have been fixed years ago, is this product still being devloped?  I really want to move my company to a non-MS mailer to lessen the thread of virus but we have to have this very common and obvious feature.
(In reply to comment #21)
> (In reply to comment #20)
> > (In reply to comment #19)
> > > I use filters to sort my mail as I download it, and to save time, I don't 
> > > download the headers on most mail.
> > 
> > I meant to say that I don't download the body on most mail, which is to say
> > that I download only the headers on most mail. Any option that would delete
> > legitimate mail from the server before I could download the body is useless to
> > me.
> > 
> 
> So is anything going to be done about this?  If it is a space problem get rid
> of the "delete from server if deleted or moved from inbox".  Does anyone
> actually use that on purpose?
> 
> This should have been fixed years ago, is this product still being devloped?  I
> really want to move my company to a non-MS mailer to lessen the thread of virus
> but we have to have this very common and obvious feature.
> 

Sorry I do not agree with comment #20.

People who run multiple machines and receive the same e-mails on them need the "delete from server if deleted" option - I sure do.

- Spike -
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > (In reply to comment #19)
> > > > I use filters to sort my mail as I download it, and to save time, I don't 
> > > > download the headers on most mail.
> > > 
> > > I meant to say that I don't download the body on most mail, which is to say
> > > that I download only the headers on most mail. Any option that would delete
> > > legitimate mail from the server before I could download the body is useless to
> > > me.
> > > 
> > 
> > So is anything going to be done about this?  If it is a space problem get rid
> > of the "delete from server if deleted or moved from inbox".  Does anyone
> > actually use that on purpose?
> > 
> > This should have been fixed years ago, is this product still being devloped?  I
> > really want to move my company to a non-MS mailer to lessen the thread of virus
> > but we have to have this very common and obvious feature.
> > 
> 
> Sorry I do not agree with comment #20.
> 
> People who run multiple machines and receive the same e-mails on them need the
> "delete from server if deleted" option - I sure do.
> 
> - Spike -
> 

Well, the point is that we want the option to delete messages from the server when they are moved to the Trash, but *not* if they are moved to another folder.  If you need that functionality, it already exists.  I don't think anyone is suggesting that it absolutely should be removed, but it *is* hard to imagine a scenario where someone would actually want this behavior.  Either way, there should be a way to distinguish between moving mail to the Trash and just moving it in general.

I use TB on multiple machines and I also use a lot of folders for organization.  The problem is, I have to wait until mail is downloaded on all machines before I can move it anywhere.  Depending on my schedule this can be hard to keep track of.

And I get way too much spam to deal with more than once, so just leaving everything on the server is actually way more tedious.
> Sorry I do not agree with comment #20.
> 
> People who run multiple machines and receive the same e-mails on them need the
> "delete from server if deleted" option - I sure do.
> 
> - Spike -
> 

If you meant comment 21 then you misunderstood me.  Of course I want email deleted from the server if I delete it.  But not if my rules auto-sort mail from a client into that clients folder.  Does anyone actually *want* that behaviour?

Get rid of the (as far as I can tell) useless "Delete if I delete or *move* my email" and replace it with what every other client has "Delete from server if I delete it locally".

It is frustrating that someone *ever* set it to the current behaviour.  It is inexcusable that it has remained this way for nearly 3 years.
I pretty much agree that it should work that way, though we'd probably need to support the old way of doing it for backwards compatibility, which is a drag.
Just split it into two options, "Until I delete them" and "Until I move them from the Inbox" and have both adopt the setting of the former single option. Users are quick enough to change those settings to their liking as soon as possible.
Guys, please. All you are doing is rehashing exactly what was already figured out in the first 5 comments, then explicitly diagrammed in comment 11. At this point the best things to do are:
1: get a good coder to join the project and fix it, or
2: set up a bug bounty on it (I'll pledge $10) and
3: get a couple thousand people to vote for it.
Discussion is good, if for no other reason than to show how much users want to see this feature implemented as outlined in Comment #11 from Frankie.

I support the Bug Bounty idea and I'm also willing to contribute $10.
This adds a hidden pref, "mail.pop3.deleteFromServerOnMove", which defaults to false. If turned on with the config editor, you'll get the 1.5 behavior of deleting a message from the server when moving the message anywhere. The new default behavior is to only delete from server when the message is deleted/moved to the trash. I think this new behavior is much more intuitive. I've also changed the account settings UI to reflect this change.

I decided not to worry about making it so existing users get the old behavior - we should just relnote this strongly and move on. I think the old behavior was pretty non-intuitive.

I also need to add a way to delete messages from the server, probably a context menu item on a message. I'm tempted to do something similar to what Eudora does - have a server parent menu in the context menu, and have a couple flyout choices - delete from server and retrieve from server.
Attachment #239679 - Flags: superreview?(mscott)
Comment on attachment 239679 [details] [diff] [review]
change default behavior to delete from server when message deleted locally

There's an extra line of white space here:

           {
+            
             return copyService->CopyMessages(this, messages, trashFolder,
                                       PR_TRUE, listener, msgWindow, allowUndo);
           
Is this logic right?

+          if (!GetDeleteFromServerOnMove())
+            MarkMsgsOnPop3Server(mCopyState->m_messages, POP3_DELETE);

I read that as, if we aren't deleting from sever on move then Mark msgs on pop3 server as deleted.
Attachment #239679 - Flags: superreview?(mscott) → superreview+
>Is this logic right?
Yes, I think it is - I'm trying to avoid double marking as deleted, and in this case, we'll have marked it deleted elsewhere. But I'll double check.
(In reply to comment #29)
> I also need to add a way to delete messages from the server, probably a context
> menu item on a message.

I was working on a simple "Delete selected from server" command for the context menu of messages in the threadpane. I only got the basics done, but it works. Not sure if it'd be much use to you... you might code something better in 1/100th the time ;) The thing I can't decide is how to make the user feel that the command has done something... as it is, there's no feedback. A popup dialog box every time it's executed would become annoying very quickly. And a visible mark against a message that's been deleted on the server would quickly become redundant clutter, as every message is eventually deleted from the server.
Wayne, feel free to send it to me, or attach it here...
this is what I'll check in...
Attachment #239679 - Attachment is obsolete: true
fixed on trunk and branch
Status: NEW → RESOLVED
Closed: 16 years ago13 years ago
Keywords: fixed1.8.1, relnote
Resolution: --- → FIXED
Thanks much, David. We all look forward to downloading it.

PayPal, or do you prefer some other method?
I work for Mozilla, but the Mozilla Foundation is always looking for donations, if you're so inclined :-)
(In reply to comment #29)
> Created an attachment (id=239679) [edit]
> change default behavior to delete from server when message deleted locally
> 
> This adds a hidden pref, "mail.pop3.deleteFromServerOnMove", which defaults to
> false. If turned on with the config editor, you'll get the 1.5 behavior of
> deleting a message from the server when moving the message anywhere. The new
> default behavior is to only delete from server when the message is
> deleted/moved to the trash. I think this new behavior is much more intuitive.
> I've also changed the account settings UI to reflect this change.
> 
> I decided not to worry about making it so existing users get the old behavior -
> we should just relnote this strongly and move on. I think the old behavior was
> pretty non-intuitive.
> 
> I also need to add a way to delete messages from the server, probably a context
> menu item on a message. I'm tempted to do something similar to what Eudora does
> - have a server parent menu in the context menu, and have a couple flyout
> choices - delete from server and retrieve from server.
> 

Thank you very much for fixing this.  I guess Franky was wrong.  But this helps the mozilla project.  I will be switching all my users (we are a small group of less then 20 atm) to your product now that I can.
Many thanks David for resolving this issue.

Urm.... I'm sure this is a dumb q, but how do I apply this patch to my local installation of Thunderbird 1.5.0.7?

Best regards
 - Spike -
since the changes are in c++ code, not js or xul, you can't apply the patch to 1.5.0.7 - you need to wait for TB 2.0, which is in alpha right now, and will be in beta in a couple weeks...
(In reply to comment #33)
> Wayne, feel free to send it to me, or attach it here...

David, sorry it's taken me so long... I got distracted. I've finally emailed you my patch (to the address you have listed here). I hope it's of some use to you.

Could you please let me know if/when it arrives? Just in case it's eaten by a spam filter.

Cheers :)
I noticed that in Seamonkey 1.1b "Until I delete them or move them from the Inbox" was REPLACED with simply "Until I delete them". 
I truly miss the old functionality (i.e., when messages are deleted even when they are moved from Inbox). Can anybody clarify if there is way to get this old functionality back?

Thanks.
Hi!

I have the same problem and I just noticed it was fixed but I didn't understand how to fix it…

What should I do? Do I edit with Notepad my mailnews.js file (which is on Thunderbird\defaults\pref folder)?

If yes, what should I edit? The entire text? Just some copy and paste and deleting what's already there? Or do I add those line @ the end of the existing ones? 

Last question, does it work with 1.5.0.9 version of TB?
I'm using TB 1.5.0.9. Have same problem like Comment#44: I have no idea, what I have to do to use the new function. I read here that this bug is fixed, but updating thunderbird doesn't make any difference. Is there any patch? What do I have to do with it? Where to download it? Please help, it's very disapointing for me to read the bug that made working with TB so hard for me for years is fixed and I can't participate in the new function that I  missed so long.
Thx.
See comment 29, you can use the Config Editor (under Advanced > General) to set the pref. You need a 2.0 beta build.

Recent nightly 2.0 beta builds are available from
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8/

Releases from http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/
I'm using Seamonkey. Somebody referenced this bug on a checkin to seamonkey on 2006/9/27, while Seamonkey was in beta, but neglected, as far as I, or probably any normal user can see, the preferences necessary to control it, and failed to smoketest the changes, and failed to tell the end user about it.

I discovered this after not getting mail from the ISP, it having bounced after the inbox filled up. The inbox was previously kept clean enough by moving mail to another folder. But certain mails are more handy kept on the server -- for reference and addresses, when using webmail when away (if ones needs a reason).

I think this caused -->
https://bugzilla.mozilla.org/show_bug.cgi?id=372415

I'm a little mad after reading this discussion. To save a single line in the prefs dialog, it was decided to use an obscured hidden pref, which I never found. The program, while in beta, changed its mail behaviour (which the user had to have earlier explicitly set), didn't tell the user that this behaviour was going to change, and didn't offer to keep the user's set behaviour. I can't believe this checkin to Seamonkey didn't break any Mozilla quality assurance policies in multiple ways.

Read the invective this decision has gathered: http://forums.mozillazine.org/viewtopic.php?t=522586

I'd scarcely think users would get more angry if mozilla decided to auto-delete mng attachments from mails.

The idea isn't bad (yes, I think it is a good idea to not delete messages when moving them around -- a lot of people would want that). But it is also not a trivial use case that you'd like the messages deleted when moved. The change was badly implemented on Seamonkey, no matter one's idea of whether they'd like messages kept, or deleted, when moved from the inbox.
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.