Extensions fail to uninstall

RESOLVED WORKSFORME

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED WORKSFORME
14 years ago
10 years ago

People

(Reporter: lauchenauer, Unassigned)

Tracking

1.7 Branch
x86
All
Points:
---
Bug Flags:
blocking-aviary1.0 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7) Gecko/20040707 Firefox/0.8

The extension Manager shows "This item will be uninstalled after you restart
Firefox", but even after multiple restarts (even Windows) it's still there.

Firefox 0.9.2
The Extensions are:
CuteMenus 0.3
Super DragAndGo 0.2
CopyURL+ 1.0
Slogger 0.1.0


Reproducible: Always
Steps to Reproduce:
1.
2.
3.

Comment 1

14 years ago
I see the same thing sometimes on Linux.  After a few days of trying to
uninstall/reinstall an extension sometimes the mysterious log jam clears.
Status: UNCONFIRMED → NEW
Ever confirmed: true
I've also seen this on Windows XP. OS should be All; maybe severity should be major.
(Reporter)

Updated

14 years ago
Severity: normal → major
OS: Windows 2000 → All

Comment 3

14 years ago
I believe that this might be related to bug 248432. Did any of you have a failed
download?

Comment 4

14 years ago
I didn't have a failed download, as far as I can tell.  (Not that I'm sure it's
easy to tell, for an extension download.)
I don't think I had any failed extension/theme downloads; it's possible that I
initiated a second installation of the same extension, either before or after
the first attempt finished downloading.

Comment 6

14 years ago
I have this problem on Windows 98 with 0.10.1. I don't think I have a failed
download, but I have a failed installation because I didn't notice that an
extension wasn't compatible with this version.

Comment 7

14 years ago
I had the same problem with uninstalling extensions after I upgraded from .9 to
1.0PR. I ended up creating a new profile and this resolved the issue.
Unfortunatley, this meant I had to reinstall all my extnsions and themes in the
new profile. However, I was able to copy my bookmarks.html from the old profile
to the new profile. You might want to try creating a new profile to see if this
resolves the problem for you.

Comment 8

14 years ago
I am having the same/a similar problem on a Mac with Firefox preview release
1.0.  I started out with a new profile and installed a few extensions.  There
was no problem with the download/install process.

When I click on the remove button for an extension, I get the dialog box, but
the extension is NEVER removed...

Comment 9

14 years ago
*** Bug 260646 has been marked as a duplicate of this bug. ***

Comment 10

14 years ago
I have the same problem using 0.10.1 on XP.
By accident, I found a way to "fix" this, that is remove an "irremovable"
extension - I click on the uninstall button and the "This item will be
uninstalled..." dialog shows up. Then, I restart Windows WITHOUT closing Firefox
or even the Extensions Manager. This "hard restart" clears the unwanted ext...
Hope I provided some additional info for the FF dev team...
Good luck on solving the bug.

Comment 11

14 years ago
Currently having this problem on NT2000, PR1.0.
Extensions "Translate 0.5.5", and "Translation Panel 1.3.6".
Both show up as "This item will be uninstalled when you restart Firefox", but
have been that way for WEEKS and I can't get rid of them.

Comment 12

14 years ago
I have this problem with FoxyTunes 0.61 and some other extention which is listed
as 0_8.xpi
This is a show stopper bug for me. Not being able to properly uninstall
extentions is the sole reason I haven't switched from Mozilla Browser to Firefox.
Flags: blocking-aviary1.0?

Comment 13

14 years ago
without a solid minimal testcase here and time to make serious changes to
extension manager, this isn't going to make the 1.0 train. 
Flags: blocking-aviary1.0? → blocking-aviary1.0-

Comment 14

14 years ago
Does not work in RC2 for me. This is a pretty major brocken feature. If this
does not make it into 1.0 that would look very bad.

Comment 15

14 years ago
(In reply to comment #13)
> without a solid minimal testcase here and time to make serious changes to
> extension manager, this isn't going to make the 1.0 train. 

If it helps, it usually happens when a new version of an already installed
extension creates a seperate listing in the extension manager. The old version
then simply won't uninstall.

Comment 16

14 years ago
In my case I had a fresh install of Firefox and a fresh extension install. No
duplicate installs.

Comment 17

14 years ago
*** Bug 269627 has been marked as a duplicate of this bug. ***

Comment 18

14 years ago
I'm using 1.0, and the problem is still there...

Comment 19

14 years ago
Suggest that bug 269729 is a dupe of this bug and that bug 268133 is a dupe and
/ or related problem.

Comment 20

14 years ago
Can confirm that this problem exists for me since upgrading to 1.0 final. I'm
stuck on "This item will be uninstalled after you restart Firefox" with the
following extensions:

1. PRGooglebar 0.9.024
2. Search Status 1.0.4

Comment 21

14 years ago
I'm also having this problem. I have Firefox 1.0 on Linux, and I just started
with a clean profile, hoping there was just something wrong with mine. No such
luck. The first two extensions I installed (Outsidebar and Resize Search Box)
via update.mozilla.org are exhibiting the problem. In my case, Outsidebar is
shown as "This item will be installed after you restart Firefox." and Resize
Search Box is shown as "This item will be uninstalled after you restart
Firefox." I've had others that were apparently going to be disabled after a
restart, but none of these things ever happen, no matter how many times I
restart Firefox.

Comment 22

14 years ago
I've had this problem on Firefox 1.0, running on Suse Linux 8.2.

It was caused by a buggy extension.
The extension was:
ResizeSearchBox V 0.0.2
Was cured by installing V0.0.4 of resize search box.

I managed to see the following on the console while installing, and uninstalling:

1. Installing ResizeSearchBox:
*** nsExtensionManager::_disableObsoleteExtensions - failure, catching exception
so finalize window can close
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.
*** loading the extensions datasource
*** ExtensionManager:_updateManifests: no access privileges to application
directory, skipping.
*** getItemProperty failing for lack of an item. This means getResourceForItem 
               failed to locate a resource for aItemID (item ID =
http://ftp.mozilla.org/pub/mozilla.org/extensions/resize_search_box/resize_search_box-0.0.2-fx.xpi,
property = disabled)
*** getItemProperty failing for lack of an item. This means getResourceForItem 
               failed to locate a resource for aItemID (item ID =
http://ftp.mozilla.org/pub/mozilla.org/extensions/resize_search_box/resize_search_box-0.0.2-fx.xpi,
property = internalName)

At this point the extension manager shows the following:
"This item will be installed after you restart firefox"

2. Restart firefox:
*** loading the extensions datasource
*** nsExtensionManager::_finishOperations - failure, catching exception so
finalize window can close [Exception... "Cannot modify properties of a
WrappedNative"  nsresult: "0x80570034 (NS_ERROR_XPC_CANT_MODIFY_PROP_ON_WN)" 
location: "JS frame ::
file:///usr/local/firefox1.0/components/nsExtensionManager.js ::
nsExtensionInstaller_install :: line 957"  data: no]

Now the extension manager says:
"This item will be uninstalled after you restart firefox"

3. Restart firefox (again):
*** loading the extensions datasource
*** nsExtensionManager::_finishOperations - failure, catching exception so
finalize window can close [Exception... "Component returned failure code:
0x80520012 (NS_ERROR_FILE_NOT_FOUND) [nsIZipReader.open]"  nsresult: "0x80520012
(NS_ERROR_FILE_NOT_FOUND)"  location: "JS frame ::
file:///usr/local/firefox1.0/components/nsExtensionManager.js ::
nsExtensionInstaller__installExtensionFiles :: line 979"  data: no]

The extension manager still says:
"This item will be uninstalled after you restart firefox"

Comment 23

14 years ago
comment 22: were you able to install the extension?

I think your problem is caused by bug 266965. The 0.2 version of the extension
has the jar in "Chrome" subdirectory of the xpi instead of "chrome". Since
Windows is case insensitive, the bug was not visible to the extension author and
other Windows users.

Comment 24

14 years ago
Nickolay, I think you're correct.

The Problem that Nathan reported in comment 21 is probably the same bug too.

The other people reporting this problem should look at what is displayed to the
console when installing, or starting Firefox.
This should give the developers osome clue as to what's going wrong.

Also I found that each extension is stored in the profile in a directory such as:
extensions/{dc0fa13d-3daf-73ec-e852-912722c85309}/ 
If you look in these extension directories there should be a file:
uninstall/Uninstall
The extension that was causing the problem had an empty Uninstall file.

Comment 25

14 years ago
Something most probably related to this bug is the following: I was using
Tabbrowser Preferences (TBP) v.0.6.13 with FF1.0 PR. I upgraded to FF 1.0 (not a
clean instalatioin) and I was notified that my version of TBP is not compatible
with my new FF version and that it would be deactivated. I went to the
Extensions Manager, tried to Uninstall it. TBP turned blue and a sentence in red
colour appeared: "This item will be uninstalled after you restart Firefox.".
Have tried to restart both FF and my computer but the entry is still there. 
Would the deletion of the relevant folder (C:\Documents and Settings\User
Name\Application
Data\Mozilla\Firefox\Profiles\default.hlm\{9b9d2aaa-ae26-4447-a7a1-633a32b19ddd}
be of help?

Comment 26

14 years ago
I tried reinstalling firefox too... but it posed no use.... would I need to
delete regisrty keys then restart?

Comment 27

13 years ago
I found that all of the extensions that I had Disabled first and then tried
Uninstalled later would never be removed from the Extensions Manager. They
continue to read "The extension will be removed when you restart FF" but they
never do. The option to re-enable these extensions is disabled too.

Comment 28

13 years ago
Chris (comment 27): If you think you can reproduce this bug reliably by
disabling (any) extension and uninstalling it afterwards, please file a separate
bug and CC me on it. FWIW, I can't reproduce it (by disabling InfoLister
extension, restarting Firefox and uninstalling the extension).

Comment 29

13 years ago
Nickolay:  I checked this morning and the extensions are now gone. I didn't do
anything in particular other than boot-up the computer a few times over the
weekend.  It's an odd behaviour.  I'll keep an eye out if I install any new
extensions to see if I can find a commonality between the extensions that I had
trouble uninstalling.

Comment 30

13 years ago
Extension bandwidth test cannot be uninstalled

Comment 32

13 years ago
It's not clear what may cause this bug, but the problematic code that's patched
in bug 266965 may be responsible for it too, setting a dependency. Still, as
described, that bug (which is about a badly broken version of extension that
doesn't even install) isn't a dupe of this one.
Depends on: 266965

Comment 33

13 years ago
*** Bug 291353 has been marked as a duplicate of this bug. ***

Comment 34

13 years ago
Firefox 1.0.3
FoxyVoice 0.1
I must not fear! 1.0

Same Problem! Guys do something about this! You are known for resolving bugs
much faster than Microsoft!

Comment 35

13 years ago
Windows XP Home SP2: Had this same problem with other versions and it is 
sporadic. Extension often disappears (finally after reboot of system). However 
have just had the problem with 1.02 and Foxy Tunes. I tracked down the chrome 
folder in profiles and deleted it. Now the browser hangs (loads but it's dead). 
Downloaded and installed 1.03 over 1.02 and that's dead too (am having to use 
the antichrist's software to report this).

Gents, this problem does exist whether you can reproduce it or not. At least 
allow us the option to delete the extension if it is causing a problem. It's 
crude but it's something.

Comment 36

13 years ago
I do have the same problem with FireFox 1.0.4 on Windows 2000 SP4
Is there any workaround? The fact is that the extension is not uninstall. It's 
still working...
Version: unspecified → 1.0 Branch
*** Bug 271083 has been marked as a duplicate of this bug. ***

Comment 38

13 years ago
I have two people claiming my extension "Grab and Drag" won't Sumrall; Works ok
for me. Might be worth examining for hints of the problem?
https://addons.mozilla.org/extensions/moreinfo.php?id=1250

Comment 39

13 years ago
I've had the same problem on alot of mine, and it's never really bugged me before,  I've had about 3 that won't uninstall for about half a year, but now one (new) that I tried to uninstall failed, and now it's not only messing up other extensions it makes it so I can't open a new window in firefox, but for links I have to right click and click "open tab". I could deal with that, what I can't deal with is it seems it's also **** with the downloader and I can't even download anything using firefox anymore...so what I'm asking is that has this been fixed yet? Cause since the others have been like they are so long, I Doubt it will just "go away" eventually.

Comment 40

13 years ago
It may just be the extension it's happening with that these problems are happening, but now I also can't open a 2nd firefox window (like a main window from the icon, not the link) after opening the first and X out of it, so do open a 2nd FF window I have to restart my computer...any idea why the hell this is happening?

Comment 41

13 years ago
the earthlink extension for Firefox installs, but won't uninstall
The methodology used to uninstall extensions has changed in 1.5. If you have an extension that fails to uninstall it is not this bug and there are a couple of other bugs relating to this for 1.5 
lauchenauer, is this a problem for you with Firefox 1.5?
Assignee: bugs → nobody
QA Contact: bugs → extension.manager
This is WFM in Firefox 1.5
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.