right arrow when at the end of last text text widget or document causes lost caret/focus

VERIFIED FIXED in M16

Status

()

Core
Editor
P2
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: Kathleen Brade, Assigned: mjudge)

Tracking

({relnote})

Trunk
relnote
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
* click into the url bar in the browser
* select all of the text and delete it
* type "www.mozilla.org"
* press the right arrow key
notice that the caret disappears

this also happens in Composer

Comment 1

18 years ago
setting to m15
Target Milestone: M15

Comment 2

18 years ago
this might be a mike bug (arrow keys are handled by selection).  i'll look into 
it and reassignif needed.
Status: NEW → ASSIGNED

Comment 3

18 years ago
I see on Windows too. Build: 2000020108 WinNT 4 SP6

Comment 4

18 years ago
reassigning to mjudge; mike, i looked at this and dont see any weirdness with the 
content.  If you have <html>foo</html> and right array past the end of "foo", the 
caret goes away.  I think something bad is happening to selection when arrowing.
Assignee: jfrancis → mjudge
Status: ASSIGNED → NEW

Comment 5

18 years ago
This happens on any text field. In form textareas or input texts. on winNT build  
2000021408. Marking OS as ALL.
OS: Mac System 8.5 → All
(Reporter)

Comment 6

18 years ago
*** Bug 27877 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

18 years ago
*** Bug 27877 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

18 years ago
*** Bug 27958 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 9

18 years ago
*** Bug 28574 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 10

18 years ago
*** Bug 28574 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

18 years ago
*** Bug 29642 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Hardware: Macintosh → All

Comment 12

18 years ago
*** Bug 30800 has been marked as a duplicate of this bug. ***

Comment 13

18 years ago
*** Bug 30815 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
This happens also during mail/news message composition which makes writing mail 
dangerous as I navigate a lot there with cursors.
(Reporter)

Comment 15

18 years ago
upping to P2; Mike thinks this should be an easy one to fix
Priority: P3 → P2
(Reporter)

Updated

18 years ago
Keywords: relnote
(Reporter)

Comment 16

18 years ago
*** Bug 29088 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 17

18 years ago
*** Bug 21935 has been marked as a duplicate of this bug. ***
nominating for beta1 --adding self to cc list as this also affects my area
(Prefs).
Keywords: beta1

Comment 19

18 years ago
Putting on PDT- radar for beta1.
Whiteboard: [PDT-]

Comment 20

18 years ago
*** Bug 32026 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
*** Bug 32429 has been marked as a duplicate of this bug. ***

Comment 22

18 years ago
I changed the summary to include case of editing a page in mail or web 
composer. Simply using right arrow when at the end messes up the selection.
This currently causes an assert in nsInterfaceState code because 
UpdateParagraphState() is failing. I examined that code and it turns out the
anchor node of the selection is a XULElement whose tagname is "scrollbarbutton"!
Pretty weird!
Summary: right arrow when in text widget causes lost caret/focus → right arrow when at the end of last text text widget or document causes lost caret/focus

Comment 23

18 years ago
*** Bug 34049 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 24

18 years ago
*** Bug 34372 has been marked as a duplicate of this bug. ***

Comment 25

18 years ago
*** Bug 34777 has been marked as a duplicate of this bug. ***

Comment 26

18 years ago
moving to M16
Target Milestone: M15 → M16
(Assignee)

Comment 27

18 years ago
*** Bug 30038 has been marked as a duplicate of this bug. ***

Comment 28

18 years ago
*** Bug 33770 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 29

18 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 30

18 years ago
verified in 10/25 build.
Status: RESOLVED → VERIFIED

Comment 31

17 years ago
This bug still happens in xul textboxes other than the location bar (search 
sidebar, cookie manager).  Reopening.
Status: VERIFIED → REOPENED
Keywords: beta1 → nsbeta1
Resolution: FIXED → ---

Comment 32

17 years ago
Also still happens in composer at the url 
http://bugzilla.mozilla.org/show_bug.cgi?noid, so this might be a regression.

Fwiw, if you hold shift while testing this bug in the search sidebar or in the 
cookie manager, you'll notice that text is selected from where you started 
holding text to the *beginning* of the text field.

Updated

17 years ago
Blocks: 62506

Comment 33

17 years ago
*** Bug 62506 has been marked as a duplicate of this bug. ***

Comment 34

17 years ago
I can't repro this on a current windows build, using textfields, textareas and 
the URL bar

remarking fixed
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED

Comment 35

17 years ago
I still see this problem for the cases I mentioned in my last comment.  Should 
I file a new bug or reopen this one again?

Comment 36

17 years ago
yes, can you open a new bug about the shift problem

Comment 37

17 years ago
Posted bug 68367 for the search sidebar's textbox and bug 68368 for 
show_bug.cgi in composer.

Comment 38

17 years ago
I still see this at least for the cache size text box, the homepage URL in
prefs, the wrap plain text messages at xx characters still in prefs, and in
dialogs involing bookmark properties. Using B2001020904 on WinME.

Comment 39

17 years ago
matxdr@yahoo.com, that should be covered by bug 68367.

Comment 40

17 years ago
Aha, I can reproduce it too (on linux), in the homepage url in prefs.  Reopening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 41

17 years ago
Oops, I missed Jesse's comment about the other bug covering this issue.  Closing
again, sorry ...
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → FIXED

Comment 42

17 years ago
verified in 3/6 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.