Build SeaMonkey locales from Mercurial (--enable-ui-locale / source L10n)

RESOLVED FIXED in seamonkey2.0b1

Status

SeaMonkey
Build Config
RESOLVED FIXED
13 years ago
9 years ago

People

(Reporter: Robert Kaiser, Assigned: Robert Kaiser)

Tracking

Trunk
seamonkey2.0b1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

13 years ago
Followup on bug 279768 but for SeaMonkey.

gandalf told us he has to do most of SeaMonkey stuff for Thunderbird anyways, so
getting this to SeaMonkey afterwards should be much easier to do than for the
other applications.

Updated

13 years ago
No longer depends on: 286108
taking. I will try to find time for this once Thunderbird is ready.
Assignee: nobody → gandalf
(Assignee)

Updated

13 years ago
Blocks: 57878

Updated

13 years ago
Blocks: 286108
No longer blocks: 286108
(Assignee)

Updated

13 years ago
Depends on: 286108
(Assignee)

Updated

13 years ago
Blocks: 179949
Created attachment 186213 [details] [diff] [review]
Remove/change double entities [checked in]

This is SeaMonkey version of the same patch attached to the bug 286108.

Comment 3

13 years ago
Comment on attachment 186213 [details] [diff] [review]
Remove/change double entities [checked in]

Okay, looks good.
Attachment #186213 - Flags: review+
(Assignee)

Comment 4

13 years ago
Comment on attachment 186213 [details] [diff] [review]
Remove/change double entities [checked in]

requesting sr - this just removes duplicate entitities from messenger.dtd,
changing the name of one of them to a unique name.
Attachment #186213 - Flags: superreview?(bzbarsky)
Attachment #186213 - Flags: superreview?(bzbarsky) → superreview+
(Assignee)

Updated

13 years ago
Attachment #186213 - Flags: approval1.8b3?

Updated

13 years ago
Attachment #186213 - Flags: approval1.8b3? → approval1.8b3+
(Assignee)

Comment 5

13 years ago
Comment on attachment 186213 [details] [diff] [review]
Remove/change double entities [checked in]

Checked in that correctness patch. Thanks Pavel!
Attachment #186213 - Attachment description: Remove/change double entities → Remove/change double entities [checked in]
(Assignee)

Updated

12 years ago
Depends on: 325473
(Assignee)

Updated

12 years ago
Depends on: 328317
(Assignee)

Comment 6

12 years ago
I just landed the merge of all language files into a single en-US.jar on trunk, which means we have progressed a major step twoards fixing this issue as well.

Along with the work for removing the separate content packs, I've introduced suite/locales/ with one files already being built from there - this means that pref-locales.dtd is the first suite-specific file to follow the source L10n model :)

More important than this single file is that the infrastructure for moving L10n files over to the new approach is now there, and I will start to work on that within the next weeks.
(Assignee)

Comment 7

12 years ago
Created attachment 217766 [details] [diff] [review]
prepare build environment for --enable-ui-locale in suite [checked in]

This patch makes client.mk check out the locales directories we need for suite when building a different locale and adds an empty all-locales file to suite/locales.

I'd like to add "de" as a test locale to /l10n and the all-locales file but I think I have to talk to Pike about that first...
Assignee: gandalf → kairo
Status: NEW → ASSIGNED
Attachment #217766 - Flags: review?(benjamin)
(Assignee)

Updated

12 years ago
Depends on: 333383
(Assignee)

Updated

12 years ago
Attachment #217766 - Attachment description: prepare build environment for --enable-ui-loace in suite → prepare build environment for --enable-ui-locale in suite

Updated

12 years ago
Attachment #217766 - Flags: review?(benjamin) → review+
(Assignee)

Comment 8

12 years ago
Comment on attachment 217766 [details] [diff] [review]
prepare build environment for --enable-ui-locale in suite [checked in]

This one's in as well, thanks!
So now comes the part of getting stuff into suite/locales...
Attachment #217766 - Attachment description: prepare build environment for --enable-ui-locale in suite → prepare build environment for --enable-ui-locale in suite [checked in]
(Assignee)

Updated

12 years ago
Depends on: 334877
(Assignee)

Updated

12 years ago
Depends on: 334936
(Assignee)

Updated

11 years ago
Depends on: 344243
(Assignee)

Updated

11 years ago
Depends on: 346133
(Assignee)

Updated

11 years ago
Depends on: 349220
(Assignee)

Updated

11 years ago
Depends on: 366962
Depends on: 376782
(Assignee)

Updated

11 years ago
Depends on: 377799
(Assignee)

Updated

11 years ago
Depends on: 304309
(Assignee)

Updated

11 years ago
Depends on: 377801
(Assignee)

Updated

11 years ago
Depends on: 380347
(Assignee)

Updated

11 years ago
Depends on: 381157
(Assignee)

Updated

10 years ago
Depends on: 387280
(Assignee)

Updated

10 years ago
Depends on: 387279
(Assignee)

Updated

10 years ago
Blocks: 390025
(Assignee)

Updated

10 years ago
Depends on: 391656
(Assignee)

Updated

10 years ago
Depends on: 397501
(Assignee)

Updated

10 years ago
No longer blocks: 390025
Depends on: 390025
Duplicate of this bug: 401104
(Assignee)

Comment 10

10 years ago
As announced in http://home.kairo.at/blog/2007-11/source_l10n_available_for_seamonkey_trun and in the mozilla.dev.l10n newsgroup, we are now able to add languages to the "source L10n" framework.

The dependencies of this bug still cause errors on the generated builds, esp. in password manager, download manager and Windows integration, I'll leave the bug here open until those have been fixed and localized builds work correctly.
(Assignee)

Updated

10 years ago
Blocks: 403990, 404005, 404016

Updated

10 years ago
Blocks: 404067

Updated

10 years ago
Blocks: 404086
(Assignee)

Updated

10 years ago
Duplicate of this bug: 406853
(Assignee)

Updated

10 years ago
Depends on: 441050
No longer depends on: 380347
(Assignee)

Updated

10 years ago
Duplicate of this bug: 441116

Updated

9 years ago
Blocks: 445139
(Assignee)

Updated

9 years ago
Summary: Build SeaMonkey locales from CVS (--enable-ui-locale / source L10n) → Build SeaMonkey locales from Mercurial (--enable-ui-locale / source L10n)

Updated

9 years ago
Blocks: 376775
(Assignee)

Comment 13

9 years ago
Now that all dependent bugs are fixed, the Mercurial-base L10n are fully working, starting from tomorrow (when we have new nightlies), those are available from the old build machines in http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-central-l10n/ and from the new ones in http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/latest-comm-1.9.1-l10n/
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
You need to log in before you can comment on or make changes to this bug.