file selection dialog forgets filenames on chdir

VERIFIED FIXED

Status

()

P2
normal
VERIFIED FIXED
20 years ago
18 years ago

People

(Reporter: akkzilla, Assigned: bryner)

Tracking

({platform-parity})

Trunk
x86
Linux
platform-parity
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+] 6/1[STILL HAPPENS])

Attachments

(1 attachment)

(Reporter)

Description

20 years ago
In the Linux viewer, try "Debug Save", which brings up a file selection dialog
with the filename set to the name of the current page (e.g. test0.html).
Double-click on .. in the directory list, to move up one directory.  The
filename goes away -- now it's trying to save to a null filename (apparently).
Now hit OK -- the app crashes (because the backend routines have no error
checking for a bad filename -- I've filed a separate bug, 3023, on that).

The filename should stay set even when the user changes directories.

Comment 1

20 years ago
per leger, assigning QA contacts to all open bugs without QA contacts according
to list at http://bugzilla.mozilla.org/describecomponents.cgi?product=Browser

Updated

20 years ago
Assignee: kmcclusk → pavlov

Updated

20 years ago
Status: NEW → ASSIGNED
Target Milestone: M7

Comment 2

20 years ago
changing to m7 as this isn't very important imho.

Updated

20 years ago
Summary: file selection dialog forgets filenames on chdir → [PP]file selection dialog forgets filenames on chdir
(Reporter)

Comment 3

20 years ago
This may be a bug in the gtk file selection box; I've seen the same problem in
other gtk apps.

Comment 4

20 years ago
Marking M8.  If you plan to fix any of these for m7, mark them so.

Updated

20 years ago
Target Milestone: M8 → M10

Comment 5

20 years ago
this will require changing the file selection dialog a lot.  (i'll do it.  just
later.)

Comment 6

19 years ago
Moving all Widget Set bugs, past and present, to new HTML Form Controls
component per request from karnaze.  Widget Set component will be retired
shortly.

Comment 7

19 years ago
moving to XP Toolkit/Widgets since these are not HTML form controls

Updated

19 years ago
Target Milestone: M10 → M13

Updated

19 years ago
Target Milestone: M13 → M14

Comment 8

19 years ago
mass moving m14 bugs to m15

Comment 9

19 years ago
dividing up phillips bugs, he no longer works here

Updated

19 years ago
Target Milestone: M15 → M16

Updated

19 years ago
Keywords: pp

Comment 10

19 years ago
*** Bug 26203 has been marked as a duplicate of this bug. ***
Depends on: 26480

Updated

19 years ago
Summary: [PP]file selection dialog forgets filenames on chdir → file selection dialog forgets filenames on chdir

Comment 11

19 years ago
*** Bug 24908 has been marked as a duplicate of this bug. ***

Comment 12

19 years ago
Adding the "dogfood" keyword attracted by bug 24908, "[ANNOYING] Changing 
directory CLEARS filename when downloading.", and cc-ing german@netscape.com,
who was made owner of that bug.
Keywords: dogfood

Comment 13

19 years ago
jar says this behavior is present in 4.7 as well. PDT-
Whiteboard: [PDT-]

Comment 14

19 years ago
*** Bug 30932 has been marked as a duplicate of this bug. ***

Comment 15

19 years ago
*** Bug 29981 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Keywords: dogfood
Whiteboard: [PDT-]
(Reporter)

Comment 16

19 years ago
Pavlov removed the dogfood keyword, so I'm adding a beta2.  It's really hard to
do much involving saving or opening files until this bug is fixed -- really, the
only way to use the current file selection dialog is to ignore the gui and type
full pathnames into the text field. :-)

(Hopefully someone will write an html fsb before beta2 and all these bugs will
just go away.)
Keywords: beta2

Comment 17

19 years ago
*** Bug 32403 has been marked as a duplicate of this bug. ***

Comment 18

19 years ago
*** Bug 33025 has been marked as a duplicate of this bug. ***

Updated

19 years ago
Depends on: 6783
Whiteboard: fixed -- waiting for 6783
Target Milestone: M16 → M15

Comment 19

19 years ago
actually, i havn't quite fixed this yet.  it is a trival change now though.
No longer depends on: 6783
Whiteboard: fixed -- waiting for 6783

Comment 20

19 years ago
Mass-moving most M15 bugs to M16
Target Milestone: M15 → M16

Updated

19 years ago
Keywords: nsbeta2

Comment 21

19 years ago
Can we get a retest with the latest build please?  Thanks!
Keywords: beta2
Whiteboard: [RETEST NEEDED]
oh, yeah --this is still a problem. :-) [tested using 2000.04.27.09]

pavlov, what's your status on this?
Hardware: PC → Other
(Reporter)

Updated

19 years ago
Hardware: Other → PC
Whiteboard: [RETEST NEEDED] → [STILL HAPPENS]
(Reporter)

Comment 23

19 years ago
This is still a problem: Save As in the editor and browser windows use the old
file selection dialog, which has the problem, whereas Open File in the editor
uses the new file selection dialog, which unfortunately has the same problem
(plus a bunch of new layout-related problems).  So simply hooking up the new
dialog for Save As won't cure the problem, alas.

Comment 24

19 years ago
[nsbeta2+] please fix before 6/1
Whiteboard: [STILL HAPPENS] → [nsbeta2+] 6/1[STILL HAPPENS]

Updated

19 years ago
Blocks: 40158

Comment 25

19 years ago
*** Bug 40165 has been marked as a duplicate of this bug. ***
Keywords: mostfreq

Comment 26

19 years ago
*** Bug 40274 has been marked as a duplicate of this bug. ***

Comment 27

19 years ago
Mass-moving all dated nsbeta2+ bugs to M19
Target Milestone: M16 → M19
*spam*: transferring current XP Menu bugs over to jrgm, the new component owner.
feel free to add me to the cc list (unless am the Reporter) of any of these, if
you have any questions/etc.
QA Contact: sairuh → jrgm
ugh, these should go back to me...
QA Contact: jrgm → sairuh
(Assignee)

Comment 30

19 years ago
This patch fixes the problem (in the xp filepicker).  Basically, it uses this 
rule:  If the user has clicked a file in the filepicker (and its name is in the 
textfield), then we clear that on a directory change.  If the user has typed 
something in, we keep that on a directory change.  This also changes the 
textfield to show just the filename (when you click on a file), instead of the 
whole path.
(Assignee)

Comment 31

19 years ago
Created attachment 9459 [details] [diff] [review]
Proposed fix

Comment 32

19 years ago
will this patch fix it for good? if so will it be in the next milestone or what?
(Assignee)

Comment 33

19 years ago
Pavlov, can you review this patch when you get a chance?
(Assignee)

Comment 34

19 years ago
I've got this one.
Assignee: pavlov → bryner
Status: ASSIGNED → NEW
(Assignee)

Comment 35

19 years ago
Patch is now checked in.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 36

19 years ago
Is this really fixed?  I still get this consistently!  :-/
(Assignee)

Comment 37

19 years ago
This is fixed for the XP filepicker.  The Open File menu item is still hooked up 
to the native filepicker.

Comment 38

19 years ago
I am still seeing this on the FTP download dialog for Linux build 2000060508. 

What is the XP filepicker anyways?
(Reporter)

Comment 39

19 years ago
Can someone please list here the bugs for the various "Please change to use XP
filepicker", so that we can all go join the cc lists for those bugs and find out
when they're slated to be fixed?  The fix for this bug doesn't actually help
usability if it only fixed a dialog no one is using yet.  Let's get everyone
using the XP filepicker.

Comment 40

19 years ago
The main switchover bugs appear to be:
  Bug 36789, "File->Save should use nsIFilePicker instead of nsFileSpecWithUI",
             nsbeta2+
  Bug 39234, "use nsIFilePicker instead of nsFileWidget in Editor", M17
  Bug 37175, "bookmark code should use nsIFilePicker and nsILocaleFile from 
             nsIFileSpec/nsIFileSpecWithUI", LATER
Earlier work was done in bug 6783, "[feature] use nsIFilePicker to replace 
             nsIFileWidget, nsIFileSpecWithUI, etc"

File>Open File and File>Open Web Location>[Browse] should use nsIFilePicker too,
if they don't already, but that's outside of the purview of this bug.
coolio. works using 2000.06.07.10 linux opt comm bits.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.