Rebrand Firefox trunk and 1.8 branch builds to avoid confusion

RESOLVED FIXED in Firefox 2 alpha1

Status

()

P2
minor
RESOLVED FIXED
14 years ago
5 years ago

People

(Reporter: willyaranda, Assigned: beltzner)

Tracking

({fixed1.8.1})

Trunk
Firefox 2 alpha1
fixed1.8.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking-firefox2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments, 6 obsolete attachments)

57.83 KB, image/png
Details
15.92 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
1.24 KB, patch
mconnor
: review+
dbaron
: superreview+
Details | Diff | Splinter Review
1.39 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
15.97 KB, patch
mconnor
: review+
Details | Diff | Splinter Review
280 bytes, text/plain
mconnor
: review+
Details
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050917 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20050917 Firefox/1.6a1

I think that Mozilla Foundation should rename the trunk version of Firefox. It
name is Deer Park Alpha 2 and it is confusing for the people, it can be confuse:
Firefox 1.5 alpha is Deer Park Alpha 2 (with Gecko 1.8 branch) and Firefox 1.5+
(1.6a1) with Gecko 1.9 is Deer Park Alpha 2. I think that a good name can be
"The Ocho alpha 1" (codename of the Firefox 2)

Reproducible: Always

Updated

14 years ago
Summary: Mozilla.org should rename Firefox 1.6a1 (aka Deer Park) for avoid confusion with 1.0+ (Firefox 1.5alpha) → Rebrand Firefox 1.6a1 builds from Deer Park to The Ohco to avoid confusion

Updated

14 years ago
Flags: blocking1.9a1?
Summary: Rebrand Firefox 1.6a1 builds from Deer Park to The Ohco to avoid confusion → Rebrand Firefox 1.6a1 builds from Deer Park to The Ocho to avoid confusion

Comment 1

14 years ago
Still need any folders and icons with deerpark in the name to be renamed to
theocho...donno who can do those. Thunderbird patch coming up.

Comment 2

14 years ago
(In reply to comment #1)
> Created an attachment (id=199008) [edit]
> Patch for Firefox/Webtools/startpage
> 
> Still need any folders and icons with deerpark in the name to be renamed to
> theocho...donno who can do those. Thunderbird patch coming up.

Nevermind, thought TB was rebranded to deer park also.

Comment 3

14 years ago
Forgot to mention that with my patch the title bar will report 'The Ocho
(Nightly Build)' to try and furthermore try to prevent confusion on these being
stable releases.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

14 years ago
Assignee: nobody → supernova_00
Status: ASSIGNED → NEW

Updated

14 years ago
Attachment #199008 - Flags: review?(mconnor)

Comment 4

14 years ago
*** Bug 313898 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Bug 294399 was the original rebranding bug for reference.

Comment 7

14 years ago
it definitely should NOT be renamed 'The Ocho', here's why:

"The trunk will not be The Ocho after all. The Ocho will be the 1.8.1 branch which firefox 2.0 will be released from. So there is no name to rename the trunk to. The trunk actually continues forever. Only the BRANCHES from the trunk should be renamed.

See the NEW roadmap draft image:
http://cbeard.typepad.com/photos/uncategorized/releaseroadmapdraftv1_2.png

But I do agree that "Deer Park" is NOT an appropriate name for the trunk.

I think it should be renamed 'Mozilla Firefox Trunk' and then whenever they branch, just rename it to 'Mozilla Firefox'."

Comment 8

14 years ago
This shows why the trunk shouldn't be renamed to "The Ocho" but rather to something like "Mozilla Firefox [Trunk]"

Comment 9

14 years ago
Comment on attachment 199008 [details] [diff] [review]
Patch for Firefox/Webtools/startpage

obsoleteing attachment since 2.0 will be from the branch...this bug should probably be close but I'll leave that up to someone else incase what I stated above isn't true.
Attachment #199008 - Attachment is obsolete: true
Attachment #199008 - Flags: review?(mconnor)

Comment 10

14 years ago
(In reply to comment #9)
> (From update of attachment 199008 [details] [diff] [review] [edit])
> obsoleteing attachment since 2.0 will be from the branch...this bug should
> probably be close but I'll leave that up to someone else incase what I stated
> above isn't true.
> 

What you said was true.

I think you should open a new bug saying that the Trunk should NOT be named "Deer Park" and be named either just "Mozilla Firefox" or "Mozilla Firefox [Trunk]"

Comment 11

14 years ago
(In reply to comment #10)
> (In reply to comment #9)
> > (From update of attachment 199008 [details] [diff] [review] [edit] [edit])
> > obsoleteing attachment since 2.0 will be from the branch...this bug should
> > probably be close but I'll leave that up to someone else incase what I stated
> > above isn't true.
> > 
> 
> What you said was true.
> 
> I think you should open a new bug saying that the Trunk should NOT be named
> "Deer Park" and be named either just "Mozilla Firefox" or "Mozilla Firefox
> [Trunk]"
> 

Or brand it "The Next++; Big Thing"... ;)

Comment 12

14 years ago
Can't it just be Firefox Nightly?

Nah, too simple ;-)

Robin

Comment 13

14 years ago
(In reply to comment #12)
> Can't it just be Firefox Nightly?
> 
> Nah, too simple ;-)
> 
> Robin
> 

How about just lablel by it what it is as in "Trunk Nightly"

The 1.8.x branch is Firefox 1.5 and then on to Firefox 2.0 right? so how about just separating the Trunk by not really giving it a name other than naming it by what it is as in "Trunk Nightly" for example.

Comment 14

14 years ago
*** Bug 318832 has been marked as a duplicate of this bug. ***
I submitted bug 322132 for going back to the pre-DPA1 state ("Browser"/"Gecko Browser").
*** Bug 322132 has been marked as a duplicate of this bug. ***
Summary: Rebrand Firefox 1.6a1 builds from Deer Park to The Ocho to avoid confusion → Rebrand Firefox trunk builds to avoid confusion
Severity: trivial → minor
Version: unspecified → Trunk
Note: this is without the webtools part Kurt had in his patch.

Also, changes to the browser/app/macbuild/dsstore are probably required, since it contains the "DeerPark" string, but it's a Mac binary file I have no idea about. ;-)

The new image for the about dialog is in attachment 207354 [details] (browser/base/branding/about.png).

Comment 19

13 years ago
Comment on attachment 207357 [details] [diff] [review]
Patch reverting brand names back to "Gecko Browser"

>Index: configure.in
>===================================================================
>RCS file: /cvsroot/mozilla/configure.in,v
>retrieving revision 1.1577
>diff -u -8 -p -r1.1577 configure.in
>--- configure.in	23 Dec 2005 21:05:20 -0000	1.1577
>+++ configure.in	2 Jan 2006 19:20:58 -0000
>@@ -4170,17 +4170,17 @@ suite)

>-  MOZ_APP_DISPLAYNAME=DeerPark
>+  MOZ_APP_DISPLAYNAME=GeckoBrowser

I think the equivalent of 'DeerPark' in unofficial branding terms is 'Browser'. According to the mozilla/browser/locales/en-US/chrome/branding/brand.dtd changes in https://bugzilla.mozilla.org/attachment.cgi?id=184025&action=diff anyway.

>Index: configure
>===================================================================
>RCS file: /cvsroot/mozilla/configure,v
>retrieving revision 1.1574
>diff -u -8 -p -r1.1574 configure
>--- configure	1 Jan 2006 12:26:12 -0000	1.1574
>+++ configure	2 Jan 2006 19:21:15 -0000
>@@ -12922,17 +12922,17 @@ suite)

>-  MOZ_APP_DISPLAYNAME=DeerPark
>+  MOZ_APP_DISPLAYNAME=GeckoBrowser

Changes to configure aren't needed, they'll be automatically generated.

>Index: browser/app/macbuild/license.r
>===================================================================
>RCS file: /cvsroot/mozilla/browser/app/macbuild/license.r,v
>retrieving revision 1.1
>diff -u -8 -p -r1.1 license.r
>--- browser/app/macbuild/license.r	18 Aug 2005 13:29:53 -0000	1.1
>+++ browser/app/macbuild/license.r	2 Jan 2006 19:21:15 -0000
>@@ -22,39 +22,39 @@ resource 'STR#' (5000, "English") {

>-    "You are about to install Deer Park.\n"
>+    "You are about to install Gecko Browser.\n"

Browser?

>-  "DEER PARK END-USER SOFTWARE LICENSE AGREEMENT\n"
>+  "GECKO BROWSER END-USER SOFTWARE LICENSE AGREEMENT\n"

BROWSER?

>-  "A SOURCE CODE VERSION OF CERTAIN DEER PARK BROWSER FUNCTIONALITY THAT YOU MAY USE, MODIFY AND DISTRIBUTE IS AVAILABLE TO YOU FREE-OF-CHARGE FROM WWW.MOZILLA.ORG UNDER THE MOZILLA PUBLIC LICENSE and other open source software licenses.\n"
>+  "A SOURCE CODE VERSION OF CERTAIN GECKO BROWSER FUNCTIONALITY THAT YOU MAY USE, MODIFY AND DISTRIBUTE IS AVAILABLE TO YOU FREE-OF-CHARGE FROM WWW.MOZILLA.ORG UNDER THE MOZILLA PUBLIC LICENSE and other open source software licenses.\n"

BROWSER?

>-  "The accompanying executable code version of Deer Park and related documentation (the �Product�) is made available to you under the terms of this DEER PARK END-USER SOFTWARE LICENSE AGREEMENT (THE �AGREEMENT�).  BY CLICKING THE �ACCEPT� BUTTON, OR BY INSTALLING OR USING THE DEER PARK BROWSER, YOU ARE CONSENTING TO BE BOUND BY THE AGREEMENT.  IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT CLICK THE �ACCEPT� BUTTON, AND DO NOT INSTALL OR USE ANY PART OF THE DEER PARK BROWSER.\n"
>+  "The accompanying executable code version of Gecko Browser and related documentation (the �Product�) is made available to you under the terms of this GECKO BROWSER END-USER SOFTWARE LICENSE AGREEMENT (THE �AGREEMENT�).  BY CLICKING THE �ACCEPT� BUTTON, OR BY INSTALLING OR USING THE GECKO BROWSER BROWSER, YOU ARE CONSENTING TO BE BOUND BY THE AGREEMENT.  IF YOU DO NOT AGREE TO THE TERMS AND CONDITIONS OF THIS AGREEMENT, DO NOT CLICK THE �ACCEPT� BUTTON, AND DO NOT INSTALL OR USE ANY PART OF THE GECKO BROWSER.\n"

BROWSER...?

>-  "DURING THE DEER PARK INSTALLATION PROCESS, AND AT LATER TIMES, YOU MAY BE GIVEN THE OPTION OF INSTALLING ADDITIONAL COMPONENTS FROM THIRD-PARTY SOFTWARE PROVIDERS.  THE INSTALLATION AND USE OF THOSE THIRD-PARTY COMPONENTS MAY BE GOVERNED BY ADDITIONAL LICENSE AGREEMENTS.\n"
>+  "DURING THE GECKO BROWSER INSTALLATION PROCESS, AND AT LATER TIMES, YOU MAY BE GIVEN THE OPTION OF INSTALLING ADDITIONAL COMPONENTS FROM THIRD-PARTY SOFTWARE PROVIDERS.  THE INSTALLATION AND USE OF THOSE THIRD-PARTY COMPONENTS MAY BE GOVERNED BY ADDITIONAL LICENSE AGREEMENTS.\n"

BROWSER?

>Index: browser/base/branding/uninstall.properties
>===================================================================
>RCS file: /cvsroot/mozilla/browser/base/branding/uninstall.properties,v
>retrieving revision 1.1
>diff -u -8 -p -r1.1 uninstall.properties
>--- browser/base/branding/uninstall.properties	27 Jul 2005 18:24:54 -0000	1.1
>+++ browser/base/branding/uninstall.properties	2 Jan 2006 19:21:16 -0000
>@@ -1,6 +1,6 @@

>-fileUninstall=UninstallDeerPark.exe
>+fileUninstall=UninstallGeckoBrowser.exe

Browser?

>Index: browser/base/content/browserconfig.properties
>===================================================================
>RCS file: /cvsroot/mozilla/browser/base/content/browserconfig.properties,v
>retrieving revision 1.4
>diff -u -8 -p -r1.4 browserconfig.properties
>--- browser/base/content/browserconfig.properties	20 May 2005 22:42:49 -0000	1.4
>+++ browser/base/content/browserconfig.properties	2 Jan 2006 19:21:16 -0000
>@@ -1,2 +1,2 @@

>-browser.startup.homepage=http://www.mozilla.org/projects/deerpark/
>+browser.startup.homepage=http://www.mozilla.org/projects/firefox/

https://bugzilla.mozilla.org/attachment.cgi?id=184025&action=diff had http://www.mozilla.org/products/firefox/central.html as the URL previously. This now redirects to http://www.mozilla.com/firefox/central/ so I guess you could use that.

>Index: browser/installer/windows/installer.cfg
>===================================================================
>RCS file: /cvsroot/mozilla/browser/installer/windows/installer.cfg,v
>retrieving revision 1.20
>diff -u -8 -p -r1.20 installer.cfg
>--- browser/installer/windows/installer.cfg	18 Oct 2005 15:44:08 -0000	1.20
>+++ browser/installer/windows/installer.cfg	2 Jan 2006 19:21:16 -0000
>@@ -1,17 +1,17 @@

>-FileUninstall             = UninstallDeerPark.exe
>-FileUninstallZIP          = UninstallDeerPark.zip
>+FileUninstall             = UninstallGeckoBrowser.exe
>+FileUninstallZIP          = UninstallGeckoBrowser.zip

Browser?

I'm not a reviewer, but I was in the middle of making a patch for this bug myself (bit of a coincidence) so I thought I'd say what I've found.

As you said mozilla/sources/mozilla/browser/app/macbuild/dsstore (binary) has a reference as does mozilla/sources/mozilla/mail/app/macbuild/dsstore.
Also mozilla/sources/mozilla/build/package/mac_osx/pkg-dmg does too.

Comment 20

13 years ago
I would imagine you'd have to attach the new image to this bug too. At a guess either mconnor@mozilla.com or benjamin@smedbergs.us could review the patch. It might be an idea to ask chase@mozilla.org about tinderbox changes based on bug 294399 comment 68.
Assignee: supernova_00 → nobody
Depends on: 294399
Trunk will just be "Browser" and 1.8 branch will be updated to Bon Echo, waiting on updated graphics.
Assignee: nobody → mconnor
Flags: blocking1.9a1?
Priority: -- → P2
Target Milestone: --- → Firefox1.6-

Comment 22

13 years ago
(In reply to comment #21)
> Trunk will just be "Browser" and 1.8 branch will be updated to Bon Echo,
> waiting on updated graphics.
> 

finally, some real action on this bug! :D

Comment 23

13 years ago
i think that trunk ver should be Firefox (trunk)

Comment 24

13 years ago
(In reply to comment #23)
> i think that trunk ver should be Firefox (trunk)
> 

I agree, "Browser" is too general.

Comment 25

13 years ago
(In reply to comment #21)
> Trunk will just be "Browser" and 1.8 branch will be updated to Bon Echo,
> waiting on updated graphics.
> 

"Browser"? That's almost as poor as calling it "Internet" (Microsoft references notwithstanding). Considering the "Milestone" codenames have been pretty good... perhaps something a little more "worthy" is required to express the bleeding edge nature of trunk development?

Aside form "The Next++; Big Thing", for Gecko 1.9 at least... "Cairo" as the codename should do?

Comment 26

13 years ago
*** Bug 323152 has been marked as a duplicate of this bug. ***
--> taking

Current proposals:

1.8_BRANCH ==> Bon Echo
trunk =======> minefield, canary, boomstam (dutch for "trunk), firefox-trunk
Status: NEW → ASSIGNED
Personally, I like Minefield or Boomstam, but Firefox-Trunk works as well (although, a bit lengthy.)
Assignee: mconnor → beltzner
Status: ASSIGNED → NEW
Status: NEW → ASSIGNED
How about simply, "Netscape 6"

;)
I'd go with Minefield or Boomstam.. Firefox-Trunk is way too generic. :)

Updated

13 years ago
Blocks: 327089
(In reply to comment #30)
> I'd go with Minefield or Boomstam.. Firefox-Trunk is way too generic. :)
> 

Minefield is good. Boomstam is just going to have everyone asking wtf it is. Leave firefox out of it, the less chance that someone thinks of it as a working version of firefox the better I think.
Summary: Rebrand Firefox trunk builds to avoid confusion → Rebrand Firefox trunk and 1.8 branch builds to avoid confusion
*** Bug 325676 has been marked as a duplicate of this bug. ***
"Gecko Browser" is out - we don't own the Gecko trademark, and so that would lead to unnecessary complication.

How about "Firefox-Unstable"? That way, it's clear both that it's a form of Firefox and also that it's a version you shouldn't be using unless you know what you are doing. 

I'd rather we didn't create yet more names (e.g. "Minefield" or "Boomstam"); history tells us that names tend to stick, and then we end up having to do trademark work on them, and finding problems, and changing them, and it's all a mess.

Gerv

Comment 34

13 years ago
How about "Boomstam Minefield" for a bit of Anglo-Dutch creolo? :D
(In reply to comment #33)
> How about "Firefox-Unstable"? That way, it's clear both that it's a form of
> Firefox and also that it's a version you shouldn't be using unless you know
> what you are doing. 

This seems reasonable, but it must also be the name for unofficial builds (e.g. those not using branding stuff from the other-licenses dir), and in the last year we were avoiding the Firefox name outside other-licenses/ (builds without -enable-official-branding were called either Gecko Browser or Deer Park).
Good point - I'd forgotten that. So no Firefox, then.

So does "Firefox 3" have a code name (like Deer Park and Bon Echo) yet? Code names are not so bad as long as they have a fixed, limited lifespan. This prevents them taking on a life of their own.

Gerv

Comment 37

13 years ago
Another idea would be to follow the linux kernal development tradition and have odd numbers like FF 1.5.3 indicate development builds while even number represent either stable or branch builds
(In reply to comment #36)
> So does "Firefox 3" have a code name (like Deer Park and Bon Echo) yet? Code

Not yet, no, The idea behind this is that trunk will get a stable, unchanging codename that always means "this is the trunk build". At the same time, we'll rebrand the 1.8 branch to be "Bon Echo" since its eventual goal is to become the 1.8.1 branch that will be Firefox2.

(In reply to comment #37)
> odd numbers like FF 1.5.3 indicate development builds while even number
> represent either stable or branch builds

I think we have quite enough difficulty managing the numbering differences between Gecko Branches and their eventual product version numbers without adding any more complexity :)

Comment 39

13 years ago
Indeed, this has to fit all builds without official branding. Attachment 207537 [details] [diff] is essentially just reverting the changes made in bug 294399. Before those changes, unofficial builds were:

brandShortName "Browser"
brandFullName "Gecko Browser"
vendorName "Generic"

See here for proof: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/browser/locales/en-US/chrome/branding/brand.dtd&rev=1.1&root=/cvsroot

In my opinion, unofficial branding should always have this naming, and any naming changes should only be made once trunk has branched, and only to official branding terms.
(In reply to comment #39)
Read comment 33: Mozilla has no rights to the Gecko trademark. (Why?! Does Netscape/AOL still own it?)

Comment 41

13 years ago
Would something like Generic XULRunner Browser work?

Comment 42

13 years ago
Can we get this done on the 1.8 branch like soon? It is not possible in talkback to distinguish nightly Firefox builds on the 1.8.0 branch from nightly Firefox builds on the 1.8 branch since they both have identifiers in talkback like: MozillaOrgFirefox15Win322006030105. 

I don't care about the big picture branding issues: just change the Firefox version to 2.0a1 like was done on tbird today and change the rv to 1.8.1a1. Then you can deal with the other branding issues are your leasure.
If it is actually based on XULRunner, than XULRunner Browser would probably work.

I don't know the status of "XULRunner", and whether we are seeking a trademark.

Regardless, Bob is right - can someone with the relevant knowledge please prepare the patch he's asking for? Version number changes should be uncontroversial (famous last words...).

Gerv
XULRunner is not a registered trademark, but we have "first use in commerce" trademark rights to it. However, "XULRunner Browser" would probably be a reasonable title to put on trunk builds.

However, again, don't let this question hold up the version number change.

Gerv

Comment 45

13 years ago
"XULRunner browser" is ridiculous. We won't be shipping XULRunner-based Firefoxen by default for a while yet.
OK, so basically we need the Parks and Gardens Management team to come up with another park-related name for Firefox 3. And then we can use that for the trunk.

Gerv
Depends on: 330533
(In reply to comment #46)
> OK, so basically we need the Parks and Gardens Management team to come up with
> another park-related name for Firefox 3. And then we can use that for the
> trunk.

No, that would be wrong -- we specifically do not want the trunk to use a codename that will be used for Fx3 or any actual product (otherwise we'll end up in the situation we're in now again, just a few months later!).  The trunk name will always remain on the trunk, and the product will change its name once it's branched.

There have already been a bunch of good suggestions in this bug; I'd go with "Minefield" and leave it at that.
Flags: blocking-firefox2+
Target Milestone: Firefox 2 → Firefox 2 alpha1
This just changes the strings from "Deer Park" and "Firefox" to "Bon Echo" for the MOZILLA_1_8_BRANCH. Patch coming for trunk, as well ...

still need to
  - check in and update about.png (from attachment 215148 [details], bug 330533)
  - make the changes to the version number
Attachment #207357 - Attachment is obsolete: true
Attachment #215271 - Flags: review?
Attachment #215271 - Flags: review? → review?(mconnor)
for MOZILLA_1_8_BRANCH, this changes the browser version number to 2.0a1
Attachment #215277 - Flags: review?(mconnor)
(this is for trunk)
Attachment #215282 - Flags: review?(mconnor)
Given history, before that patch gets checked in can someone _please_ check carefully that there is no existing open source project called "Minefield"?

Gerv

Comment 53

13 years ago
(In reply to comment #52)
> Given history, before that patch gets checked in can someone _please_ check
> carefully that there is no existing open source project called "Minefield"?
> 
> Gerv
> 

Searching for "minefield-*tar*"

http://www.google.com/search?q=%22minefield-*.tar*%22

Aside from references to licensing minefields... the only other results just appear to be obscure shareware games.

Comment 54

13 years ago
Comment on attachment 215282 [details] [diff] [review]
changes version number to 3.0a1

There's already a patch for this in Bug 330528, it looks like you might have missed a file as well (not that I know what I'm talking about).
reversions branch to 2.0a1, added the missing file (thanks, Axel!)
Attachment #215277 - Attachment is obsolete: true
Attachment #215295 - Flags: review?(mconnor)
Attachment #215277 - Flags: review?(mconnor)
Depends on: 330528
Comment on attachment 215282 [details] [diff] [review]
changes version number to 3.0a1

As Axel mentioned, this is handled in bug 330528, so I'll just mark this patch obsolete.
Attachment #215282 - Attachment is obsolete: true
Attachment #215282 - Flags: review?(mconnor)

Comment 57

13 years ago
(In reply to comment #55)
> reversions branch to 2.0a1, added the missing file (thanks, Axel!)

I'm not Axel (I should probably get a different e-mail address for bugzilla to avoid confusion).

Comment on attachment 215271 [details] [diff] [review]
change branding elements to "Bon Echo" (for 1.8 branch) 

looks good.  When we land this, make sure someone's around to rejig the scripts to handle this right on Mac
Attachment #215271 - Flags: review?(mconnor)
Attachment #215271 - Flags: review+
Attachment #215271 - Flags: approval-branch-1.8.1+
Attachment #215281 - Flags: review?(mconnor) → review+

Comment 59

13 years ago
Please also update the releaseBaseURL entity in browser/locales/en-US/chrome/branding/brand.dtd from http://www.mozilla.org/projects/deerpark/releases/ to bonecho/releases/.
Comment on attachment 215295 [details] [diff] [review]
changes version number to 2.0a1

I'm 99% sure this is right, but I'm going to ask dbaron to verify, since he's done way more of the version bumps than I have.
Attachment #215295 - Flags: superreview?(dbaron)
Attachment #215295 - Flags: review?(mconnor)
Attachment #215295 - Flags: review+
Comment on attachment 215295 [details] [diff] [review]
changes version number to 2.0a1

sr=dbaron.  You're welcome to actually put a newline at the end of the file, though.
Attachment #215295 - Flags: superreview?(dbaron) → superreview+
Is the version going to become 2.0a1 on both trunk and branch?  Do we want to do something like 3.0a0 for the trunk?
Never mind, I can't read; sorry for the spam.
Attachment #215295 - Flags: approval-branch-1.8.1+
landed the branch patches with the newline and the change to releaseBaseURL. Go beltzner!
Keywords: fixed1.8.1
The mac application menu title hasn't changed, there's a InfoPlist.strings file somewhere in browser/app/macbuild which has to be changed.

There's also an issue with the application bundle name:
http://lxr.mozilla.org/seamonkey/source/configure.in#4362

Comment 66

13 years ago
Comment on attachment 215271 [details] [diff] [review]
change branding elements to "Bon Echo" (for 1.8 branch) 

> Index: browser/app/macbuild/license.r

This is still EULA v1.0.  It was never updated to 1.1 in bug 309693 because nobody seems to care what EULA belongs on unofficial-branding builds.

Updated

13 years ago
No longer depends on: 330848
Oops. I blame Textwrangler's search and replace for inexplicably not finding this string until I searched TWICE. Ugh.

(I've obsoleted the patch for trunk, and will refile an omnibus patch a little later today for that)
Attachment #215281 - Attachment is obsolete: true
Attachment #215706 - Flags: review?(mconnor)
Attachment #215706 - Flags: review?(mconnor)
Attachment #215706 - Flags: review+
Attachment #215706 - Flags: approval-branch-1.8.1+
(In reply to comment #65)
> The mac application menu title hasn't changed, there's a InfoPlist.strings 
> file somewhere in browser/app/macbuild which has to be changed.

Mento tells me that it's actually picked up from MOZ_APP_NAME, which we leave as Firefox. At least, that's what we did back in the days of Deer Park, and in fear of licensing problems, I shall leave it that way here, too :)

> There's also an issue with the application bundle name:
> http://lxr.mozilla.org/seamonkey/source/configure.in#4362

I don't so much care about the seamonkey CVS path. The one I care about is here:
http://lxr.mozilla.org/mozilla1.8/source/configure#12932

(In reply to comment #67)
> Also, there's
> http://lxr.mozilla.org/mozilla1.8/source/browser/installer/removed-files.in#67

mconnor assures me that we don't use anything other than uninstall.exe anymore, so that's being left there for legacy purposes; this was not my intentional brilliance, however, so nice catch on something I'd missed! :) 

Comment 70

13 years ago
Help>About Bon Echo
copyright is still 1998-2005.

When will Trunk be rebranded.

Comment 72

13 years ago
Allan, what about it? We want to use the Firefox profile, not a special BonEcho profile.

Comment 73

13 years ago
(In reply to comment #72)
> Allan, what about it? We want to use the Firefox profile, not a special BonEcho
> profile.

s/Firefox/Bon Echo/ and s/2005/2006/ is what I meant

Comment 74

13 years ago
Help>About Bon Echo
copyright is still 1998-2005.

now 2006.

Comment 75

13 years ago
http://addict3d.org/index.php?page=downloadfile&ID=5528

"Mozilla Firefox 3.0 Alpha 1 (Deer Park Alpha 2)"

That's at least one site that has downloaded a trunk build, and thought it was Firefox 3.0 Alpha 1. OK, so that's what the version number says, but I doubt this confusion would have occurred had the application name not had the word "Alpha" in it.

I'm a bit skeptical about the name "Minefield" (also not sure if comment 52 has been addressed) but attachment 215281 [details] [diff] [review] would a least be a start...

I'm slightly confused, beltzner attached the patch, mconnor gave it r+ and then beltzner obsoleted it without checking it in...

What's the status of this?

Comment 76

13 years ago
Beltzner, I think you obsoleted the wrong patch in mid March.

beltzner@mozilla.com  	2006-03-20 14:58:10 PDT  	  
Attachment #215281 [details] [diff] is obsolete  	    	1
Attachment #215706 [details] [diff]Flag 	  	review?(mconnor@mozilla.com)

You obsoleted a trunk patch to renamed to Minefield with a branch patch to be renamed to Bon Echo.
(In reply to comment #77)
> http://digg.com/software/Firefox_3.0_Alpha_1_Already_Better_Than_Firefox_2.0_Alpha_1_
> http://digg.com/software/Download_Firefox_3.
> http://tech.cybernetnews.com/2006/04/08/test-firefox-30-alpha-1-yes-that-says-30/
> 
> 'Good news' spreads fast...
> 

I think this further indicates why the trunk needs to be renamed quickly. Whether there's a new graphic or not really doesn't matter as long as it avoids confusion for end-users who think they're getting the latest and greatest thing when it's merely an early alpha.  

Comment 79

13 years ago
Also http://www.9down.com/story.php?sid=6433

At least the sites are not linking to the Tinderbox anymore so far. http://developer.mozilla.org/en/docs/Tinderbox

I think it would be nice to change the filenames as well (e.g. "minefield-3.0a1.blahblaf.tar.bz2" or even just "minefield.blahblah.tar.bz2" instead of "firefox-3.0a1.blahblah.tar.bz2"). Simply avoid "firefox" appearing simultaneously with "3.0a1" in the filenames.

This will surely reduce the number of premature articles about 3.0a1.
(In reply to comment #76)
> You obsoleted a trunk patch to renamed to Minefield with a branch patch to be
> renamed to Bon Echo.

No, that was intentional, as I'd missed a reference in the original Minefield patch. New one coming up shortly.
ok, patch is in; steve garrity has promised me some artwork in bug 330533 shortly, so we'll hopefully have this (finally - my bad!) wrapped up today
Bah - missed one reference. But this also serves as a reminder that we'll need to make some /minefield webpages on mozilla.org/projects as per these changes. Of course, I'm not sure what the /projects/minefield/releases/ structure will look like, since there won't ever be a "minefield" release (it will always be trunk, when we release the Fx3 alpha off of it we'll be renaming that to the Fx3 codename as per above discussion).

Something to ponder! :)
Attachment #217861 - Attachment is obsolete: true
Attachment #217862 - Flags: review?(mconnor)
Attachment #217861 - Flags: review?(mconnor)

Comment 85

13 years ago
Mike Beltzner, we need to have a big scray message for the start page. Nothing elaborate or pretty (and definently not as busy as the beta/alpha release pages are because not everyone sees the message on there) since its not a release or ever going to be. Can be something short and simple like "THIS IS NOT A RELEASE/BETA/ALPHA SOFTWARE, THIS IS A DEV BUILD, USE AT OWN RISK!!! NO END USER SUPPORT WILL BE PROVIDED!" and then link to info about trunk builds and roadmap.
Comment on attachment 217862 [details] [diff] [review]
renames "Deer Park" to "Minefield" for trunk

shazam
Attachment #217862 - Flags: review?(mconnor) → review+
When this is checked in, can attachment 217869 [details] (from bug 330533) please be checked in as well. Thanks!

(In reply to comment #85)
> Mike Beltzner, we need to have a big scray message for the start page. Nothing
> elaborate or pretty (and definently not as busy as the beta/alpha release 

Filed bug 333476 for the creation of those pages.
Comment on attachment 217862 [details] [diff] [review]
renames "Deer Park" to "Minefield" for trunk

Landed this and attachment 217869 [details] on the trunk.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 89

13 years ago
(In reply to comment #88)
> (From update of attachment 217862 [details] [diff] [review] [edit])
> Landed this and attachment 217869 [details] [edit] on the trunk.

There's every chance I'm missing something obvious, but the configure.in change from attachment 217862 [details] [diff] [review] doesn't seem to have been checked in.
Hm. From http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=gavin&whotype=regexp&sortby=Date&hours=2&date=explicit&mindate=2006-04-10&maxdate=2006-04-11&cvsroot=%2Fcvsroot I see:

mozilla/browser/base/branding/about.png                 1.3 	
mozilla/browser/base/branding/uninstall.properties 	1.3
mozilla/browser/base/content/browserconfig.properties 	1.5 	
mozilla/browser/app/macbuild/license.r 	                1.2
mozilla/browser/installer/unix/installer.cfg            1.8 
mozilla/browser/installer/windows/installer.cfg         1.22
mozilla/browser/installer/windows/uninstaller.inc       1.2
mozilla/browser/locales/en-US/chrome/branding/brand.dtd 1.5
mozilla/browser/locales/en-US/chrome/branding/brand.properties  1.4

Oops?
I checked in the missing configure.in check on the trunk. Thanks for catching that Pike. This turned atlantia red, but rhelmer updated tinderconfig (thanks Robert!) so it should go green.
OS X: The application menu is still labled "Deer Park" (although its top item is "About Minefield").
Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20060412 Firefox/3.0a1
Hm. I can't see any references in LXR that would be causing this, and wonder if it might be due to the tinderbox configuration. Let me kick off a full local build and see what happens ...

Comment 94

13 years ago
Not a big deal but aboutCredits.png wasn't changed.  
bsmedberg's a start and told me that the OS X menu bar name is grabbed from /browser/app/macbuild/Contents/Resources/English.lproj/InfoPlist.strings. Here's a new one; worked for me in my local tree, so I think my text editor even saved it with the right UTF settings, but someone should check me on that.
Attachment #218185 - Flags: review?(mconnor)
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Attachment #218185 - Attachment mime type: application/octet-stream → text/plain
Comment on attachment 218185 [details]
new InfoPlist.strings file with "Minefield" and "Copyright 2005-2006"

You say 2005-2006 in the attachment comment, but 1998-2006 is what is in the file. Which do you mean? :)
*** Bug 333736 has been marked as a duplicate of this bug. ***
Comment on attachment 218185 [details]
new InfoPlist.strings file with "Minefield" and "Copyright 2005-2006"

r=me, subject to followup about where the official-branding bits come from
Attachment #218185 - Flags: review?(mconnor) → review+
Depends on: 333816
Comment on attachment 218185 [details]
new InfoPlist.strings file with "Minefield" and "Copyright 2005-2006"

checked this in.
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → FIXED

Comment 100

13 years ago
The update status during restart still reads Firefox and not minefield
Depends on: 337834

Updated

13 years ago
No longer depends on: 337834

Updated

13 years ago
Depends on: 337834
You need to log in before you can comment on or make changes to this bug.