Closed Bug 324763 Opened 14 years ago Closed 14 years ago

Tabs that lack focus can no longer be selected

Categories

(Firefox :: Tabbed Browser, defect, major)

x86
All
defect
Not set
major

Tracking

()

RESOLVED FIXED

People

(Reporter: bugzilla, Assigned: roc)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1

When a new tab is opened the original tab is no longer able to be selected.  The only way to return to the original tab is to close the new tab.  This appears to have regressed since the 20060125 nightly build.   

Reproducible: Always

Steps to Reproduce:
1. Open a new tab
2. Attempt to select the previous tab
3. 

Actual Results:  
Unfocused tab is not able to be selected.

Expected Results:  
Unfocused tab should regain focus when clicked on.
Version: unspecified → Trunk
Keywords: regression
I see this on my windows build too, checked out 2006-01-25 22:10.
OS: Linux → All
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012609

Confirmed , this makes FF "useless"
Status: UNCONFIRMED → NEW
Ever confirmed: true
Attached patch fixSplinter Review
See https://bugzilla.mozilla.org/show_bug.cgi?id=317375#c110. I had a fix for this in one version of my patch but somehow it dropped out.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #209724 - Flags: review?
Attachment #209724 - Flags: review? → review?(mconnor)
Attachment #209724 - Flags: review?(mconnor) → review+
It works on the older hourly build

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060125 Firefox/1.6a1 ID:2006012517

But as have said, it doesn't work on the 0126 nightly build.
fix checked in.
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
*** Bug 324838 has been marked as a duplicate of this bug. ***
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012612

verified on windows
*** Bug 324858 has been marked as a duplicate of this bug. ***
*** Bug 324912 has been marked as a duplicate of this bug. ***
The patch of this bug caused the close buttons on tabs not to work anymore, if tabs have a fixed width by means of this .css:

.tabbrowser-tabs > hbox {
  display: block !important;
}

.tabbrowser-tabs tab {
  min-width: 100px !important;
}

At least, in the 2006012621 build they stopped working. 
(In reply to comment #10)
> The patch of this bug caused the close buttons on tabs not to work anymore, if
> tabs have a fixed width by means of this .css:
> 
> .tabbrowser-tabs > hbox {
>   display: block !important;
> }
> 
> .tabbrowser-tabs tab {
>   min-width: 100px !important;
> }
> 
> At least, in the 2006012621 build they stopped working. 
> 
There's a lot more weirdness if you fix the width
-flickering [X] when you hover over it
-doubleclick on tabbar doesn't work
-height misrendering of the tabs

(caused by display:block ?)

You need to file a new bug for this, cc me pse
*** Bug 324931 has been marked as a duplicate of this bug. ***
*** Bug 324937 has been marked as a duplicate of this bug. ***
*** Bug 326343 has been marked as a duplicate of this bug. ***
something to try = try clicking your mouse wheel on-off a few times (i.e., the middle button) and/or open your mouse control panel, change the mouse wheel settings, and save the new settings. why? read these 2 bug reports: 

From:  Bug 465259 -  firefox randomly stops responding to mouse clicks  
  -------  Comment #2 From  Brandon Mitchell   2009-07-16 13:34:11 PDT  -------

I experienced this issue yesterday for the first time, after upgrading from FF3
to FF3.5 a few weeks ago, and I believe (but am not certain) that I was able to
fix the problem by middle clicking on the scrollbar to activate and then
deactivate autoscroll. (Actually I used an AutoHotkey mapping of the left
Windows key to the middle mouse button; I don't have a mouse and my touchpad
doesn't have a middle button.) Today I have been unable to reproduce the
phenomenon. On the one hand, I wish I knew how to reproduce this bug; on the
other hand I sincerely hope that I don't encounter this nasty business again.

Based on my reading of support forum pages (first two of the three URLs pasted
below), I wildly conjecture that this might possibly be related to the middle
mouse button somehow. Some posters have suggested that it is due to a driver
problem or a mechanical problem such as a stuck middle mouse button, but
posters also point out that the problem seems to be specifically related to
Firefox 3.x software. One person (see third URL pasted below) claims that he
still had the problem after installing a new mouse.

There are at least two or three other
"Firefox-won't-respond-to-mouse-clicks-unless-I-switch-focus-to-another-app-window"
bugs that might be duplicates of this one: Bug 442572, Bug 451116, Bug 483254.

http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_threshold=0&comments_parentId=86324&comments_offset=0&comments_per_page=20&thread_style=commentStyle_plain

http://support.mozilla.com/tiki-view_forum_thread.php?forumId=1&comments_threshold=0&comments_parentId=125737&comments_offset=0&comments_per_page=20&thread_style=commentStyle_plain

http://vavai.net/2009/01/21/temporary-solved-annoying-bug-on-firefox-3-right-click-menu/


From:  Bug 450735 -  Firefox doesn't respond to mouse clicks on links and buttons  
  -------  Comment #3 From  Martin   2008-08-18 10:24:10 PDT  -------

I have solved the problem for myself. It was not a bug, but a mechanical
problem. Nevertheless Firefox is the only browser that seemed to be affected:

My middle mouse button was not working. I realized that, when I opened Excel
and found the program selecting multiple cells as if I kept pressing the left
mouse button.

I opened my mouse and found that the little mechanical transmitter for the
middle mouse button (wheel)was jammed. I released it and now everything works
fine.
You need to log in before you can comment on or make changes to this bug.