Closed Bug 324819 Opened 17 years ago Closed 15 years ago

Fixed positioned elements now lag/flicker when scrolling (regression from bug 317375)

Categories

(Core :: Layout, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: martijn.martijn, Unassigned)

References

()

Details

(Keywords: regression, testcase)

Another testcase that should give the bug:
https://bugzilla.mozilla.org/attachment.cgi?id=90636

See bug 317375, comment 47 and bug 317375, comment 49:
"Also, it is expected that fixed positioned elements 'lag' when scrolling the
page, right? (something that you are planning to fix later in the game)"

Roc:
"The flicker you see with fixed-pos elements is expected. It will get fixed
later."

So this bug will get fixed, but people will file bugs about it, so these should be duped against this one.
Confirm broken in build:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060126 Firefox/1.6a1 ID:2006012612
fixed-pos <iframe>s don't appear to have the lag
Blocks: 324980
*** Bug 324980 has been marked as a duplicate of this bug. ***
Confirming it's a problem in Linux (GTK+) as well.
*** Bug 328267 has been marked as a duplicate of this bug. ***
OS: Windows XP → All
Flags: blocking1.9a1?
Blocks: 340428
Another test case:
http://www.seisomapaikka.com/esiintyjat/
Black figure on the left side of the page shouldn't jump up/down while scrolling.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060611 Minefield/3.0a1 ID:2006061104 [cairo]
Blocks: 343430
Flags: blocking1.9a1? → blocking1.9-
Whiteboard: [wanted-1.9]
Flags: blocking1.9- → blocking1.9+
Whiteboard: [wanted-1.9]
It seems like we should be dividing the scrolled area into rectangles and either blitting, repainting, or doing nothing to each rectangle, as appropriate (and in the correct order based on the scrolling direction).  (That would require nsIWidget::ScrollRect to be reliably implemented across platforms, and perhaps that it have a variant that doesn't invalidate the region at the edge.)
*** Bug 363319 has been marked as a duplicate of this bug. ***
confirming this bug for: 

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061204 Firefox/2.0
(In reply to comment #9)
> confirming this bug for: 
> 
> Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20061204 Firefox/2.0
> 

This is WRONG. I'm sorry but I've missed that I was using the stable version when I wrote it.

I can confirm this bug for:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20061209 Minefield/3.0a1

Another testcase can be found in bug 363319



This bug also affects bengoodger.com really badly
http://sierkbornemann.de/ is also badly touched by this bug.
The CSS rule "background-attachment: fixed" is used for the left logo (sierkbornemann.de), which should remain fixed while you scroll the page.
Firefox up to 2.0 renders this correctly (as all other browsers like Opera 9, Safari/Konqueror, IE7 also do). Firefox trunk (3.0alpha) fails in keeping this logo fixed, it flickers annoying. This bug should be fixed as soon as possible.
This problem has been around for a very long time.  There's a bug in one of the modules but a workaround is applied to betas and finals so you don't see it there.  Alphas don't have this workaround.

One of the devs once explained which particular module that was, but I can't remember the bug number where that was posted nor the name of the module.  I think there was a "6" in its name and that it was supposed to be updated to "7".
Guys, I think there's enough "me too" bugs for this.

To summarize:
1.) It's a trunk-only regression (hence why only 3.0a1 sees it)
2.) It affects a lot of sites in unpleasant ways
3.) It affects all OSes

So, unless there's anything else to add which is different from those two main points, read https://bugzilla.mozilla.org/page.cgi?id=etiquette.html before posting.
Yet another test case:
http://www.csszengarden.com/?cssfile=/202/202.css&page=0
(This one could double as a performance bug for linux as even minimizing the window does not bring down the CPU usage, switching to another tab does)
Duplicate of this bug: 373523
Duplicate of this bug: 372846
can confirm for linux on 
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a4pre) Gecko/20070409 Minefield/3.0a4pre - Build ID: 2007040904

another test case:
http://www.agecommunity.com/
background moves as expected with this bug.
Duplicate of this bug: 375400
Wouldn't this depend on bug 374980? If that's the case, can someone update the Depends on list? And regarding bug 374980 comment #6, Robert O'Callahan just mentioned that it won't make it for 1.9.
This bug depends on bug 352093, and that bug depends on bug 374980, so it is already dependancy 'connected'.
roc, do you know what approach you're going to take to fix this?  I think there's basically two options here: one, to reintroduce widgets for fixed-position elements (not too hard, but hacky).  The other option is to modify the widget-level scrolling code to be able to deal with this situation (using a clip region or something like that).
343430 is checked in, so marking this fixed.
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → FIXED
There is still something broken, If you open http://www.csszengarden.com/?cssfile=/202/202.css&page=0 in Firefox 2.0.4 and in the nightly version simultaneously and try to scroll down the page, you'll see that the scrolling is much faster in Firefox 2.0.4

And also in the 3.0 nightly, a black horizontal line appears when scrolling from the bottom upwards, something like when 2 different images can be seen in a fast game due to VSYNC, the line appearing in the split between those 2 images

this can be seen on my Windows XP SP2
also on this page: http://www.agecommunity.com/
the scrolling is absolutely smooth in Firefox 2.0.4 compared to the 3.0 nightly
The black horizontal line problem is bug 383010, I think.
The performance problem with scrolling is probably related to bug 361754, I think.
there is also a redraw problem while scrolling as can be seen on this page for e.g. http://trainofthoughts.org/blog/2007/06/24/openpkg-apache2/

I made a screenshot: http://img.photobucket.com/albums/v647/mu-lan/scrolling.png
You can see that the right side of the text is shifted quite considerably.

this is visible both in Firefox 2.0.4 and in the latest trunk build.
It is OK is Opera 9.21 and also IE 7
Milan, you probably should file a new bug for that (also mention your video card and your computer speed there).
I tried to search for the bug, if it has not been entered already,
and this should be the same problem as I've observed:
https://bugzilla.mozilla.org/show_bug.cgi?id=380181

So I posted a comment containing these links to that bug. Hopefully it will get fixed :)
You need to log in before you can comment on or make changes to this bug.