Virtual bookmarks as links to Folders and Bookmarks (bookmark aliases)

RESOLVED DUPLICATE of bug 298009

Status

--
enhancement
RESOLVED DUPLICATE of bug 298009
19 years ago
5 years ago

People

(Reporter: andre, Unassigned)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

19 years ago
It would be great if one could create "links" to folders and bookmarks and the
bookmark database, these links could be placed eg. in the personal toolbar
folder and represent a small extract from all the bookmarks the user has created,
advances:
- you don´t have to change all bookmarks, because you get no double or triple
(or more) entries
- you can organize your bookmarks in a logical order and the most often used
items can be linked for access, instead of having a part of the bookmarks in the
personal toolbar folder (as I have at the moment) an the rest in another folder
(or the case above, redundant bookmarks and folders)
Changing to enhancement, confirming.

Gerv
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

19 years ago
tweaking summary. btw you can put/create other folders in the Personal Toolbar Folder. In those folders you can put anything you 
like, in any order(including your whole damn bookmarks file),without messing up your general bookmarks file.

I don't see what functionality/feature you are missing.
Summary: [Feature Request] Virtual bookmarks as links to Folders and Bookmarks → [RFE] Virtual bookmarks as links to Folders and Bookmarks
(Reporter)

Comment 3

19 years ago
copying the whole bookmarks will at least result in collisions when using
"custom keywords", also descriptions and anything else would have to be updated
twice, if not easy to implement it perhaps makes more sense to crowd the
database with duplicate titles, URLs, descriptions and so on... also sheduled
settings if existent before copying would be copied, then mozilla checks all
pages which are sheduled twice, at least :)

Comment 4

19 years ago
Interesting idea ...
Target Milestone: --- → Future

Comment 5

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 7

17 years ago
Navigator 4.x had this kind of feature, though it only worked for folders. It
called them bookmark "aliases". Bug 68288 is filed specifically against the lack
of this feature in Mozilla. I'll mark it as a duplicate of this one.
Keywords: 4xp
OS: Windows NT → All
Hardware: PC → All
Summary: [RFE] Virtual bookmarks as links to Folders and Bookmarks → [RFE] Virtual bookmarks as links to Folders and Bookmarks (bookmark aliases)

Comment 8

17 years ago
*** Bug 68288 has been marked as a duplicate of this bug. ***

Updated

17 years ago
Blocks: 68289

Comment 9

17 years ago
Er, what I meant to say was that Navigator 4.x's aliases only worked for
*bookmarks*, not folders. It would be nice to see this implemented for both in
Mozilla.
Status: NEW → ASSIGNED
Priority: P3 → P4
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 11

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Updated

16 years ago
URL: n/a
Summary: [RFE] Virtual bookmarks as links to Folders and Bookmarks (bookmark aliases) → Virtual bookmarks as links to Folders and Bookmarks (bookmark aliases)

Comment 12

16 years ago
*** Bug 194242 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
as a workaround I still use Netscape 4.75 to manage my bookmarks

but if you do beware of bug 86974 which truncates your bookmark descriptions to
one line, always keep the original copy of your Netscape bookmarks.htm and don´t
let Mozilla touch it

Comment 14

16 years ago
Do the aliasid= and aliasof= keywords work in mozilla bookmarks?

Comment 15

15 years ago
likely not, since, while importing bookmarks from netscape 4, aliases (aliasof)
are replaced with a copy of the original (aliasid) bookmark

looks there is no progress of bookmark bugs ?
I'd suggest to do it this way:

In the bookmark manager you can check the field
"Show this bookmark(folder) in personal toolbar, too"
The checkbox could be placed in a column in the general view, and also in each
bookmarks' preferences dialog.

A bookmark could then have the flags "toolbar" or "both".
No flag (or "normal"/"bookmarks") to appear in the bookmarks only.

Also, if a bookmark is added, it should be always checked if the site is already
bookmarked. (but maybe that's another bug :)

Comment 17

15 years ago
> "Show this bookmark(folder) in personal toolbar, too"

This is an alias restricted to the personal toolbar. I would prefer complete
freedom :)

But is there any1 responsible alive ?
Product: Browser → Seamonkey

Comment 18

14 years ago
*** Bug 279047 has been marked as a duplicate of this bug. ***

Comment 19

12 years ago
Saved search (bug 285834) folders? That would be nice with tagging. (bug 310888)

I've also read an RFE that proposes the bookmarks toolbar to show the base folder of the bookmarks instead of only its special folder - bug 170994. Bug 174764 is more flexible.

Bug 18152 is about detecting duplicates.
Assignee: bugs → nobody
QA Contact: claudius → bookmarks

Updated

12 years ago
Duplicate of this bug: 360223

Comment 21

7 years ago
Now that we are using SQLite to store bookmarks in places.sqlite, all bookmarks with the same URL are just pointers to the same entry in the database so updating e.g. keywords in one bookmark will update all the bookmarks so effectively they are all aliases of each other.

I'm going to close this as WORKSFORME as this is an ancient bug. If you still want to alias bookmark folders, please file a new bug. Thank you.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 22

7 years ago
Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20110706 SeaMonkey/2.2

The first paragraph in comment #21 is not correct.  I have Wikipedia twice in my bookmarks, each with the identical URI.  If I change the Name or Description of one entry, that change does not appear for the other entry.  This is true for both the entries within the Bookmarks Manager window and the exported bookmarks.html file.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Updated

7 years ago
Status: REOPENED → NEW

Comment 23

6 years ago
Looks like still valid rfe
Priority: P4 → --

Updated

6 years ago
Whiteboard: [2012 Fall Equinox]

Comment 24

6 years ago
(In reply to Philip Chee from comment #21)
> Now that we are using SQLite to store bookmarks in places.sqlite, all
> bookmarks with the same URL are just pointers to the same entry in the
> database so updating e.g. keywords in one bookmark will update all the
> bookmarks so effectively they are all aliases of each other.
> 
As David pointed out in his comment #22, Phil, I am not seeing this functionality. Changing the name of one "copy" of the bookmark has no effect on the other (original), even when the url's match, and changing the url in either has no effect on the other.

As bookmarks have been steadily increasing as more sites have come on the net and more and more time is spent between them (remember when we didn't need browser tabs or multiple browser windows? - I'm dating myself!), organizing these things has become a real chore.

I agree with comment #23 - this is still a valid RFE. I'm surprised more people haven't requested it (I can't even find an extension to add this functionality).

Comment 25

6 years ago
See also Toolkit bug 298009.
(In reply to Lewis Rosenthal from comment #25)
> See also Toolkit bug 298009.

Aren't these two bugs essentially about the same problem? They seem to me to be dupes of each other, except that this one is (by far) the older one but the other is in the right Product/Component for an all-Mozilla solution.

Or maybe this SeaMonkey bug should remain open, in case no one acts on bug 298009 and (who knows?) after some time someone decides to implement a SeaMonkey-only fix? (Not that _either_ of them saw any real action in years.)

Comment 27

6 years ago
Now that SeaMonkey has been "toolkit-ized," I would think that these two bugs could be merged. This is one of those things which has "bugged" me for ages, and only in the past couple weeks has it annoyed me again, as I've been sifting through the cruft of several years in my bookmarks collection. Frankly, I think that an extension would be a better way to handle it than in the base code.

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 298009
You need to log in before you can comment on or make changes to this bug.