[tbird] cannot install dictionaries in thunderbird since bug 216382 landed

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: mkmelin, Assigned: mscott)

Tracking

Dependency tree / graph
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
Using a thunderbird branch build, if you try to install a dictionary it says install was successful, but the dictionary does not show up under preferences > composition > spelling. (And seems not to work either...)

This broke 2006062903 -> 2006063003, so caused by bug 216382.

I tried swedish, but it probably affects all.
http://forums.mozillazine.org/viewtopic.php?t=436549&sid=807ae0c3ee6fc8d97bfca9838439e6ea
(Assignee)

Comment 1

12 years ago
This would block our 2.0 release if we can't install our dictionaries anymore.
Flags: blocking-thunderbird2+

Comment 2

12 years ago
The location in which to install dictionaries has changed. Dictionaries should now be installed as extensions into <extension>/dictionaries. See http://developer.mozilla.org/en/docs/Bundles#Application-specific_Extension_Files

Comment 3

12 years ago
See also bug 343076, which is about adding new-style dictionary extensions to AMO.

Comment 4

12 years ago
-> All/All
Severity: normal → major
OS: Linux → All
Hardware: PC → All

Updated

12 years ago
Depends on: 343076

Updated

12 years ago
Summary: cannot install dictionaries in thunderbird since bug 216382 landed → [tbird] cannot install dictionaries in thunderbird since bug 216382 landed

Comment 5

12 years ago
*** Bug 345859 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
*** Bug 346601 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

12 years ago
*** Bug 358874 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 8

12 years ago
Currently trying to install an old style dictionaries will say "install successful", but do nothing useful at all. That needs to get fixed. (New style dictionaries install just fine.)

I think there should also be a note about the dictionary format change on 
http://www.mozilla.com/en-US/thunderbird/dictionaries.html
(Reporter)

Comment 9

12 years ago
*** Bug 360508 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

12 years ago
Duplicate of this bug: 369294

Comment 11

12 years ago
So it sounds like we'd have to implement some sort of hack to get old dictionaries to work; e.g. copy the installed files into /dictionaries. Does Firefox do this? (I don't think it does...)

If older dictionaries aren't going to work, we shouldn't make them available. It sounds like in bug 343076 the dictionaries in the link mentioned in comment 8 were converted to the new format and added to AMO. So don't we just need to update that page to link to Add-ons (rather than to mozdev) and let the owner of the mozdev dictionaries project know about this, and suggest they make a note of it on their website?

Comment 13

12 years ago
Looks like the proper server redirects have been set up. So when clicking on the Download More Dictionaries link in Thunderbird Options->Composition->Spelling, it takes me to https://addons.mozilla.org/en-US/thunderbird/browse/type:3, which is the correct page. Thunderbird also uses the correct url: http://bonsai.mozilla.org/cvsblame.cgi?file=/mozilla/mail/app/profile/all-thunderbird.js&rev=1.44.2.45#349

The old page was at http://www.mozilla.com/en-US/thunderbird/dictionaries.html.

I guess this can be considered WFM.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

12 years ago
Unfortunately the old dictionaries don't have (at least the ones i checked) any install.rdf or similar, so if you try to install an old type dictionary in 2.0 it will "install" - with all files getting copied and installation success confirmation. Only they go to the old place so and won't work. 

I suppose its expected, and I don't know if there's much to do about it, but http://www.mozilla.com/en-US/thunderbird/dictionaries.html need a BIG notice that the dictionaries listed there will only work in <= 1.5. 
(In reply to comment #14)
> I suppose its expected, and I don't know if there's much to do about it, but
> http://www.mozilla.com/en-US/thunderbird/dictionaries.html need a BIG notice
> that the dictionaries listed there will only work in <= 1.5. 

Bug 376458 [dictionaries.html should state compatibility] created. :)
You need to log in before you can comment on or make changes to this bug.