[Windows] Widget Animation

RESOLVED FIXED

Status

()

Core
Widget: Win32
RESOLVED FIXED
11 years ago
9 months ago

People

(Reporter: robarnold, Assigned: robarnold)

Tracking

(Blocks: 2 bugs, {polish})

Trunk
x86
Windows Vista
polish
Points:
---
Dependency tree / graph
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [polish-hard][polish-interactive][polish-p1])

(Assignee)

Description

11 years ago
Many widgets animate as they change states (scrollbars, buttons, checkboxes/radio buttons, combo boxes, tree arrows, etc...). Currently, the widget code does not do any animation.

The changes will not be small, but they are important.

Updated

11 years ago
Flags: in-litmus?

Comment 1

11 years ago
Same is true for GTK+ widgets as well, but I am not sure if the changes are doable at all.
(Assignee)

Updated

10 years ago
Depends on: 444007
this bug is eligible for bug 462080
Keywords: polish
Whiteboard: [polish-hard][polish-interactive]
Whiteboard: [polish-hard][polish-interactive] → [polish-hard][polish-interactive][polish-high-visibility]
would it be something like a new -moz-background-fade or something like that? (that would be really cool, and attractive to web developers). On a side note, smil could probably do this...

Updated

9 years ago
No longer blocks: 420232
This bug's priority relative to the set of other polish bugs is:
P1 - Polish issue that appears in the main window, or is something that the user may encounter several times a day.

hard to give this bug a UI location given that widgets are everywhere, clearly a P1 polish issue.
Whiteboard: [polish-hard][polish-interactive][polish-high-visibility] → [polish-hard][polish-interactive][polish-p1]
Summary: Widget Animation on Vista → [Windows] Widget Animation
Blocks: 546842
No longer depends on: 546842

Updated

9 years ago
Depends on: 542862

Updated

9 years ago
Blocks: 542862
No longer depends on: 542862

Updated

8 years ago
Duplicate of this bug: 597703

Comment 6

8 years ago
Hello? This bug is dead?
I think this bug is very important.

Updated

7 years ago
No longer blocks: 542862

Updated

6 years ago
No longer blocks: 333484

Updated

9 months ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.