Last Comment Bug 406742 - create a separate linux theme space for tb3
: create a separate linux theme space for tb3
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Linux
: -- normal with 3 votes (vote)
: Thunderbird 3.0b2
Assigned To: Magnus Melin
:
Mentors:
: 349215 (view as bug list)
Depends on: 473207
Blocks: 415415
  Show dependency treegraph
 
Reported: 2007-12-04 03:40 PST by Michael Monreal [:monreal]
Modified: 2010-09-04 02:17 PDT (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
proposed fix (46.00 KB, patch)
2008-12-01 10:56 PST, Magnus Melin
no flags Details | Diff | Review
proposed fix, v2 (44.12 KB, patch)
2009-01-04 07:50 PST, Magnus Melin
standard8: review+
Details | Diff | Review

Description Michael Monreal [:monreal] 2007-12-04 03:40:09 PST
There is much work going on to make Firefox 3 look like a native Linux application at the moment. Widgets are fixed to display using the look of the active GTK theme and icons are either pulled from the desktop theme or redone using the Tango guidelines.

Thunderbird is already getting a few things (fixed widget look) for free, but it would be even better if TB3's theme would also integrate better with matching icons. From what I see, most icons (folders, send, receive, delete...) could just be used from the desktop theme. A few others would need to be shipped in the theme, but luckily most of them have already been done for Firefox 3.
Comment 1 Michael Monreal [:monreal] 2007-12-04 04:09:19 PST
After having a close look I realized that there are much more icons in TB than what you realize on the first look ;)

So this would not be as straightforward, but there is some interest from some tango artists, so it would certainly be possible.
Comment 2 Jakub 'Livio' Rusinek 2008-02-16 05:42:51 PST
Add here dependency on bug 415415.
Comment 3 Hylke Bons 2008-06-14 12:33:11 PDT
I'm willing to work on this. I use Thunderbird every day, but the tango skin for 2.0 has issues. Would be great if we could give 3.0 the same native look as Firefox 3.
Comment 4 s 2008-09-29 15:29:55 PDT
Well, it's been a long time now since this was reported, and I for one would really like to see Thunderbird use native GTK+ icons on Linux.  That's really the only thing keeping me from using Thunderbird.
Comment 5 Magnus Melin 2008-10-19 05:05:49 PDT
FYI, i just landed bug 459286 which takes care of the menu icons part.
Comment 6 Kevin Lange 2008-11-03 08:28:16 PST
I really think this is a big deal. Using native GTK icons on Linux (with a set of Tango-styled icons for those that are missing) would be a major plus - and we're already doing with Firefox, so why not?
Comment 7 Gary Kwong [:gkw] [:nth10sd] 2008-11-17 19:00:09 PST
*** Bug 349215 has been marked as a duplicate of this bug. ***
Comment 8 Magnus Melin 2008-12-01 10:54:43 PST
I think I'll just go ahead an hijack this bug for the actual theme space creation, and let bug 415415 handle getting icons for it.
Comment 9 Magnus Melin 2008-12-01 10:56:22 PST
Created attachment 350789 [details] [diff] [review]
proposed fix

Create a gnomestripe theme space, and use it for linux.
Comment 10 Mark Banner (:standard8) 2008-12-01 11:18:01 PST
Whilst we're doing this, could we drop the intermediate mail/themes/gnomestripe/Makefile.in or combine the two jar.mn files into one in that directory?

This will minimise the file stats that we have to do when building (I need to do a similar change to mail/themes/{qute,pinstripe} sometime, but doing it here for gnomestripe would save a changeset.
Comment 11 Magnus Melin 2008-12-01 11:42:13 PST
Can't say, my build foo is weak ;)
Comment 12 Mark Banner (:standard8) 2008-12-09 05:10:13 PST
(In reply to comment #10)
> Whilst we're doing this, could we drop the intermediate
> mail/themes/gnomestripe/Makefile.in or combine the two jar.mn files into one in
> that directory?

(In reply to comment #11)
> Can't say, my build foo is weak ;)

Unless Phil's got any objections, let's go with combining the two jar.mn files into one, so that we therefore only have to open one jar.mn, one output jar etc.
Comment 13 Phil Ringnalda (:philor) 2008-12-09 09:44:26 PST
Seems reasonable to me.
Comment 14 Magnus Melin 2009-01-04 07:50:38 PST
Created attachment 355293 [details] [diff] [review]
proposed fix, v2

Updated patch to work with the fixes from bug 469655.

Still need someone to provide the theme content...
Comment 15 Mark Banner (:standard8) 2009-01-04 10:56:34 PST
(In reply to comment #14)
> Created an attachment (id=355293) [details]
> proposed fix, v2
> 
> Updated patch to work with the fixes from bug 469655.

A quick glance and this looks fine.

> Still need someone to provide the theme content...

I think that just getting this patch in will enable that to happen, unless you're thinking something should block it. IMHO Even if we don't have anything different straight away, just having the capability to do it will make some of the UI patches easier, especially as I know David had a lot of trouble with getting the new message header working on both Windows & Linux with the same theme.
Comment 16 Magnus Melin 2009-01-04 11:24:56 PST
Comment on attachment 355293 [details] [diff] [review]
proposed fix, v2

My thinking was it's double work to get fixes in for two theme copies, but maybe that's not so much of a problem considering it's easier for some patches...
Comment 17 Mark Banner (:standard8) 2009-01-06 06:07:20 PST
Comment on attachment 355293 [details] [diff] [review]
proposed fix, v2

nit: you need to add the new makefile to mail/makefiles.sh

I'm hoping that having these separated will encourage more work on Linux (or Windows) specifics, and of course make some of our UI patches easier.
Comment 18 Magnus Melin 2009-01-09 11:41:14 PST
Gnomestripe landed. I'll file a new bug to get rid of some css ifdefs etc we don't need anymore.

changeset:   1590:d693449a3c68
http://hg.mozilla.org/comm-central/rev/d693449a3c68

->FIXED
Comment 19 Mark Banner (:standard8) 2009-01-09 15:50:26 PST
I checked in a bustage fix for this: http://hg.mozilla.org/comm-central/rev/81b5bb466b70

Note You need to log in before you can comment on or make changes to this bug.