Ensure search plugins can be uploaded through dev cp

VERIFIED FIXED in 3.5

Status

addons.mozilla.org Graveyard
Developer Pages
VERIFIED FIXED
10 years ago
2 years ago

People

(Reporter: clouserw, Assigned: fligtar)

Tracking

Dependency tree / graph

Details

(Reporter)

Description

10 years ago
Had a meeting ( http://wiki.mozilla.org/Update:Remora_Meeting_Notepad#December_19th ) about this today.  We'll be treating search plugins as normal add-ons.  That means they'll be localizable, have complete pages, unique URLs, etc.
(Reporter)

Updated

10 years ago
Blocks: 375052
(Reporter)

Comment 1

10 years ago
As I see it, the steps for this are:

1) Notify everyone that has a search engine on the current site (both public and sandbox) that we're changing the format (bug 404373) and putting search engines in categories (bug 408525).  Let them know that since we're treating them as standard add-ons they'll need to upload/maintain the search engine themselves, L10n is available for meta data, etc.

2) Land 408525 as soon as we can.  Land 404373 with 3.2 launch.

3) Make a requirement of this bug that anyone can upload an opensearch search engine, put it in categories, localize it, nominate it, give it screenshots, reviews, etc.

4) Implement step 3 as soon as we can and let people know when they can upload search engines.  Also let them know that they won't show up on the search engine list and that, in fact, the list is going away with 3.2.  Make sure they know that they'll be sprinkled around in the categories like other extensions.

5) Launch 3.2, resolve this bug.

Updated

10 years ago
Target Milestone: --- → 3.2
Assignee: nobody → clouserw
(Reporter)

Comment 2

10 years ago
Step 2 is complete.  Patch in bug 404373 is committed since 3.2 is on trunk now.  Step 3 appears to be a decent sized patch - we'll have to give search engine's guids, not hardcode them to en-US, etc.
(Reporter)

Updated

10 years ago
Depends on: 417727

Updated

10 years ago
Depends on: 422254

Updated

10 years ago
Depends on: 417985

Comment 3

10 years ago
Moving to target v3.4
Target Milestone: 3.2 → 3.4
(Reporter)

Updated

10 years ago
Blocks: 409080

Comment 4

10 years ago
Please enable dev CP upload capability for search engines on preview and we'll test - thanks. 
Assignee: clouserw → fligtar

Updated

10 years ago
Component: Search Plugins → Developer Pages
Summary: treat search plugins as normal add-ons → Ensure search plugins can uploaded thru dev cp
Target Milestone: 3.4 → 3.5
(Assignee)

Updated

10 years ago
Summary: Ensure search plugins can uploaded thru dev cp → Ensure search plugins can be uploaded through dev cp
(Assignee)

Updated

9 years ago
Blocks: 435600
(Assignee)

Comment 5

9 years ago
This is fixed in 3.5. OpenSearch plugins can be uploaded through the new Dev CP and the process works as expected. The name and summary are pulled from the .xml file thanks to Gavin's OpenSearch component he wrote 2 years ago for us.

The only fields I hid for search engines are displaying the GUID and Add-on flags on the Edit Properties page. If there are others, please let me know.

Versioning is still handled the same using the current date.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Duplicate of this bug: 455479
(Reporter)

Updated

9 years ago
Duplicate of this bug: 455739
(Reporter)

Updated

9 years ago
Keywords: push-needed
Hey fligtar: I uploaded "a9.xml" (downloaded from https://addons.mozilla.org/en-US/firefox/addon/4594), and in its "Properties" page (https://remora-3.5.php5stage.mozilla.com/en-US/developers/addon/edit/7533/properties), I see an empty textfield for "GUID     Only change if you understand all of the consequences." -- is that a bug?
(Assignee)

Comment 9

9 years ago
That should only show up if you are an admin. As long as that's the case, it's not a bug.
That is indeed the case; thanks!

Verified FIXED
Status: RESOLVED → VERIFIED

Comment 11

9 years ago
Do we say that it is fixed already and registered users can upload search plugins? How to do it? Developers page still doesn't except files with .xpi extension. Should we use some other format of the file?
(Assignee)

Comment 12

9 years ago
You'll need to use the new tool. After you click on Developer Tools, click on "Use New Tools" in the notice at the top of the page.

Comment 13

9 years ago
Got it now. Thank you. New tool somehow is not available in my language (RU).

Comment 14

9 years ago
hm. I've upload my search plugin with usage of new tool. But I can not add description, summary and it's name. This data just not saved! But when I press Update Descriptions or Properties buttons, it says that data is saved (when really it doesn't happen).
My search plugin id is 8932.
(Assignee)

Comment 15

9 years ago
(In reply to comment #14)
> hm. I've upload my search plugin with usage of new tool. But I can not add
> description, summary and it's name. This data just not saved! But when I press
> Update Descriptions or Properties buttons, it says that data is saved (when
> really it doesn't happen).
> My search plugin id is 8932.

I filed bug 456090 for this. It's not specific to search plugins - it's a cache problem. I'm pretty sure the data is being saved, it's just not shown immediately.
(Reporter)

Updated

9 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.