Add to Address Book in new header section doesn't offer choice of target address book

RESOLVED FIXED in Thunderbird 3.3a1

Status

defect
RESOLVED FIXED
11 years ago
6 years ago

People

(Reporter: mitra_lists, Assigned: mkmelin)

Tracking

({regression, ux-control})

Dependency tree / graph
Bug Flags:
in-testsuite +

Thunderbird Tracking Flags

(thunderbird3.2 ?)

Details

(Whiteboard: [UXprio][gs])

Attachments

(3 attachments)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-GB; rv:1.9.0.2) Gecko/2008090512 Firefox/3.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b1pre) Gecko/20080917025353 Shredder/3.0b1pre

You no longer get a choice of what address book to add an address to.

Reproducible: Always

Steps to Reproduce:
1.Click on a message
2.Ctrl-click on From
3.Add to Address Book

Actual Results:  
Nothing appears to happen - though its possible its adding somewhere I'm not looking

Expected Results:  
A choice as to what address book I can add it to .
This was an intentional change and will make more sense when we have the star UI in place. The address is stored in the same book as the collected addresses.
Ick - that is a nasty step backwards, I have multiple address books, and don't want to have to go to some other location at a seperate time and try adn remember why I saved the address. 

For example .... I have an Address Book that keeps addresses that belong to mailing lists, and another for colleagues at work. These address books are used by filters so that in future email coming in is sorted properly. 

- Mitra
Hi Mark - i wonder if you could explain the "Star UI" and why this (IMHO) step backwards has been taken in the meantime. 

Also - related to that, is there a reason that outgoing email addresses are collected even if they are already in one or more of the other address books?
> Hi Mark - i wonder if you could explain the "Star UI" and why this (IMHO) step
> backwards has been taken in the meantime. 

I think what you were seeing is a broken "Star UI", if you try again I hope it will be working as intended now.  The intention is to allow people to collect addresses easily without a modal address book dialog.  For simple contact additions, which is most often the case, the star ui is a large improvement.  For more complex contact additions, like yours, it should be about the same number of steps if you don't use the star.  

> Also - related to that, is there a reason that outgoing email addresses are
> collected even if they are already in one or more of the other address books?

I believe this is bug 471580
Hi Bryan, what exactly are the steps to collect a contact address to a specific address book. Maybe I'm being dumb, but I can't find any way to do it. 

i.e. if I ctrl-click (right-click for windows users) on the address the choice is "Edit Contact", "Compose Email", or "Copy Email Address". The "Edit Contact" doesn't allow me to change hte address book, 

if you click "Edit Contact" then "Edit Details" (which I should say is a nice way to scale the ui for more complex cases) it doesn't allow moving it to a different address book, adding that would be sufficient as a way around this.

At the moment the only way I can see is.
Open Address Book
Go to "Personal Address Book" 
Manually search by eye for the new contact
Drag it to a different address book.
> Hi Bryan, what exactly are the steps to collect a contact address to a specific
> address book. Maybe I'm being dumb, but I can't find any way to do it. 

Mitra, good point.  I thought we had the address book selector as a combobox in the contact editor dialog.  Did that go away or was it never there?  I think we'll have to solve this problem in bug 471580
The choice of where to put the address book hasn't been there in any of the variations of the header since I posted this bug in September. 

The interface keeps changing, but its clearly being designed by people who only use one address book :-)

P.S. Could you mark this as "Confirmed" it still shows Unconfirmed.
(In reply to comment #6)
> > Hi Bryan, what exactly are the steps to collect a contact address to a specific
> > address book. Maybe I'm being dumb, but I can't find any way to do it. 
> 
> Mitra, good point.  I thought we had the address book selector as a combobox in
> the contact editor dialog.  Did that go away or was it never there?  I think
> we'll have to solve this problem in bug 471580

I don't see why this should be tied to a bug with abut the antiquated collect address book.

Yes, ist recall there was a point at which there was a drop down when adding a contact. not sure when it got gone. Might it have been in the mockup?

I find it difficult/nay unacceptable that there is not a choice - so I simply don't use it - sorry.   a) I don't use collected (which seems to be the direction of bug 471580), b) my first address book (the default) is not the one I use most c) indeed two of my ABs get the bulk - each get about 40% of my total addresses, so half the time the default is going to be wrong.

I bet most people would find it acceptable to suffer a "prompt" and be  offered a choice of AB, *if they have more than two AB* (one of which is not ldap).
OS: Mac OS X → All
Hardware: PowerPC → All
Summary: Add to Address Book broken in new header section → Add to Address Book in new header section doesn't offer choice of target address book
xref bug 420867 ability to set default address book name
I think the direction of bug 471580 will probably lead to having an address book chooser somewhere.  However I can see bug 420867 as a good solution that compliments a chooser.
Yes - a default isn't sufficient, for example I need to collect addresses seperately for different clients (so that filters that filter on an address being related to a particular client will work, and the filter that spots spammers, and the one that spots low priority mailing lists and files those seperately).
in comment 8 I may have been thinking not of AB, but of firefox's ability to change folder of a bookmark on the second click of star (my memory sucks sometimes.)  Their UI looks bad IMO, but I like the idea that the most recently used folders get listed up top.

To summarize my pitiful prior rant I'd like a model something like

a) ability to set my default AB, OR default to first AB and allow me to reorder so I can determine the order of ABs
b) second click of star offers ability to change AB on Edit Contact (if user has two or more AB that are not ldap, excluding collected AB, then there's no point in presenting the choice)

alternatively for b) ability to change AB in Edit Details
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Mail Window Front End → Address Book
Ever confirmed: true
QA Contact: front-end → address-book
Duplicate of this bug: 484450
Duplicate of this bug: 528931
Duplicate of this bug: 536698
Duplicate of this bug: 539000
(In reply to comment #12)
> b) second click of star offers ability to change AB on Edit Contact (if user
> has two or more AB that are not ldap, excluding collected AB, then there's no
> point in presenting the choice)
> 
> alternatively for b) ability to change AB in Edit Details

I think this is what this bug is (rightfully) requesting. 

The dialog that the second click on the star brings up ("Edit Contact") should have a selector for the address book (if there is more than one?). The single-click already serves as the only needed "simple" method. Therefore, the 
Edit Contact dialog (two clicks on the star) doesn't need to be dumbed-down so much by not including this essential feature.

PS. I'm having deja-vu. I think this bug already exists...
here's a quick mockup for an address book drop down, things look a little squished so we need to work on the padding.  Agreed that we don't need to show this if there isn't more than one address book (excluding the collected ab).  It would be nice not just use a dropdown and instead do something similar to the firefox folder choosing system where the most recent choices are floated to the top and you can expand to have a chooser for all possible options.

This shouldn't be too difficult to implement in it's basic form but the more advanced version that remembers selection will take a bit more time but will help people complete their tasks faster.
(In reply to comment #18)
> Created an attachment (id=422028) [details]
> [screen-shot of] address book option in edit popup

That (plus some padding) is exactly what we need to fix this bug.

> It would be nice not just use a dropdown and instead do something similar to
> the firefox folder choosing system where the most recent choices are floated to
> the top and you can expand to have a chooser for all possible options.

That should definitely be a followup bug (and not delay this bug). 

Actually, I've never really liked the Firefox "folder choosing system", and would prefer if that addition were not done in Thunderbird. How often do people add addresses? How often do they add so many addresses to the same (non-default) address book that adding that convoluted UI would actually be helpful?

> This shouldn't be too difficult to implement in it's basic form

:-)
(In reply to comment #18)
> Created an attachment (id=422028) [details]
> address book option in edit popup
...
> This shouldn't be too difficult to implement in it's basic form but the more
> advanced version that remembers selection will take a bit more time but will
> help people complete their tasks faster.

My concern with this address book option is that obviously the intention is to move a card from one address book to another - what should happen if that card is included in a mailing list?

Currently mailing lists can only reference cards in the address book that the mailing list is in. So if you move the card to a different AB it will (I'm pretty sure it will) be removed from any mailing lists that it is in.
(In reply to comment #20)
> My concern with this address book option is that obviously the intention is to
> move a card from one address book to another 

No, the primary intention is to place a *new* contact into an address book. Management of existing contacts are typically done in the Address Book. (The From line in the header doesn't even show which address book the contact is in)

> what should happen if that card is included in a mailing list?

This is an edge case (see above) and should be dealt with in a followup bug. This also affects how contacts that are in a mailing list are treated when they are moved to another address book.
(In reply to comment #19)
> (In reply to comment #18)
> > Created an attachment (id=422028) [details] [details]
> > [screen-shot of] address book option in edit popup

nice! except, as Mark points out, AB choice should not be offered in the case of edit. This bug is only about Add.

> How often do people
> add addresses? How often do they add so many addresses to the same
> (non-default) address book that adding that convoluted UI would actually be
> helpful?

(not implying favor for any particular UI)

In the larger context, if email is important as we all think it is, then arguably usefulness of contact/AB system rates as very high need (which is not to say that AB needs to be at the level of a full blown contact management system).

Back to your questions - for me, frequently (~daily), and frequently (~daily); which I would expect in certain environments (various work environments/models, multitaskers, uber-organizers, etc), and in other environments not at all (mom+dad, single taskers, first time users, etc). I don't claim any insight into what % of users each environment might be, but I don't believe the population that lives in multiple AB is trivial and should be subjugated to the minimal needs of the other population :)  


(In reply to comment #17)
> (In reply to comment #12)
> > b) second click of star offers ability to change AB on Edit Contact (if user
> > has two or more AB that are not ldap, excluding collected AB, then there's no
> > point in presenting the choice)
> > 
> > alternatively for b) ability to change AB in Edit Details
> 
> I think this is what this bug is (rightfully) requesting. 

correct. a) is  Bug 420867 - ability to set default address book name - which I listed as a possible stopgap solution and am still much interested in.
(In reply to comment #21)
> (In reply to comment #20)
> > My concern with this address book option is that obviously the intention is to
> > move a card from one address book to another 
> 
> No, the primary intention is to place a *new* contact into an address book.
> Management of existing contacts are typically done in the Address Book. (The
> From line in the header doesn't even show which address book the contact is in)

Whilst that's the suggestion of this bug, Bryan's clearly using the Edit popup, and his intention about New is unclear.

> > what should happen if that card is included in a mailing list?
> 
> This is an edge case (see above) and should be dealt with in a followup bug.
> This also affects how contacts that are in a mailing list are treated when they
> are moved to another address book.

And knowingly introduce a dataloss bug? I don't think that is a good idea at any time.
(In reply to comment #23)
> (In reply to comment #21)
> > (In reply to comment #20)
> > > My concern with this address book option is that obviously the intention is to
> > > move a card from one address book to another 
> > 
> > No, the primary intention is to place a *new* contact into an address book.
> > Management of existing contacts are typically done in the Address Book. (The
> > From line in the header doesn't even show which address book the contact is in)
> 
> Whilst that's the suggestion of this bug, Bryan's clearly using the Edit popup,
> and his intention about New is unclear.

Good point Mark, I hadn't thought of how we'd handle moving an address in that particular situation.

> > > what should happen if that card is included in a mailing list?
> > 
> > This is an edge case (see above) and should be dealt with in a followup bug.
> > This also affects how contacts that are in a mailing list are treated when they
> > are moved to another address book.
> 
> And knowingly introduce a dataloss bug? I don't think that is a good idea at
> any time.

Agreed.

I'm not quite sure how to proceed here.  I don't think we want to add some kind of address book chooser when a user clicks the star for the first time.  We could be tempted to try allowing this UI only just after a contact has been added and then disabling it after that however those type of interactions just cause confusion.  We could also try only allowing the change if the card isn't included in a mailing list; though I'm not sure how easy it is to detect this and would certainly cause some unneeded confusion.

I'm wondering what the possibility of fixing mailing lists would be, likely a large project just to get this piece in.
Bryan, my only other thought on a possible solution (which wouldn't necessarily be ideal, but would be a possibility), for an address not in the mailing list:

- Click Star => Adds straight to the address book where collecting addresses.

- Click Email Address and select "Add to Address Book" from the drop-down menu => brings up an Add to address book option with the ability to change the name and address book.

To fix mailing lists would really be part of a much bigger address book refactoring.
(In reply to comment #25)
> To fix mailing lists would really be part of a much bigger address book
> refactoring.

Exactly. The mailing list issue already exists when managing contacts within the Address Book UI. Delaying this bug because of that would be a classic case of "the perfect is the enemy of the good".

The name "Address Book" is confusing because the Address Book contains Address Books. Perhaps "Contacts"?
Duplicate of this bug: 542140
Duplicate of this bug: 517835
Hello, I'm new to this bug (see bug 542140), but I also need a way to add users to not-default address books without jumping through hoops.

I also use address books for filtering, and specifically I have books for a. people I like, b. people I don't like and c. people I /really/ don't like :-). ("Neutral" people aren't in an address book.) Obviously when I decide to put someone into one of those books, it is important to be able to choose which one.

Since clicking on the star is redundant with the current right-click, add to address book, maybe the 'add' in the context menu should instead expand to a list of your address books. This would avoid the modal dialog and save time in the case you don't need to edit the contact also (and, for that matter, there could be an option in the list of books to go straight into editing the contact...).
(In reply to comment #25)
> To fix mailing lists would really be part of a much bigger address book
> refactoring.

In that case, I should have a patch for this (following in the footsteps of Bryan's proposal). I'll try to clean it up and post it tomorrow.
I like the star feature to add multiple new addresses to an address book. 
I keep "collected addresses" empty, click the stars to add new names then drag and drop them as a batch to the new address book, usually mailing lists people emailed requests to get on.

The trouble comes when someone is already on another email list via a different address book.  I'd like the old ability to right click on the name with a yellow star and get the option to add the address to a different address book.

BTW, if someone sends me an email request with their email address in the body of the message, then I can right click and add it to any address book I want.  You just need to give that feature to the "from" address and I think everyone would be happy.

I'd also like to see a list of what address books they are already on so I can see if they are duplicates.

thanks
While we are at it, I would like to be able to have a "Remove" address book into which one can add addresses to be excluded from recipient lists, probably at the request of the recipient. Whenever one tried to send to someone in that address book, one would be warned and given an option of removing the address from the current recipient list, or overriding and sending anyway.

An enhancement would be for email with "Remove" in the subject line to have the sender's address automatically added to the "Remove" address book, so the entire process could proceed with a minimum of labor on the part of the user.
(In reply to comment #30)
> In that case, I should have a patch for this (following in the footsteps of
> Bryan's proposal). I'll try to clean it up and post it tomorrow.

Ok, nevermind. My work machine currently doesn't POST!
Hi everybody,

I have developed an addon adding the list of AB in the edit contact panel which is open by a second click on the star. The list allows to move the contact in other AB if there are not remote (LDAP are written in red). Is name is StarMoveContact and it is available on AMO : https://addons.mozilla.org/fr/thunderbird/addon/72070

Enjoy (hoping it works fine !)
(In reply to comment #34)
> Hi everybody,
> I have developed an addon adding the list of AB in the edit contact panel
> https://addons.mozilla.org/fr/thunderbird/addon/72070
> Enjoy (hoping it works fine !)

This is a very nice improvement.

Very nice if the name only appears in one address book. 

Is there a way to list all address books the email address appears in?
It would be possible to add checkboxes in the list and then allow multiple selection but, as it is implemented for the moment in TB3, the displayed address is linked only with one AB. Checking all AB in which the contact appears involves a research, the link is not immediate. It could be an improvement, with an option to choose between one or multiple selection.
(In reply to comment #34)
> Hi everybody,
> 
> I have developed an addon adding the list of AB in the edit contact panel which
> is open by a second click on the star. The list allows to move the contact in
> other AB if there are not remote (LDAP are written in red). Is name is
> StarMoveContact and it is available on AMO :
> https://addons.mozilla.org/fr/thunderbird/addon/72070
> 
> Enjoy (hoping it works fine !)

This extension is great!  Nicely done!

I have a couple of recommendations if you don't mind.

* You should use a <row> element and place the address book chooser in the grid instead of after so it lines up correctly

* I think it would look a lot better if we used the HUD style theme that FF has developed and is using for their folder location chooser on their bookmark popup

* For addresses in a read-only AB we should disable the chooser
* Similarly for contacts in mailing list (for now - follow up bug to handle)
# bonus points - When this is disabled we add a (?) indicator with a tooltip explaining why

* We should disable read-only ABs in the popup menu (the mac AB show up causes problems)


I've tested this some and with the above fixed I think feel like we could try to land this.

Luc, would you be interested in this?
Yes of course, any help is welcome. Do you have an account on AMO so I can add you as developer for the addon (this way you can also correct my bad English if you mind) or do you prefer me to do merge ?
(In reply to comment #38)
> Yes of course, any help is welcome. Do you have an account on AMO so I can add
> you as developer for the addon (this way you can also correct my bad English if
> you mind) or do you prefer me to do merge ?

I think Bryan you'd prefer that you did the merge !
Whiteboard: [UXprio]
Hi all,

I'm having this problem, but I find it does store the address somewhere.

I'm finding any address which I do not have stored; if I right click and select to add to address book; all I find is that the address is added to my address book; when I would actually expect to be prompted with the 'Add New Contact' box to appear.

Hope this helps clarify status of this.
Pete

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1.8) Gecko/20100216 Thunderbird/3.0.2

TB Addons = British Dict 1.19, Copy Plain Text 0.3.3, MinimizeToTray 0.0.1.2006102615+, and Update Notifier 0.1.5.5

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.2) Gecko/20100115 Firefox/3.6 (.NET CLR 3.5.30729)

Windows XP Pro 32-bit
Hello,

In line with Comment 31..

If the star is intended to quickly add an email address to Collected Addresses, fine. I ask for two things:

1) Let the tooltip for the star say 'Add to Collected Addresses' instead of 'Add to Address Book'

2) Allow the context menu item 'Add to Address Book' implement the same functionality that it would if I right click an email address in the Body. I really miss the ability to choose the address book I wish to add to. In other words, put it back the way it was please. :)

A further command on 2) - If I want to take the time to right click an email address, then I want to be able to choose the address book - give me the modal popup window. As implemented, I thought something was wrong when nothing seemed to happen.

thanks,

chris
(In reply to comment #35)
> (In reply to comment #34)
> > Hi everybody,
> > I have developed an addon adding the list of AB in the edit contact panel
> > https://addons.mozilla.org/fr/thunderbird/addon/72070
> > Enjoy (hoping it works fine !)
> 
> This is a very nice improvement.
> 
> Very nice if the name only appears in one address book. 
> 
> Is there a way to list all address books the email address appears in?

I used this addon before to check for duplicate contact manager to check this in TB2 (https://addons.mozilla.org/en-US/thunderbird/addon/2505); unsure if the Duplicate Contact Manager 2 works in TB3.0.2 (https://addons.mozilla.org/en-US/thunderbird/addon/53145)
I just wanted to say that I've been using the addon StarMoveContact (see Comment#34) and its been working well to fix this problem. Having the second click on the star allow editing INCLUDING shifting to a different address book works fairly intuitively and integrating this addon might be an easy way to fix this bug.
Duplicate of this bug: 555744
This add-on does work pretty well for me.  I'd be happy to help out more with this though we're running out of time for the 3.1 period.
(In reply to comment #41)
> ...
> 2) Allow the context menu item 'Add to Address Book' implement the same
> functionality that it would if I right click an email address in the Body. I
> really miss the ability to choose the address book I wish to add to. In other
> words, put it back the way it was please. :)

Yes, put it back the way it was (and the way that makes sense).

Ben
In Thunderbird 2.0, when clicking on an email address in the 'From' line, it would display the 'add email address' dialog with the default target of the "Personal Address Book".  Additionally, the save "sent" email addresses function used the "Collected Addresses" address book (by default).

So this defined the Personal Address Book at the place people keep manually added emails (by default) and the Collected Addresses as the place people keep automatically collected addresses (by default when the option was selected).

By changing manually saved emails to be saved to the [formerly automatically] Collected Addresses folder, it's changing the user visible functional design of the application. 

Additionally, it's breaking years of already created email filters for people like me who use filters referencing the Personal Address Book to do special things for people I know (aka people whose email addresses I manually added).

And, as Chris accurately observed in comment 41, if there's no dialog box after clicking on "Add to Address Book", it feels like nothing happened.  Very confusing.

Also agreeing with comments 31 & 41, having the "Add to Address Book" behavior for the 'From' email address be consistent with the "Add to Address Book" behavior for an email in the message body seems like a good idea.

Ben
My five cents. I did not read whole discussion since it is long.

Guys wouold it be so difficult to add preference to TB to people that need select specific AB to be able to do that? 
Or add one menu item more "add to specific AB" It could be allowed also by preference not to disturb easy going users. 
I guees TB is not replacement for dumb Outlook Expres it is widelly extensible postman.

I upgraded to TB3 on one machine and I do regret it very much. It is realy nasty stepbackward without workaround. I know nobody can know others workflow and habits for 100%.

For me this funcion was quite important since nobody until know implemented add sender to specific addressbook mailing filter rule.
Nobody took drag and drop in TB and its AB too serious. For ours, mac users, that are get used for as standard from early '90 it is ... how to say that... it drives me mad sometime when I can not move something by drag and drop. And in addressbook it is way too often. I know this is for another threed.

But last thing. Reason why I need this is lask of mentione mailing filter rule. I must add sender asking to be added to various mass mailing group manually. It can not be solved by choosing default addressbook.

So please solve it acceptable. I know you all do it for free and respect belongs to you for that. I do no coding so can only test and criticise :-)
There is experimental add on
https://addons.mozilla.org/cs/thunderbird/addon/72070

that can save you(us) :-)
Duplicate of this bug: 557624
Duplicate of this bug: 559072
Posted patch proposed fixSplinter Review
Also taking care of bug 539000.
Assignee: nobody → mkmelin+mozilla
Status: NEW → ASSIGNED
Attachment #444299 - Flags: ui-review?(clarkbw)
Attachment #444299 - Flags: review?(bugzilla)
Blocks: 539000
Glad to hear there's a fix, but I'm not able to interpret the source code modifications.   Does the fix permit a choice of address book when I right click on the "from" address and select "Add to Address Book"?
With the patch: Add to Address Book will add to the personal address book. If you click the contact again you get the situation of https://bugzilla.mozilla.org/attachment.cgi?id=422028
There if you change address book the contact is moved to the one you want.
Duplicate of this bug: 570885
Comment on attachment 444299 [details] [diff] [review]
proposed fix

Sorry, this turned into an unintentional filibuster.  It looks good to me overall.  I'm concerned about the change of default from collected to personal but as the compose autocomplete uses all address books I don't think this will matter much for people who don't care to manage these things.  For others who do the edit chooser should help fix things.

Mark suggested adding some warning text for the mailing list case I don't mind doing that as a follow up to this.
Attachment #444299 - Flags: ui-review?(clarkbw) → ui-review+
I'm not going to be able to get to review this for a bit over a week.

However, I did notice that on Mac the drop down doesn't look right in the edit popup. Its the native mac colours, as opposed to the dark grey/black background on the dialog. We probably just need to borrow some css from Firefox as their current edit Bookmark popup dialog has a drop down box in it.
Comment 18 is showing exactly what I would love to see "back."
I have multiple AB due to my (multiple) clients who have the same clients. Each client requests their card have different information. I need to know which AB the contact is in to edit and add requested information. (it's also an issue when I'm sending email but that's another story). I don't want collected address, I don't need an automatic add. I need to be able to easily edit an existing contact with the knowledge of where that contact is located before doing so. I need to have the same person in multiple AB, duplicates are necessary.
I don't see how this is an enhancement when it's a clear regression from previous TB2.0 functionality. Comments?
(In reply to comment #59)
> I don't see how this is an enhancement when it's a clear regression from
> previous TB2.0 functionality. Comments?

indeed
Severity: enhancement → normal
Keywords: regression
Version: unspecified → 3.0
Comment on attachment 444299 [details] [diff] [review]
proposed fix

Sorry for the delay in getting back to this. r=Standard8 with the proviso that this lands with the additional Mac theme patch that I'm just about to post on this bug.
Attachment #444299 - Flags: review?(bugzilla) → review+
This fixes the style drop-down menu on Mac in the edit contact panel. I've matched it to mozilla-1.9.2's edit bookmark dialog as that's what we originally copied from and we haven't updated those themes for trunk yet.
Attachment #469425 - Flags: review?
Attachment #469425 - Flags: review? → review?(nisses.mail)
(In reply to comment #63)
> This fixes the style drop-down menu on Mac in the edit contact panel. 

Any chance of including the Mac address book as one of the "target" ABs? That would *partially* fix bug 391057. </dream>
(In reply to comment #64)
> (In reply to comment #63)
> > This fixes the style drop-down menu on Mac in the edit contact panel. 
> 
> Any chance of including the Mac address book as one of the "target" ABs? That
> would *partially* fix bug 391057. </dream>

No, the only way that would be included is by fixing bug 391057 in the first place.
Comment on attachment 469425 [details] [diff] [review]
Fix Drop down menu style on Mac

Looks good to me!
Attachment #469425 - Flags: review?(nisses.mail) → review+
Checked in both patches:

http://hg.mozilla.org/comm-central/rev/0adf0814bf38
http://hg.mozilla.org/comm-central/rev/d444c67ecd17
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
> I have multiple AB
Yes!
> I need to know which AB the contact is in to edit and add
> requested information.
Yes!

I also used Collected Addresses but *NOT* for this purpose. Collected Addresses scroll off after a certain time and file size. This is not the intent surely.
If you right-click an email link in the text area (not the header), the OLD OPTION STILL SHOWS UP.
post-fixed note, this was a big ticket item per http://getsatisfaction.com/mozilla_messaging/topics/added_addresses_go_to_wrong_address_book
Whiteboard: [UXprio] → [UXprio][gs]
Duplicate of this bug: 631857
Whether a dup or not (it's not), it's been fixed, v24 and subsequent.
(In reply to Michael Johnston from comment #71)
> Whether a dup or not (it's not), it's been fixed, v24 and subsequent.

Yes. Bug 631857 was a duplicate of this bug, which has obviously long since been fixed (since TB5).
You need to log in before you can comment on or make changes to this bug.