Closed Bug 46041 Opened 20 years ago Closed 16 years ago

Multiple accounts without multiple folders (global inbox, etc.)

Categories

(MailNews Core :: Backend, enhancement, P3)

x86
Windows 2000
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 30057
Future

People

(Reporter: mozilla, Assigned: Bienvenu)

References

Details

In order for multi-pop to be very useful, users need to be able to have all of 
their mail activity consolidated to one set of folders (eg, Inbox, Sent, etc.). 
While having a separate structure for each account is fine for two or three 
accounts, it gets ridiculous with many accounts. It makes keeping track of mail 
a real pain.

I have heard the argument that there is no way to keep track of how reply-to 
addresses should be set without this separate structure for each account, but 
this argument is weak. Relying on which folder a mail is in when it gets replied 
to is a nasty hack for multiple account functionality. Mail composition should 
look at the To: and CC: fields and try to match up the recipient(s) with an 
account, and use that as the From: address.
marking future. Putterman can you mark this a dup of the virtual folders bug? I
think you own that one. 
Assignee: mscott → putterman
Target Milestone: --- → Future
Are you talking about bug 11051 ?
QA Contact: lchiang → esther
I'm not sure if we have a dup for this. I don't know if there are Universal
Inbox, Universal Sent, etc bugs out there. This is slight different than what
11051 mentions so I wouldn't call this a dup.
See bug 30057 (and bug 58380 ? )
Mass removing self from CC list.
Now I feel sumb because I have to add back. Sorry for the spam.
*** Bug 100520 has been marked as a duplicate of this bug. ***
[RFE] is deprecated in favor of severity: enhancement.  They have the same meaning.
Severity: normal → enhancement
Is this bug still alive?
If not, shouldn't it be resolved sometime?

Is this the same as bug 126341 (Download mail from multiple accounts into Local
Folders inbox)?
*** Bug 126341 has been marked as a duplicate of this bug. ***
taking. However, the reply-to issue is still real - you can get mail that's not
directly addressed (to or cc) to you. And you can get mail that's address to you
in multiple accounts.
Assignee: scottputterman → bienvenu
Well, after getting used to the separated folders for each account,
I think current approach seems to be good.

Problem is that it is not convenient to retrieve all email from all accounts,
However there is an extension, "Receive All". So... Try usuing it.
Jongam, if you're using thunderbird, there is an extension, like you say. For
the Mozilla suite app, the Get Msgs toolbar button has a "get all new messages"
choice. I think the Thunderbird extension just adds back that functionality to
thunderbird.
OK. David. So, what is wanted is that the Thunderbird has "Gell All Messages" built-in.
OK. It is good.
Re: comment 8 - Fixed.

Re: comment 11 - Since some mail isn't directly sent to the recipient wouldn't
an "Account" column fit better than a "Recipient" column?  Keep the recipient,
but add account and put it in the column layout by default when someone switches
to this layout.  I think "Write" when one of the collapsed-to folders is
selected should still use the default account (it's easy enough to change it),
but "Reply" should go by the account the mail is received from.

Re: comment 14 - See bug 222380--it's the nearest match i can make to having a
"get all messages" function in TB.  Of course, there's an extension anyway.
Summary: [RFE] Multiple accounts without multiple folders → Multiple accounts without multiple folders
"However, the reply-to issue is still real - you can get mail that's not
directly addressed (to or cc) to you. And you can get mail that's address to you
in multiple accounts."

So what? 

In the absence of being able to pick an address for replying with, surely it
should just use the default account (whichever that is set as), which the user
can then easily switch if they need to. If Microsoft can manage this, TB
developers can and will do a far better job in the end IMO.

There should definitely be support for single folders, it would make the
interface much more user friendly and, well, usable.
*** Bug 157372 has been marked as a duplicate of this bug. ***
Summary: Multiple accounts without multiple folders → Multiple accounts without multiple folders (global inbox, etc.)
*** Bug 242357 has been marked as a duplicate of this bug. ***
duping - this is working now

*** This bug has been marked as a duplicate of 30057 ***
Status: NEW → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.