Address bar autocomplete and search bar autocomplete doesn't always work with compiz after emerging from gnome-screensaver lock or suspend

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
10 years ago
7 years ago

People

(Reporter: erappleman, Assigned: karlt)

Tracking

Trunk
x86
Linux
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 -, blocking1.9.2 -)

Details

(Whiteboard: [analysis in bug 631518][fixed in compiz 0.8.8])

Reporter

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090729 Ubuntu/9.10 (Karmic Koala) Firefox/3.6a1pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090729 Ubuntu/9.10 (Karmic Koala) Firefox/3.6a1pre

For the past few weeks, the trunk builds have exhibited a behavior where the autocomplete of the so-called awesome bar will only work sporadically.

There are some times where the autocomplete will not work at all and other times when it will appear for a few milliseconds after typing a letter before disappearing.

I haven't been able to pin-point what causes this, but I have found that restarting the browser resolves the issue until it occurs again.

This doesn't happen very often, but at least a few times each day.

Reproducible: Sometimes
Reporter

Updated

10 years ago
Component: General → Location Bar and Autocomplete
Version: unspecified → Trunk
QA Contact: general → location.bar
is this in safe mode? do you have any add-on that could interfere with it?
reporter, please respond to the safe mode question.
Whiteboard: closeme 2009-09-25
Reporter

Comment 3

10 years ago
Happens in safe mode and even when no add-ons are installed.

Also affects 3.5.3 and 3.7a1.
Reporter

Comment 4

10 years ago
Also, I can confirm that this happens on a fresh Ubuntu Jaunty or Karmic install.
Reporter

Comment 6

10 years ago
I've also noticed that if I leave my laptop on overnight with the browser open, this bug will occur without fail.
Reporter

Comment 7

10 years ago
I forgot to mention that my machine doesn't enter hibernation or suspend and this happens both with and without the screensaver being active.
Whiteboard: closeme 2009-09-25
Reporter

Comment 8

10 years ago
Right-clicking on a webpage seems to fix the autocomplete until it acts up again.
I think this may be a focus issue.
After watching the behavior a bit, it's really starting to feel to me like this is an issue with the popup. I sometimes see a brief flash of the popup with what I believe is the correct autocomplete information. Also sometimes I see no popup, but the cursor changing from the input cursor to the default cursor for a split second. I think the popup is closing as soon as it's opened.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 10

10 years ago
Is this related to compiz in some way?
Reporter

Comment 11

10 years ago
Possibly related to Compiz.

I left my laptop on all night with Compiz disabled and the screensaver didn't trigger the bug this morning.
Duplicate of this bug: 508463

Comment 13

10 years ago
I can confirm this bug as well with Compiz turned off. It is hard to reproduce on command though.
I also hit this bug occasionally; it seems to occur more frequently after I've been away from my machine for a while and had the screensaver kick in. Is there any sort of debug information/output that could be checked? Or anything we could try while in that state that might provide more information?

Comment 15

10 years ago
I'm also having this problem, on 3.5.3.
just confirming that this also affects the search box, as one might expect.
Alright, so given comment 16 this is likely an AutoComplete bug.  Dietrich was seeing something like this today I think too.
Component: Location Bar and Autocomplete → Autocomplete
Product: Firefox → Toolkit
QA Contact: location.bar → autocomplete

Comment 18

10 years ago
Still see the problem in 3.5.4.
Reporter

Comment 19

10 years ago
Still present in upstream:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2pre) Gecko/20100109 Ubuntu/10.04 (lucid) Namaroka/3.6pre

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.3a1pre) Gecko/20100109 Ubuntu/10.04 (lucid) Minefield/3.7a1pre
Alright, noticed a couple more things about what happens when Firefox gets in this mode:

1) After selecting all of the text in the url bar, mousing out of the window (like moving your mouse over the title bar) will unselect everything in the url bar, much like what would happen if you focused another window.

2) After clearing everything in the address bar, mousing out of the window will show the emptytext ("Search Bookmarks and History"), much like what would happen if you focused something else.

Focusing another window will take Firefox out of this mode.

This problem is really not okay for Ubuntu users.
opening chrome://global/content/console.xul and evaluating "window.focus()" fixes it as well
Asking for blocking because this is a pretty bad user experience bug for Ubuntu users, it happens every time I leave the computer for more than a few minutes and not having the awesomebar autocomplete is pretty frustrating after having gotten used to it.

Although it comes back after focusing another window, this is both annoying to have to do every time and not immediately discoverable.
blocking1.9.2: --- → ?
blocking2.0: --- → ?

Comment 23

9 years ago
I've narrowed down a way to reproduce this on Ubuntu 9.10:
1. Open a Firefox window.
2. Suspend the computer.
3. Unsuspend it back (note: in my case, I have to unlock the screen).

After this, the address bar autocompletion in the previously open window is broken. A way to fix it is to get keyboard focus elsewhere (I use right-click menu on the gnome panel) and then return it to the location bar.

Similar behavior is observed with Eclipse 3.5. In fact, it's worse there, because keyboard presses cease to have any effect when the buggy state is reached.
In an unrelated Eclipse bug, it's been noted that certain changes made in Gtk+ 2.18 may break applications or widget frameworks that are using Gtk+ in weird undocumented ways which happened to work before.
If this is also happening with Eclipse, are we sure it's actually a Firefox box as opposed to an Ubuntu bug?

Please renominate if you can track down a regression range or definitively pin this on us.
blocking1.9.2: ? → -
blocking2.0: ? → -

Comment 25

9 years ago
According to the following comment, this bug has also been reproduced on Arch Linux, which I don't believe has a similar patch lineage to Ubuntu:

https://bugs.launchpad.net/ubuntu/+source/firefox-3.0/+bug/428703/comments/19

If other non-ubuntu folks are experiencing this issue, please confirm here to get it documented.

Comment 26

9 years ago
I'm using 32bit Arch Linux and have had this problem for a while (I commented twice already above, but didn't mention my system). I also had this problem with 64bit Arch Linux.

Right now I'm using Gnome, Firefox 3.6, 32bit Arch Linux, 2.6.32 kernel.
Reporter

Updated

9 years ago
Summary: Address bar autocomplete doesn't always work → Address bar autocomplete and search bar autocomplete doesn't work after emerging from a screensaver or suspend
Reporter

Updated

9 years ago
Summary: Address bar autocomplete and search bar autocomplete doesn't work after emerging from a screensaver or suspend → Address bar autocomplete and search bar autocomplete doesn't always work after emerging from a screensaver or suspend
I've started seeing a slightly different behavior with this bug. The awesome bar popup will display very very briefly. Not long enough to read it, but enough for it to blend in with the current background of the page as it attempts to fade in.

That's using Debian 6.0 "Squeeze" x64.

Comment 28

9 years ago
Is it reproducible with Metacity?

Comment 29

9 years ago
(In reply to comment #28)
> Is it reproducible with Metacity?

I should have asked, with something else than Compiz?

Comment 30

9 years ago
(In reply to comment #28)
> Is it reproducible with Metacity?

No, It's not reproducible with Metacity.

In FF4 the problem has worsened, even the bookmarks button does not work properly because of this bug. 
[running 4.0~b8~hg20101128r58314+nobinonly-0ubuntu1~umd1~maverick]

When i click the bookmarks button, the menu drops down, (menu items get highlighted but does not receive focus?)  And as soon as I move the pointer to (mouse over) a bookmark folder which leads to a submenu the main menu itself disappears and closes.

This has been a recent problem in FF4.
I believe the problem with the buttons and submenu started since update: firefox-4.0 (4.0~b8~hg20101122r57984+nobinonly-0ubuntu1~umd1~maverick) to 4.0~b8~hg20101123r58015+nobinonly-0ubuntu1~umd1~maverick.
But, it took me a while to realize that it is related to this bug.

[A workaround for the button is, switching to another window and back.]

Comment 31

9 years ago
I'll add a "me too" here. I never saw this with FF3, but now with FF4 I'm seeing it every few days (not hours). Certainly annoying. The awesome bar is soooo good that my lazy mind is totally incapable of working without it - it hurts when it doesn't work!

I'm a Fedora13 desktop - no hibernate, but I have compiz and password-protected screensaver. I can't say I've noticed any relationship between screensaver and when the fault hits - it seems to be random to me

Jason
Duplicate of this bug: 537517
Duplicate of this bug: 545846
Duplicate of this bug: 580994
This might be related to bug 604710, although that bug doesn't talk about waking up from screensaver or suspend.

Comment 36

9 years ago
I am 100% seeing this triggering after unlocking the screensaver. I am also running compiz. Note: if I manually lock the screen and immediately unlock it, the fault doesn't happen - so I don't know what the exact trigger is

Moving to a different virtual desktop and back again seems to clear the fault - and awesome becomes awesome again

This is with FF4.0b8 under Fedora13

Comment 37

9 years ago
Hi,

you should lock your screen and then wait for a couple of seconds. 

I tried this myself. I you unlock the screen immediately after locking it, nothing happens and the autocompletion works quite fine. But if your are running Compiz on your machine, lock the screen and then wait for a couple of seconds (just count to ten) and after that unlock your screen you will notice that the autocompletion is not working at all. You have to switch to another virtual desktop (and then back to the firefox window) to have it work again. 

Interesting is that the screensaver is not of any importance here. If the screensaver is triggered it does not affect the autocompletion. Only if activating the screensaver also locks your desktop, then autocompletion is not working.
(In reply to comment #37)
> you should lock your screen and then wait for a couple of seconds. 

FWIW, I can't reproduce on my Ubuntu box, although I do experience bug 604710.

Comment 39

9 years ago
I cannot reproduce with Firefox 3.6 on Fedora 13, whether running compiz or not. I used to see the problem all the time in early Firefox 3.6 builds, but have not seen this bug in months (when not running compiz), nor in the past week (running compiz).
Anyone still getting it with compiz 8.6 / firefox 3.6.13? I have never been able to reproduce this bug systematically but had it quite frequent - without apparent trigger - despite never having used a screensaver. 

Now I too haven't seen it for a few months. Might have been gone for a few firefox and/or compiz versions already?

Comment 41

9 years ago
For me this problem only kicked in after going FF4 - I never saw it under FF3.any either

Comment 42

9 years ago
XeHK added the following comment to Launchpad bug report 438868:

Yep. For now I've got compiz 0.8.6 and FF 3.6.13 on my ubuntu 10.10, and this bug is still reproduces after screensaver. This is quite annoying to live with such bug for more than a year. 

-- 
http://launchpad.net/bugs/438868

Comment 43

9 years ago
I have noticed that the address bar failure often seems linked to another error I've seen -- sub-menus don't work at all. For example, if I pull up the bookmark menu I can select a top level bookmark, but if I try to view a folder the bookmarks menu goes away. Same for the main Firefox 4 menu.

I've been bothered by the two errors (no awesome bar suggestions, no sub-menus) fairly often, but I have not considered checking to see if they are linked until just now.

I'm running Minefield on Ubuntu 10.10, Mozilla/5.0 (X11; Linux x86_64; rv:2.0b9pre) Gecko/20110109 Firefox/4.0b9pre right now, switching to a new version after I finish this reply. I've seen this issue with more than one version, but I don't know when it started.

(In reply to comment #37)

> But if your are
> running Compiz on your machine, lock the screen and then wait for a couple of
> seconds (just count to ten) and after that unlock your screen you will notice
> that the autocompletion is not working at all.

I have Compiz installed. I don't think every ten-second screen lock causes the issue.

> You have to switch to another
> virtual desktop (and then back to the firefox window) to have it work again. 

Thank you for this tidbit, I had been restarting Firefox to solve the problem. I tried this right now and it work -- I had non-functioning menus and non-functioning awesome bar and switching desktops fixed both problems.
Sub-menu issues are bug 616833.  It would be very interesting if these were related!

Comment 45

9 years ago
I was so focused on experiencing the issue in bug 616833 that I didn't really think about this, but I've also been seeing this as well, so it's not outside the realm of possibility it's related.  I also forgot to consider that I tend to put my laptop to sleep/wake it fairly frequently, so that fits.

Comment 46

9 years ago
I don't know if it can help, but when this problem occurs, RSS Live Bookmarks in personal address bar don't work anymore either.
I just came out of suspend and noticed that, in addition to not getting any awesomebar suggestions, right-clicking in a Gmail plain text message textbox didn't produce a context menu.  Perhaps this isn't related to the location bar.
Moving out of toolkit/autocomplete, since this appears to be a larger problem.
Component: Autocomplete → General
QA Contact: autocomplete → general

Comment 49

8 years ago
Any idea how hard this is to fix? Could this be a Firefox 4 blocker?

When this happens, users are going to think Firefox is totally broken. If I didn't know the work-around I would have looked at switching to another browser.
I'm not sure if this helps, but when I see this I can see the blue focus ring on the address bar when my mouse is over Firefox, but when I move my cursor up to the GNOME panel at the top of my screen where my Application/Places/System menus are I can see the focus ring move to one of the shortcuts I have on that panel.

I do not have window focus set to follow the cursor.
Duplicate of this bug: 533211
Duplicate of this bug: 633514
Since this is a regression finding exactly what caused it to regress might help in fixing it.
Assignee

Updated

8 years ago
Blocks: 638386
Assignee

Updated

8 years ago
Summary: Address bar autocomplete and search bar autocomplete doesn't always work after emerging from a screensaver or suspend → Address bar autocomplete and search bar autocomplete doesn't always work with compiz after emerging from a screensaver or suspend
Assignee

Updated

8 years ago
Blocks: 631518
Assignee

Updated

8 years ago
Assignee: nobody → karlt
Summary: Address bar autocomplete and search bar autocomplete doesn't always work with compiz after emerging from a screensaver or suspend → Address bar autocomplete and search bar autocomplete doesn't always work with compiz after emerging from gnome-screensaver lock or suspend
Whiteboard: [analysis in bug 631518]
Assignee

Comment 54

8 years ago
http://cgit.compiz.org/compiz/core/commit/?id=30a92d8a060d79181a28840d7c66428ef431200c

WFM with compiz fix.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
Whiteboard: [analysis in bug 631518] → [analysis in bug 631518][fixed in compiz 0.8.8]

Comment 55

8 years ago
Karl - thanks for the link, that fixes it for me too. I'll make sure Ubuntu users get this next week :)

Comment 56

7 years ago
I'm using Debian Squeeze and I have encountered this bug too. When Firefox is focused and after I re-login to gnome (after the minimum allowed idle time has passed) the autocomplete of address bar doesn't work. I have to minimize and then maximize Firefox to make the autocomplete work.
You need to log in before you can comment on or make changes to this bug.