Last Comment Bug 533692 - Kaspersky Anti-Spam Extension causes blank main window on 2.0.0.23 to 3.0 upgrade
: Kaspersky Anti-Spam Extension causes blank main window on 2.0.0.23 to 3.0 upg...
Status: RESOLVED FIXED
[for current status see comments 40 a...
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: 3.0
: All Windows 7
: -- critical with 3 votes (vote)
: Thunderbird 3.1a1
Assigned To: Mark Banner (:standard8)
:
Mentors:
http://www.kaspersky.co.uk/ http://gs...
: 533799 534476 536039 536241 536823 537491 540220 540223 (view as bug list)
Depends on: compdir-lockdown
Blocks:
  Show dependency treegraph
 
Reported: 2009-12-09 04:42 PST by Mark Banner (:standard8)
Modified: 2011-03-09 08:05 PST (History)
36 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
.1+
.1-fixed


Attachments
Possible workaround (1.50 KB, patch)
2010-01-07 04:39 PST, Mark Banner (:standard8)
robert.strong.bugs: review+
standard8: approval‑thunderbird3.0.1+
Details | Diff | Review

Description Mark Banner (:standard8) 2009-12-09 04:42:07 PST
I've seen multiple reports of this on getsatisfaction and also in talking to a user on irc. The basic issue appears to be:

- Kaspersky 2010 software installs an extension into Thunderbird
- The extension installation puts two files into our components directory: klthbplg.dll and IKLAntiSpam.xpt
- These files cause some sort of issue on Thunderbird being upgraded from 2.0.0.23 to 3.0 and I'm guessing prevent proper registration of all components.

I have a copy of the files but not looked at them yet.

Next steps are to let Kaspersky know about this issue and see if there is something we can do to protect our users when we upgrade - this is exactly the sort of thing that bug 519357 is intended to fix. It looks like it will go into the 1.9.1 branch but I can't tell if it actually will be or not.


For reference, getstatisfaction subjects so far:

http://getsatisfaction.com/mozilla_messaging/topics/thunderbird_3_upgrade_woes
http://getsatisfaction.com/mozilla_messaging/topics/upgrade_to_tb_3_0_shows_useless_empty_main_window_on_win7_x64
Comment 2 [:Aureliano Buendía] 2009-12-09 08:54:54 PST
I can't observe this behavior because I haven't installed Kaspersky spam-filter on my Kaspersky for Windows Workstation.

I had similar issue (related to KAV and Thunderbird) as described in bug #530714 (resolved disabling proactive defense, see http://forum.kaspersky.com/index.php?showtopic=146785 I think that is a KAV "bug" because block my extension but don't alert me).

The issue is still present also if user disable spam-filter from Kaspersky console?
Comment 3 Daniel Schunk 2009-12-09 12:19:26 PST
I had exactly the same issue:

I made the upgrade from Thunderbird 2.0.0.23 to Thunderbird 3.0 on an IBM Thinkpad T41 running Windows 7 Home Premium.

The anti virus tool is Kaspersky 2010. Thunderbird 3.0 is getting all account settings so far, but all mail folders seems to be lost.

The issue is still present, while disabling the Kaspersky anti spam add-on in Thunderbird. It's not possible, to remove this add-on.

Kind regards,
Daniel
Comment 4 baudry 2009-12-09 14:18:32 PST
It's a same proble m for me I can't read my mail and see all folders corresponding to my accounts. It contains all mails, but with thunderbird 3, I can't see nothing? I install thunderbird 3 after thunderbird 2.3 on windows xp. but in Local settings\Mozilla thunderbird I can see my profile, I hope this installation can't delete my mail and folder.
Comment 5 Roland Tanglao :rolandtanglao 2009-12-09 15:12:02 PST
(In reply to comment #4)
> It's a same proble m for me I can't read my mail and see all folders
> corresponding to my accounts. It contains all mails, but with thunderbird 3, I
> can't see nothing? I install thunderbird 3 after thunderbird 2.3 on windows xp.
> but in Local settings\Mozilla thunderbird I can see my profile, I hope this
> installation can't delete my mail and folder.

please try the workarounds here:
http://getsatisfaction.com/mozilla_messaging/topics/kaspersky_anti_spam_extension_causing_blank_window_problems_with_thunderbird_3_upgrade
Comment 6 Mark Banner (:standard8) 2009-12-10 00:25:31 PST
*** Bug 533799 has been marked as a duplicate of this bug. ***
Comment 7 Mark Banner (:standard8) 2009-12-10 02:50:06 PST
I've just been doing some tests with the files (klthbplg.dll and IKLAntiSpam.xpt).

Either file in the components is enough to cause problems with the TB 3 installation.

Getting the components directory lockdown fix (bug 519357) into TB 3 would be enough only for the klthbplg.dll. It doesn't go so far as to lock down the components directory for .xpt files.

So we'd still need to do something for the .xpt file. My thought would be to remove the files by listing them in removed-files.in, though I guess we may need something extra for the extension registration part.

Have we come across things like this before? and if so, how have we handled them?
Comment 8 Henrik Skupin (:whimboo) 2009-12-10 08:48:55 PST
Just a note that the components folder lockdown feature is not available on 1.9.1 yet. AFAIK no eta exists yet to get it onto 1.9.1.
Comment 9 Mike Dodge 2009-12-10 09:44:39 PST
A little less invasive solution for the time being, at least for me, is to disable IMAP/POP/SMTP scanning from within Kaspersky - seems to have done the trick. According to the AV, this scans email streams while they are being received. Emails are still scanned after they are received if you disable the stream scanning, for those who are concerned.
Comment 10 Wayne Mery (:wsmwk, NI for questions) 2009-12-11 05:05:33 PST
from mozilla.support.thunderbird, subject "Re: Fundamental TB3 problem - blank folder pane" 
 "The strange thing is that I don't actually use the Kaspersky anti-spam option and I had the Kaspersky add-on disabled in TB2, but it nevertheless seems to cause this problem in TB3!"
Comment 11 Chris Cain 2009-12-11 06:33:11 PST
Same here.  I turned off the Kaspersky AntiSpam a long time ago but still had the problem.
Comment 12 jay garcia 2009-12-11 06:45:14 PST
A user in the Moz forum indicated that he found the two files, deleted them and that fixed it.

I don't have those two files so I assume this is only related to KAV 2010, not previous versions. I'll wait to see what happens with KAV.
Comment 13 Phil Ringnalda (:philor) 2009-12-12 19:48:00 PST
*** Bug 534476 has been marked as a duplicate of this bug. ***
Comment 14 Carsten Book [:Tomcat] 2009-12-14 03:19:32 PST
back to the pool - i think Johnathan has contacted Kaspersky
Comment 15 Herbert Eppel 2009-12-14 08:32:36 PST
Jay, assuming that I'm the user who "indicated that he found the two files, deleted them and that fixed it", I actually went back to TB 2 for the time being because I wasn't sure that this is a proper, stable solution.

Meanwhile I submitted report request to Kaspersky and their reply/recommendation wasn't particularly satisfactory, i.e. they recommended to do a custom installation into a non-standard installation folder.

I might 'play' with this on my laptop but I asked them whether they are planning to develop solution that is suitable for the standard installation of Thunderbird 3 in due course.

By the way, I don't really regard this as a Thunderbird 3 bug but as unwelcome interference by a third-party product with the Thunderbird installation.

Any comments/views on all this?
Comment 16 Carsten Book [:Tomcat] 2009-12-17 01:52:49 PST
Update from Kaspersky:

> We know from our support about some problems of Thunderbird or FireFox
> plug-in upgrades when Kaspersky 2010 installed. We already have made some
> fixes in our hot-updates which could fix the most cases. 

So this is fixed in the versions with updates ? Would nice to know the exact version number where this problem is not fixed
Comment 17 [:Aureliano Buendía] 2009-12-22 23:52:54 PST
*** Bug 536039 has been marked as a duplicate of this bug. ***
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2009-12-23 00:14:07 PST
Mark, as a workaround you can delete these files in PostUpdate as well as on install. I suggest doing it this way and not use removed-files.in since you can specify the file will be deleted on reboot if it is in use.
http://mxr.mozilla.org/comm-central/source/mail/installer/windows/nsis/shared.nsh#38

http://mxr.mozilla.org/comm-central/source/mail/installer/windows/nsis/installer.nsi#200
Comment 19 Roland Tanglao :rolandtanglao 2009-12-24 10:41:20 PST
Carsten: please ask Kaspersky for the exact Kaspersky version number and exact Kaspersky anti-virus db version number where it is fixed.
Comment 20 [:Aureliano Buendía] 2009-12-27 03:49:59 PST
*** Bug 536823 has been marked as a duplicate of this bug. ***
Comment 21 Mark Banner (:standard8) 2010-01-07 04:39:06 PST
Created attachment 420535 [details] [diff] [review]
Possible workaround

This is a possible fix to the installer. It should remove the bad files from the components directory on upgrade or on installation over an existing version of Thunderbird.

This will at least give users a usable Thunderbird. We're currently working with Kaspersky to ensure they have a solution that will allow their extension to work with Thunderbird 3 as well.

I've not compiled or tested this yet (I've just thrown it at the try server though).
Comment 22 Mark Banner (:standard8) 2010-01-07 11:33:04 PST
Comment on attachment 420535 [details] [diff] [review]
Possible workaround

I've just been testing this patch for the situation where the TB 3 installer is run and installs Thunderbird over the top of an existing Thunderbird 2 installation with the files in the components directory - they are correctly removed and Thunderbird starts up fine.

I still have to test the update case, which I think I can do, but it'll take a bit longer so I'll do it tomorrow.

Try server build with this patch is here: http://s3.mozillamessaging.com/build/try-server/2010-01-07_07:40-bugzilla@standard8.plus.com-st8-kaspersky-2/bugzilla@standard8.plus.com-st8-kaspersky-2-mail-try-win32.installer.exe (its called Shredder, but you can redirect the installation over a Thunderbird 2 install).

Rob, would you mind taking a quick look at this? I need to land it before end of Friday, so if you're busy, I'll see if I can find someone else to take a look.
Comment 23 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-07 11:36:36 PST
Comment on attachment 420535 [details] [diff] [review]
Possible workaround

Looks good. You can also test the update case without actually performing an update by running <path to helper.exe>\helper.exe /PostUpdate
Comment 24 Mark Banner (:standard8) 2010-01-08 01:59:19 PST
(In reply to comment #23)
> (From update of attachment 420535 [details] [diff] [review])
> Looks good. You can also test the update case without actually performing an
> update by running <path to helper.exe>\helper.exe /PostUpdate

I couldn't get post update to run like that or any other form - it didn't remove the files, but it also didn't remove the talkback directory that it created.

I'll keep playing, but I believe the code is right, so I've landed it in time for the nightlies which should allow a full proper test anyway:

http://hg.mozilla.org/comm-central/rev/e810cfd4a17b
Comment 25 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-08 02:02:08 PST
When you ran /PostUpdate was any UI shown? It shouldn't have been and if it wasn't it likely ran. Was Thunderbird running when you ran /PostUpdate?
Comment 26 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-08 02:05:57 PST
If you are running Windows Vista or Windows 7 the updater is already elevated when it launches helper.exe. If this is the case type cmd.exe in the search box, right click it, and select run as administrator. Then from the command prompt issue the same command line for helper.exe /PostUpdate
Comment 27 Mark Banner (:standard8) 2010-01-08 02:22:41 PST
(In reply to comment #25)
> When you ran /PostUpdate was any UI shown? It shouldn't have been and if it
> wasn't it likely ran. Was Thunderbird running when you ran /PostUpdate?

I get no UI showing with or without /PostUpdate...

It doesn't make any difference if I go into an administrator command prompt either.
Comment 28 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-08 02:43:09 PST
Launching the helper.exe should show the uninstall wizard when you don't specify a command line option. No idea what could be going on here.
Comment 29 Mark Banner (:standard8) 2010-01-08 03:24:27 PST
(In reply to comment #28)
> Launching the helper.exe should show the uninstall wizard when you don't
> specify a command line option. No idea what could be going on here.

I found that I was using the try server build for testing (based on 3.0.1pre) - that didn't work for some reason.

I switched to my self build of 3.1a1pre and that worked fine. I had backed this out from trunk:

http://hg.mozilla.org/comm-central/rev/5c9fabf6e6fe

but given my teting I've relanded on trunk for the 3.1a1pre builds:

http://hg.mozilla.org/comm-central/rev/5ba6e09336f2

I'll do a self build of 3.0.1pre and check the uninstall functionality on the tinderbox builds and verify if we have an issue there or possibly with the try server version.
Comment 30 Mark Banner (:standard8) 2010-01-08 06:15:03 PST
I just verified that updating from a build Lanikai dated the 7th, to a Lanikai build dated the 9th correctly removed the files if they were in the components directory.

Still trying to figure out what is going on with 3.0.1pre, so won't resolve this yet.
Comment 31 Ludovic Hirlimann [:Usul] 2010-01-08 07:35:32 PST
*** Bug 537491 has been marked as a duplicate of this bug. ***
Comment 32 Mark Banner (:standard8) 2010-01-08 09:26:54 PST
I've just verified that my self build of 3.0.1pre works correctly wrt the uninstaller & the PostUpdate step - I guess this could then be an issue with the try server builds.

However, this bug is now fixed on trunk - in that we won't have an issue with a blank window. Kaspersky will still not work afaik - we are currently having an open discussion with them about this issue (and we may take the results of that into a separate bug).
Comment 33 Mark Banner (:standard8) 2010-01-09 02:37:52 PST
Comment on attachment 420535 [details] [diff] [review]
Possible workaround

a=Standard8 (low risk, high value to upgraders).
Comment 34 Mark Banner (:standard8) 2010-01-09 02:55:19 PST
Patch checked in for 3.0.1:

http://hg.mozilla.org/releases/comm-1.9.1/rev/d795bb3d660d
Comment 35 Colin KLINE 2010-01-09 13:57:33 PST
Hey Guys,

I'm just an everyday user of computers, a "Joe Citizen".

What you guys are talking about, in "patches", "workarounds", "etc", are far too complicated, "too hard", and perhaps even "not robust enough" for a Joe Citizen.

Currently I cannot use TBird3  - AT ALL - and I absolutely refuse to swap over to a virus-prone emailer like Outlook.

So I'm missing out on emails from near & dear, and have to drive a considerable from my way out regional (country) home to get access via a friends' computer.  Worse, it's no use me emailing important (e.g. financial) email to myself at home from this friend becasue - I CAN'T USE THE FRICKIN' EMAILER.

Can't anyone get this fixed - soon - instead of sitting around smoking pipes, saying "Oh jolly wizard problem, we must think on this more"?

Ozogg
Comment 36 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-09 19:39:37 PST
No because I like sitting around smoking pipes.

Seriously, Joe Citizen doesn't have to do anything to apply the patch / workaround / etc. besides installing the next version of Thunderbird which will have this fix available. We on the other hand do have to consider the affect of and possible side affects of the patch / workaround / etc. since the cure could potentially be worse than the symptom.
Comment 37 Mark Banner (:standard8) 2010-01-09 23:18:23 PST
(In reply to comment #36)
> We on the other hand do have to consider the affect of
> and possible side affects of the patch / workaround / etc. since the cure could
> potentially be worse than the symptom.

Rob, we are actively trying to communicate with Kaspersky to ensure that they understand the issue and come up with a fix if they haven't already. My hope is that they do this before we release 3.0.1, however we need to start building and testing that now for all the other fixes we're landing as well.
Comment 38 Robert Strong [:rstrong] (use needinfo to contact me) 2010-01-09 23:20:17 PST
Sorry Mark, I was replying to comment #35.
Comment 39 Andrea 2010-01-11 05:07:36 PST
Hi guys,

this issue has got the status fixed. But I fail to find the solution?!? Any chance you can explain that so even I can understand it? Or do I just have to wait for updates?

I've downgraded back to 2.03 Which is a real shame because on the other computer ver 3 works and it looks absolutely awesome.

Thanks for your time
Comment 40 Mark Banner (:standard8) 2010-01-11 05:17:17 PST
(In reply to comment #39)
> this issue has got the status fixed. But I fail to find the solution?!? Any
> chance you can explain that so even I can understand it? Or do I just have to
> wait for updates?

The fix will be include in an update that we are currently planning on releasing on the 20th.

Additionally Kaspersky are also looking at fixing their software but no ETA is known for that yet.
Comment 41 baudry 2010-01-11 14:29:34 PST
I send mail to Kaspersky  and post message in kaspersky forum 
and they said it's  the responsibility of Mozilla to take into account the integration of security solutions and not vice versa
Comment 42 baudry 2010-01-11 14:31:30 PST
(In reply to comment #41)
> I send mail to Kaspersky  and post message in kaspersky forum 
> and they said it's  the responsibility of Mozilla to take into account the
> integration of security solutions and not vice versa

and it's not possible to see anything in thunderbird 3.0 on windows xp! just reply on thunderbird 2.023
Comment 43 Colin KLINE 2010-01-11 14:41:08 PST
@baudry

Yup, "passing the buck" seems to be the (usual) order of the day !!!
Comment 44 Mark Banner (:standard8) 2010-01-11 15:01:33 PST
(In reply to comment #41)
> I send mail to Kaspersky  and post message in kaspersky forum 
> and they said it's  the responsibility of Mozilla to take into account the
> integration of security solutions and not vice versa

To clarify earlier developments: The Thunderbird developers have been in direct contact with Kaspersky employees about this issue.

They know the steps we are taking in Thunderbird 3.0.1 so that Thunderbird correctly starts up after upgrade.

They also have passed the information to their product manager so that Kaspersky will be made to work with Thunderbird 3 and are looking to get a fix incorporated into their products soon.

(In reply to comment #43)
> Yup, "passing the buck" seems to be the (usual) order of the day !!!

There is no passing the buck. We are working together, providing fixes for our own products.
Comment 45 Jim Michaels 2010-01-16 23:08:31 PST
"KL AntiSpam 8.0"
"Kaspersky AntiSpam extension"
"Not compatible with Thunderbird 3.0"

kaspersky is listed under extensions, not plugins, but when you look under the real folders, it is stored in components (why?). tb 3.0 (now that I have upgraded) will not allow me to uninstall the extension.  please fix that.

I don't want to lose my mail or profile.

I removed all the .msf files from the profile, but this did not do the trick.

Correct me if I am wrong, but I think I have a workaround for disabling this component.  it worked for me. follow these steps (I just figured this out while writing this post):


1. go into kaspersky settings|Protection|anti-malware|Enable Email and IM Protection and uncheck it.  
2. click OK repeatedly until the Kaspersky dialogs are gone, entering passwords if required.
3. open up windows Explorer to:
C:\Program Files\Mozilla Thunderbird\components
I choose to have the address bar and show the address in the address bar in XP (nice feature!)
4. choose to view windows explorer in detail view, and sort by date (click on the Date column name).
5. delete these files: 
IKLAntiSpam.xpt
klthbplg.dll
6. start tbird.  your mail will work now.

please note that this workaround only disables/removes the kaspersky plugin, and is not intended to be a permanent fix.  The workaround allows tbird 3.0 to work.

please let me know if kaspersky intends to release the patch as an upgrade to 2009 (which is what I am staying with - 2010 is too alpha/unstable right now) or whether the update is coming down the wire as an update.  Or do they intend to only release this for 2010? (please support 2009).
Comment 46 Ludovic Hirlimann [:Usul] 2010-01-17 01:30:56 PST
*** Bug 540223 has been marked as a duplicate of this bug. ***
Comment 47 Mark Banner (:standard8) 2010-01-17 04:45:49 PST
*** Bug 540220 has been marked as a duplicate of this bug. ***
Comment 48 Mark Banner (:standard8) 2010-01-17 04:49:42 PST
(In reply to comment #45)
> please let me know if kaspersky intends to release the patch as an upgrade to
> 2009 (which is what I am staying with - 2010 is too alpha/unstable right now)
> or whether the update is coming down the wire as an update.  Or do they intend
> to only release this for 2010? (please support 2009).

Please see comment 44, that is the latest information we have.
Comment 49 [:Aureliano Buendía] 2011-03-09 08:05:46 PST
*** Bug 536241 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.