Implement the First Run experience

RESOLVED FIXED in Firefox 4.0b4

Status

Firefox Graveyard
Panorama
P1
normal
RESOLVED FIXED
8 years ago
2 years ago

People

(Reporter: aza, Assigned: mitcho)

Tracking

Trunk
Firefox 4.0b4
Dependency tree / graph

Details

(Whiteboard: [fixed-tabcandy] tracked first-run)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
As described here: https://wiki.mozilla.org/Firefox/Projects/TabCandy/Design/FirstRun, but with stub content for the help group.
(Reporter)

Updated

8 years ago
Assignee: nobody → ian
Blocks: 567391
Whiteboard: tracked first-run
(Assignee)

Comment 1

8 years ago
http://hg.mozilla.org/users/edward.lee_engineering.uiuc.edu/tabcandy-central/rev/d5981ba7535a

Fixed first run experience so tabs actually are grouped (again), now without the unnecessary animation.
(Reporter)

Comment 2

8 years ago
Awesome. We should definitely get this in for b4.
(Reporter)

Updated

8 years ago
Blocks: 586788
(Reporter)

Updated

8 years ago
Whiteboard: tracked first-run → tracked first-run b4
Created attachment 465471 [details] [diff] [review]
Patch v1

This patch makes the first run experience a lot less confusing; we're hoping to get it into today's nightly. 

Before, all of the user's tabs ended up bunched in the lower right hand corner. This patch puts them into the freshly created group.
Attachment #465471 - Flags: review?(dolske)
Comment on attachment 465471 [details] [diff] [review]
Patch v1

>-            + "<h1>Welcome to Firefox Tab Sets</h1>" // TODO: This needs to be localized if it's kept in
>-            + "<div>(more goes here)</div><br>"
>+            + "<h1>" + "Welcome to Firefox Tab Sets" + "</h1>"
>+        //    + "<div>" + "(more goes here)" + "</div><br>"

Should just leave this chunk out, and let bug 586685 make the change directly to the desired final state. r+ with that.
Attachment #465471 - Flags: review?(dolske) → review+
(Reporter)

Updated

8 years ago
Priority: -- → P1
Attachment #465471 - Flags: approval2.0+
Blocks: 586861
Whiteboard: tracked first-run b4 → tracked first-run b4 [fixed-tabcandy]
(Reporter)

Updated

8 years ago
Duplicate of this bug: 586995
(Reporter)

Updated

8 years ago
Depends on: 586971
(Reporter)

Updated

8 years ago
Depends on: 586992
(Reporter)

Updated

8 years ago
Duplicate of this bug: 587053

Comment 7

8 years ago
Mass moving all Tab Candy bugs from Mozilla Labs to Firefox::Tab Candy.  Filter the bugmail spam with "tabcandymassmove".
Component: TabCandy → TabCandy
Product: Mozilla Labs → Firefox
Target Milestone: -- → ---
Version: unspecified → Trunk
Duplicate of this bug: 587217
http://hg.mozilla.org/mozilla-central/rev/a8b5109c2a6c

If there's more open a new bug.
Assignee: ian → mitcho
Status: NEW → RESOLVED
Last Resolved: 8 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → FIXED
Whiteboard: tracked first-run b4 [fixed-tabcandy] → tracked first-run
Target Milestone: --- → Firefox 4.0b4
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
This seemed to be causing these failures:

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Found a tab after previous test timed out: about:blank

Updated

8 years ago
Blocks: 586971
No longer depends on: 586971

Updated

8 years ago
Blocks: 586992
No longer depends on: 586992
blocking2.0: --- → ?
Looking at the patch, it sure doesn't look like they could be causing this problem, but who knows, I suppose. Can we try it just by itself on Maple?

Also, don't forget to remove the two lines of "welcome/more" change from the patch; we want what's already on mozilla-central there.
I pushed a build with just this patch:

http://hg.mozilla.org/projects/maple/rev/41d853b8dbdd

Its parent is this one patch and the parent of that is the backout, so it's only this patch in.

http://hg.mozilla.org/projects/maple/rev/a8b5109c2a6c
Whiteboard: tracked first-run → [fixed-tabcandy] tracked first-run
I tried with just moving the tabitems initialization to above the firstrun block:

http://hg.mozilla.org/projects/maple/rev/d368d6bf434d

Same test failure:

TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Found a tab after previous test timed out: about:blank
Seems like ehsan wrote the original test.

It's failing here:
TEST-INFO | chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js | Console message: [JavaScript Error: "win is null" {file: "chrome://mochikit/content/browser/browser/components/privatebrowsing/test/browser/browser_privatebrowsing_windowtitle.js" line: 93}]

92:        let win = gBrowser.replaceTabWithWindow(tab);
93:        win.addEventListener("load", function() {

tabbrowser is returning null because it says there's only one visible tab left:

      <method name="replaceTabWithWindow">
        <parameter name="aTab"/>
        <body>
          <![CDATA[
            if (this.visibleTabs.length == 1)
              return null;

Why it break with the changeset I have no idea..

http://hg.mozilla.org/projects/maple/rev/d368d6bf434d
This blocks based on the dependencies of which bug 586971 and bug 586861 are particularly bad, both apparently to be fixed by this patch.

Ehsan: can you help Ed understand these test failures?
blocking2.0: ? → beta4+
Depends on: 586693

Comment 17

8 years ago
According to an email thread, it seems like we have a fix at hand by removing some unneeded timeouts which resulted in race conditions (see bug 586693).
The bug referenced in comment 17 is RESO FIXED - can this land yet?

Updated

8 years ago
QA Contact: tabcandy → tabcandy
All of the salient bits for this bug landed with the patch for bug 586693. The remaining bits we want (animation suppression) are already on tabcandy-central, so we'll pull them in next time we do a merge.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Product: Firefox → Firefox Graveyard
You need to log in before you can comment on or make changes to this bug.