implement the 'filter' CSS property (Internet Explorer proprietary)

VERIFIED WONTFIX

Status

()

Core
CSS Parsing and Computation
--
enhancement
VERIFIED WONTFIX
17 years ago
9 years ago

People

(Reporter: Sean Bryant, Assigned: Pierre Saslawsky)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20001229
BuildID:    2000122920

The cascading style sheet effect for shadow does not work for any sites using
that effect. Its a nice feature and adds additional coolness to pages. I did not
see style sheets in the list for component so I chose I best one I could.

Reproducible: Always
Steps to Reproduce:
Just visit the site!

Actual Results:  No Shadow

Expected Results:  A Shadow
The shadow effect in question uses the filter: style rule which is an MSIE 
extension and is not in either the CSS1 or CSS2 specifications.  So this is not 
a standards-compliance issue.

Confirming the request for enhancement, however.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Shawdow CSS does not work. → rfe: implement the filter: style rule
There's already an RFE for implementing the 'text-shadow' property that *is* in
the CSS standard: bug 10713.
I strongly recommend we mark this WONTFIX. 'filter' is not widely used, and we
(Mozilla) have plenty of other fish to fry. In addition, implementing this is
arguably bad since it is encouraging the use of non-standard techniques when
standard techniques either exist (text-shadow, SVG) or are likely to exist at
some point in the future.
Whiteboard: WONTFIX?
Netscape's standard compliance QA team reorganised itself once again, so taking 
remaining non-tables style bugs. Sorry about the spam. I tried to get this done 
directly at the database level, but apparently that is "not easy because of the 
shadow db", "plus it screws up the audit trail", so no can do...
QA Contact: chrisd → ian
(Assignee)

Comment 5

17 years ago
Agreed with Hixie: WontFix.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX
*** Bug 142886 has been marked as a duplicate of this bug. ***
VERIFIED
Status: RESOLVED → VERIFIED

Comment 8

16 years ago
wontfix? do you realize that without the flipH filter, a user that will want to
install a Hebrew (or any other RTL language) language pack, will also have to
install a special theme with all the graphics flipped? not to mention the fact
that we (the Hebrew l10n team) also have to develop this theme, in addition to
making the language pack.
I'd suggest filing a separate bug for us implementing '-moz-img-flip' taking
values 'horizontal', 'vertical', 'both', and 'normal'.

That would be SIGNIFICANTLY easier than implementing 'filter' (or as it should
be called, '-ie-filter').
*** Bug 147259 has been marked as a duplicate of this bug. ***

Comment 11

15 years ago
*** Bug 186904 has been marked as a duplicate of this bug. ***

Comment 12

15 years ago
*** Bug 109437 has been marked as a duplicate of this bug. ***

Comment 13

15 years ago
*** Bug 213971 has been marked as a duplicate of this bug. ***

Comment 14

14 years ago
*** Bug 222878 has been marked as a duplicate of this bug. ***

Comment 15

14 years ago
What follows is just some thoughts. It is most certainly NOT intended to be
criticism.

Re Bug Report 222878 which has been marked as a duplicate of this:

IE Image transitions don't really count as filters !

> It has already been decided not to support IE filters.
That's a bit of a shame. I am finding more and more that IE doesn't support
large chunks of the standards, especillay CSS. At the same time more and more
clients are asking for this kind of functionality rather than use Flash. I even
have had a request to implement a feature I had never heard of in IE. The
ability to use an IFrame as an on-line web editor / designer !! But now M$ has
decided to abandon IE and completely bundle it with the OS. This may mean no
major update until 2006 !! So web designers are stuck. Why develop sites that
are more standards / CSS compliant when IE doesn't support them ? Why not use
some of these IE only features since, unfortunately, they are actually quite
nice ! Sadly this, once again, appears to leave all other browser in the lurch.
Which is slightly ironic since all other browsers do standards better than IE.

> fwiw, this shouldbe easily possible with svg..
Please could you tell me how ? and is this possible with `photographs' ?

Comment 16

14 years ago
*** Bug 223825 has been marked as a duplicate of this bug. ***
> I even have had a request to implement a feature I had never heard of in IE.
> The ability to use an IFrame as an on-line web editor / designer !!

We support that.

Soon we'll be checking in some patches that bring our opacity support into line
with the CSS3 spec. Once we've verified that they really work, we should be able
to rename -moz-opacity to 'opacity' and you'll be able to use fully
standards-based translucency.

The new opacity support patches will make it much easier to support more general
SVG/IE style filters. It's not beyond the realms of possibility that we could
implement an extension that allows SVG filters to be applied to HTML elements.

http://www.w3.org/TR/SVG11/filters.html

Comment 18

14 years ago
Hi,
Maybe it is the time to change WONTFIX to OPEN?
The statement was made 2 years ago.
Now filter IS more widely used.

1. As 99% browsers are IE, the webmasters just don't care about other.
2. And as long as Mozilla will not support IE extensions it will not take more
users. Why - because users are interested in final effect - not in standards. So
again we are in point 1.

I want to see such pages correctly. As I work with linux 99% time, the solution
to use IE instead, is not for me!
*** Bug 224507 has been marked as a duplicate of this bug. ***

Comment 20

14 years ago
>> I even have had a request to implement a feature I had never heard of in IE. 
>> The ability to use an IFrame as an on-line web editor / designer !! 
 
> We support that. 
 
I don't think so. Take a look at : 
https://www.enjudica.co.uk/gbhs/docs/maintenance/authentication/index.jsp?site=GBHS 
(uname= demo, pword= demo) to see what I mean.  
 
Apparently this uses a DOM element in IE called "designMode". See 
http://www.insidedhtml.com/tips/contents/ts12/page2.asp for more 
information.  
 
This is what I was talking about :-) 

Comment 21

14 years ago
Image transitions would be excellent using SVG or anything else. 
However, it appears that most authors already know about 
"DXImageTransform", see 
http://msdn.microsoft.com/workshop/author/dhtml/howto/applyingtransition.asp 
This puts Mozilla in the same position as ALT tags ! I.e. no one is 
going to rewrite sites simply to comply with Mozilla when it already 
does what is expected in IE. Moreover, SVG won't address text DIVs and 
SPANs which "DXImageTransform" does cater for. 
*** Bug 232311 has been marked as a duplicate of this bug. ***

Comment 23

14 years ago
*** Bug 238140 has been marked as a duplicate of this bug. ***

Comment 24

14 years ago
*** Bug 241575 has been marked as a duplicate of this bug. ***

Comment 25

14 years ago
what a luck was that images are in w3c standarts becouse other way people which
want to see images in their browser will have to use IE.
STANDARTS is not only for folloing , standarts have to be created also.
All this bugs about makeing thigs easer and are marked WONTFIX are bad.

Comment 26

14 years ago
*** Bug 252963 has been marked as a duplicate of this bug. ***

Comment 27

14 years ago
WONT FIX??? Why? I thought you people CARED about your users??! UNLIKE bigger
(cough microsoft) browsers??? :( 
Because 'filter' is (a) non-standard and (b) used on almost no pages, despite 
being available for years and (c) would be hard to implement interoperably on 
multiple platforms.

But don't worry: when Mozilla implements SVG filters, you'll be able to use 
those. And those are standard and everything.

Comment 29

14 years ago
*** Bug 256275 has been marked as a duplicate of this bug. ***

Updated

14 years ago
OS: Windows 2000 → All
Hardware: PC → All
Summary: rfe: implement the filter: style rule → implement the filter: style rule (css)
Whiteboard: WONTFIX?

Comment 30

13 years ago
(In reply to comment #28)
> But don't worry: when Mozilla implements SVG filters, you'll be able to use 
> those. And those are standard and everything.

Looking at the bug history we will see it in 2008 :)

Just take a look at your comment #3.

Any hint to do something like "opacity" with current mozilla. And have it
working in IE too?

Comment 31

13 years ago
*** Bug 264706 has been marked as a duplicate of this bug. ***

Comment 32

13 years ago
*** Bug 286904 has been marked as a duplicate of this bug. ***

Comment 33

13 years ago
you REALLY REALLY should add in this. i miss it. i have to go to (shudder) ie
just to look at these features

Comment 34

12 years ago
*** Bug 334652 has been marked as a duplicate of this bug. ***

Comment 35

12 years ago
A lot of things are marked duplicates of this..maybe it should be fixed

Comment 36

12 years ago
(In reply to comment #35)
> A lot of things are marked duplicates of this..maybe it should be fixed

Or maybe better not.

CSS text-shadow property will be implementes soon

Comment 37

12 years ago
*** Bug 346429 has been marked as a duplicate of this bug. ***
*** Bug 357884 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 479217
Summary: implement the filter: style rule (css) → implement the 'filter' CSS property (Internet Explorer proprietary)
You need to log in before you can comment on or make changes to this bug.