Last Comment Bug 65111 - delete whole thread (if collapsed when deleting)
: delete whole thread (if collapsed when deleting)
Status: RESOLVED DUPLICATE of bug 448288
:
Product: MailNews Core
Classification: Components
Component: Backend (show other bugs)
: unspecified
: All All
: P5 enhancement with 28 votes (vote)
: Thunderbird 3.0rc1
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 91276 93518 162269 176867 286194 442259 462152 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-11 12:54 PST by Pádraig Brady
Modified: 2009-01-13 00:38 PST (History)
41 users (show)
davida: wanted‑thunderbird3+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Pádraig Brady 2001-01-11 12:54:48 PST
When messages shown in threaded mode,
in my opinion you should be allowed to
delete a whole (collapsed) thread, rather
than just the top level item.
Comment 1 laurel 2001-01-11 13:31:32 PST
We probably won't implement a "delete thread" per se, but we do have "Select
Thread" in the works which would select all messages in the thread, hence easier
deletion.  Ref:  bug 21094.
Comment 2 Sheela Ravindran 2001-01-12 17:07:19 PST
change status to new.
Comment 3 Keyser Sose 2001-03-06 16:01:43 PST
Recommend Wontfix. As per laurel@netscape.com comments.
Comment 4 now michael@endbracket.net 2001-07-03 05:30:10 PDT
I would like the delete/remove key to delete the entire thread when the thread 
is collapsed.  Microsoft Outlook Express (sorry!) does this, and it is most 
useful.  Could this at least be a user preference?

Is it likely that a user would intend/desire only to delete the top-most 
(threadwise) message in the thread when pressing delete?  I think one would 
expand the thread, and then delete that individual message if that was the 
desired outcome.

On a related note, it appears (visually) that the entire thread is selected 
when clicking on a collapsed thread in the thread pane.  If only the top-most 
message is being selected, perhaps the highlight color should be 
gray/shaded/lighter.
Comment 5 Dwayne 2001-07-18 11:56:03 PDT
*** Bug 91276 has been marked as a duplicate of this bug. ***
Comment 6 Dave 2001-08-03 13:46:49 PDT
*** Bug 93518 has been marked as a duplicate of this bug. ***
Comment 7 Scott Davis 2001-08-15 16:49:52 PDT
I agree with wontfix - I use and like the fact that I can read a thread while
not taking up the screen space of expanding it. I can also read mail in threaded
mode without thinking about some of the messages being the tops of threads and
some being the only message. I can read with the focus on the message text,
using cursor keys for scrolling the text and Delete for moving to the next
message in the thread or in the next thread.

Clicking on the Thread icon opens and selects the entire thread. Is it difficult
to make that column not part of the normal visual highlighting of the selected
message? Then it can be obviuos whether the message or the entire thread is
selected.
Comment 8 Pádraig Brady 2001-12-11 11:45:55 PST
Laurel:

Using just the keyboard to select the whole thread (Ctrl+Shift+A)
is a great help, and would do me except it's not intutitive I think.
Note I think working the same way as outlook is "good" for obvious
reasons.

Scott:

I see your point Scott, but it should be configurable IMHO
as it's a great timesaver for very high volume lists.
Also as you say if the "delete whole (collapsed) thread" is *NOT* 
selected, it would be really nice if the "thread icon column" would 
not be  highlighted, so logic would be:

if (view->mode==threaded && config->delete_whole_colapsed_thread)
    highlight_threadIcon_column = true;
else
    highlight_threadIcon_column = false;
Comment 9 Pádraig Brady 2001-12-11 12:09:49 PST
Oh I forgot to mention one other disadvantage of not being able to
delete a collapsed thread. You can not select more than one thread
at a time to delete. I.E. you must do Ctrl+Shift+A, Delete for each
thread, rather than just selecting multiple (collapsed) threads and
hitting delete once.
Comment 10 Håkan Waara 2002-01-10 16:01:05 PST
I agree with others about wontfix. There is no need for this enhancement, just 
click the little "thread" icon, and hit delete and the thread is deleted.
Comment 11 Pádraig Brady 2002-01-11 03:15:34 PST
Another reason should delete whole thread is that it's much
faster when doing X over dialup. It's MUCH slower to display 
all messages in thread (select thread), and then delete.

At least allow Ctrl+Shift+A to select all of the selected 
colapsed threads, not just one thread.
Comment 12 Eric Vaandering (no email) 2002-03-05 07:22:49 PST
comment 9 expresses my view. The same behavior is used in news with Mark->Read.
If I want to catch-up to where I've read by selecting a large number of threads
and marking them read, I currently have to expand all the threads before the
mark to make sure I mark more than just the top message read.

Can the behavior be changed just for the case where more than one thread/message
is already selected? (I agree that if I'm reading the first message of a thread
and hit delete the whole thread shouldn't disappear).
Comment 13 Phillip A Remaker 2002-07-24 10:59:54 PDT
I want a delete thread function as well.  I see the value of single-item delete,
within a thread, but there should be a thread-delete, too.

For example, why not bind shift+ctrl+del to whack an entire thread?

I'd just as soon not see another config option.

Also, it should be context sensitive.  If multiple messages are selected, I'd
expect delete to delete the entire collapsed thread.  I can see the "delete each
member" logic if you are winding your way through messages, but if there is a
marked collapsed thread as part of a group, delete should take out the whole thread.

Minimally, a delete thread keybinding is in order.
Comment 14 timeless 2002-07-24 11:14:31 PDT
no no no no no.
we don't need dataloss keybindings.

a select thread key binding should exist (oh wow, it even does according to
earlier comments), and you should be able to type it, and then press <delete>.

as for not intuitive, i thought about it just reading the bug summary, as did
many other people.
Comment 15 Phillip A Remaker 2002-07-24 11:32:12 PDT
Shift-ctrl-a (break out thread) only works on a single thread.  

I still have no way to mark *n* collapsed threads and quickly delete them. 
Unless I unthread first.

I stand by my request for a delete-thread key.  I get a lot of e-mail, and need
to delete a lot of e-mail.  Outlook Express (which I am trying to get rid of)
allows me this function.

Maybe the bug needs to change to "allow ****-ctrl-a to expand multiple threads"
but I always dislike having to do two keystrokes for what I expect to be able to
do in one.

Comment 16 timeless 2002-07-24 11:52:12 PDT
bug 88593 should work for you. please don't morph bugs.
if you can come up with a way to handle keybindings for select multiple threads
then file a new bug suggesting it (and feel free to mention its number here).
the problem is that mailnews is pretty overloaded for keybindings so i doubt
you'll find one that people would be willing to accept.
Comment 17 Mike Patterson 2002-07-26 08:52:29 PDT
In my opinion: You should be able to move the entire thread to another folder as
well, not just the top item.
Comment 18 Christopher W. Curtis 2002-08-03 16:10:48 PDT
Just found this bug after being similarly frustrated by the poster (actually, I
came from bug 94765) ... regarding keybindings, I initially hit Shift+Delete,
expecting it to work.  If this could be bound, it would be a nice feature, if
not a necessity, not only for IMAP, but reading news in general (though I must
admit I don't read much news anymore).  Clicking the thread icon works, though
it is a bit hokey when you're trying to delete lots of small threads.  Also,
when you are not using the mouse ... Delete and Shift+Delete are nice binding, imho.
Comment 19 Robert Wall 2002-08-12 05:36:26 PDT
*** Bug 162269 has been marked as a duplicate of this bug. ***
Comment 20 Samuel Sieb 2002-09-23 20:59:56 PDT
I just ran into this.  I have 10000 messages in a folder (mailing list) and I
wanted to go through them quicker, and I realized I could thread them and just
skim through them by topic.  I went through many and then selected all the
threads, hit delete and continued reading.  The threads I was now looking at 
looked awfully familiar and some were already read...  Now that's unintuitive! 
There is currently *no* way to delete threads.  I would be happy with even a
reasonable workaround.  You can't even select multiple threads, then do select
thread, because that will only select one thread. (More unintuitive...)
Comment 21 Christian :Biesinger (don't email me, ping me on IRC) 2002-09-24 02:25:23 PDT
but there is a way to delete a whole thread. clicking the thread icon (left of
the message) will select the whole thread, then you can hit enter.
Comment 22 Phillip A Remaker 2002-09-24 02:47:41 PDT
I need to delete quickly and with extreme prejudice.  I get a LOT of mail.  
Selecting multiple threads is not possible, and I want a single keybinding to 
whack a thread of set of threads.  Sadly, I have to use outlook express to get 
delete thread functionality (they don;t have the option to delete single 
messages in an unexpanded thread.

People that insist on linear delete should expand threads and delete by 
message.  I think delete on a collapsed thread should mean to delete the 
thread.  Or at least give me an option to do so.

<*thwack*> Take that, dead horse!
Comment 23 Samuel Sieb 2002-09-24 11:46:45 PDT
I have over 500 threads, I don't want to delete them one at a time!
Comment 24 Phillip A Remaker 2002-10-10 17:02:03 PDT
What is the status on these enhancement bugs?  Who needs to buy into a feature?

This is an obstacle to my adoption of Mozilla.  I know, "boo hoo, who cares?" 
But I'd really like to dump OE and can't understand the opposition to this
enchancement.  Or does an enhancement get made only if you submit the code
yourself?  (as if I can code)
Comment 25 R.K.Aa. 2002-10-26 09:19:25 PDT
*** Bug 176867 has been marked as a duplicate of this bug. ***
Comment 26 Karl Palsson 2002-11-15 12:31:03 PST
This is an interesting conundrum. 

21094 is a great start, and I didn't even know about that.

88593 will make it even better when it gets fixed.  But you still need a mouse.
 I guess that is just part and parcel of using a gui mail client.  :)

I _personally_ would expect that when I'm in collapsed view, pressing delete as
is would delete the whole thread.  Others disagree, and it's not something that
should really be forced one way or the other, yet is such a stupidly small thing
that it probably doesn't warrant a config for it.  

*ponders* I would probably be happy with things when 88593 gets fixed.

*ramble ramble further monologue*
Comment 27 Dai Yuwen 2002-12-16 21:10:43 PST
I also think this feature is useful especially in very high volumn mail lists.
Comment 28 James Ots 2003-01-20 22:17:11 PST
I'm another of the 'delete should delete entire collapsed thread' people. 
Comment 29 Simon Liddington 2003-04-10 18:28:27 PDT
One way around this is to expand your threads with *. Then Ctrl-A, delete will
delete everything, or you can use your mouse to select particular threads to
delete. Its just not as nice as being able to select a set of collapsed threads
to delete. ;(
Comment 30 Samuel Sieb 2003-04-10 22:17:00 PDT
When multiple threads are selected, delete should delete the whole threads.  Can
anyone explain why it would be intuitive to only delete one message from each
thread in that situation?
Comment 31 Kean Johnston 2003-05-11 20:52:15 PDT
I would like to support the "delete whole thread" camp. Outlook express, outlook,
mutt all do this (albeit with mutt you use a different key). It is highly
frustrating to be scanning through a high volume list like, say, the gcc list,
marking a whole set of topics you dont care about, hit delete, only to discover
that your gcc folder still has 70 new messages in it when visually you are lead
to believe that they should all have been deleted.
Why are people so adverse to config options? Or alternate key bindings? Surely
the more choice you give a user the better the program? A little checkbox in the
prefs dialog cannot be either that hard to code, maintain or represent visually.
If the conflicting opinions in this bug are anything to judge by, its proof of
why it should be a user option and not a developed mandate.
Comment 32 Phillip A Remaker 2003-06-06 10:13:39 PDT
What is the status of this bug?  Seems to be WONTFIX, but who gets to decide?  
People say this is not needed and there have been several suggestions:

Suggestion: Click the thread icon and press delete.
Objection: Requires a mouse event.  I read mail from the keyboard.  I want a 
single keystroke.

Suggestion: Expand a thread with shift-ctrl-a, and use delete
Objection[1]: Requires multiple keystrokes 
Objection[2]: Cannot delete multiple threads without multiple expansions
Objection[3]: Using X on a slow link, the expand event can take a long time.

Suggestion: Go away, our browser is to pure and elite for you.
Objection: I am doing that now, but I really want to use Mozilla Mail and News.

All I want is a keystroke to delete a thread, like Outlook Express.  At least 8 
people agree and have voted for it.  Why is this such a problem to get 
implemented?  I want the OPTION for a dataloss keybinding.  I should be at 
least given the rope, even if it isn't the default.  Even if I do delete a 
message, it goes to trash or stays around until I purge IMAP.  So I disagree 
with the "data loss" key binding.

Is this so hard to implement?  Does it really run that far afoul of Mozilla 
design philosophy?  Please save me from Outlook!!!

Do I need to build a Mozilla private branch to get this feature?
Comment 33 Jo Rhett 2003-06-12 13:20:36 PDT
I'm in full and complete agreement here.  We are getting roughly 5 tech support
tickets a week from users who complain that deleting threads doesn't work. 
CTRL-SHIFT-A is way too arcane.  If someone wants to delete one message at a
time, they would uncollapse the thread anyway!

There is lots of existing precedence here, INCLUDING Communicator 4!  We need to
be compliant with expectation...
Comment 34 Andreas Schrafl 2003-07-05 01:32:32 PDT
I would appreciate such a function very mutch. perhaps you know mutt where this
is a keyfunktion for me to still use mutt instead of mozilla mail.
Comment 35 Jo Rhett 2003-07-07 14:16:50 PDT
Just for fun, I tried to read one of my busier mailing lists using Mozilla
instead of Mutt last night.  After more than 100 ctrl-shift-A, del sequences I
was ready to drop Mozilla mail entirely.  It's simply not usable for mass mail
reading in this state.

I detest Outlook Express for functionality and usability reasons - not just on
principle - but even it allows me to select a dozen threads and delete them in a
few simple steps.  This simply must be fixed.
Comment 36 Conall O'Brien 2003-08-01 08:07:15 PDT
I agree. It's rather hard purging undesired threads from high volume lists like
debian-user and openbsd-misc without such a keybinding.

The ability to select a thread by right clicking the thread icon and selecting
delete means Mozilla Mail, and more importantly Thunderbird, *has* this feature.

All people want is a keybinding that selects all messages in the current thread
and mark them for deletion, without all the pointy clicky.


Personally, I think Ctrl-d (the same keybinding Mutt has for this) would be
nice, if it's still unassigned.
Comment 37 Jo Rhett 2003-08-01 11:19:27 PDT
I hate to disagree with someone who is agreeing with me, but actually a key
binding to delete a thread would not solve it for me.  If I want to delete a
single thread, the current key binding plus delete is enough for me.  The
problem is when I want to delete dozens or hundreds of threads.

I don't care about keys versus mouse, or what the key presses are.  I care about
the ability to select a dozen threads and toast them all.
Comment 38 Conall O'Brien 2003-08-01 11:30:23 PDT
But this bug isn't specifically about multiple thread selection. It's about a 
command to delete the currently selected thread only, just like what other mail
clients have.


What you want is something like Mutt's pattern match delete. With it, you can
use regexps (eg particular subject keywoards) to flag mail for deletion.
Comment 39 Jo Rhett 2003-08-01 11:41:02 PDT
Regexs to delete threads is not a sufficient answer.  I could spent 5 minutes
trying to find a regex that matches the threads right in front of me.  That's dumb.

This is a visual medium.  I see a dozen threads on the screen.  I click and
shift-click and delete and they are gone.  Or shift arrow, arrow, etc. delete.
On every mailer except for Mozilla.

I talk to many, many people who work on Mozilla and none of them use the mail
client.  Why is that?  Mozilla's insistence on not supporting this means that no
technical person who reads high-volume mailing lists can use it as their primary
mailer.
Comment 40 Conall O'Brien 2003-08-01 14:21:33 PDT
Which would take longer? 5 min devising a regexp or using Mozilla Mail to delete
your undesired threads?


What about having an option to "tag" an entire thread, not just mark it as read,
etc? Then, after you've marked allt he undesired threads, 1 delete command
purges them all.

Comment 41 Jo Rhett 2003-08-01 15:11:53 PDT
Using Mozilla Mail would take longer right now ;-(

Anyway, yes tag multiple threads and delete them would be great.  Ideal, as far
as I know.  And I believe it solves every problem listed here.
Comment 42 Neil Fraser 2004-04-21 02:00:12 PDT
I think comment 30 says it perfectly, if multiple threads are selected then
delete should definitely delete the entire threads, not just the top level
message in each.

However, comment 38 is also correct, this bug was originally about a single
thread (which is an arguable case).  Do we need to create a new bug specifically
for multiple-select deletions in thread mode?
Comment 43 Phillip A Remaker 2004-04-21 10:49:58 PDT
Really, it is simple.  I want a delete keybinding that says "delete this whole 
thread" and also if multiple threads are selected, it should mean "delete all 
messages in all these threads."

Similarly, I would like to be able to drag and drop collapsed thread(s) to 
storage mailboxes, which also is not possible (only top message is moved).

Perhaps what this bug really needs is a mode which say "treat actions (delete, 
copy, move, forward) on the top message(s) of a collapsed thread(s) as appying 
to the entire thread(s)"  

This is how Outlook Express behaves by default, and I am very fond of it for 
managing my high-volume mailing list mailboxes and my spam folder.
Comment 44 andreas 2004-05-12 16:39:32 PDT
I also think there should be at least e key binding to delete whole threads,
even if I'm not on the topmost message. Just hit (say) shift-delete and the
whole thread is gone. If more than one thread is selected, then all are gone.
Otherwise, using mozilla/thunderbird for high-volume mailing lists is nonsense
and unpractical. Try to read linux-kernel, or even postfix-users, or other list
with 300+ messages a day and you will see what we (those in favor of
thread-deleting keys) mean.
Comment 45 Matthijs Wensveen 2004-07-05 01:28:25 PDT
I agree with comment #43. IMO this is the most convenient way to delete multiple
AND single threads (no need to file another bug).
Selecting multiple threads are not the issue here (bug #21094 and bug #88593)
are about that.
Comment 46 Luke Morey 2004-07-29 07:10:29 PDT
This is how it feels in a folder with a lot of threads.

  + thread one
    thread two
  + thread three
  + thread four

Highlight all 4 threads, press delete.  Now you see

  + thread one
    thread three
  + thread four

Highlight all 3 threads, press delete.  Now you see

  + thread one
    thread four

Highlight 2 remaining threads, press delete.  Now you see

  + thread one

Still not all gone.  Now multiply that process 50 times for a large folder with
a lot of threads.  It just ain't right.

"Dataloss keybinding"?  Well, we're talking about the delete key, which is
intended to lose data, however you cut it.  At the moment it just deletes a
weird-ass subset of what you were actually trying to delete.

Are there any other mail clients that don't treat a selected, collapsed thread
as a whole?
Comment 47 David :Bienvenu 2004-09-15 08:06:50 PDT
you can now cntrl click multiple thread icons to extend the thread selection, so
you can do it all with multiple clicks and one delete key.
Comment 48 Ralf Utermann 2004-09-28 05:10:20 PDT
You still can't de-select a thread with cntrl-click, if you had
selected several threads.
Comment 49 timeless 2004-11-01 10:30:05 PST
ralf.utermann@physik.uni-augsburg.de: true, is there a bug for that? please
find/file it and reference it here, thanks.
Comment 50 Heikki Toivonen (remove -bugzilla when emailing directly) 2005-02-27 17:00:31 PST
If someone wanted to implement this, where should s/he look in the code?

This has really started bugging me since moving away from newsgroups and into
multiple high traffic email lists that I want to read threaded. Seems newsgroup
usage is declining in general, so I see more and more need for this feature.
Comment 51 Phillip A Remaker 2007-01-18 11:57:28 PST
There is now an extension for Thunderbird that supports Delete Thread called "BUTTONS!" (http://forums.mozillazine.org/viewtopic.php?t=53664) which has added Delete Thread.  If you use it together with a keyboard shortcuts extension, you can get delete thread capability from the keyboard.  It is a clunky solution, but a reasonable workaround.  I'm pretty sure this bug is deader than dead.
Comment 52 Jo Rhett 2007-01-18 12:03:31 PST
FYI, the combination of those two extensions DO NOT work together.  Tried that.

I am really honestly confused as to why non-intuitive and "will never be useful" behavior is being chosen over intuitive behavior that would (if it worked) require multiple workarounds to achieve.

Nearly *EVERYONE* wants Delete Thread.

In all the conversations I've seen about this topic, not a single individual has ever *EVER* stood up and said that they prefer the current behavior.  Even the singular developer that said it made sense to him, admitted that it made less sense and was downright counter-intuitive when someone selects a dozen threads and gets the top message deleted from all of them.

I real all my list e-mail from Mail.app.  The fact that a mailer as clunky as Mail.app is significantly more useful than Thunderbird should give you pause.
Comment 53 Wayne Mery (:wsmwk, NI for questions) 2007-01-18 12:11:13 PST
even if the extension worked...
* This is a seamonkey suite bug, so Thunderbird extension is not a solution.
* WONTFIX recommendation (which I don't buy) is based on developer comment 1 - comment 1 is merely a work around - removed "WONTFIX" from whiteboard
* bug has 21 votes

This bug should remain open
Comment 54 Marius Andreiana 2007-05-25 02:33:27 PDT
Ctrl+Shift+A selects only current thread. How could I select ALL messages in a folder & delete them? (as ctrl+a does in non-threaded view). Thanks

PS Threaded view on mailing lists is unusable due to lack of easy deletion.
Comment 55 Nuno 2008-02-17 15:16:29 PST
I did moved recently from Outlook Express to Thunderbird and I'm also missing the function to easily delete all messages in a thread like in Outlook Express... I usually handle many mail messages and just use cursor keys to move over messages and del key to delete then, it's the fastest way to handle them and it's not easy to select threads manually before deleting them :(

In my opinion I think the best behavior is the one like in Outlook Express: when thread is expanded then deleting 1st message deletes just this message, but when thread is collapsed deleting it would delete all the thread and not just the 1st message.

Despite I think this is the best behavior, I respect the other users with different opinion and I think this could be optional in the about:config.
Comment 56 Nuno 2008-02-17 16:11:43 PST
Just to add: also it's interesting that using the "mark as junk" function affects all the messages in a thread (outlook-like behavior), just the delete function doesn't.
Comment 57 Magnus Melin 2008-02-18 09:03:40 PST
Gmail does it too.
Comment 58 Magnus Melin 2008-02-18 09:17:13 PST
Moving to Core since it should affect very little non-shared code (if any).
Comment 59 Magnus Melin 2008-02-18 09:17:47 PST
*** Bug 286194 has been marked as a duplicate of this bug. ***
Comment 60 Tilman Schmidt 2008-03-19 12:05:40 PDT
Adding my vote to this. How many more are needed to have this 7 year old bug fixed? Yes, I call it a bug. The current behaviour is completely counterintuitive.
Comment 61 David Ascher (:davida) 2008-04-04 18:01:59 PDT
Carrying wanted-thunderbird3+ from discussion in 214111.

Keeping out of blocking list for now, as per that bug.
Comment 62 Ralph deGennaro 2008-05-19 08:08:12 PDT
I like comments in #43, and adding my vote to "fix" the "design flaw" (not a bug, and not an enhancement :-) ).  I disagree with some comments (in this thread and others) that say selection is for "what you see" and you don't see sub-messages.  I think most people understand that a thread is more like a file-folder (or directory/folder in file-system speak).  Or perhaps, for those who think that way, it should be an option for them.  

So a bit of general UI thread thoughts:

1) Configure thread behavior in preferences.  Default to treat all messages
   in collapsed thread in same manner for all functions (delete, move, mark
   as read, etc.) as this is most intuitive and common behavior.  Though
   to keep consistency with existing functionality/UI, making me change the 
   setting is okay.  :-)
2) Keybindings should reflect configured behavior.  E.g. if "Treat Collapsed
   Thread as One" is checked, DEL deletes all.  If unchecked, DEL deletes
   just displayed message (end of thread message).  If checked, then 
   CTRL (or command)-SHIFT-A would not have any purpose.  If unchecked, it
   should selected all messages in each thread (is this another bug?)  
3) Based on flag, opening collapse thread when it is selected, keeps all 
   included messages selected.  When unselected, leaves all unselected.
4) On opened thread(s), CTRL-SHIFT-A selects all messages in thread regardless
   of "Treat Collapsed Thread as One".  
5) Opened thread should have the same sort as the message sort outside thread
6) Changing sort should not turn off threaded view (or another flag for this?)

The last few are basically different, but so is the general solution to this and other "bugs".  And since it all made more sense together I put them in.  

BTW, how do you use bug tracker to deal with smaller changes related to one big change?  Oh, is there a way to take a poll for certain behaviors for all Thunderbird fans?  Or to see what has been decided for inclusion to Thunderbird 3?
Comment 63 Joshua Cranmer [:jcranmer] 2008-06-27 07:45:23 PDT
*** Bug 442259 has been marked as a duplicate of this bug. ***
Comment 64 Magnus Melin 2008-08-21 11:57:46 PDT
Keeping wanted‑thunderbird3+, low priority. 
Any takers?
Comment 65 Jason Merrill 2008-10-03 09:27:42 PDT
When I hit delete on the first message of a collapsed thread, I want it to show me the next message in the thread; I usually delete messages as I read them unless I feel the need to keep them around for later reference.  Unfortunately, since I have it set to mark as deleted rather than move to Trash, currently Thunderbird skips ahead to the next thread instead, so I have to back up and hit 'n' to see the next message in the thread I was reading (bug 367689).

I'd also like to be able to use something like shift-ctrl-delete to delete the whole thread at once, but I don't want that to happen when I just hit delete.
Comment 66 Josef Karthauser 2008-10-11 03:29:36 PDT
This is crazy. I've been using threaded news readers and mail readers for years. Having just now started to use thunderbird I am very surprised by the threading model adopted. It seems to have implemented thread select functionality without surveying the best practices already adopted and refined by other products.

This bugs is about deleting threads, but that's a red herring. The actual bug is that selected a closed thread ought to select the entire thread. If you are operating on a closed thread you would expect the "top" entry to represent the entire contents. Then having selected the entire thread the user is able to move or delete or do whatever they want with it.

Who owns the threading code?
Comment 67 Joshua Cranmer [:jcranmer] 2008-10-29 07:58:04 PDT
*** Bug 462152 has been marked as a duplicate of this bug. ***
Comment 68 Joshua Cranmer [:jcranmer] 2009-01-11 12:36:13 PST
See bug 448288 comment 2

*** This bug has been marked as a duplicate of bug 448288 ***
Comment 69 Pádraig Brady 2009-01-11 17:05:51 PST
Resolved exactly 8 years later :)
Thanks for looking at it.
Comment 70 Phillip A Remaker 2009-01-12 14:47:59 PST
The problem is that it is **NOT** resolved.  It just got assigned to a newer, active bug.

The fact that it is linked to a new bug hides the problem of just how long we have been asking for it.  8 years!  Crimeney.  And I am still on Outlook Express in the meanwhile.  I would LOVE to drop Outlook Express.  The replacement client from Microsoft is awful.  If we could fix this, Thunderbird would fit the bill.
Comment 71 Tilman Schmidt 2009-01-13 00:38:56 PST
I don't agree that this is a duplicate of bug 448288.
Bug 448288 is Thunderbird specific, while this bug applies equally to Seamonkey.

Note You need to log in before you can comment on or make changes to this bug.