[SeaMonkey] Delete key should delete location bar history list entry

REOPENED
Unassigned

Status

--
enhancement
REOPENED
18 years ago
2 years ago

People

(Reporter: terra, Unassigned)

Tracking

(Blocks: 1 bug, {helpwanted})

Trunk
helpwanted
Dependency tree / graph

SeaMonkey Tracking Flags

(seamonkey2.1 wontfix)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS 5.8 sun4u; en-US; rv:0.9.1+) Gecko/20010610
BuildID:    2001061022

I often find myself wanting to weed the url bar history
list.  The best I can currently do is to (a) edit the
file in which it is stored, or (b) wipe it out completely
somewhere in the prefs.

It would be nice if the delete key would delete the
highlighted item.

Comment 1

18 years ago
a good idea.. it might be kind of tricky to figure out how we indicate that
focus is in the list though - I mean, you could be typing, in which case
"delete" should  delete the character to the right of the cursor (which it does now)

the other issue is whether or not this affects the current view, or actually
deletes entries out of global history

I should add that you don't have to go edit the file - Tasks->Tools->History
will allow you to delete history entries, as well as entire domains, from your list
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Priority: -- → P4
Target Milestone: --- → Future
(Reporter)

Comment 2

18 years ago
Careful here.  There are two drop-downs in this neighbourhood.

There's history (those urls you have visited, one way or another).  I have
no problem with the current workings of this.  (And this one seems to be
the one you are commenting on.)

Then there are those urls you have explicitly typed into the url bar.
The url entry is a "combo" with a show-me-the-list button at the right.
Press that one and you will see the typed history.  This is where I want
a delete key operation.

Comment 3

18 years ago
well, eventually we're going to get rid of the second one (the urlbarhistory
one) and merge it into the first, and then flag certain urls in global history
as "typed" - i.e. ones that the user entered on the keyboard rather than got
there by clicking on a link.

So potentially, we could simply "unflag" that entry if the user deletes it.

Comment 4

18 years ago
Resummarising for easier searchability.
Summary: Delete key should delete list entry → Delete key should delete URL bar history list entry

Comment 5

17 years ago
reassign url bar bugs to new owner..
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
Target Milestone: Future → ---

Updated

17 years ago
Target Milestone: --- → mozilla0.9.7

Updated

17 years ago
Target Milestone: mozilla0.9.7 → mozilla0.9.8

Comment 6

17 years ago
*** Bug 114271 has been marked as a duplicate of this bug. ***

Comment 7

17 years ago
First, some quick way to deal with "bad" entries in the urlbar autocomplete
suggestions (while still using the urlbar) would be much, much more convenient
to use. I could eliminate those really annoying typos with a single button press
without having to really stop the process of entering the url I want to go to.

Second, there should not be a conflict in the meaning of delete. The only time
you have the autocomplete suggestion list selected (while typing in the urlbar)
is after typing some characters and then hitting tab. At that point, the cursor
is at the end of the text you have entered, so delete does nothing to the text.
 I've tried to get it in such a state that delete would be undefined, but I
can't and I don't think it's possible with the current implementation.

I'll try to take a look at the relevant code and figure out how hard this will
be  to add. Hopefully, it will be some trivial javascript.

Updated

17 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Comment 8

17 years ago
reassigning to default owner.
Assignee: blakeross → hewitt
OS: Solaris → All
Priority: P4 → --
Hardware: Sun → All
Target Milestone: mozilla0.9.9 → ---

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 9

17 years ago
*** Bug 144642 has been marked as a duplicate of this bug. ***

Comment 10

17 years ago
*** Bug 149023 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
See also Chimera's bug 181716.

Comment 12

16 years ago
*** Bug 213284 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
Comment #4 and up: I think the line is called a 'location bar', that's why I 
didn't find it and had to file a new bug.

Comment #3: That looks ok. The implementation doesn't need to be the same as 
the original reporter requested. Just add ANY way to edit (or just remove) urls 
from the location (URL) bar history.

Comment 14

16 years ago
Changing summary to "location bar"...
Summary: Delete key should delete URL bar history list entry → Delete key should delete location bar history list entry

Comment 15

15 years ago
*** Bug 198327 has been marked as a duplicate of this bug. ***

Comment 16

15 years ago
IMO, a context menu (bug 198327) is a far better solution and will avoid issues
such as that described in comment #1 and comment #7.

Comment 17

15 years ago
When viewing the history (CTRL+H) and grouping by domain from the view menu, you
can easily use the del key to remove an entire domain. However, if you expand
the domain for a list of sites in it, you can't delete those. I've tried the
delete key and the mouse key.

Mozilla 1.6

Updated

15 years ago
Blocks: 164421

Comment 18

15 years ago
*** Bug 251874 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Blocks: 251874

Comment 19

15 years ago
Thanks to one of Asa's blog posts
(http://weblogs.mozillazine.org/asa/archives/006092.html) I now know that we
already have this functionality in the auto-complete list.  (Starting typing in
a URL, get the auto-complete list, arrow down to an entry and hit <Shift><Del>
to remove it.)

I should *think* (although I don't really know) it would be a somewhat easy
procedure to take the code that does this for auto-complete and stick it into
the routine for the Location Bar history list.

Updated

14 years ago
Assignee: hewitt → location-bar
Status: ASSIGNED → NEW
Keywords: helpwanted
QA Contact: claudius

Comment 20

13 years ago
It already works. Open the dropdown list in the location bar, hover over the
desired URL and press Shift-Del.

I think this bug is resolved. If we don't want to argue forever about the exact
hotkey...

Comment 21

13 years ago
> It already works.

Neither Del nor Shift-Del does anything in the location bar.  You can only be
talking about Firefox.  This bug is targetted against Core, which also includes
Seamonkey.

(Note: The procedure from comment 19 in the auto-complete dropdown no longer
works for me with a 9/24 build of Seamonkey.)

Comment 22

13 years ago
Yes, I was talking about Firefox. But can this be fixed in the core? Isn't this
a UI stuff that is different in both products? If it got fixed in firefox, it
probably has a different code for the location bar.

Comment 23

13 years ago
Right, but unfortunately some of the components are in the wrong product :-(

Updated

13 years ago
Blocks: 251912

Comment 24

12 years ago
Firefox fixed this with Bug 171605/Bug 241774.
Summary: Delete key should delete location bar history list entry → [SeaMonkey] Delete key should delete location bar history list entry
*** Bug 157751 has been marked as a duplicate of this bug. ***
*** Bug 357176 has been marked as a duplicate of this bug. ***

Updated

12 years ago
Duplicate of this bug: 377589
(Assignee)

Updated

10 years ago
Product: Core → SeaMonkey
OK, so basically the difference here is that FF is using Toolkit's autocomplete.xml (where the functionality requested here has been implemented in the onKeyPress method, which calls nsAutoCompleteController::HandleDelete), while we are still using XPFE's autocomplete.xml (which doesn't have it in its processKeyPress method).

Neil, what's keeping us from using Toolkit's autocomplete in the Location Bar? And if there's good reason, could we at least re-use the controller part? Unfortunately this is back-end where I don't feel at home at all.
Actually our location bar history doesn't and can't use autocomplete at all.

Comment 30

8 years ago
Deleting the extraneous URLs from the address box dropdown is something I've been trying to dope out since Netscape. With SeaMonkey, the only way to do it is to goto my Profile folder and manually edit out the stuff in Localstore.rdf.

I've got a .bat program on my Desktop that deletes the History.dat; XUL.MFL; and Downloads.rdf with a click.

Unfortunately, I'm not smart enough to write a program that specifically targets the "<RDF:li>http://www..." and will open it in Notepad where I can delete, save changes, and close. 

I do like having a few URLs in there for ease of use rather than having to open Bookmarks all the time.
Note that SeaMonkey 2.x now stores location bar history in urlbarhistory.sqlite which can be easily deleted (to clear all the history) or edited with the sqlite utility of your choice.

Comment 32

8 years ago
@Neil,

Thanks for the info. I'm still on v.1.1.18. I'll upgrade to 2.x one of these days.
Assignee: location-bar → nobody
QA Contact: location-bar
Target Milestone: Future → ---
No longer blocks: 157751

Comment 33

8 years ago
Better be quick, SeaMonkey 2.1 will be out soon.
status-seamonkey2.1: --- → ?

Updated

8 years ago
status-seamonkey2.1: ? → wontfix

Updated

6 years ago
Depends on: 325690, 330578

Updated

6 years ago
Depends on: 241774

Updated

6 years ago
tracking-seamonkey2.18: --- → ?

Comment 34

6 years ago
I'm sorry, but we are not tracking this.
tracking-seamonkey2.18: ? → ---

Comment 35

6 years ago
 neil@parkwaycc.co.uk 2010-11-08 01:13:14 PST
wrote:
"Note that SeaMonkey 2.x now stores location bar history in urlbarhistory.sqlite which can be easily deleted (to clear all the history) or edited with the sqlite utility of your choice."

That's not user friendly - the delete key is far better.

Comment 36

5 years ago
Re comment #35:

Furthermore, deleting urlbarhistory.sqlite will delete the entire address area (URI bar) history.  This bug is about deleting only selected entries in the address area history, not the entire history.

Comment 37

2 years ago
Taking into account that dependent bugs are fixed now, is this still actual?
Whiteboard: [closeme 2017-05-15]

Comment 38

2 years ago
Works in Seamonkey 2.46
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 39

2 years ago
Morten Welinder (Reporter): Any comment?

"WFM"?
Flags: needinfo?(terra)

Updated

2 years ago
Flags: needinfo?(terra)
Resolution: FIXED → WORKSFORME
Whiteboard: [closeme 2017-05-15]

Comment 40

2 years ago
In what version of Gecko or Toolkit is this fixed?

Comment 41

2 years ago
Comment #38 said: Fixed in SM 2.46
I have SM 2.46 User agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0 SeaMonkey/2.46
so Gecko >= 20100101

Comment 42

2 years ago
Windows 7 Ultimate
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:49.0) Gecko/20100101 SeaMonkey/2.46

This does NOT work for me.  

I selected the down-triangle at the right of the address area (URI window), moved my cursor to an entry in the list of URIs, and hit the Delete button on my keyboard.  The entry was NOT deleted.  

Next, I opened a new tab, selected the down-triangle at the right of the address area, and actually selected an entry in the list of URIs.  This caused the Web page for that URI to appear.  I then hit the Delete button on my keyboard.  The address area went blank.  I closed the tab.  From another tab, I selected the down-triangle at the right of the address area and saw the "deleted" URI still in the list of URIs, now at the top of the list.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---

Comment 43

2 years ago
> This does NOT work for me. 

I will second this. The procedure described in comment 42 doesn't result in anything being deleted.

Comment 44

2 years ago
It has worked for quite some time with the auto-complete URL dropdown list, but as pointed out, it does not work with the regular dropdown list.
You need to log in before you can comment on or make changes to this bug.