Can't change colors in Text when replying. Intermittent.

RESOLVED FIXED in Thunderbird 30.0

Status

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: rgeiken, Assigned: aceman)

Tracking

({regression})

21 Branch
Thunderbird 30.0
regression
Dependency tree / graph

Thunderbird Tracking Flags

(thunderbird28 fixed, thunderbird29 fixed, thunderbird_esr2428+ fixed)

Details

(Whiteboard: [regression:TB21][dupetome])

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
This seems to be intermittent. In all previous versions of Thunderbird, changing Text color was a simple operation, but in June 2013 with Version 22, it is an iffy things to change text color. I see this has been a problem over the years, but it can be frustrating to find a function that has worked perfectly in the past now may not function at all. I have the latest version of 22 installed. I am on the beta release channel.I think that everything else in this version works OK. I tried to use one of the different themes, but that is not where the problem is being initiated. Seems like sometimes the color changer for text works, but other times not. I like to be able to change text color to separate my reply from the initial message.

Comment 1

5 years ago
I have the same problem in TB 24.0 on the Mac (OS X 10.8.5). I found a workaround that works for me, but it's annoying at best: basically the text color palette seems to only work after you first apply it to a new message.

Workaround steps:

1. If you have started typing a reply already, copy your text from your reply so you don't have to type it again (because you're going to cancel out of this one -- the workaround doesn't work if you try to color the text in the same message after steps 2-5; it has to be a new reply).
2. Close the reply message and don't save (you'll hit Reply again in a moment and then paste your text in).
3. Start a new message. Text color works fine in a new message.
4. Go back to the message you were replying to and hit Reply again to start a new reply.
5. Paste your copied text back in and then apply whatever color you want. It will work now.

Looking forward to a better fix.

Comment 2

5 years ago
D'oh, I meant to say in Step 3 -- apply a color to some text.

So step 3 should be:

3. Start a new message and type some text (doesn't matter what, just anything), then apply color to it. The color palette will work now and in subsequent messages, until the next time you quit/restart Thunderbird or you sleep/power off your computer. In those situations, you'll have to redo the steps above.
Thanks for the workaround.

Other workaround:

Set the text color using the menu:  'Layout', option: 'Text color'.

Anyway, this is a very annoying bug, I really hate it!
Eveline
The intermittent character of the bug is similar to that of Bug 917027 - "check spelling as you type" periodically breaks for the duration of the process
(Reporter)

Comment 5

5 years ago
The change color is a feature that was in Thunderbird for years, and all of a sudden it just disappeared. Actually all features to do it show up, it just doesn't work. Unfortunately both Firefox and Thunderbird have features that don't work as advertised. I use both of them and don't want to change to anything else. Sometimes it is almost like the engineers in charge of these programs don't know what to do. I think that you can still change the text font, but not the color. Some of these bugs are so obvious it is hard to believe that they don't work. When I make changes on things in my life, I make sure that what is supposed to happen really does. If you have fixes that are too technical, the less technical users won't be able to figure out what to do. Unfortunately sometimes Thunderbird seems to be in a shamble. I am on version 24 on the beta update channel. I wish now that I had stayed on a version from earlier that actually worked. Sometimes I disable all the other add ons just to make sure one of them is not causing the problem. Since I don't know what is going on in the programming to perform the function, I am at a loss to suggest anything.

Comment 6

5 years ago
I have the same problem. I used to write my reply, then swipe it, then change the font and color. I can still change the font, but not the color.

I'm going back to v7.09. You can get the esr version with a Google search.

Comment 7

5 years ago
I meant v17.09 esr...
(Reporter)

Comment 8

5 years ago
I cannot recommend Thunderbird to friends, since it is really an incomplete program when you show a function and then it does not work. Mozilla has lots of problems with both Thunderbird and Firefox and they are very slow to fix them up. Too many irons in the fire perhaps. Most of us users don't understand how they can continue to do this and then try to con people into using their product. For a very large percentage of less experience users, Chrome might be a better product to use. Even Microsoft's e-mail program for W7 is probably a better bet. Lets face it, all Mozilla products are for the enthusiast since they require a lot of tending to to keep them operating properly. The Thunderbird color problem seems to have been around in various forms for a long time. I would really like an explanation of how it works on one version of Thunderbird and then stops working on a later version. This whole product is starting to sound like a "House of Cards".
unusable because of color - seems doubtful nor common.  Let's please keep comments to productive investigation.

1. Please confirm that it worked in version 21 beta - available from https://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/21.0b1/

2. Datapoint - this issue would appear to be far from common - if "reply" is really a required step. I find no reports in support forums. Also doesn't appear to be in BMO since TB21/22 began development ~1 year ago - https://bugzilla.mozilla.org/buglist.cgi?o5=anywordssubstr&f1=OP&o3=anywordssubstr&v6=undo%20link&list_id=8226901&short_desc=color&bug_severity=major&bug_severity=normal&bug_severity=minor&v3=compos&classification=Client%20Software&classification=Components&o2=anywordssubstr&o6=nowordssubstr&f4=CP&chfieldto=Now&v5=reply%20repli&query_format=advanced&j1=OR&chfieldfrom=12m&f3=component&f2=longdesc&short_desc_type=allwordssubstr&f5=longdesc&component=Composition&component=Composition&component=Editor&component=Editor&component=Message%20Compose%20Window&component=Message%20Compose%20Window&f6=short_desc&v2=thunderbird%20tbird&product=Core&product=MailNews%20Core&product=Thunderbird

3. I don't normally deal in these types of bugs nor use formatted text, so please post a set of numbered steps in the shortest, tersest way possible.
Keywords: regression, regressionwindow-wanted
Summary: Can't change colors in Text when replying → Can't change colors in Text when replying. Intermittent.
Whiteboard: [regression:TB??]
(Reporter)

Comment 10

5 years ago
I have beta update version 24 installed. Evidently they have put another update into my version, since I have all the tools there to change text color, but when I try to select the color nothing happens. Earlier in version 24, I could get the text to change to orange or any other color, but when I started typing, it reverted to Black and that was all I could get. The change color function worked fine in previous versions, but it quit working sometime back. I went from released version 3 to beta 24 in the past couples of years and not sure where this stopped working since I was just trying to use it and not testing it. I even tried to disable all the other add ons and only have the one that had to do with text color and that didn't help. I would imagine the 90 to 95% of users that use that function are having problems too. I have had plenty of updates in the past few months and none of them have helped. I had the calender function quit working several times with new builds, but they have always fixed that OK. As far as it working in version 21 beta, I can't be sure, since I really wasn't tracking the problem by version numbers. I get a feeling that this is low on the totem pole of fixes for Thunderbird, and fortunately I can still use the program even with that missing.
(In reply to Ronald Geiken from comment #10)
> I have beta update version 24 installed. Evidently they have put another
> update into my version, since I have all the tools there to change text

this doesn't add information that gets us toward a solution
(Reporter)

Comment 12

5 years ago
I have all of my extensions disabled right now and the color shows up, but when I put the cursor on the first line of text, the color goes away. If someone from Thunderbird has any rational options, I will be glad to try them. For people that are not very computer literate, trying to make this work is not a very easy task. When I opted for the Beta program, I understood that at times some functions would be inoperative but they would get them working in a reasonable time. This problem has been present for over 4 months, and nothing helps. Unfortunately they don't offer an option to abandon ship and get back to the released version. What are you options for me to try to find a solution. If they would give me a hint, I would certainly give it a try. Disabling all of the extensions should have done something, but still doesn't work. I will be restarting things tomorrow and see if disabling things has helped at all. Some of the things that have you just restart the program really don't suffice for completely shutting the computer down and restarting it.
forget the other stuff. they best way you can help IMO is #1 and #3 of comment 9.
Flags: needinfo?(rgeiken)

Comment 14

5 years ago
Seems like it's working OK at the moment -- at least for me (updated from 24.0, in my first comment, to 24.0.1).

I tried the 21 beta and that worked fine, as well.

I then tried rebooting my Mac and launching 24.0.1 fresh to see if it would revert to the odd behavior and it did not.

So far, so good. Perhaps it was fixed in the update?
Duplicate of this bug: 876182
(Reporter)

Comment 16

5 years ago
I have version 25 installed as of 10/27/2013, and just tried changing text color on a reply, and the color change did not work. I am not even sure what extension is used to provide this service or if it is inherent in the Thunderbird Program instead. You have to be a real techie to stick with a program like Thunderbird Beta.The Beta has provided a lot of pluses, but the minuses can be pretty frustrating.
Flags: needinfo?(rgeiken)
workaround:

Set the text color using the menu:  'Layout', option: 'Text color'.

Anyway, this is a very annoying bug, I really hate it!
Eveline
(Reporter)

Comment 18

5 years ago
I already have the return Text Color set to orange, and it doesn't respond to that when I try to respond to an e-mail. I ran a test within the past month and removed all of the add on Extensions and it still would not respond to the text color called for in the options settings. At least on version 25 and even 24, the text color function does not work properly. If they don't have the time and money to make this function work, they should just remove it. Nothing worse than having a supposed function inoperative. I wish they would provide something to all us to jump off of the beta test and get back to a fully operative version. Right now, I guess that might be version 17. Having unsuspecting users downloading a beta and then find out all the problems could be frustrating to them.

Comment 19

5 years ago
I noticed the loss of color control starting about v24 (now running 24.1.0).  It is intermittent, as described in Bug 925273 which gives a much better description of the problem and illustration of what fails to happen.  Simply, the color selections (foreground and background) sometimes do not activate.

I've never had it fail in a new letter, but it fails intermittently on REPLY or FORWARD.  In fact, I've had it work in a reply and then fail moments later on a similar operation in the same message!  At first I thought the problem was that the original message was non-HTML or unformatted, etc, which understandably doesn't allow format controls; but no, it fails regularly on messages that already have color in them too.

So far I haven't identified any rhyme or reason for the failure -- only that it usually (but not always) fails on reply, and usully (I think always) works on new messages.
(Reporter)

Comment 20

5 years ago
I was reading the above comment, and was hoping that it was so, but I have version 25 beta, and I just tried putting color on a new message, It shows that it is taking, but then the color goes away. Since I have not idea how this whole scheme works, I can only try it after someone posts a possible fix. So far, nothing that has been posted here has been able to bring the color back.      November 12, 2013

Comment 21

5 years ago
Two observations about this

Comment 22

5 years ago
I am grateful to have found this forum. I thought I was going crazy. For a couple of months or so, I have only intermittently been able to color any text. Regarding the workaround, I can sometimes color text in a reply. I haven't found any consistency in its not working. I hope they fix it soon.

I have had at least one update since the problem began. I now have TB 24.2.0. 

Wayne Mery said: "unusable because of color - seems doubtful nor common.  Let's please keep comments to productive investigation." Perhaps I misunderstand Wayne, but I, too, use color in many of my emails to separate or highlight text.
(Reporter)

Comment 23

5 years ago
I have Thunderbird on two different machines, and on my Lenovo Laptop the color selection works OK,but on my Lenovo Desktop, it does not work. I have tried things like disabling all apps and restarting to see if that helps at all. Doesn't seem to. I have been wondering if a particular app has been causing the problem, but not sure which one. Seems like someone from Mozilla should be able to give us a clue. For the longest time, the color changing seemed to work just fine, but I am on the rapid update program and on Version 27 on my Desktop. The Laptop is probably around that version too. Since I don't have any idea what could disable this function, not sure exactly what to do. It will act like it is going to change the color with the new color showing up in the box, but when you actually start typing text, the color disappears. This might seem like a small problem to some people, but I would never recommend Thunderbird to any of my friends since every update can bring some new problem. I will keep monitoring this site in case someone solves the problem, but since it has seemed to be around forever, I am not going to hold my breath. Seems like everything else works with version 27 now. +

Comment 24

5 years ago
Question: Users can apply color to text in one of two ways: Format > Text Color (which _always_ displays the Text Color dialog box), and clicking the color button on the toolbar (which _intermittently_ displays the Text Color dialog box). Shouldn't both those events call the same statement to display the Text Color dialog?

Comment 25

5 years ago
I have TB 24.02 from the release channel and can confirm that this bug is - INTERMITTENTLY - reproducible.  The ability to color text within a reply has always been available via the Format/Text Color menu dropdown as far as I can establish, but clicking the option button in the icon ribbon above the text simply fails to trigger the color popup dialog.

I have proven to my own satisfaction that the workaround suggested above, namely start a new message#change color#return to original message#click reply#click color icon does seem to work, so it begs the question, as Mark identified above:

If the Menu item and the ribbon button are calling the same method, what is wrong with the ribbon button processing that stops this call from working???

NickB

Comment 26

5 years ago
I'm on TB 24.2.0, and the problem is still intermittent here on Windows 7(32).  Not trying to introduce a red herring, but here's an additional unique observation:  I've had the same issue with Microsoft Excel (Office 2007) intermittently for the past two years -- the control buttons don't respond.  (I have to minimize and maximize the Excel window, then it works.)  Could the TB problem actually be something in Windows that TB calls?  Might explain why the two supposedly same calls (Comments 24 & 25) work differently.  Just a thought.

Comment 27

5 years ago
Unlikely a Windows problem. I use Linux and I observe this bug.

(In reply to Dan Pernokis from comment #26)
> I'm on TB 24.2.0, and the problem is still intermittent here on Windows
> 7(32).  Not trying to introduce a red herring, but here's an additional
> unique observation:  I've had the same issue with Microsoft Excel (Office
> 2007) intermittently for the past two years -- the control buttons don't
> respond.  (I have to minimize and maximize the Excel window, then it works.)
> Could the TB problem actually be something in Windows that TB calls?  Might
> explain why the two supposedly same calls (Comments 24 & 25) work
> differently.  Just a thought.

Comment 28

5 years ago
Yep, I don't think the OS matters. I notice it on my Mac, as well. (In the meantime, I've just been using the method that Eveline mentioned above -- using the menu. Easy enough for now.)

Comment 29

5 years ago
@ Wayne Mery,
maybe the following observation could be interesting for you:
a helper in the German forum "Thunderbird Mail DE" proposed a "workaround" which consists in changing the value of the hidden pref "mail.compose.max_recycled_windows" from "1"(= default) to "0"
http://www.thunderbird-mail.de/forum/viewtopic.php?p=351651#p351651
I recently proposed the same workaround in the French Mozilla forum "Geckozone".
Oddly enough this manipulation seemed to work for users in both forums but maybe the results are biased since most of them previously had tried other manœuvres. 

I've tested with both values in TB 24.2.0 (Mac) in several profiles:
although I previously had observed several times the "change color text problem", this time I could not reproduce the problem with the value = 1.
(Reporter)

Comment 30

5 years ago
Eckard, I like what you are proposing, but what is the actual method used. Where do you actually make these changes? The fact that my Thunderbird program color change works OK on my Lenovo Laptop, but on my Lenovo Desktop it does not work. If something should be changed in the programming, Mozilla should do it so all of the users would get some consistency. Lets face it, Thunderbird is for techies and the normal users if they use it should go light on the add on extensions. Also the beta program is not the place for people who need someone to dot the i's and cross the t's. Eckard if you can actually explain where you go to make these changes, I would like to try it out. On W7, Thunderbird program parts seem to be scattered all over the place.
(Reporter)

Updated

5 years ago
Version: 22 → 27

Comment 31

5 years ago
(In reply to Ronald Geiken from comment #30)
> Eckard if you can
> actually explain where you go to make these changes, I would like to try it
> out. 
Go to Tools -> Options -> Advanced -> General -> and open the Config Editor.
Search for the preference mail.compose.max_recycled_windows, double-click it and set its value to "0".
Regarding this pref also see "Cached compose window FAQ" https://developer.mozilla.org/en-US/docs/Mozilla/Thunderbird/Cached_compose_window_FAQ
possible examples 
bug 927197, bug  bug 876182, bug 716861, bug 932746, bug 952798, bug 940437

Comment 33

5 years ago
(In reply to Eckard Berberich from comment #31)

Thank you for this fix. My toolbar button for changing text color now works all the time.
(Reporter)

Comment 34

5 years ago
I just made this change from 1 to 0, and restarted Thunderbird, and it did not work. Maybe I have to restart the computer to effect this change and will do that later and tomorrow I will know if that works OK. Likely restarting the computer rather than just the program is required. If that works, will re-post on the 2nd of February and let everyone know whether it worked OK for me after making the change in the configuration editor and then recycling computers.
(Reporter)

Comment 35

5 years ago
I have restarted the computer and the change that I made in Comment 34 still did not work after I restarted computer. The change was from 1 to 0. It looks like there are many hundreds of things that have to do with text color in the configuration editor. I suppose that is where changes have to be made to finally allow the text color to be changed. Seems like if someone from Mozilla actually knows how this is supposed to function they should be able to make it work. I have a Laptop and Desktop both Lenovo late models, and the Laptop Color changer works, but the one in the Desktop does not. They are both at the same version level give or take a version or so. The color comes up in the box, but when you start typing, it goes away and the text stays black. I originally had the text color set to orange, but it still would only give black text. I used search in the configuration editor and looked at the settings that had to do with color, and could not see any difference between computers. This problem has been UNSOLVED for almost a year now, and I would do my research on it, but not sure what is involved in changing and sustaining the text color change.

Comment 36

5 years ago
Just a comment for clarity to make sure we're looking at the whole problem:  Looks like in Comments 34 & 35 (and previously), Ron's problem is that the color button is pressed so that subsequently typed text should become the new color, and apparently it does not.  In fact the problem is that sometimes the button does not react AT ALL, as evidenced if you highlight/select text and press the color button hoping to change color -- nothing happens, because the button does not press.  This could be a mouse focus issue -- somehow that element of the menu bar is no longer sensitized, or is misdirected to who-knows-where.  As a workaround, I find the menu selection (FORMAT, Text Selection...) works well for both procedures.  Thanks, Mark (Comment 24).

But I'm skeptical of random patches that suddenly appear to work.  My color stuff works fine, and then it doesn't, and I've done nothing to change anything.  You're trying to prove a negative -- that it no longer fails because it didn't fail THIS time -- when the reality is it works only sometimes (including the most recent times).

Comment 37

5 years ago
This happens frequently.  Can't change text color.  This problem makes it impossible to edit mime emails.  For example, lets say you wanted to add a normal text comment before or after a link.  The link is underlined and in blue.  You can remove underlining but you can't change the color of the non-link comment.  This is a SEVERE bug.  It makes using Thunderbird for customer support impossible to use at times.  (I use a Mime template and modify the template... which now you can't do FREQUENTLY)

To reproduce, paste an html fragment with lists and links.  For one of the list items, have ONLY a link.  Try to go add a text comment at the beginning of the element.

Comment 38

5 years ago
Bill, the guys are working on this problem.  In the meantime, do whatever you do to change color, but instead of pressing the color button, go to the menu bar and select "FORMAT, Font Color...".  You then get exactly the same color box popup.  (If you don't have the menu bar visible, you can activate it using the square barred OPTIONS button in the very top right corner of TB.)

Comment 39

5 years ago
Thanks Dan.  I saw another comment above yesterday about the menu option for color selection.  That solved my problem for the near term. Thanks for taking the time to comment!  Very appreciated.

Being a software developer and having written (still writing) a cross platform semi-automated customer email support system (so, I'm doing everything that Thunderbird does with the automation thrown in and html templates with intelligent form filling) and I have to have a GUI (Qt4, Qt5) and scripting (Perl integrated with C++) and I know that Apple and new OSX releases stink for backwards compatibility, blah blah.... so I know about Thunderbird development hurdles.

Anyway... temper my severe comment above since there is this usable alternative for color.
And thanks again for taking the time to comment.

  
(In reply to Dan Pernokis from comment #38)
> Bill, the guys are working on this problem.  In the meantime, do whatever
> you do to change color, but instead of pressing the color button, go to the
> menu bar and select "FORMAT, Font Color...".  You then get exactly the same
> color box popup.  (If you don't have the menu bar visible, you can activate
> it using the square barred OPTIONS button in the very top right corner of
> TB.)
(Assignee)

Comment 40

5 years ago
Sorry, but this report is still unclear. There are different symptoms being described.
I did not understand how does "Can't change colors in Text when replying" actually exhibit itself.
1. Is the button for text color disabled and unclickable?
2. Is it clickable but the shown palette does not respond?
3. Does it respond and closes after choosing a color but the selected text does not change to the color?
4. Does the text change the color but, the color is lost on sending the message or reopening it?

I did not yet get from the comments which of these cases you are getting here.

Comment 41

5 years ago
:aceman    Its   #1

The color toolbar button is disabled.  The color menu action works.

Comment 42

5 years ago
:aceman    Its   #1

The color toolbar button is disabled.  The color menu action works.

In reply to :aceman from comment #40)
> Sorry, but this report is still unclear. There are different symptoms being
> described.
> I did not understand how does "Can't change colors in Text when replying"
> actually exhibit itself.
> 1. Is the button for text color disabled and unclickable?
> 2. Is it clickable but the shown palette does not respond?
> 3. Does it respond and closes after choosing a color but the selected text
> does not change to the color?
> 4. Does the text change the color but, the color is lost on sending the
> message or reopening it?
> 
> I did not yet get from the comments which of these cases you are getting
> here.
(Assignee)

Comment 43

5 years ago
OK, when that happens, are other icons enabled?
Also, is the problem also seen on the background color icon?
(Assignee)

Comment 44

5 years ago
And does the text color icon enable itself when you change selection? Or is it stuck in disabled mode for the whole session (until you close compose window or restart TB)?

Comment 45

5 years ago
Ace, see my Comment #36...  "...sometimes the button does not react AT ALL..."

Mousing over the color button, clicking the button, nothing happens.  The button does not enlarge -- ie, the image of the bigger button doesn't toggle -- and if clicked, there is no response, no color popup.  Doesn't matter whether you have text selected to be changed, or whether you want new text (from the cursor onward) to be colored -- nothing happens.  The button doesn't change and no popup occurs.  This is what makes me think it might be a mouse/focus issue.

Ditto for the background color button -- no reaction to mouseover, no popup.  (And no obvious workaround except to change the default background color under the FORMAT menu.) 

BTW, it should be noted that in some programs (eg, MS WORD), once you've picked a color, then selecting text and clicking the color button applies that color to the selected text.  (Only if you specifically go to the color selector does it let you pick another color.)  In TB, however, clicking the color button always brings up the color popup (bug situation excepted!) and requires a color choice.  It does not just automatically change the text.  (TB has only one button -- a selector, not an applicator.)  So don't be misled -- this aspect is NOT the problem being reported.

Hope that clarifies.

Comment 46

5 years ago
(In reply to :aceman from comment #43)
> OK, when that happens, are other icons enabled?
> Also, is the problem also seen on the background color icon?

Yes, the other toolbar buttons are enabled.  For example Bold.  

I do not know about background color.  I'll check that next time I encounter this which will be sometime today.

Comment 47

5 years ago
(In reply to :aceman from comment #44)
> And does the text color icon enable itself when you change selection? Or is
> it stuck in disabled mode for the whole session (until you close compose
> window or restart TB)?

No.  The button never re-enables itself in that window.

Comment 48

5 years ago
I'll confirm that ONLY the color button has the disabled problem.  All other buttons continue to work normally.  And yes, the background button is always disabled when the FG button doesn't work.

Comment 49

5 years ago
I'll also confirm that once the problem has occurred (color button becomes non-responsive), it has never reactivated in a current window, and I think it has been disabled for the life of the TB session.  

But I have also had it work OK in a message, and then quit seconds later within the same message.  Most notably it happens in REPLY or FORWARD, but occasionally in new messages too.  Exact same symptoms always.
(Assignee)

Comment 50

5 years ago
OK, one last question:
1. Are the buttons really disabled - with grey shade over them and partly transparent so that the background color icon edge is visible through the foreground color icon?

2. Or do they look normal and also get a black border when hovered over, just do not popup the palette when clicked?

It seems I have now got into state 2 in my tests.
(Assignee)

Comment 51

5 years ago
I got into the state 2. by Saving the message (as draft). Or it can happen if you compose the message for long enough so that automatic saving kicks in.
Can anybody confirm this?

Comment 52

5 years ago
(In reply to :aceman from comment #51)
> I got into the state 2. by Saving the message (as draft). Or it can happen
> if you compose the message for long enough so that automatic saving kicks in.
> Can anybody confirm this?

I agree.  Its the draft save that causes the issue.

I couldn't get the color button to fail to respond until I saved the draft.

Comment 53

5 years ago
(In reply to :aceman from comment #50)
> OK, one last question:
> 1. Are the buttons really disabled - with grey shade over them and partly
> transparent so that the background color icon edge is visible through the
> foreground color icon?
> 
> 2. Or do they look normal and also get a black border when hovered over,
> just do not popup the palette when clicked?
> 
> It seems I have now got into state 2 in my tests.

The color button does not change appearance between problem mode operation (not) and normal operation.
It just fails to popup the palette when clicked when in problem mode.
(Reporter)

Comment 54

5 years ago
One thing to remember as I stated in a previous post is that I have one computer with Thunderbird where the color changer works fine, and one version where it works like what is described in these other posts. I was originally wondering if the problem was being caused by another extension, but started my failing version of Thunderbird in Safe Mode, with no extensions working and it still did not work. Must be something else within the program causing the problem. The earlier versions of TB on this Lenovo Desktop worked fine for a long time before the color changer failed. I can't remember what version that was. This may be why some people are seeing the failure and others now. It is a vexing problem, but not universal.

Comment 55

5 years ago
I just tried the save-to-draft trick on both new and reply messages.  Can't get it to fail right now -- all working normally.  (To complicate matters, I upgraded to TB 24.3.0 yesterday!)

And as for the button icon:  When it fails, on mouseover there is literally no reaction -- no enlargement, no border, no greying or transparency, absolutely no change in appearance -- and no response to clicks (left or right).
(Assignee)

Comment 56

5 years ago
(In reply to Ronald Geiken from comment #54)
> One thing to remember as I stated in a previous post is that I have one
> computer with Thunderbird where the color changer works fine, and one
> version where it works like what is described in these other posts. I was
> originally wondering if the problem was being caused by another extension,
> but started my failing version of Thunderbird in Safe Mode, with no
> extensions working and it still did not work. Must be something else within
> the program causing the problem. The earlier versions of TB on this Lenovo
> Desktop worked fine for a long time before the color changer failed. I can't
> remember what version that was. This may be why some people are seeing the
> failure and others now. It is a vexing problem, but not universal.

Check in TB options -> Composition -> General whether you have "Auto save" turned off on the machine that does not exhibit the problem.
(Assignee)

Comment 57

5 years ago
OK, I tentatively mark this as regression from bug 528793, where I implemented the disabling of the color buttons (they were the only buttons missing this feature). That landed in TB21, which may correspond with the original report mentioning TB22 (it could go into late builds of 21 so the user got it only after updating to 22).
I see a code bug in that patch that should explain my observation of text color disabled after saving as draft.

Let's see if after that fix any other case remains.
Maybe some of you do not see the hover effects as they may depend on the platform (I see Win 7, Mac OS and linux comments here)

I'm taking this bug.
Assignee: nobody → acelists
Blocks: 528793
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Updated

5 years ago
Keywords: regressionwindow-wanted
Whiteboard: [regression:TB??] → [regression:TB21]
(Assignee)

Comment 58

5 years ago
Created attachment 8371725 [details] [diff] [review]
patch

It seems like an unfortunate interaction of bug 271730 and bug 528793. Before Save, the icon had no "disabled" attribute, after Save (which temporarily disables all widgets) it was set to disabled="false". The icon was checking if "disabled" attribute is just set, not if it actually has a value of "true" (usually that is enough as "disabled=false" is rarely set on elements).

So this patch makes it more robust on both fronts. Make updateAllItems the value of "disabled" saving and restoring more accurate (if there was no "disabled" previously, also restore it to no such attribute afterwards).
Attachment #8371725 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 59

5 years ago
Could any of you guys try out the patch on TB24?
You need to do this:
0. close TB
1. find the file omni.ja in Thunderbird install folder.
2. backup the file as you will need the original for later official updates to succeed
3. open it as zip archive in some program like WinRAR or 7zip
4. browse through chrome -> messenger -> content -> messenger -> messengercompose
5. edit the file editorOverlay.xul
6. Find this line:
         onclick="if (!this.hasAttribute('disabled')) { EditorSelectColor('', event); }"
7. change it to (must be a single line, it is shown wrapped in this comment):
         onclick="if (!this.hasAttribute('disabled') || this.getAttribute('disabled') != 'true') { EditorSelectColor('', event); }"
8. save the file and whole archive and exit from it
9. find the file startupCache.4.little in you TB profile and delete it.
10. start TB
11. report findings to this bug :)
12. copy back the omni.ja file from backup before next TB update
Comment on attachment 8371725 [details] [diff] [review]
patch

Review of attachment 8371725 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM! r=mkmelin
Attachment #8371725 - Flags: review?(mkmelin+mozilla) → review+
(Assignee)

Comment 61

5 years ago
Thanks.

Wayne, are there any GS topics about this?
Keywords: checkin-needed
OS: Windows 7 → All
Hardware: x86_64 → All
Whiteboard: [regression:TB21] → [regression:TB21][dupetome]
Version: 27 → 21
https://hg.mozilla.org/comm-central/rev/09c8c61c2803
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 30.0
(In reply to :aceman from comment #61)
> Wayne, are there any GS topics about this?

1. many topics about text color since ~7/1/2013 and I'm sure many are this bug.
2. is bug 933782 aka https://getsatisfaction.com/mozilla_messaging/topics/no_thoughts_from_mods_on_changing_text_color_problem the same issue?
Flags: needinfo?(acelists)
(Assignee)

Comment 64

5 years ago
(In reply to Wayne Mery (:wsmwk) from comment #63)
> (In reply to :aceman from comment #61)
> > Wayne, are there any GS topics about this?
> 
> 1. many topics about text color since ~7/1/2013 and I'm sure many are this
> bug.
Yeah, if that is 1st of July, then that may be the correct date. Please collect them here.

> 2. is bug 933782 aka
> https://getsatisfaction.com/mozilla_messaging/topics/
> no_thoughts_from_mods_on_changing_text_color_problem the same issue?
Pity that I didn't find that bug since the beginning. It has the right STR (Save draft involved) in it since comment 0. So yes, that bug up to comment 6 is the same as this one. Then some other comments appeared that are not sure whether they I are the same problem.
There are also other GS topics mentioned, please collect them here if they look the same.

Key identifier to look for is if the icon stops working after Saving as draft or a failed send of a message. Due to compose window recycling, the issue may crop up if those operations were done in a previous message but the user just notices the problem when composing another message.

I intend to propose this for TB24, so it could get to users quickly and we can weed out the dupes.
Flags: needinfo?(acelists)

Comment 65

5 years ago
Before you consider this 100% resolved...  I did some testing with my existing program (TB 24.3.0, no patch).  Yes, if I SAVE and then try color, the color selector table no longer pops up.  But the color button icon right now reacts on mouseover (enlarges or displays border, whatever), whereas previously it always remained frozen -- no enlargement, absolutely no indication on mouseover.

So are there two parts to this mystery?  I'll agree that the save-to-draft may trigger failure of the pop-up, but I fear there might be something else inhibiting the button reaction which of course prevents the color selector table altogether.  (See my Comment #55 re: no reaction, and Comment #45 re: mouse focus.)
(Assignee)

Comment 66

5 years ago
Yes, I am aware this may not solve all problems. But for ease of tracking we can't solve all problems in this bug. So this bug fixes one real problem and we dupe some bugs to it. I already said in comment 64 that I saw reports that may not be this bug. So those will stay open and we can work on them separately. Maybe one of them covers also your problem. You will decide after trying a TB build with this patch.
So this bug solves the case after save as draft, when the button responds on hover, but does not open the color palette.
(Assignee)

Comment 67

5 years ago
Comment on attachment 8371725 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): bug 271730 and bug 528793
User impact if declined: non-working "text color" button after saving a draft. Already about 30 GS topics that are candidates for being about this bug. We will go through them and link them here. Also some bugs that are candidates to be duped here. (I need to go through some tests with the reporters or make them try out trunk.)
Testing completed (on c-c, etc.): The fix is working for me on current trunk (TB30).
Risk to taking this patch (and alternatives if risky): potential for reopening bug 271730 again or some other bad effects on disabling compose widgets (when saving or sending).

Let this bake on trunk for a while and then we could push it to 24.
Attachment #8371725 - Flags: approval-comm-esr24?
(Assignee)

Updated

5 years ago
Blocks: 933782
See Also: → bug 933782
(Assignee)

Comment 68

5 years ago
(In reply to :aceman from comment #67)
> Risk to taking this patch (and alternatives if risky): potential for
> reopening bug 271730 again or some other bad effects on disabling compose
> widgets (when saving or sending).

standard8, if this is too risky, we can split only a safe version of this (the change described in comment 59) for TB24.
(Assignee)

Comment 69

5 years ago
Created attachment 8376429 [details] [diff] [review]
883540-TB24.patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Testing completed (on c-c, etc.): 
Risk to taking this patch (and alternatives if risky):

This is the safe version for TB24. It is enough to fix the bug for the text-color button. The full version of the fix for trunk is more robust and potentially fixes yet undetected problems with other elements.
Attachment #8376429 - Flags: approval-comm-esr24?
(Assignee)

Updated

5 years ago
Duplicate of this bug: 932746
Comment on attachment 8376429 [details] [diff] [review]
883540-TB24.patch

[Triage Comment]
Lets get this onto aurora & beta for some testing.
Attachment #8376429 - Flags: approval-comm-beta+
Attachment #8376429 - Flags: approval-comm-aurora+
tracking-thunderbird_esr24: --- → 29+
Attachment #8376429 - Flags: approval-comm-esr24? → approval-comm-esr24+
https://hg.mozilla.org/releases/comm-esr24/rev/a27ee7a01aac
status-thunderbird_esr24: --- → fixed
tracking-thunderbird_esr24: 29+ → 28+
Attachment #8371725 - Flags: approval-comm-esr24?
(Assignee)

Comment 74

5 years ago
Can you guys test it now in TB 24.4.0 ?

Comment 75

5 years ago
I didn't see this fix listed in the release notes for TB 24.4.0, but I downloaded it last night and specifically tested for the problem anyway.  Tried straight edits (no saves), edit with save, reply, reply with save, edit/save/close reopen, and reply/save/close reopen.  Couldn't make it fail.

But then, 23.3.0 was working OK for me too in the past little while, whereas it wasn't previously (eg comment #65).  So I don't know if this is a valid confirmation for you or not.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 933782

Comment 77

5 years ago
This has been reported as still existing in the forums

See https://support.mozilla.org/en-US/questions/992366?
(Assignee)

Comment 78

5 years ago
If the text color palette comes up and he chooses a color but it has no effect on the text then that is a different bug.

The bug here is about the icon stopping responding as in not showing the color palette.
(Assignee)

Updated

5 years ago
Duplicate of this bug: 940437
(Assignee)

Updated

5 years ago
Duplicate of this bug: 927197
You need to log in before you can comment on or make changes to this bug.