Closed Bug 887673 Opened 7 years ago Closed 7 years ago

[User Story] Export of contact to USIM

Categories

(Firefox OS Graveyard :: Gaia::Contacts, defect, P1)

x86
macOS
defect

Tracking

(blocking-b2g:koi+)

VERIFIED FIXED
blocking-b2g koi+

People

(Reporter: wmathanaraj, Assigned: arcturus)

References

Details

(Keywords: feature, Whiteboard: [TEF][UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0][Sprint 2])

Attachments

(2 files)

User Story:

As a user I expect to be able to go to the Contacts app and select multiple contacts and export those contacts, that I am allowed, to USIM. 
As a user, when I am in the contacts app, I want to be able to see an indication that some contact export onto USIM is currently taking place.
As a user I want to be informed how many contacts have been imported and how many were not imported from the total number of contacts I have chosen to import.


Preconditions:

* USIM is present in the device
* Contacts app is open


Acceptance Criteria:

* User should be informed if there is not enough space on the SIM
* User should be given information of any other errors in an understandable message
* User should be informed if there is no SIM in the device
* User should be informed of a successful import of contacts (pass/fail v total)
A Pivotal Tracker story has been created for this Bug: http://www.pivotaltracker.com/story/show/52538247
David Scravaglieri deleted the linked story in Pivotal Tracker
Whiteboard: [ucid:Comms5] → [ucid:Comms5], [u=commsapps-user c=contacts p=0]
Depends on: 888931
No longer blocks: 890490
Depends on: 890490
listed as must have in v1.2 for COMM team. koi+
blocking-b2g: koi? → koi+
Flags: in-moztrap?
Comms5
MozTrap #9047, #9048
Flags: in-moztrap? → in-moztrap+
Whiteboard: [ucid:Comms5], [u=commsapps-user c=contacts p=0] → [ucid:Comms5 KOI:P1], [u=commsapps-user c=contacts p=0]
Depends on: 895169
Assignee: nobody → noef
Whiteboard: [ucid:Comms5 KOI:P1], [u=commsapps-user c=contacts p=0] → [UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0]
Assignee: noef → nobody
Whiteboard: [UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0] → [TEF][UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0]
Assignee: nobody → francisco.jordano
Depends on: 895886
Duplicate of this bug: 831663
Whiteboard: [TEF][UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0] → [TEF][UCID:Comms5, FT:comms, KOI:P1], [u=commsapps-user c=contacts p=0][Sprint 2]
(In reply to Wilfred Mathanaraj [:WDM] from comment #0)
> User Story:
> 
> As a user I expect to be able to go to the Contacts app and select multiple
> contacts and export those contacts, that I am allowed, to USIM. 
> As a user, when I am in the contacts app, I want to be able to see an
> indication that some contact export onto USIM is currently taking place.
> As a user I want to be informed how many contacts have been imported and how
> many were not imported from the total number of contacts I have chosen to
> import.
> 
> 
> Preconditions:
> 
> * USIM is present in the device
> * Contacts app is open
> 
> 
> Acceptance Criteria:
> 
> * User should be informed if there is not enough space on the SIM
> * User should be given information of any other errors in an understandable
> message
> * User should be informed if there is no SIM in the device
> * User should be informed of a successful import of contacts (pass/fail v
> total)

There is a tension in the requirements of this bug. Title says 'Export of contact to USIM' but comment 0 mentions importing in several places. Are we doing export only to USIM? or export and import to USIM?

NeedInfo to Wilfred to confirm requirments
Flags: needinfo?(wmathanaraj)
Sorry - my mistake - it should all be "export"!
Flags: needinfo?(wmathanaraj)
wireframe solution for bug
pages 09 and 10 are the relevant pages in document
Depends on: 901887
QA Contact: isabelrios
Test cases already defined but not shared to be imported into Moztrap yet
Please find visuals for this flows in the following link:

https://www.dropbox.com/sh/rz8h7kkzdgip46d/nd40dk2Eoj

If you any question do not hesitate.
Victoria
Attached file Pointer to PR 11638
Attachment #792900 - Flags: review?(bkelly)
Looks pretty good.  I added some comments to the github PR.  I think I was a little nit picky, but the main thing I would like to address is a bit better is the error path.  Specifically, I think we should catch exceptions during our export async loop and also add some tests to validate the error path.

Also, I haven't been able to run this on my phone yet.  I need to track down my sim card and move it to my b2g dogfood phone.  Hopefully I can do that later today or tomorrow morning.
Comment on attachment 792900 [details]
Pointer to PR 11638

Looks good!  I only had one new comment in the PR.  I verified the tests run locally, but don't have time to test on my device.  I think most of the device specific stuff is under the icc component, though, so I don't see any reason it would fail on the device.

Assuming you've verified it works on the device and that last comment is addressed, I'll give r+.

Thanks Francisco!
Attachment #792900 - Flags: review?(bkelly) → review+
Landed:

https://github.com/mozilla-b2g/gaia/commit/3999bc22473235a0dc7ccc290bcd29c81d3fa1d3

Thanks Ben for the help here!
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Depends on: 909708
Depends on: 910170
Depends on: 910188
Depends on: 911089
Depends on: 910176
Sorry for linking all the bugs to the US. A new follow up bug has been created for that. So, now all bugs related to this US are linked to bug915641.
The only bug pending in the follow up is covered by other US. There are no more bugs about this US, so verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.