Closed Bug 927061 Opened 7 years ago Closed 4 years ago

[tracker] Make taskcluster mac debug builds Tier-1

Categories

(Infrastructure & Operations Graveyard :: CIDuty, task, P3)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: hwine, Unassigned)

References

(Depends on 1 open bug)

Details

bug 921040 will determine if this is both possible and a reasonable thing to do. This bug will track all the related issues about getting it successfully deployed in production
Summary: [tracker] Determine how to support and role out darwin-on-linux in production → [tracker] Determine how to support and roll out darwin-on-linux in production
Blocks: 928193
Status update for tracked bugs:

Looking Good:
 - bug 921040 has a Mac build (with caveats), 
   - path to a full build seems likely
   - engaging QA to sanity check build performance on multiple OSX versions

Still much too do before decision made:
 - tooling for packaging is still an unknown (new dependent bug coming)
 - which portions of packaging and other non-compile work can be shifted to linux
 - if other mac operations can be moved (updaters, l10n repacks)
Depends on: 935237
No longer blocks: 928193
> Status update for tracked bugs:
> 
> Looking Good:
>  - bug 921040 has a Mac build (with caveats),

2 caveats (webrtc & ICU) appear well in hand (patches ready to land)

Symbol support for crash reporter may be an issue, may not be possible
at first (bug 921040 comment 114). Worst case will need to do on inhouse
hardware.

>    - path to a full build seems likely
>    - engaging QA to sanity check build performance on multiple OSX versions

QA Results still pending. Performance will only be an approximation, as
talos tests currently not working natively on mac (bug 935997).

>  - tooling for packaging is still an unknown (new dependent bug coming)

Bug 935237 has the latest. We can do it, however current image is about
2x the size of native due to compression. Still investigating where
compression is being done, and if we can reproduce on linux.

> Still much too do before decision made:
>  - which portions of packaging and other non-compile work can be shifted to
> linux
>  - if other mac operations can be moved (updaters, l10n repacks)

This work currently blocked by basic packaging work above. Will
re-evaluate after solutions there are found.
(In reply to Hal Wine [:hwine] (use needinfo) from comment #2)
> > Status update for tracked bugs:
> 
> QA Results still pending. Performance will only be an approximation, as
> talos tests currently not working natively on mac (bug 935997).

QA test results are in, two issues need dev investigation:
 1. "Geolocation position is: Position acquisition timed out" occurs
    on all OS versions.
 2. Severe increased memory usage on tests using SWF.
(In reply to Hal Wine [:hwine] (use needinfo) from comment #3)
> QA test results are in, two issues need dev investigation:
>  1. "Geolocation position is: Position acquisition timed out" occurs
>     on all OS versions.

This is bug 935451, so not unique to the cross compile builds. Whew!
status update:
 - compile/link issues resolved -- awaiting landings
 - QA testing via mozmill shows no differences from 25.0.1 on any of 10.6, 10.7, 10.8, or 10.9
 - packaging work ongoing
 - initial integration into build farm whiteboarded, bugs to be filed
Depends on: 945879
Assignee: nobody → hwine
Priority: -- → P3
Depends on: 936115
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → INCOMPLETE
Status: RESOLVED → REOPENED
Resolution: INCOMPLETE → ---
Assignee: hwine → nobody
No longer depends on: 936115
No longer depends on: 946795
(In reply to Hal Wine [:hwine] (use NI) from comment #0)
> bug 921040 will determine if this is both possible and a reasonable thing to
> do. This bug will track all the related issues about getting it successfully
> deployed in production

That bug is all-but-done, so I'm going to try to make sure I have all the deps marked here so we can track "turn off the buildbot Mac builds in favor of the Taskcluster cross-mac builds" in this bug.
We'll need to fix bug 992323 in order to not lose test coverage--the cross-builds don't run `make check`.
Depends on: 992323
No longer depends on: 945879
The cross-mac builds are using a newer clang than the existing mac builds, we should fix that (by updating clang on the existing mac builds) so we're comparing apples to apples.
Depends on: 1209930
Is there anything remaining to do here?  The universal builds work is captured elsewhere (bug 1183613).
If we don't fix bug 992323 we'll lose test coverage of whatever's in `make check` right now because we can't run that in a cross-compile scenario.
Also: I don't know if bug 1184122 still blocks this--we don't currently have any test jobs running off of the TC mac build jobs. We had talked about standing them up by using the buildbot Mac testers, but if that's not the current plan then you can close that bug.
OK, those are both important, and noted.  I'm still not sure what *this* bug represents, or is tracking..
I'm scoping this bug specifically to cover debug builds at tier 1.

Opt builds and nightlies are covered by bug 1267425.
No longer depends on: 1184122
Summary: [tracker] Determine how to support and roll out darwin-on-linux in production → [tracker] Make taskcluster mac debug builds Tier-1
bug 1360964 made this change.
Depends on: 1360964
Status: REOPENED → RESOLVED
Closed: 7 years ago4 years ago
Resolution: --- → FIXED
Component: Platform Support → Buildduty
Product: Release Engineering → Infrastructure & Operations
Product: Infrastructure & Operations → Infrastructure & Operations Graveyard
You need to log in before you can comment on or make changes to this bug.