Closed Bug 937166 Opened 6 years ago Closed 4 years ago

[e10s] Tilt needs to be remotable

Categories

(Firefox Graveyard :: Developer Tools: 3D View, defect, P3)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: rcampbell, Unassigned)

References

(Blocks 1 open bug)

Details

Tilt needs to be remotable for e10s.
Using the LayerScope backend for this might be a splendid idea.
Mass tracking-e10s flag change. Filter bugmail on "2be0fcce-e36a-4e2c-aa80-0e3d33eb5406".
tracking-e10s: --- → +
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
We have decided to disable tilt as victorporof says it will take about 2 months to make it remote-able.
Assignee: mratcliffe → nobody
Status: ASSIGNED → NEW
Depends on: 1086492
(In reply to Michael Ratcliffe [:miker] [:mratcliffe] from comment #4)
> We have decided to disable tilt as victorporof says it will take about 2
> months to make it remote-able.

Well, 2 months to *rewrite* it. Hacking something together should be easier, but I don't believe it's worth it if a revamp is planned anyway.
Duplicate of this bug: 1088291
These DevTools bugs should probably block e10s from riding to Aurora.
harthur says these DevTools bugs are not Aurora blockers for e10s.
Whiteboard: [e10s-m7]
Summary: Tilt needs to be remotable → [e10s] Tilt needs to be remotable
Duplicate of this bug: 1144730
Duplicate of this bug: 1035706
There are users who chose Developer Edition in order to use Firefox as a devtool, and Tilt is one of the things that draws them to Firefox because Chrome Dev Tools don't offer it.

Can we at least bring back 3d view and when checked prompt the user about tuning e10s off for that to work?
While tilt does need to be remotable, we don't intend to fix it right now. Tilt is turned off by default when e10s is enabled, so I don't believe we need to do anything in this bug for e10s.

ni? :jsantell to be sure (in Victor's absence)

If that's right this bug shouldn't be tracking e10s.
Flags: needinfo?(jsantell)
Its my understanding making tilt remotable would require a full rewrite, and the consensus is IIRC, if we are rewriting it, we might as well do it in a better way, supporting more than element nesting, but it's undecided what these other features will be. W/r/t resources for a full rewrite, we have very few users of tilt monthly
Flags: needinfo?(jsantell)
Removing [e10s-m7] flag. We'll treat tilt v2 as a new/rebooted feature, and not fix as part of the e10s effort.
Whiteboard: [e10s-m7]
Priority: -- → P3
The 3D View has been removed in Firefox 47. Closing all bugs inside that component as the component will be moved to Firefox Graveyard.

Filter on #BYETHREEDVIEW.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
Product: Firefox → Firefox Graveyard
(In reply to Tim Nguyen :ntim from comment #16)
> The 3D View has been removed in Firefox 47. Closing all bugs inside that
> component as the component will be moved to Firefox Graveyard.
> 
> Filter on #BYETHREEDVIEW.

Are there still plans to revamp this feature and bring it back, in some form?
tracking-e10s: + → ---
(In reply to Andy Mercer from comment #17)
> (In reply to Tim Nguyen :ntim from comment #16)
> > The 3D View has been removed in Firefox 47. Closing all bugs inside that
> > component as the component will be moved to Firefox Graveyard.
> > 
> > Filter on #BYETHREEDVIEW.
> 
> Are there still plans to revamp this feature and bring it back, in some form?

I believe we hope to revive the idea some day, but there is no concrete schedule for it.  It would likely be a while before it happens.

This could be something worth exploring as an add-on (that works for e10s).
It was a great feature. Please add it back.
Will this feature make its comeback?
You need to log in before you can comment on or make changes to this bug.