Closed Bug 938422 Opened 6 years ago Closed 6 years ago

[B2G][DSDS][User Story] Settings necessary for DSDS feature

Categories

(Firefox OS Graveyard :: RIL, defect)

x86
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: khu, Unassigned)

References

()

Details

(Keywords: feature, Whiteboard: [ucid:DSDS1, 1.3:p1, ft:RIL], [L0])

Attachments

(1 file)

As a user, I need a settings menu for "Dual SIM settings".
Duplicate of this bug: 918533
1) Use should have a predictable way of finding a place where they can set configurations around Dual SIMs. Logically this menu would be under ""Settings"" and called out explicitly as ""Dual SIM Settings"". 

2) All configurable settings for each SIM present should be accessible under this menu.

3) There should be a visual indication of current settings per SIM.
Whiteboard: [ucid:DSDS1, FT:RIL, 1.3:p2] [L0] → [ucid:DSDS1, FT:RIL, 1.3:p1] [L0]
No longer depends on: 928284
It looks like we don't need 928280 to block this user story, right?
Flags: needinfo?(skamat)
(In reply to Kevin Hu [:khu] from comment #3)
> It looks like we don't need 928280 to block this user story, right?

I think it does depend on it. see comment 

https://bugzilla.mozilla.org/show_bug.cgi?id=928280#c3
Flags: needinfo?(skamat)
Attached file [SPEC] DSDS v0.8 .pdf
Blocks: b2g-dsds-1.4
No longer blocks: b2g-dsds-1.4
Blocks: 938440
Whiteboard: [ucid:DSDS1, FT:RIL, 1.3:p1] [L0] → [ucid:DSDS1, FT:RIL, 1.3:p1, dsds_US_test] [L0]
Update whiteboard tag to follow format [ucid:{id}, {release}:p{1,2}, ft:{team-id}]
Whiteboard: [ucid:DSDS1, FT:RIL, 1.3:p1, dsds_US_test] [L0] → [ucid:DSDS1, 1.3:p1, ft:RIL], [dsds_US_test] [L0]
Whiteboard: [ucid:DSDS1, 1.3:p1, ft:RIL], [dsds_US_test] [L0] → [ucid:DSDS1, 1.3:p1, ft:RIL], [L0]
Whiteboard: [ucid:DSDS1, 1.3:p1, ft:RIL], [L0] → [ucid:DSDS1, 1.3:p1, ft:RIL], [dsds_US_test] [L0]
Blocks: 927893
Blocks: 923629
Blocks: 926342
Blocks: 942267
No longer blocks: 930299
Kevin,

What release is this user story being targeted for? This is a DSDS feature and hence the question.
Flags: needinfo?(khu)
1.3. 
Since all depending bugs are all closed, maybe we can close this one, too. Wesley, are seeing something different? Thanks.
Flags: needinfo?(khu) → needinfo?(whuang)
No longer blocks: 938440
See Also: → 938440
No longer blocks: 923629
See Also: → 923629
No longer blocks: 927893
See Also: → 927893
No longer blocks: 926342
See Also: → 926342
QA can test when both bug 928294 and bug 928297 uplifted to 1.3.
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(whuang)
Resolution: --- → FIXED
Whiteboard: [ucid:DSDS1, 1.3:p1, ft:RIL], [dsds_US_test] [L0] → [ucid:DSDS1, 1.3:p1, ft:RIL], [L0]
QA verified on Fugu
Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.