Get rid of nsIPlatformCharset

RESOLVED FIXED in Firefox 59

Status

()

--
enhancement
RESOLVED FIXED
5 years ago
a year ago

People

(Reporter: hsivonen, Assigned: m_kato)

Tracking

({meta})

unspecified
mozilla59
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox59 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
See also bug 653031.

Since it  appears that we could on all platforms except OS/2 assume UTF-8  where we currently query for nsIPlatformCharset and users of nsIPlatformCharset typically rely on nsCharsetAlias, which is being superceded by EncodingUtils, let's remove nsIPlatformCharset and let the OS/2 port deal with non-UTF-8 system encodings on the port level without surfacing the issue to cross-platform Gecko code.
(Reporter)

Updated

5 years ago
See Also: → bug 653031
(Reporter)

Updated

5 years ago
Depends on: 848842
(Reporter)

Updated

5 years ago
Depends on: 943273
(Reporter)

Updated

5 years ago
Depends on: 943276
(Reporter)

Updated

5 years ago
Depends on: 943283
(Reporter)

Updated

5 years ago
Depends on: 943284
(Reporter)

Updated

5 years ago
Depends on: 943287
(Reporter)

Updated

5 years ago
Depends on: 943288
(Reporter)

Updated

5 years ago
Depends on: 943291
(Reporter)

Updated

5 years ago
Depends on: 943294
(Reporter)

Updated

5 years ago
Depends on: 943296
Severity: normal → enhancement
Keywords: meta
(Reporter)

Updated

5 years ago
Depends on: 393246
(Reporter)

Updated

5 years ago
No longer blocks: 943268
(Assignee)

Updated

2 years ago
Depends on: 1351543
(Assignee)

Updated

2 years ago
Depends on: 1381762
(Assignee)

Updated

a year ago
Assignee: nobody → m_kato
(Assignee)

Updated

a year ago
Depends on: 1417328
(Assignee)

Updated

a year ago
Duplicate of this bug: 653031
(Assignee)

Comment 2

a year ago
all code is removed, so let's remove this interface.
Comment hidden (mozreview-request)
(Assignee)

Updated

a year ago
Attachment #8932016 - Flags: review?(jfkthame) → review?(VYV03354)

Comment 4

a year ago
mozreview-review
Comment on attachment 8932016 [details]
Bug 943272 - Get rid of nsIPlatformCharset.

https://reviewboard.mozilla.org/r/203084/#review210006

\o/
Attachment #8932016 - Flags: review?(VYV03354) → review+
Sorry for my lack of response to the initial r? here, Kato-san.... I thought I had reviewed this, but there's clearly no trace of it! I guess I must have killed the window/browser without having hit the right button, or something. :(

Comment 7

a year ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/436dbeb1d9b4
Status: NEW → RESOLVED
Last Resolved: a year ago
status-firefox59: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla59
You need to log in before you can comment on or make changes to this bug.