slow performance w/ multiple animated gifs

RESOLVED FIXED in Future

Status

()

Core
ImageLib
--
major
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: bslesins, Unassigned)

Tracking

({topperf})

Trunk
Future
topperf
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801
BuildID:    2001080104



Reproducible: Always
Steps to Reproduce:
Visit the above URL.


Actual Results:  This page displays an animated comic strip.  In mozilla it
stops rendering after drawing half the page, the CPU load goes to 100%, and very
little progress is made after that (it stops responding to input.).  In Netscape
4.x the page draws and some of the animation starts, but it's also stops responding.

Expected Results:  Maybe run the animation at a lower priority?  The back button
should at least work.

Previous pages on the site do work - this one seems to have more animation than
usual.

I'm on a 300Mhz laptop, 64MB memory.  It doesn't seem to be swapping.

Comment 1

17 years ago
WFM, win98SE, 2001080703.  I've gor a bit more horsepower than the reporter
though: duron 800, 384mb RAM + Cable Modem

Reporter, how are you accessing the internet?  Modem or broadband?  
(could it be related to slow load breaking off half way?)

Comment 2

17 years ago
Wfm, Linux, 2001080910
however , I have a Duron 850, 250M and cable modem
still cpu is loaded pretty much but the machine is completely responsive
top shows cpu is 20% idle, mozilla takes about 60% and X 20%
I guess an animated gif can takes all ressources, which it should not
(Reporter)

Comment 3

17 years ago
I'm using DSL.  I'd guess it's the limited CPU since 80% of a 850mhz Duron is
probably more than a 300mhz Celeron can handle.

Updated

17 years ago
Assignee: asa → pavlov
Component: Browser-General → ImageLib
QA Contact: doronr → tpreston

Comment 4

17 years ago
-> imglib

Comment 5

16 years ago
Confirming, but this may be a dupe.
Pages w/ multiple animated gifs eat up 100% of available CPU time.  (I'm on a
700MHz athlon)
Another URL which has this problem is:  http://www.myearthlive.com/
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Summary: slow performance/stops responding on animated comic (zark.com) → slow performance w/ multiple animated gifs

Updated

16 years ago
Blocks: 71668

Comment 6

16 years ago
Here is another URL to test this on:
http://www.geekculture.com/geekycomics/Aftery2k/y2Karchives/403.html
With above page and mozilla 0.9.7/W2K both on 866 MHz Intel and 1.33GHz Athlon
the OS is still somewhat responsive but e.g. moving of mouse cursor
slows down to around 2-4 fps and mozilla takes about 99% of CPU resources.

Updated

16 years ago
Blocks: 119597

Updated

16 years ago
Target Milestone: --- → Future

Comment 7

16 years ago
from the testcase in the URL this image alone causes Moz to use 100% CPU:
http://zark.com/pages2/az56/az56warp_animation3.gif
this too:
http://zark.com/pages2/az56/az56rings_animation1.gif
this too:
http://zark.com/pages2/az56/az56lines_animation1.gif

this is a dup of bug 86319

*** This bug has been marked as a duplicate of 86319 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 8

16 years ago
reopening

there might be some other issue besides the large animated images.

note that:
http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif
is probably related to bug 86319
Status: RESOLVED → REOPENED
Depends on: 86319
Resolution: DUPLICATE → ---

Updated

16 years ago
No longer depends on: 86319

Updated

16 years ago
Depends on: 86319

Comment 9

16 years ago
I was expecting that the fix for bug 125025 should also affect this one (when
the page is minimized) but this is not the case. Cpu usage remains high (70%)
even when the window that contains http://zark.com/pages2/az56.html is
minimized. Tested on K6-III/400, 192MB ram, Win98, 2002022308.

Updated

16 years ago
Keywords: mozilla1.0+

Comment 10

16 years ago
*** Bug 136075 has been marked as a duplicate of this bug. ***

Comment 11

16 years ago
After looking at the URL (http://zark.com/pages2/az56.html), I see:

1) Several animated .gifs (including the 3 mentioned in Comment #7) that have a
frame rate of zero (which currently means they will run as fast as they can). 
Bug 125137 would partially fix this problem with a minumum frame rate delay.

2) Images that are set to visibility: hidden are still being animated.  In IE,
the big images are only animated when the mouse is hovering over them (producing
a 80% CPU usage on my system).  Is there a bug for this, or has it been
determined somewhere that animations should be played even when invisible?

3) Removing "Position: Absolute"'s made things run faster (not that you'd notice
since those images in 1) are still using 100% CPU)

Comment 12

16 years ago
*** Bug 138327 has been marked as a duplicate of this bug. ***

Comment 13

16 years ago
*** Bug 139149 has been marked as a duplicate of this bug. ***

Comment 14

16 years ago
*** Bug 140502 has been marked as a duplicate of this bug. ***

Comment 15

16 years ago
*** Bug 140289 has been marked as a duplicate of this bug. ***

Comment 16

16 years ago
Are people having problems with this who do not have NVidia graphics cards?  It
looks like 86319 is graphics card-specific, so this might be too...

Comment 17

16 years ago
Yes, seen with http://zark.com/pages2/az56.html and
http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif:

Matrox G400-TV (latest drivers)
Windows 98
Athlon 700MHz
384MB RAM
56K Dial-up

Comment 18

16 years ago
Sorry for the spam, forgot to say seen with builds 2002051808, M1RC1 and M1RC2.

Comment 19

16 years ago
Francis, could you 'spam' us one more time with the CPU usage for both of those
URLs?

http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif is more to do
with Bug 86319 since it's large and only one gif.  
On my RC2, Win2k PIII-933, nVidia VANTA, 1280x1024 @ 16bit, I'm getting 40% CPU
usage.  http://zark.com/pages2/az56.html is at 100%.

Comment 20

16 years ago
The following figures are from build 2002051808 and RC2.
Desktop set to 1280x960 @ 32 bit.
CPU usage estimated from MS System Monitor (how reliable are these measurements?).
Idle CPU usage: 35%

http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif
Moz: 100%
IE6: 40% (when displayed at original size; when resized to browser frame: 65%)

http://zark.com/pages2/az56.html
Moz: 100%
IE6: 40% (55% with mouseover effect)

When I mouseover the cartoon, I get a large animated effect in IE6, but not in
Mozilla.

Updated

16 years ago
Keywords: perf
Hardware: PC → All

Comment 21

16 years ago
The following figures are from Mozilla 1.0RC3 (tested 2002-05-27)
Desktop set to 1280x1024@32 bit. 
OS: Windows XP Pro.
CPU: Athlon XP 1900+.
CPU usage estimated from MS System Monitor (how reliable are these measurements?).
Idle CPU usage: 0%

http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif
Moz: 100% (and animation is very slow).
IE6: 0% (when displayed at original size; when resized to browser frame: 35%)

http://zark.com/pages2/az56.html
Moz: 100%
IE6: 0% (16% with mouseover effect)

When I mouseover the cartoon, I get a large animated effect in IE6, but not in
Mozilla.

The whole system responds very sluggish whenever an animated gif appears in a
web page.

Comment 22

16 years ago
Additional comment to #21.
Strange thing happened: 
I tried the same tests later today (I'm not even sure if I have restarted the
computer, but I might have), and now everything works great on the first
animated gif.

http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif
Moz: 29% (and animation is just as it should be).

http://zark.com/pages2/az56.html
Moz: 100%

The following figures are from Mozilla 1.0RC3 (tested 2002-05-27)
Desktop set to 1280x1024@32 bit. 
OS: Windows XP Pro.
CPU: Athlon XP 1900+.
Idle CPU usage: 0%

Updated

16 years ago
Depends on: 147938

Comment 23

16 years ago
Created attachment 85488 [details]
http://zark.com/pages2/az56.html working in Mozilla

I changed the functions CSSetStyleVis and CSGetStyleVis so that they would use
getElementById first if it exists.  This makes the onmouseover animation
display and disappear properly.  Before the code was using agent string
checking.. and thus failed.

This does not effect CPU usage.. well, not yet.. ;)
(still at 100% with hover on or off)

Comment 24

16 years ago
Adding dependency of Bug 143830

By applying the patches in Bug 147938 and Bug 143830, I can get Attachment 85488 [details]
down to 35% CPU when mouseover effects are off.  Still 100% when mouseover
effects are on.

Applying just one and not the other results in 100% cpu.  Most likely each patch
reduces CPU usage, but not enough for my system until both are applied. 
Everyone else's results will probably vary.
Depends on: 143830

Comment 25

16 years ago
On some sites with animated GIFs, this bug eats so much
performance that it disconnects me from my ISP on Windows 2000.

As far as I remember Netscape and Mozilla both had problems
with animated GIFs since the beginning.

Please mark it as CRITICAL!

Updated

16 years ago
Keywords: mozilla1.0.1

Updated

16 years ago
Severity: normal → major
Keywords: mozilla1.0.1 → mozilla1.1
*** Bug 152569 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
I have found a regular page which causes a disconnect on my Windows 2000 PC.

http://detik.com/
Tested: June 26th, 2002, 22:10 CET

This is an Indonesian news site (it changes very often), so the
behavior might be different in few minutes.
After typing this URL, I can watch the CPU load jump on 100%
and wait 30 seconds until I get disconnected from my ISP.

Comment 28

16 years ago
The CPU usage also depends on the color depth used (32bit vs. 16bit).

Comment 29

16 years ago
Bug 143830 and Bug 147938 are now checked in.
Build 2002071008 on PIII-933 w/Win2k @ 16 bit color:

For Attachement 85488
32% with mouse not over image
99% with mouse over image

Previous to this, both were 99% on my system.  Is anyone else seeing this gain
(on the attachemnt) with the latest nightly?

Attachement using IE:
<1% with mouse not over image
40% with mouse over image.

Still a long way to go.

Comment 30

16 years ago
Bug 143830 speed up the animation alot.  There are probably timer issues
associated with the mouse over the animation.  Not sure whats thats about.. but
with the test cases I saw exactly what your reporting.
*** Bug 157059 has been marked as a duplicate of this bug. ***

Comment 32

16 years ago
regarding comment #29: Might this be somehow related to bug 117436 comment 
#39 ?

Comment 33

16 years ago
re: Comment 32
I'm not sure how the parser effects the page after it's been completely
modified, so I can't comment on that.  I do however know of 3 areas that need
improving (among others that I don't know of) for the testcase:

1) Comment 11, point 2 (don't animate invisible images)
2) Comment 11, point 3 (absolute positioning slows animation down)
3) GIF code optimizations (Bug 148637)

I haven't found a way to do (1) yet, and (2) is beyond my knowledge so far.  (3)
is sitting on my HD, waiting for the blocker to clear.

Updated

16 years ago
Keywords: perf → topperf

Comment 34

16 years ago
This may have been helped by bug 148598.

Comment 35

15 years ago
*** Bug 165850 has been marked as a duplicate of this bug. ***

Comment 36

15 years ago
One more site with other then animated GIF performance problem.

http://www.togethersoft.com

Move the mouse pointer in the left hand vertical bar and watch heavy
CPU activity together with noticeable mouse pointer movement delay especially
when the mouse pointer is over items with dark blue background.

Comment 37

15 years ago
Created attachment 97586 [details]
Areas where performance deteriorates

This picture for Additional Comment #36.
The red marked areas show where mouse pointer movements cause
performance degradation.

Comment 38

15 years ago
Created attachment 97730 [details]
Areas where performance deteriorates (2)

One more site: 
http://www3.corel.com/cgi-bin/gx.cgi/AppLogic+FTContentServer?pagename=Corel/Landing

with the same problem as indicated in Additional Comment #37

Comment 39

15 years ago
Several more sites with the same problem as indicated in Additional Comment #37

Menu on the page:
http://www.powerquest.com

Menu on the page:
http://www.borland.com

Menu on the page:
http://www.bea.com/index.shtml

Comment 40

15 years ago
Performance degradation for sites mentioned in additional
Comment #36 through #39 happens if another Mozilla windows
with several tabs is opened and after several navigations
in these tabs.

Comment 41

15 years ago
*** Bug 173009 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: mozilla1.1 → mozilla1.2

Comment 42

15 years ago
*** Bug 173582 has been marked as a duplicate of this bug. ***

Comment 43

15 years ago
From Bug 173582
http://www.twilightguild.org/images/signatures/FairyDance.htm

Fast on IE, slow on Mozilla.

I did some digging around using this testcase and found 30% of the CPU usage was
being in between nsImageFrame::FrameChanged and nsImageFrame::Paint  (ie,
exiting out of FrameChanged immediately caused 0% CPU, Exiting out of Paint
immediately caused 30%).  FrameChanged calls Invalidate.  Invalidate eventually
ends up in a paint, but not until a lot of used CPU cycles.

Comment 44

15 years ago
Just registering my interest in this bug.. sorry for the pointless comment, but
I can't find a "add yourself to this bug mailing list" button in bugzilla.. and
adding myself to the CC field seems a bit dumb, since bugzilla already knows my
email address.

Comment 45

15 years ago
*** Bug 181620 has been marked as a duplicate of this bug. ***

Comment 46

15 years ago
http://www.thegamblingway.com/banners/sands_600x500.gif
Here too. Renders ok on IE. Slows cpu over 50% on Mozilla.

dup. report I guess:
http://bugzilla.mozilla.org/show_bug.cgi?id=86319

Updated

15 years ago
Keywords: mozilla1.2

Comment 47

15 years ago
This problem occures also with single small animated GIF - when it used as the
background image.
For example, http://members.cox.net/lxix/ithurts/5.html (sorry ;)).
The GIF is only 64x64 pixels, and still kills the CPU [and your eyes].

Comment 48

15 years ago
Zvi: What build are you using?  I don't have a problem on that page.  0% CPU
utilization.

Comment 49

15 years ago
I thought I'd mention that I have an ATI graphics card now, but the pages that
gave problems before still do.

Comment 50

15 years ago
I'm using the latest Mozilla (1.3b, Build ID 2003021008).
System: PIII/600MHz with 256Mb. OS: Win2K SP3.

Updated

15 years ago
Depends on: 194627

Comment 51

15 years ago
Also having 100% cpu usage with trunk build 2003022304 on winxp pro
sp1,1.1ghz,512ram - with a GeForce2 Go at 32bit color depth.
What also is somewhat shameful is that the Viewer-Demo #10 -
resource:///res/samples/test10.html - is also having 100% cpu usage.

Comment 52

15 years ago
After a PC and OS upgrade (now with Duron 1.2GHz, 768MB RAM, W2K SP3, Matrox
G400 5.39.019 driver package) the high CPU usage remains in some instances.

Here are some CPU load figures for 
FB: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b) Gecko/20030611
Mozilla Firebird/0.6
RC3: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4) Gecko/20030624


http://www.csszengarden.com/?cssfile=/012/012.css&page=1 (while scrolled down to
"Select a Design", 17 ani-GIFs visible)
FB: 25 to 40% (smooth scrolling is noticeably sluggish on this page and stops OS
from multitasking normal priority processes)
RC3: 12 to 30% (no smooth scrolling)
IE5.5: 15%

http://members.cox.net/lxix/ithurts/5.html
FB: 16%
RC3: 14%
IE5.5: 16%

http://www.thegamblingway.com/banners/sands_600x500.gif
FB: 0%
RC3: 0%
IE5.5: 0%

http://www.twilightguild.org/images/signatures/FairyDance.htm
FB: 99%
RC3: 99%
IE5.5: 48%

http://zark.com/pages2/az56.html (not mousing over)
FB: 30%
RC3: 29%
IE5.5: 0%

resource:///res/samples/test10.html
FB: 35 to 55%
RC3: 30 to 50%
IE5.5: 20% (but not proper transparency)

Comment 53

14 years ago
*** Bug 232336 has been marked as a duplicate of this bug. ***

Comment 54

14 years ago
Hi there,

I have:
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040210 Firefox/0.8

Using Linux 2.6.3, XOrg 6.7.0, Gnome 2.6.0 I get the following in "top" when
viewing:
resource:///res/samples/test10.html


4039 root      23   0  168m  36m 140m R 90.6  2.4  38:17.38 X
7619 hachre    15   0 61192  41m  31m S  6.6  2.7   0:34.62 firefox-bin

The value with 90.6 is CPU%. Its 6.6 for firefox...
When I have the page opened on firefox but I am viewing another tab and switched
to another desktop in Gnome it takes up the same CPU...

When I close this page top looks like this:
4039 root      15   0  168m  36m 140m S  5.3  2.4  38:22.42 X
7619 hachre    15   0 58388  40m  31m S  1.7  2.7   0:35.95 firefox-bin

This happens on pages with far fewer animated gifs too...

Feel free to ask if you need more information.
bye
Harald

Comment 55

14 years ago
I forgot to post my hardware, sorry:

AMD Athlon XP 2400+
With 1.5 GB RAM

So it is not a speed issue... I am also experiencing a slowdown on a testing
machine with Firefox for Windows... so it's not my Linux setup eigther...

Comment 56

13 years ago
I ran a code profile on this problem and found thatwin32k.sys code is used about
64% of the CPU time on my machine. Almost all of this is in EngPaint. Firefox
code used 1.24% of the CPU time. A little testing with SPY++ showed a lot of
WM_PAINT and WM_<erasebackground> messages. Internet Explorer just had lots of
WM_PAINT messages. That may be something to look into.

At any rate, the animated GIF that I was using to test used CPU in the 0 to 3
percent range while Firefox used about 30 to 40 percent. This is on an AMD
Athlon64 3200+ system which I consider to be a pretty fast machine for running
Firefox.

Comment 57

12 years ago
The trunks from months ago as well as the latest trunks seem to fix most of the
problems, but some animated gifs still bog it down, such as the following:
http://img154.imageshack.us/img154/8002/chibiassassinsig7vh.gif
http://lolzing.com/albums/GIFs/crowdapplause.gif

Comment 58

12 years ago
The animated images (In reply to comment #57)
> The trunks from months ago as well as the latest trunks seem to fix most of the
> problems, but some animated gifs still bog it down, such as the following:
> http://img154.imageshack.us/img154/8002/chibiassassinsig7vh.gif
> http://lolzing.com/albums/GIFs/crowdapplause.gif

The animated images w/ transparent background caused problems for NVidia cards.
See comment #9 in a bug 293222. NVidia may have fixed their drivers.

Comment 59

12 years ago
Indeed, the latest 81.84 Forceware drivers have fixed the 100% CPU usage on some
animated GIFs. However, I was just viewing the example case
http://www.geekculture.com/geekycomics/Aftery2k/y2Kimages/403.gif given in a
post above, and CPU usage is around 50%. Opera and IE views it at a much lower
CPU usage, and it would seem the in Firefox, the rats are coming out REALLY
fast(as in breakneck speed), while in Opera/IE they are coming out slower(you
can make them out individually). Is this a separate bug?

Comment 60

12 years ago
Created attachment 217827 [details]
memory and cpu usage with firefox in safe mode

I got this problem with the last firefox version ( 1.5.0.1 or 1.8.0.1 it
depends... I still don't understand the way of numbering versions :( ). The ram
consumption grows to more than 700 Mo (out of 1,5Go) and the cpu usage keeps
around 80 100 % while loading http://facs.scripps.edu/surf/images/euranim.gif

even if I open it in a single tab, right after starting firefox and in safe
mode (no extension loaded) what is strange is that when doing exactly the same
with mozilla there's absolutely no problem : the max memory usage is only 35Mo
and cpu usage about 5 or 10 % (with many extensions loaded)
So if there's a problem with Firefox picture rendering, why not use the mozilla
version ?

Comment 61

12 years ago
I just tried this with the Official 1.5.0.1 Windows on an Athlon 3200+ and
the CPU usage was 0 to 2 percent. Memory usage was 12 MB.

I tried this with an unofficial build and found similar results.

So I'd guess that there's something in your configuration or environment
that's quite a bit different from mine.

(In reply to comment #60)
> Created an attachment (id=217827) [edit]
> memory and cpu usage with firefox in safe mode
> 
> I got this problem with the last firefox version ( 1.5.0.1 or 1.8.0.1 it
> depends... I still don't understand the way of numbering versions :( ). The ram
> consumption grows to more than 700 Mo (out of 1,5Go) and the cpu usage keeps
> around 80 100 % while loading http://facs.scripps.edu/surf/images/euranim.gif
> 
> even if I open it in a single tab, right after starting firefox and in safe
> mode (no extension loaded) what is strange is that when doing exactly the same
> with mozilla there's absolutely no problem : the max memory usage is only 35Mo
> and cpu usage about 5 or 10 % (with many extensions loaded)
> So if there's a problem with Firefox picture rendering, why not use the mozilla
> version ?
> 

Comment 62

12 years ago
(In reply to comment #61)
> I just tried this with the Official 1.5.0.1 Windows on an Athlon 3200+ and
> the CPU usage was 0 to 2 percent. Memory usage was 12 MB.
> 
> I tried this with an unofficial build and found similar results.
> 
> So I'd guess that there's something in your configuration or environment
> that's quite a bit different from mine.

Yes, there is a difference with better hardware, and a big difference with much memory. Look in Debian's bugtrack (bug #286508), what I had reported :


>  Firefox in a while consumes (or at least tries to consume) more than
>  100MB memory. If your machine has - let say - 256MB, it starts crawling,
>  it becames unresponsive, raises about 99% of CPU load, and you have to 
>  kill it. I tried on a AMD64 with 2GB memory and on a P4/2.4 with 1.5 GB 
> memory and it worked almost well. On any other machine with less memory 
> it happens all the times. Even on my old PIII/600 with 768MB (running

Things got (a bit) better after March 2005 , but the problem is not totaly solved. As far as I can track it the problem originates the 90's and the old Netscape code.

Comment 63

12 years ago
Its pretty clear that Firefox can use a lot of memory but this page alone
doesn't use that much. In general, 256 MB for Windows XP is underpowered.
It sounds like you are seeing a lot of paging on your system as Windows
tries to make room for the additional 12 MB or so of memory.

Perhaps you have some disk or pagefile issues as well.

What you might want to look into is configuring Firefox with a small
memory model. There's a page on CNet that talks about doing this under
the general category of modding the browser. It can mean turning off
some options or reducing some performance settings so that they use
less memory.


(In reply to comment #62)
> (In reply to comment #61)
> > I just tried this with the Official 1.5.0.1 Windows on an Athlon 3200+ and
> > the CPU usage was 0 to 2 percent. Memory usage was 12 MB.
> > 
> > I tried this with an unofficial build and found similar results.
> > 
> > So I'd guess that there's something in your configuration or environment
> > that's quite a bit different from mine.
> 
> Yes, there is a difference with better hardware, and a big difference with much
> memory. Look in Debian's bugtrack (bug #286508), what I had reported :
> 
> 
> >  Firefox in a while consumes (or at least tries to consume) more than
> >  100MB memory. If your machine has - let say - 256MB, it starts crawling,
> >  it becames unresponsive, raises about 99% of CPU load, and you have to 
> >  kill it. I tried on a AMD64 with 2GB memory and on a P4/2.4 with 1.5 GB 
> > memory and it worked almost well. On any other machine with less memory 
> > it happens all the times. Even on my old PIII/600 with 768MB (running
> 
> Things got (a bit) better after March 2005 , but the problem is not totaly
> solved. As far as I can track it the problem originates the 90's and the old
> Netscape code.
> 

Comment 64

12 years ago
I've got exactly the same symptoms with official 1.5.0.2 release, in the same case with two pc :
- Pentium 2400 with 1Go of ram and a nvidia GeForce FX5200 under Win98 SE
- Celeron 2000 with 1,5Go of ram and a SIS 650 chipset under win Xp Pro SP1

As you can see there's nothing in common between my two config, but I get exactly the same result, while Mozilla suite doesn't have any problem...
It's why I think the bug shouldn't appear for Core product which is common for the two browser, it's very specific to Firefox

(In reply to comment #61)
> I just tried this with the Official 1.5.0.1 Windows on an Athlon 3200+ and
> the CPU usage was 0 to 2 percent. Memory usage was 12 MB.
> 
> I tried this with an unofficial build and found similar results.
> 
> So I'd guess that there's something in your configuration or environment
> that's quite a bit different from mine.
> 
> (In reply to comment #60)
> > Created an attachment (id=217827) [edit]
> > memory and cpu usage with firefox in safe mode
> > 
> > I got this problem with the last firefox version ( 1.5.0.1 or 1.8.0.1 it
> > depends... I still don't understand the way of numbering versions :( ). The ram
> > consumption grows to more than 700 Mo (out of 1,5Go) and the cpu usage keeps
> > around 80 100 % while loading http://facs.scripps.edu/surf/images/euranim.gif
> > 
> > even if I open it in a single tab, right after starting firefox and in safe
> > mode (no extension loaded) what is strange is that when doing exactly the same
> > with mozilla there's absolutely no problem : the max memory usage is only 35Mo
> > and cpu usage about 5 or 10 % (with many extensions loaded)
> > So if there's a problem with Firefox picture rendering, why not use the mozilla
> > version ?
> > 
> 

Comment 65

12 years ago
I suspect that this problem will be rather hard to debug without a reproduceable
test case by someone with the tools and skills to debug it. I assume that you
emptied your cache, are running with no extensions and using the default theme,
have the latest graphics drivers and don't have a huge number of fonts loaded.

(In reply to comment #64)
> I've got exactly the same symptoms with official 1.5.0.2 release, in the same
> case with two pc :
> - Pentium 2400 with 1Go of ram and a nvidia GeForce FX5200 under Win98 SE
> - Celeron 2000 with 1,5Go of ram and a SIS 650 chipset under win Xp Pro SP1
> 
> As you can see there's nothing in common between my two config, but I get
> exactly the same result, while Mozilla suite doesn't have any problem...
> It's why I think the bug shouldn't appear for Core product which is common for
> the two browser, it's very specific to Firefox

Comment 66

12 years ago
Try this:
http://browse.deviantart.com/icons/avatars/?order=9&startts=1149494422&endts=1149667222

On my P4 2.8Ghz box it goes to 100% in a matter of seconds.

It doesn't matter if I minimize or switch the workspace, the CPU is kept at 100%. Only when I switch the tab I get back to 0%.

The weird thing is that I get about 50% when I first open the page, but once another window is placed on top the gif images, that's when the CPU usage starts to increase.

It seems it's not firefox the one that's eating the CPU, it's Xorg. But Opera doesn't have any problems rendering the exact same page.

I have tried with several versions of Firefox, I am sure at least 1.5.0.3, 1.5.0.4 and 2.0a3 have this problem.

My graphics card is an ATI Radeon Mobility 7500 and I'm using Fedora Core 5 updated. But I've had the same problem in other boxes.

I can test tomorrow on other machines if needed, but I wonder why is this not a blocking bug? The performance rendering that page is awful.
Did you try latest trunk with clean profile?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

With Firefox 1.5.0.4 and 3.0a1 (latest build) all works correct for me.

Comment 68

12 years ago
With Firefox 1.5.0.4 under Windows XP SP2 on a 2.79 GHz Pentium 520J with 512 Mibytes of RAM, the pages load so fast that I have a hard time to try to test the recent advice of trying to overlay something on top of Firefox before it finishes loading (with the originally listed URL, I can't even do this -- can barely do it with the recently listed URL).

I suspect that the problem will only show up on a low RAM and/or slow CPU system.  If I get a chance I will try this on a 266 MHz Pentium II with 64 Mibytes of RAM running Windows NT 4.0 SP6a, but that is going to have to wait a while.  If this theory is correct, that machine will totally bog down.
*** Bug 341138 has been marked as a duplicate of this bug. ***

Comment 70

12 years ago
With 3.0a1 I had even worst problems, everything from the beggining to the end was so slow that it wasn't usable.

However, 1.5.0.3 on Windows XP SP2 takes some CPU but less than 30%, it's much butter than on Linux. Same machine.

I guess the video driver on Linux (radeon) makes it a lot worst. I tried the latest from CVS too, same problem.

I tried exactly the same page on another Linux box and had no problems, however the video driver was intel, and it was a dual 3.8 Ghz. The CPU load was barely noticeable. It was the same Linux system (FC5 updated).

Updated

11 years ago
Assignee: pavlov → nobody
Status: REOPENED → NEW
QA Contact: tpreston → imagelib

Comment 71

10 years ago
With bug 143046 fixed, we can re-ask the question:

Did you try latest trunk with clean profile?
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/

With Firefox 3.0b2pre (latest build) all works correct for me.

To trigger people retesting this issue, I will close this bug as 'fixed by bug 143046'
Status: NEW → RESOLVED
Last Resolved: 16 years ago10 years ago
Resolution: --- → FIXED

Comment 72

10 years ago
This is fixed _only_ partially.

Multiple gifs as in here are fixed:
http://browse.deviantart.com/customization/icons/avatars/

But not this:
http://members.cox.net/lxix/ithurts/5.html

I'm using "Minefield" on pristine Fedora 8. I removed my .mozilla dir.
You need to log in before you can comment on or make changes to this bug.