Closed Bug 962610 Opened 6 years ago Closed 6 years ago

[User Story] Browser Chrome: Top Sites

Categories

(Firefox OS Graveyard :: Gaia::Search, defect)

defect
Not set

Tracking

(feature-b2g:2.1, tracking-b2g:backlog, b2g-master verified)

VERIFIED FIXED
2.1 S3 (29aug)
feature-b2g 2.1
tracking-b2g backlog
Tracking Status
b2g-master --- verified

People

(Reporter: benfrancis, Assigned: daleharvey)

References

Details

(Keywords: feature, Whiteboard: [ucid:System243], [ft:systemsfe])

User Story

As a user, when I launch the Browser via the icon, I want to be able to see the top sites that I visit regularly so that it is easy to load content I use all the time.

Acceptance Criteria:
1. Clicking on the Browser icon from the homescreen launches the Browser with the top sites displayed.
2. The top sites can be preconfigured in the same way as the old Browser in 2.0.
3. The display of the top sites follows the UX spec.
As a user I want to see a list of the top sites I have visited most "frecently"
Flags: needinfo?
In the browser app you can see a list of your top sites.

Peter, I noticed that we didn't have a bug for this for the system browser. Is it a requirement for the system browser or not? If so, is it part of the MVP?
User Story: (updated)
Flags: needinfo? → needinfo?(pdolanjski)
Keywords: productwanted
Thanks for filing Ben.  I am expecting the UX spec to highlight if we want to keep this functionality in the new Browser.  NI on Francis.
Flags: needinfo?(pdolanjski) → needinfo?(fdjabri)
Top sites are included in the browser start page. Latest UX spec (v0.11) on Box at: https://mozilla.box.com/s/ope5ebfg2gdxhimyhfqw
Flags: needinfo?(fdjabri)
Given the latest UX spec, we should display thumbnail screenshots of top sites on an about:newtab page when the system browser is launched.

Broadly we need to:
* Store screenshots of top sites in the places database
* Implement a better frequency or frecency mechanism to actually calculate Top Sites
* Provide a way to query top sites in the places database
* Create an about:newtab page (fake it in Gaia rather than implementing in Gecko, so we have access to the places database)
* Make the browser2 icon load the about:newtab page
Keywords: productwanted
Whiteboard: [systemsfe] [p=8]
Blocks: 992884
Duplicate of this bug: 1042049
blocking-b2g: --- → backlog
feature-b2g: --- → 2.1
User Story: (updated)
Whiteboard: [systemsfe] [p=8] → [ucid:System243], [ft:systemsfe]
Component: Gaia::System::Browser Chrome → Gaia::Search
Depends on: 1053265
Target Milestone: --- → 2.1 S3 (29aug)
Depends on: 1054447
Depends on: 1052492
No longer depends on: 1054447
No longer depends on: 1052492
Depends on: 1055723
Just assign an owner on user story bug. Candice, feel free to dispatch the bug to engineering managers or leads if it's much better for then to own the user story bugs. Thank you.
Assignee: nobody → cserran
Assignee: cserran → dale
This should be fixed in another bug without any changes to the search app. Kevin will dupe.
No longer depends on: 1055723
Ready for acceptance testing
Status: NEW → RESOLVED
Closed: 6 years ago
Keywords: verifyme
Resolution: --- → FIXED
blocking-b2g: backlog → ---
This issue is Verified Fixed for Aries 2.5

Result: Screenshots of top sites appear in browser successfully. Top sites appear to be queried in places database. New tab functionality is working correctly when user selects the New Window button underneath Top Site Images.

Environmental Variables:
Device: Aries 2.5 Kk Fullflash (319mb)
Build ID: 20150930115400
Gaia: 14a64f1ebd353bccc3f1c0399e1a01a03327749e
Gecko: 97e537f85183ef31481602ab9e5587a6e7d16b4d
Gonk: 2916e2368074b5383c80bf5a0fba3fc83ba310bd
Version: 44.0a1 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.