Open Bug 985024 Opened 8 years ago Updated 24 days ago

Show all bookmarks should not scroll with the bookmarks menu contents

Categories

(Firefox :: Bookmarks & History, defect, P3)

defect
Points:
5

Tracking

()

People

(Reporter: mak, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: regression, Whiteboard: [Australis:P4+])

The issue here is that users think we removed:
- the Library
- the backups
- the possibility to export html
- undo / redo
cause now Show all bookmarks is at the bottom of the Bookmarks panel, and on commonly long menus, it's out of the view. These users are unlikely to know about an exotic arrowscrollbox.

We need to change the places popup implementation to have static content out of the scrollable part, and likely stop using arrowscrollbox in favor of a normal box with a scrollbar.
Blocks: 966905
Same issue as bug 980038. I suspect this remains WONTFIX for the current implementation, but if we think it's realistic to reimplement things (post-Australis!) to make this fixable, maybe we should reopen that as a followup fix?
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 980038
No longer blocks: fxdesktoptriage
I don't think this is wontfix, as well as bug 980038 was not wontfix. We need to reimplement things to make this work as expected, Australis or not, doesn't matter.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Status: REOPENED → NEW
Flags: firefox-backlog?
No longer blocks: fxdesktoptriage
Flags: firefox-backlog? → firefox-backlog+
Duplicate of this bug: 986866
See bug 986866 comment 4 for some thoughts by Gijs.
Keywords: regression
Whiteboard: [Australis:P3-]
Whiteboard: [Australis:P3-] → [Australis:P3-] p=5
We should fix this properly, but we won't manage for 29. We'll probably end up adding an item at the top of the menu for now. We'll deal with that in bug 986866. I'm lowering the priority here to indicate we're not going to be fixing it for 29.
Whiteboard: [Australis:P3-] p=5 → [Australis:P4+] p=5
See Also: → 986866
Marco, can we fix this in a way that doesn't involve switching away from using a menu as the base?
Flags: needinfo?(mak77)
it's a tricky question, off-hand I'd say yes (for example we could move stuff outside the arrowscrollbox), but until we try that's just a guess.
Flags: needinfo?(mak77)
Points: --- → 5
Whiteboard: [Australis:P4+] p=5 → [Australis:P4+]
Duplicate of this bug: 1047891
Duplicate of this bug: 1135083
Priority: -- → P3
Duplicate of this bug: 1390344
Blocks: 1709532
Duplicate of this bug: 1713856
Duplicate of this bug: 1716194
Duplicate of this bug: 1723105
Duplicate of this bug: 1740199
You need to log in before you can comment on or make changes to this bug.