Auto-watch threads you've posted to (Preference)

NEW
Unassigned

Status

MailNews Core
Backend
--
enhancement
18 years ago
3 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Unassigned)

Tracking

(Blocks: 2 bugs, {helpwanted})

Trunk
helpwanted
Dependency tree / graph
Bug Flags:
blocking-aviary1.5 -
wanted-thunderbird3 ?

Firefox Tracking Flags

(Not tracked)

Details

ooh, this is a nice one.
Whiteboard: HELP WANTED
Target Milestone: M15
marking m15

Comment 2

18 years ago
Bulk-resolving requests for enhancement as "later" to get them off the Seamonkey
bug tracking radar. Even though these bugs are not "open" in bugzilla, we
welcome fixes and improvements in these areas at any time. Mail/news RFEs
continue to be tracked on http://www.mozilla.org/mailnews/jobs.html

Comment 3

18 years ago
Reopen mail/news HELP WANTED bugs and reassign to nobody@mozilla.org

Updated

18 years ago
Keywords: helpwanted

Updated

18 years ago
Summary: [HELP WANTED] Auto-watch threads you've posted to → Auto-watch threads you've posted to
Whiteboard: HELP WANTED
Target Milestone: M15

Comment 4

17 years ago
You could always set the follow-up: to be your email or something. Seth, is this
still valid/useful?

Comment 5

17 years ago
IMHO setting follo-up to my mail account and having the threads I posted to
marked for easy finding are two things that are as completely different as two
newsgroup issues can possible be.

I believe this would be a great enhancement of the Watch Thread feture (still
missing in Mozilla, see bug 16920) 

Updated

16 years ago
Depends on: 72279

Comment 6

16 years ago
I don't think this is needed.  I accomplished this in NS4 by creating a filter
that would mark as watched any message where the sender is me.  (I also did it
for subject, in case someone was trying to contact me.)  I think that when bug
17483 is resolved, this will no longer be necessary, since it will be easy for
the user to make a custom filter.

I would guess that this depends on the same backend work that is covered by bug
17483 anyway, so it's not like we'd have this in the meantime while waiting for
news filters to be implemented.  Unless of course, it is going to be triggered
by the actual sending.

Comment 7

16 years ago
burpmaster,

Are you suggesting that the need to add filters is all that is required, or are
you assuming that the likes of Netscape could add the desired functionality
automatically via filters in their implementation?

Filters may work, but given the (requested) alternative, I think filters are
more a hack than should be necessary.

Comment 8

15 years ago
*** Bug 142239 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
*** Bug 160286 has been marked as a duplicate of this bug. ***

Comment 10

15 years ago
*** Bug 164080 has been marked as a duplicate of this bug. ***

Updated

15 years ago
QA Contact: lchiang → nobody

Updated

14 years ago
Blocks: 214286

Comment 11

14 years ago
*** Bug 227223 has been marked as a duplicate of this bug. ***

Updated

14 years ago
Blocks: 236849

Updated

13 years ago
Blocks: 148744
Product: MailNews → Core

Updated

12 years ago
Flags: blocking-aviary1.1?

Updated

12 years ago
Flags: blocking-aviary1.1? → blocking-aviary1.1-
and Bug 215021
*** Bug 215021 has been marked as a duplicate of this bug. ***
This worksforme since you actually can set a filter for any newsgroup/newsaccount such as:

For incoming messages with:
From is $youremail
Perform this action:
Watch Thread.

JFTR: Bug 261223 is about the ability to watch threads on POP/IMAP.

Closing WORKSFORME.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Jürgen, thanks for your comment. I'm glad we now can use the technique you have described.

However, I don't think we should close a bug when a workaround is present. This bugs cover the need of doing an automatic trigger because it's logical for the user to be that way without configuring anything.

Given the explanations, I'm reopening the bug.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(In reply to comment #15)

> However, I don't think we should close a bug when a workaround is present. This
> bugs cover the need of doing an automatic trigger because it's logical for the
> user to be that way without configuring anything.

Ok. I understand you want the ability to automatically watch a thread to be set by a pref. Just one click at the pref panel to create this filter.

I'll change the subject of this bug accordingly. Because the ability to "Auto-watch threads you've posted to" is already given i'll state that this is a request for a single click solution. 

Also signing this bug as a RFE.

Severity: normal → enhancement
Summary: Auto-watch threads you've posted to → Provide a single-click pref to Auto-watch threads you've posted to
Yes, it would be interesting to have an automated solution, and I agree this is an RFE now.

However, I don't think we need a one-click solution but a zero-click solution :)

Think of it: who would want not to watch his own threads? Well, perhaps a strange person, but at least we could leave it enabled by default.

Changing title accordingly. Thanks.
Summary: Provide a single-click pref to Auto-watch threads you've posted to → Provide a single-click pref to Auto-watch threads you've posted to (default to be enabled)

Updated

10 years ago
Status: REOPENED → ASSIGNED
Summary: Provide a single-click pref to Auto-watch threads you've posted to (default to be enabled) → Auto-watch threads you've posted to (Preference)

Updated

10 years ago
Status: ASSIGNED → NEW
Priority: P3 → --
QA Contact: nobody → backend
usability win for TB3 IMO
Flags: wanted-thunderbird3?
(Assignee)

Updated

9 years ago
Product: Core → MailNews Core
No longer blocks: 148744
Duplicate of this bug: 412376
You need to log in before you can comment on or make changes to this bug.