Closed Bug 1134701 Opened 5 years ago Closed 5 years ago

[Meta] v1 implementation of Bugzilla Lite

Categories

(Firefox OS Graveyard :: Gaia::Bugzilla Lite, defect, P1)

x86
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: jgong, Assigned: daleharvey)

References

Details

(Whiteboard: [spark][systemsfe])

User Story

This is a meta bug for tracking all on device bug triggering user stories.

1. On device bug generation is triggered by hard keys (volume up & Power button), it would automatic generation of the following
- screenshot of current UI (auto generated)
- system log (auto generated)
- capture of Component (auto generated)
- capture Product (auto generate)

2. A dialog will appear showing the following

- thumbnail image of screenshot 
- Input field for description and bug title
- click to save, cancel
- save to submit bug to bugzilla

3. User can review screenshot to verify 
- when screenshot is generated, show thumbnail of image
- user taps on thumbnail and it will expand to full image
- after screenshot review, user can tab to close image

4. On device setting to turn on/off bug trigger feature
- In Settings UI 
- Can turn On device bug trigger features On/Off
- Enter email address to be sent with bug submission and receive email notification
- Need entire login details

5. Email submission of bug to bugzilla. Should include user's email as part of the CC list

IxD Spec:
https://mozilla.box.com/s/fz6tk8nluox0iece5593g5z8c4o6fa6h

Attachments

(4 files, 6 obsolete files)

This is a meta bug for tracking all on device bug triggering user stories.

1. On device bug generation is triggered by hard keys (volume up & Power button), it would automatic generation of the following
- screenshot of current UI (auto generated)
- system log (auto generated)
- capture of Component (auto generated)
- capture Product (auto generate)

2. A dialog will appear showing the following

- thumbnail image of screenshot 
- Input field for description and bug title
- click to save, cancel
- save to submit bug to bugzilla



3. User can review screenshot to verify 
- when screenshot is generated, show thumbnail of image
- user taps on thumbnail and it will expand to full image
- after screenshot review, user can tab to close image

4. On device setting to turn on/off bug trigger feature
- In Settings UI 
- Can turn On device bug trigger features On/Off
- Enter email address to be sent with bug submission and receive email notification
- Need entire login details

5. Email submission of bug to bugzilla. Should include user's email as part of the CC list

v1: after hw key: A dialog would pop up 
could submit to bugzilla
Summary: [Meta] This is a meta bug for tracking all on device bug triggering user stories → [Meta] This is a meta bug for tracking all on device bug triggering UI
Moved my feature requirement to user story field.
User Story: (updated)
No longer blocks: 1135879
Depends on: 1135860
Duplicate of this bug: 1079760
This is my testing installation, going to keep it up to date - http://ladybug.pouchdb.com/

Its working against a test bugzilla implementation so dont worry about filing random bugs
Component: Gaia::Build → Developer Tools
Taking this since I am working on the blocking bugs to get this landed
Assignee: nobody → dale
Summary: [Meta] This is a meta bug for tracking all on device bug triggering UI → [Meta] v1 implementation of ladybug
User Story: (updated)
I've added the link to the IxD spec in the user story description.
Attached file Ladybug_VSD_Spec_1.0.pdf (obsolete) —
Hi Dale, 

I've attached the VSD spec for ladybug. Let me know if you have any questions.
Hey Amy, Thats great thanks. I have a few notes on the Visual Spec

First Time Use - A 

This dialog is handled by the system, when we shake (or press hardware keys) a notification is shown and when you press the notification you will get an activity picker (which as standard across the os will show the application name + icon of apps that can handle this activity). We can maybe remove the notification although that seems intrusive (it forces the user to deal with the bug logging now as opposed to finishing what they were doing) but the activity UI is very standard across the OS so it will say 

   |  Email  | 
   | Ladybug | 
   | Cancel  |

and not match the visual spec unless / until we do an OS wide update to the activity dialog

The demo implements this pretty much as is so would be good to check that your happy with it as implemented.


Filing a Bug - D 

I dont believe we have an API or the capability to do these types of passive toaster notifications, I havent seem them used elsewhere at least. Once 'ladybug' closes itself the notification displayed will not be visible over other applications (ie messages) so I think this will need to be some type of modal confirmation.

There will also be the case in which the user filed a bug from launching the homescreen icon so not sure closing the application would be suitable for that situation, after a modal confirmation the bug is filed it may go back to an empty form?
Component: Developer Tools → Gaia::Feedback
Got to implementing most of these

One thing that is missing is error states for login + submitting a bug

Login may fail due to bad connection or bad login details, submitting a bug may fail due to bad networks or incomplete data
Amy one last thing, the progress dialogs in the gaia components are determinate whereas the login / submit process is indeterminate, an example of this dialog being indeterminate would be great. 

I dont think we will be able to use the gaia-components code in this app yet, I want to have this app be an actual web application so at the least we will need to wait until web components are enabled on nightly at the least. But I can copy the components style for the most part until we switch to actual components.
Whiteboard: [systemsfe]
Summary: [Meta] v1 implementation of ladybug → [Meta] v1 implementation of Bugzilla Lite
(In reply to Dale Harvey (:daleharvey) from comment #9)
> Got to implementing most of these
> 
> One thing that is missing is error states for login + submitting a bug
> 
> Login may fail due to bad connection or bad login details, submitting a bug
> may fail due to bad networks or incomplete data

I would think a toast notification should be used for error states if we are able to implement them. Jacqueline what do you think?
Flags: needinfo?(jsavory)
(In reply to Dale Harvey (:daleharvey) from comment #10)
> Amy one last thing, the progress dialogs in the gaia components are
> determinate whereas the login / submit process is indeterminate, an example
> of this dialog being indeterminate would be great. 
> 
> I dont think we will be able to use the gaia-components code in this app
> yet, I want to have this app be an actual web application so at the least we
> will need to wait until web components are enabled on nightly at the least.
> But I can copy the components style for the most part until we switch to
> actual components.

I believe there is an indeterminate version of the progress dialog. I’ve seen it used in the P2P Sharing app that Doug is working on.
(In reply to Dale Harvey (:daleharvey) from comment #7)
> Hey Amy, Thats great thanks. I have a few notes on the Visual Spec
> 
> First Time Use - A 
> 
> This dialog is handled by the system, when we shake (or press hardware keys)
> a notification is shown and when you press the notification you will get an
> activity picker (which as standard across the os will show the application
> name + icon of apps that can handle this activity). We can maybe remove the
> notification although that seems intrusive (it forces the user to deal with
> the bug logging now as opposed to finishing what they were doing) but the
> activity UI is very standard across the OS so it will say 
> 
>    |  Email  | 
>    | Ladybug | 
>    | Cancel  |
> 
> and not match the visual spec unless / until we do an OS wide update to the
> activity dialog
> 
> The demo implements this pretty much as is so would be good to check that
> your happy with it as implemented.
> 
> 
> Filing a Bug - D 
> 
> I dont believe we have an API or the capability to do these types of passive
> toaster notifications, I havent seem them used elsewhere at least. Once
> 'ladybug' closes itself the notification displayed will not be visible over
> other applications (ie messages) so I think this will need to be some type
> of modal confirmation.

Are we able to have this toast show up in the ladybug app and then it closes afterwards? I’ve seen toast notifications in the clock app when setting an alarm and in the email app when you send an email. 
> 
> There will also be the case in which the user filed a bug from launching the
> homescreen icon so not sure closing the application would be suitable for
> that situation, after a modal confirmation the bug is filed it may go back
> to an empty form?

NI Jacqueline on UX questions
Component: Gaia::Feedback → Bugzilla Lite
Generally for input box errors we have red text under the input box stating the error, for the network error and anything else we should use a dialogue. I will add these screens to UX spec. 

If the user is filing a bug after launching Bugzilla Lite from the homescreen, I agree that we should not close the application and returning to an empty form will work. As long as we still have the toast notification informing the user the bug has been filed.
Flags: needinfo?(jsavory)
I've updated the UX spec with the errors and the offline flow. The link in the User Story section should always link to the latest version.
Attachment #8578733 - Attachment description: IxD Spec link... → IxD Spec: https://mozilla.box.com/s/fz6tk8nluox0iece5593g5z8c4o6fa6h
No longer depends on: 1141992
Attached image buzilla_lite_icon_x1.png (obsolete) —
Attached is the Bugzilla Lite icon for homescreen. Let me know if any other sizes are needed. 

Cheers
Attached image bugzilla_lite_icon_x1.png (obsolete) —
Minor colour update to icon.
Attachment #8583110 - Attachment is obsolete: true
Minor colour update to icon.
Attachment #8583198 - Attachment is obsolete: true
Also attaching x2.25 version of icon for demoing on Aries device.
Amy

We arent using the standard gaia build system for Bugzilla lite, is there any chance I can get it in 512px and 128px, if it was possible to get svg as well that would be awesome but not required (I would like to fix our support for svg icons, having all these resolutions is driving me nut)

Also if you could attach it to https://bugzilla.mozilla.org/show_bug.cgi?id=1136787 would keep things in the right place
Flags: needinfo?(amlee)
(In reply to Dale Harvey (:daleharvey) from comment #21)
> Amy
> 
> We arent using the standard gaia build system for Bugzilla lite, is there
> any chance I can get it in 512px and 128px, if it was possible to get svg as
> well that would be awesome but not required (I would like to fix our support
> for svg icons, having all these resolutions is driving me nut)
> 
> Also if you could attach it to
> https://bugzilla.mozilla.org/show_bug.cgi?id=1136787 would keep things in
> the right place

Done!
Flags: needinfo?(amlee)
Attached file Bugzilla_Lite_VSD_Spec_1.1.pdf (obsolete) —
Updated VSD spec: 

1. Added “Logout” button and relocated attachment button based on UX
2. Updated header colour (pg 3)
3. Text link colour (pg 4)
4. Element spacing (pg 5)
Attachment #8573526 - Attachment is obsolete: true
Attachment #8584778 - Attachment description: Ladybug_VSD_Spec_1.1.pdf → Bugzilla_Lite_VSD_Spec_1.1.pdf
No longer blocks: 1142815
Depends on: 1149012
Blocks: spark
Priority: -- → P1
Whiteboard: [systemsfe] → [systemsfe][lightsaber]
Attached file Bugzilla_Lite_VSD_Spec_1.1.pdf (obsolete) —
Attachment #8584778 - Attachment is obsolete: true
Attached file Bugzilla_Lite_VSD_Spec_1.2.pdf (obsolete) —
Attachment #8585501 - Attachment is obsolete: true
Blocks: 1151963
No longer blocks: 1151963
Depends on: 1151963
No longer depends on: 1136790
Removing the gaia-commit as blocking, will work on it but I dont think it needs to block everything (the gaia commit should be able to be infered from the central commit)

With that considering v1 complete :) I think its ready to see if we can land in gaia now
Status: NEW → RESOLVED
Closed: 5 years ago
No longer depends on: 1149012
Resolution: --- → FIXED
Whiteboard: [systemsfe][lightsaber] → [ignite][systemsfe]
Depends on: 1155719
Whiteboard: [ignite][systemsfe] → [spark][systemsfe]
Updated spec. Modified submit button to be sticky to the bottom of the screen.
Attachment #8586260 - Attachment is obsolete: true
Depends on: 1161723
Depends on: 1154746
Depends on: 1156384
Depends on: 1159417
You need to log in before you can comment on or make changes to this bug.