Closed Bug 1268936 Opened 5 years ago Closed 8 months ago

Mentioned "Sidebar Advanced Search Mode" does not exist (cs_nav_prefs_navigator.xhtml) and missing explication for checkbox "Show search suggestions" ( nav_help.xhtml, cs_nav_prefs_navigator.xhtml)

Categories

(SeaMonkey :: Help Documentation, defect)

Unspecified
All
defect
Not set
normal

Tracking

(seamonkey2.49esr wontfix, seamonkey2.53+ fixed, seamonkey2.57esr? affected)

RESOLVED FIXED
seamonkey 2.75
Tracking Status
seamonkey2.49esr --- wontfix
seamonkey2.53 + fixed
seamonkey2.57esr ? affected

People

(Reporter: RainerBielefeldNG, Assigned: nunojsg)

References

(Blocks 1 open bug)

Details

(Whiteboard: SM2.53.3)

Attachments

(3 files, 2 obsolete files)

+++ This bug was initially created as a clone of Bug #1268357 +++

Steps how to reproduce  with  English SeaMonkey 2.45a1  (Windows NT 6.1; WOW64; rv:48.0)  Gecko/20100101 Firefox/48.0 Build 20160308001946  (Default Classic Theme)  on German WIN7 64bit:

1. Browser → F1
   » Help appears
2. Type search string "Browser Preferences" → Click hit 
   "Browser Preferences"
   » Related Help appears
3. In page find "Sidebar Search Tab Preference"
   Bug: this does not exist

a) If you want to test "Sidebar Search Tab Preference" with an old
   SM version be careful, Latest SM versions will crash when try to 
   launch with selection / Advanced"
b) Suggestion for Fix: drop this list item
Blocks: 1270212
No longer blocks: 1270212
 i want to work on this bug , can you assign me .
(In reply to Suraj Ghimire from comment #1)
Great, thank you! You generally simply can start to work on a fix also without being assigned. Simply leave a short comment that you were able to reproduce the problem (were you?) and that you will work on a fix. Within few hours someone will assign you, and that's enough, in this SeaMonkey Help area there is not much hustle ;-)
After 4 Weeks or so you should ask for CANCONFIRM here <https://bugzilla.mozilla.org/page.cgi?id=get_permissions.html>).
Assignee: nobody → suraj.ghimire7
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Comment on attachment 8759664 [details] [diff] [review]
revision1 -  dropped "Sidebar Advanced Search Mode"

Thanks. Can we fix the rest here too (nav_help)? I know it's a separate bug for nav_help, but we shouldn't fix content changes in just one file - we should remove/update content in all files at the same time (especially with these kind of rather small changes).
Attachment #8759664 - Flags: review?(stefanh) → review+
thanks for feedback , can you give me link of  nav_help bug , so i can work on it
I think Stefan talks about other bugs in this document <https://bugzilla.mozilla.org/buglist.cgi?list_id=13057439&short_desc=cs_nav_prefs_navigator.xhtml&query_format=advanced&bug_status=UNCONFIRMED&bug_status=NEW&short_desc_type=allwordssubstr&product=SeaMonkey>?

I am ready with standard tests for this document (typos, bad links), I will do  for correct sense of the contents much later. So it would not make sense to wait for more Bug reports concerning cs_nav_prefs_navigator.xhtml, fixes for all currently known bugs would terminate current efforts for this document.
(In reply to Rainer Bielefeld from comment #6)
> I think Stefan talks about other bugs in this document
No I'm refering to bug 1268936 which is about Sidebar search advanced mode not existing.
(In reply to Stefan [:stefanh] from comment #7)
Hm, Bug 1268936 is THIS bug. I don't understand your intention, do you want to suggest to recreate that function?
See Also: → 1278589
Blocks: 1278591
Sorry, I ment bug 1268357 and all other things that should be removed regarding to Sidebar Advanced Search Mode. It's OK with a bug for a bunch of typos or minor correction, but when it comes to removing content it's much better with one bug for each, let's call it, subject. For example, in this case you want one bug dealing with "Remove all references to Sidebar Advance Seach Mode".
For example: Here's one query using mxr.mozilla.org that would give me some content that probably could be removed:

Sidebar Advanced:
http://mxr.mozilla.org/comm-central/search?string=Sidebar%2BAdvanced
Sorry for late reply i was busy in exams , can you tell (In reply to Stefan [:stefanh] from comment #10)
> For example: Here's one query using mxr.mozilla.org that would give me some
> content that probably could be removed:
> 
> Sidebar Advanced:
> http://mxr.mozilla.org/comm-central/search?string=Sidebar%2BAdvanced

Sorry for late reply i was busy in exams can you guide me where to find other things related to Sidebar Advanced Search Mode .  http://mxr.mozilla.org/comm-central/search?string=Sidebar%2BAdvanced is not working right now
(In reply to Suraj Ghimire from comment #11)
> Sorry for late reply i was busy in exams can you guide me where to find
> other things related to Sidebar Advanced Search Mode . 
> http://mxr.mozilla.org/comm-central/search?string=Sidebar%2BAdvanced is not
> working right now

Yeah, it's down permanently. You can use https://dxr.mozilla.org instead (you need to switch tree to comm-central). Just type the string you want to look up.
Keywords: good-first-bug
Whiteboard: [easyconfirm][good first bug] → [easyconfirm]

No movement -> reset assignee

Assignee: suraj.ghimire7 → nobody
Status: ASSIGNED → NEW

Should Suraj's patch be used as is?

(In reply to Nuno Silva from comment #14)

Should Suraj's patch be used as is?

I cannot spot any further removals needed, but a description for "Open the Search tab in the sidebar when a search is invoked" is required.

Attachment #9146784 - Flags: feedback?(iann_bugzilla)

This one also mentions "Show search suggestions" (bug 1278764).

Attachment #9146784 - Attachment is obsolete: true
Attachment #9146784 - Flags: feedback?(iann_bugzilla)
Attachment #9146849 - Flags: feedback?(iann_bugzilla)
Comment on attachment 9146849 [details] [diff] [review]
cs_nav_prefs_navigator.xhtml: update the description of internet search preferences, v2

>   <li><strong>Default Search Engine</strong>:
>     <ul>
>       <li><strong>Search using</strong>: Use the drop-down list to select the
>         search engine you want use for web searching.</li>
>+      <li><strong>Manage Search Engines</strong>: Click this to open a dialog
>+        where you can manage the search engines list. In this dialog you can
>+        also select <strong>Show search suggestions</strong> to have
>+        &brandShortName; show suggestions from the search engine as you type a
>+        search string in the Sidebar search tab or in the Search Bar.</li>
We also need to add something similar in nav_help.xhtml:
https://dxr.mozilla.org/comm-esr60/source/suite/locales/en-US/chrome/common/help/nav_help.xhtml#508

>+      <li><strong>Open the Search tab in the Sidebar when a search is
>+        invoked</strong>: Select this to have &brandShortName; open the Sidebar
>+        when a search is invoked using the Search button.</li>
As we are planning to drop this preference in Bug 1279806, I'd not bother adding it here.

f+ for the moment, thanks for the work so far.
Attachment #9146849 - Flags: feedback?(iann_bugzilla) → feedback+
Summary: cs_nav_prefs_navigator.xhtml: Mentioned "Sidebar Advanced Search Mode" does not exist → Mentioned "Sidebar Advanced Search Mode" does not exist (cs_nav_prefs_navigator.xhtml) and missing explication for checkbox "Show search suggestions" ( nav_help.xhtml, cs_nav_prefs_navigator.xhtml)
Duplicate of this bug: 1278764

Adds "show search suggestions" to nav_help.xhtml and removes "Open the Search tab in the Sidebar [...]" from this file.

"Open a tab instead of a window for a context menu web search" was not mentioned in that part of nav_help.xhtml, so I added it as well.

Attachment #9146849 - Attachment is obsolete: true
Attachment #9147063 - Flags: feedback?(iann_bugzilla)
Depends on: 1279806
Duplicate of this bug: 1280100
Assignee: nobody → nunojsg
Status: NEW → ASSIGNED
Comment on attachment 9147063 [details] [diff] [review]
cs_nav_prefs_navigator.xhtml, nav_help.xhtml: update the description of internet search preferences, v3

[Triage Comment]
Thanks, LGTM r/a=me
Attachment #9147063 - Flags: review+
Attachment #9147063 - Flags: feedback?(iann_bugzilla)
Attachment #9147063 - Flags: approval-comm-release+
Attachment #9147063 - Flags: approval-comm-esr60+
Comment on attachment 8759664 [details] [diff] [review]
revision1 -  dropped "Sidebar Advanced Search Mode"

[Triage Comment]
This needs to land too
Attachment #8759664 - Flags: approval-comm-release+
Attachment #8759664 - Flags: approval-comm-esr60+

Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/d39ef72c33b5
cs_nav_prefs_navigator.xhtml: Mentioned 'Sidebar Advanced Search Mode' does not exist .r=IanN
https://hg.mozilla.org/comm-central/rev/c1ae94f3453d
Update help for Internet Search preferences. r=IanN

Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED

Hi, are you also working on a patch for those locales that need this fix too?

Flags: needinfo?(nunojsg)

A first version of a l10n patch, covering help files in English. I tried to do en-GB as well, but it might need further changes for British English.

Flags: needinfo?(nunojsg)
Attachment #9150314 - Flags: feedback?(iann_bugzilla)
Comment on attachment 9150314 [details] [diff] [review]
l10n patch to update search documentation, v1

[Triage Comment]
Thanks, LGTM. You picked up the correct differences for en-GB. r/a=me
Attachment #9150314 - Flags: review+
Attachment #9150314 - Flags: feedback?(iann_bugzilla)
Attachment #9150314 - Flags: approval-comm-release+
Attachment #9150314 - Flags: approval-comm-esr60+

Anything required for de?

Flags: needinfo?(frgrahl)
Keywords: good-first-bug
Whiteboard: [easyconfirm] → SM2.53.3

Target 2.53.3
https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/e8ddedb21a622c92c6ef42044f8dd566de56d4cf
cs_nav_prefs_navigator.xhtml: Mentioned 'Sidebar Advanced Search Mode' does not exist .r=IanN a=IanN
https://gitlab.com/seamonkey-project/seamonkey-2.53-comm/-/commit/d26cde81b6c255e924e16631d516ccf1e8549431
Update help for Internet Search preferences. r=IanN a=IanN

Anything required for de?
I did a big de cleanup in Bug 1641885. Too much to do it piecemeal. Changes for the sidebar are in for 2.53.4

Flags: needinfo?(frgrahl)
You need to log in before you can comment on or make changes to this bug.