Closed Bug 1340626 Opened 3 years ago Closed 3 years ago

Ugly border around dropdown buttons in UI

Categories

(Firefox :: Theme, defect)

54 Branch
All
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 54
Tracking Status
firefox51 --- unaffected
firefox52 --- unaffected
firefox53 --- unaffected
firefox54 --- verified

People

(Reporter: ajarope, Assigned: dao)

References

Details

(Keywords: regression)

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170217094919

Steps to reproduce:

run autoland win10/64 opt build:
https://hg.mozilla.org/integration/autoland/rev/554a4f2a1523


Actual results:

ugly border around "show your bookmarks" button


Expected results:

no ugly border around "show your bookmarks" button
possibly fallout from landing of bug 1340495 patch?
Blocks: 1340495
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64
Component: Untriaged → Theme
Flags: needinfo?(dao+bmo)
I tested using Fx 53.0a1 on Ubuntu and could not reproduce the problem.
Assignee: nobody → dao+bmo
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Flags: needinfo?(dao+bmo)
Keywords: regression
OS: Windows 10 → Windows
Hardware: x86_64 → All
Richard feel free to steal this review if you want.
Comment on attachment 8838785 [details]
Bug 1340626 - Remove fallback styling from dropmarker.css.

https://reviewboard.mozilla.org/r/113590/#review115164
Attachment #8838785 - Flags: review+
Thanks!
Attachment #8838785 - Flags: review?(mak77)
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/91b0938bc976
Remove fallback styling from dropmarker.css. r=Paenglab
That seems to have fixed the issue.
Duplicate of this bug: 1340816
Duplicate of this bug: 1340818
Has Regression Range: --- → yes
Has STR: --- → irrelevant
Summary: ugly border around "show your bookmarks" button (bug 1340495 fallout?) → Ugly border around dropdown buttons in UI
Duplicate of this bug: 1340906
I'm not sure if this is the same issue, but I don't think the dropdown button UI at about:addons looks the same as it did a couple days ago.
https://hg.mozilla.org/mozilla-central/rev/91b0938bc976
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 54
Blocks: 1341036
Duplicate of this bug: 1340888
Blocks: 1341047
Blocks: 1341048
Duplicate of this bug: 1341000
Just to add a screenshot to this bug report
Duplicate of this bug: 1341225
good news, we see a performance improvement with this change!

== Change summary for alert #5219 (as of February 17 2017 23:56 UTC) ==

Improvements:

  4%  tresize windows8-64 opt      11.69 -> 11.21

For up to date results, see: https://treeherder.mozilla.org/perf.html#/alerts?id=5219
Blocks: 1341269
VERIFIED as fixed with Mozilla Firefox 54.0a1 (2017-02-21).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.