Closed Bug 138933 Opened 18 years ago Closed 14 years ago

Menus on wrong screen when dual screens activated after startup

Categories

(Core :: XUL, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 245418

People

(Reporter: samjie, Assigned: hyatt)

References

Details

Attachments

(1 file)

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.9) Gecko/20020311
BuildID:    2002031104

After starting Mozilla and switching to dual screens, menus are displayed on the
first screen for browser windows on the second.

Reproducible: Didn't try
Steps to Reproduce:
1. Start Mozilla
2. Activate dual screens
3. On a window on the second screen, click on a menu

Actual Results:  Menu for browser on second screen appears on first screen.

Expected Results:  Menu appears on second screen underneath menu.
*** Bug 149445 has been marked as a duplicate of this bug. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
New insight for me, after turning on Nvidia nNview, mozilla menus no longer jump
to the first screen.

Window
 nView Options
  Enable window spanning across monitors
  Enable child window spanning across windows
 Enable application position memory
 Enable dialog repositioning
 Extend application system menus with nView options

Hope this helps.
This is a dupe of bug 21942. See comment #22 in bug 21942 to reproduce this.
Sam, Nathan, can you reproduce this with a current trunk build?
Bug 21942 has been resolved as fixed, but seems not really to be fixed. Maybe it
should be reopened, so your info might be helpful.
Same behavior observed using two-screen support on Radeon Mobility 7500, Win XP
SP1.  Unique to Mozilla, other programs have no problems.
*** Bug 186191 has been marked as a duplicate of this bug. ***
*** Bug 193746 has been marked as a duplicate of this bug. ***
*** Bug 210814 has been marked as a duplicate of this bug. ***
*** Bug 133845 has been marked as a duplicate of this bug. ***
*** Bug 145935 has been marked as a duplicate of this bug. ***
Reproduced with "Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.4b)
Gecko/20030516 Mozilla Firebird/0.6" on Windows 2000 with Radeon 9700.  As
someone else said it's unique to Mozilla - other programs work fine.
I've seen this problem too. My solution was to get a screen with more resolution and get rid of the attached monitor.

BTW, I've run into several other problems that don't behave well with multi-screen setups. QuoteTracker and Tarantella do funny stuff with multiple monitors. Even the Sound Volume Control isn't well-behaved with attached monitors and that's a
Windows function. At any rate, I found that the menus would come up in the
upper right corner of the first monitor even though Firebird was in the second
screen.
Attached image how it looks like...
*** Bug 234086 has been marked as a duplicate of this bug. ***
I've encountered the same bug on a Mac OS X (Panther) PowerBook when using a
monitor attached to my laptop as a second screen. If I view a browser window in
the monitor and bring up the context menu or try to use an autom-complete widget
(for example in the URL bar) the menu comes up on my main laptop screen. This
happens in both Firefox 0.8 and Thunderbird 0.5.
I can confirm this behavior with "Mozilla/5.0 (Windows; U; Windows NT 5.1;
de-AT; rv:1.5) Gecko/20031007" on WinXP using an IBM Thinkpad with ATI drivers. 

The problem occurs only if the second screen is added/configured after the
current Mozilla session has been started. AFAIK Windows notifies applications
when the screen configuration changes. I presume that Mozilla doesn't
receive/handle this notification and caches the screen configuration on startup,
so that it doesn't know about the second screen.
This bug still exists as I have been able to reproduce is with WinXP and Mozilla
1.7.  The same problem occurs in mail/chatzilla and all other mozilla apps that
use a menu. 

An idea as to the cause: Mozilla is using the size and location of the main
window to create and place the menu lists.  It should gather this information
dynamically from the current window position.  I've had problems doing this same
thing :)
Confirmed also in Thunderbird 0.7.2 and Firefox 0.9.2 (clone defect?)
Windows XP SP1, ATI Mobility Radeon 9600

I think that the applications are keying off the edges of the "original" display
(the one where the window first appeared), or perhaps off the main/#1 display
(the one with the taskbar). If the main display is on the right, menus appear on
its right edge. If it's on the left, menus appear on its right edge.

IE, Outlook, and Windows/MSN Messenger display menus correctly.
doh!

if main/orginal display is on left, menus appear on its right edge
if     "           "     "  " right,  "     "     " its left    "

sorry 'bout that
duplicate of bug 245418 ?
Bug still present in Firefox 1.5RC3/MAC OSX 10.4.3
cannot reproduce with SeaMonkey/2005120708-trunk/WinXP.

(In reply to comment #20)
> duplicate of bug 245418 ?
I think so, too.
Yes, this is dup of bug 245418.

*** This bug has been marked as a duplicate of 245418 ***
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Component: XP Toolkit/Widgets: Menus → XUL
QA Contact: shrir → xptoolkit.widgets
You need to log in before you can comment on or make changes to this bug.