Last Comment Bug 93959 - (FlashTransparency) [WMODE] Evangelize Macromedia to enable partial transparency/layering/z-index in Flash
(FlashTransparency)
: [WMODE] Evangelize Macromedia to enable partial transparency/layering/z-index...
Status: VERIFIED FIXED
[Flash Code][THIS IS NOT A MOZILLA IS...
: testcase
Product: Tech Evangelism Graveyard
Classification: Graveyard
Component: English US (show other bugs)
: unspecified
: All All
: P4 normal
: ---
Assigned To: Arun Ranganathan
: shrirang khanzode
Mentors:
http://www.teledanmark.dk/html/forsid...
: 95174 146735 157985 159682 162153 174767 179015 187072 193389 193999 226463 (view as bug list)
Depends on:
Blocks: 134375 139820
  Show dependency treegraph
 
Reported: 2001-08-06 12:34 PDT by Skewer
Modified: 2015-04-19 23:39 PDT (History)
41 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
simple sample showing how to create a plugin for Gecko with transparency and z-index (sample.zip) (262.32 KB, application/x-zip-compressed)
2002-06-24 23:43 PDT, Peter Lubczynski
no flags Details

Description Skewer 2001-08-06 12:34:45 PDT
Procedure: View <http://www.gadgetscope.com/tests/trans.html>.

Expected: "Trans" is floating over background image, no white box is present.

Actual: "Trans" is drawn over a box of the animation's background color.

This might be a limitation within Macromedia's Netscape plug-in, but it's
probably a good idea for a bug on this to exist anyway, to find out whether the
browser is able to handle effects like this.

Build: 2001080508 Win98
Comment 1 Fabricio Campos Zuardi 2002-03-05 21:27:47 PST
Macromedia Flash MX is about to be released, I think that MM guys should correct
this in the new version of his plugin. 
Testing the testcase with the Flash Player 6 Beta the problem still occurs.
Anyone know some MM people email to include on the CC?

The URL to download the Flash6 beta player is:
http://www.macromedia.com/shockwave/download/beta/flashplayer6/
and the feedback form to bug report about this beta player is:
http://www.macromedia.com/bin/fp6betafeedback.cgi

I've already reported a bug about this in their form, but if more people report
this bug maybe Macromedia make something about this old and annoing issue.
Comment 2 Fabricio Campos Zuardi 2002-03-05 21:46:14 PST
Adding Arun and Marcio to CC, they may have other ways to help us with it.
Comment 3 Fabricio Campos Zuardi 2002-03-13 22:42:28 PST
Ok, in a a discussion on a Macromedia newsgroup, I've been informed from MM
people that it has nothing to do with the Flash plugin, they say the browser
that must support wmode.
Anyone knows if there's a specific bug for this wmode problem, I know the bug
99974 and bug 64090 but they were marked INVALID... should we reopen those bugs?

BTW, the people that told me that this problem has nothing to do with the player
was Petter Hall
(http://www.macromedia.com/support/forums/team_macromedia/team_flash.html) and
Clint Critchlow (Macromedia Technical Support)
Comment 4 Peter Lubczynski 2002-03-14 07:36:42 PST
Flash does not support wmode in 4.x either. The ball is currently in
Macromedia's court to implement this. If there are bugs in Mozilla, we can fix
them if we know what they are.

Mozilla now supports the windowless API for plugins. In this mode, plugins are
not confined to a widget and can render anywhere on the page. During
compositing, the plugin gets a device context from us to render into. We've been
working with Viewpoint (http://www.viewpoint.com/) on their windowless plugin
and it has features similar to Flash's wmode plus is scriptable. It may be a
possible workaround.
Comment 5 rubydoo123 2002-03-14 12:39:33 PST
pushing out to 1.1
Comment 6 Jonas Sicking (:sicking) PTO Until July 5th 2002-05-19 05:06:45 PDT
One interesting thing is that the Macromedia people hasn't bothered filing a bug
if they don't manage to get a wmode implementation working. Couldn't someone
(Fabricio?) who has been in contact with them ask them to do so, or ask them to
comment in this bug. Mozilla and plugin authors obviously need to work together
to get things going, it can't be fixed on one side only.
Comment 7 Fabricio Campos Zuardi 2002-05-19 19:59:15 PDT
Hi Jonas, I've asked for it in both Macromedia newsgroup and in the Flashcoders
mailing list. Below is the feedback by Branden Hall and Clint Critchlow:

Branden Hall:
"It actually has nothing to do with MM until Mozilla settles on a plugin
format. The netscape plugin format is old and quite funky and it doesn't
support windowless plugins very easily. Until the Mozilla project settles on
a new format there's nothing that MM can do about it.

-Branden"

Clint Critchlow:
"I already posted my comment on this problem with the Netscape browsers.  You
can see it at <http://bugzilla.mozilla.org/show_bug.cgi?id=93959>.

You can make feature requests at,
<http://www.macromedia.com/support/email/wishform/?6213=9>"
Comment 8 Fabricio Campos Zuardi 2002-05-19 21:48:02 PDT
The link of the 2 threads I've opened in MM newsgroup and in Figleaf FlashCoders

MM newsgroup
http://webforums.macromedia.com/flash/messageview.cfm?catid=194&threadid=347358

Figleaf FlashCoders
http://chattyfig.figleaf.com/cgi-bin/ezmlm-cgi?1:sss:35091:mefkmmialipfpijednae#b
Comment 9 Peter Lubczynski 2002-05-24 11:18:18 PDT
*** Bug 146735 has been marked as a duplicate of this bug. ***
Comment 10 Peter Lubczynski 2002-06-24 23:43:19 PDT
Created attachment 89039 [details]
simple sample showing how to create a plugin for Gecko with transparency and z-index (sample.zip)

Okay, after spending the day with chrisd working on this problem, I have
created a simplified testcase showing an example of how easy it is to use both
transparency and z-index layering in Gecko as long as the plugin supports it.
It contains the Win32 source of the windowless sample from the mozilla tree,
the compiled binary (npwinless.dll) and a testcase using absolute positioning.
Notice in the testcase the plugin can be layered underneath even a transparent
DIV like you would create menus with.

Perhaps someone from Macromedia would like to look at this sample?
Comment 11 Fabricio Campos Zuardi 2002-06-25 00:37:36 PDT
Good work guys!
I've posted again in both MM Newsgroup and in FlashCoders mail list, telling
about this sample. I think that it will help Macromedia programmers. Lets wait :)

MM newsgroup
http://chattyfig.figleaf.com/cgi-bin/ezmlm-cgi?1:mss:38623:200206:kiifdihimecdmhdplock

Figleaf FlashCoders
http://webforums.macromedia.com/flash/messageview.cfm?catid=194&threadid=379250
Comment 12 Fabricio Campos Zuardi 2002-07-05 10:22:00 PDT
I have emailed Petter Hall, Branden Hall and Mike Chambers telling about this
demo and asking them to forward the info for the right people on the Flash
Player team.

I received a reply from Mike Chambers only, he have forward the links to this
bug to the appropriatte people...
Comment 13 rubydoo123 2002-07-09 17:13:40 PDT
this needs to go to Arun
Comment 14 rubydoo123 2002-07-09 17:18:34 PDT
*** Bug 95174 has been marked as a duplicate of this bug. ***
Comment 15 Skewer 2002-07-09 22:52:22 PDT
Since Mozilla already theoretically supports everything Macromedia will need to
make their Flash plugin support windowless mode with Mozilla, this is an
evangelism issue.
Comment 16 Braden 2002-07-09 23:32:57 PDT
Is it really? The Platform and OS for this bug are both set to All, but isn't
this only working under Windows?
Comment 17 Peter Lubczynski 2002-07-10 09:10:55 PDT
See bug 137189 for the RFE for winless support on Linux. 

This bug is set to ALL but implies just platforms that it's possible. Since Mac
does not use native widgets at all, it's possible to have a
winless/transparent-effect on Mac platforms.
Comment 18 Skewer 2002-07-10 15:57:54 PDT
Well, doesn't Flash only support windowless mode on Windows anyway? In that case
adding support for it to other OS's ought to be put in another bug.
Comment 19 rubydoo123 2002-07-10 16:26:05 PDT
yes it is being tracked in bug 137189
Comment 20 shrirang khanzode 2002-07-10 16:29:01 PDT
this is still not working with flash6.0r40 and 0710 brnch. wmode support is stil 
not there, i assume. have sent a mail to macromedia qa to confirm.
Comment 21 Peter Lubczynski 2002-07-12 09:16:37 PDT
*** Bug 133968 has been marked as a duplicate of this bug. ***
Comment 22 Alfonso Martinez 2002-07-17 14:29:33 PDT
*** Bug 157985 has been marked as a duplicate of this bug. ***
Comment 23 Alfonso Martinez 2002-07-27 02:46:09 PDT
*** Bug 159682 has been marked as a duplicate of this bug. ***
Comment 24 Arun Ranganathan 2002-08-02 12:25:22 PDT
Yes it is true that "wmode" (windowless mode) support is still not there in the
Flash plugin available for Netscape and Mozilla browsers (Win32/OSX in
particular).  I'm working with MM to see that this happens.  Here's peterl's
brain dump on what the plugin ought to do via ye olde 4.x Netscape Plugin API :-) :

"You can refer to the 4.x API doc, specially this section:
http://developer.netscape.com/docs/manuals/communicator/plugin/draw.htm#1005641

You can also check out a simple Win32 sample windowless plugin I attached in bug
93959.

Basically, windowless plugins on Windows are similar to regular plugins on Mac
in that the browser provides the plugin with a drawing surface (hdc/port) to
render into and passes all events (as opposed to getting them from the OS). By
setting setting some flags through the NPAPI, you can make the plugin area
opaque and by using CSS z-index, you can control what order the plugin is asked
to paint. Let me know if you have any questions." 
Comment 25 Alfonso Martinez 2002-08-11 03:20:29 PDT
*** Bug 162153 has been marked as a duplicate of this bug. ***
Comment 26 Alfonso Martinez 2002-10-16 10:02:28 PDT
*** Bug 174767 has been marked as a duplicate of this bug. ***
Comment 27 Boris Zbarsky [:bz] 2002-10-19 14:48:52 PDT
From the Flash 6 beta release notes
(http://www.macromedia.com/software/flashplayer/special/beta/release_notes/):

What's New in this Version
  Windowless Mode now implemented for Netscape Windows & Mac OS X
     Windowless mode allows you to take advantage of the transparent movie,
     absolute positioning, and layering capabilities available in the browser
   . Windowless mode is controlled with the wmode parameter in the object tag.

     The following browsers are supported:
        Windows Netscape 7.0
        Windows AOL
        Windows Mozilla 1.0
        Windows CompuServe
        Mac OS X Netscape 7.0
        Mac OS X AOL
        Mac OS X Mozilla 1.0
        Mac OS X CompuServe

Which would be all stable Windows/OSX gecko based browsers, to my knowledge...

Now all we need is Linux support.  ;)
Comment 28 /\/\arcio Galli 2002-10-19 15:30:14 PDT
Simple testcase reusing the macromedia sample: 

http://taboca.com/worlds/gek/testcases/wmode/wmode-macromedia.html

At Macromedia documentation, the link
(http://www.macromedia.com/support/flash/ts/documents/wmode.htm) that is located
from the release notes document is not updated corretly with the wmode attribute
for the EMBED element (EVANGELISM ISSUE :) The above URL is the version with the
EMBED element and wmode="transparent" attribute. Just works!!! :) Tested with W2K ;)
Comment 29 Doron Rosenberg (IBM) 2002-10-19 17:32:26 PDT
there are some focus issues in that testcase, I can't seem to press the play button.
Comment 30 Ed Millard 2002-10-23 11:38:01 PDT
Implementation of Windowless mode on Linux appears to be blocked by 137189.  I 
have the framework in place, it seems to work, but I can't complete it unless I 
have the hooks to copy the pixels from the browser window into our offscreen 
buffer at the start of our refresh cycle.  After a little thought this would 
pretty much require Mozilla to render to an offscreen XImage and ping Flash 
when the browser has rendered its image so we can pickup the buffer and do our 
render pass. 
 
Alternately the browser needs to query the plugin so we give you our XImage, 
you render in to it and return it when done so we can do our render pass and 
then either the browser or the plugin copies it to the display. 
 
Comment 31 Ed Millard 2002-10-24 15:38:01 PDT
If this is going to make it in to the Flash 6 Linux player there will beed to 
be a working API to get an off screen image of the browser window by November 
4th.  Once an API is roughed out I will supply a player that is using it for 
testing. 
Comment 32 Doron Rosenberg (IBM) 2002-11-07 10:51:20 PST
A new beta just went out, and on windows, wmode/events seem to be fixed
Comment 33 Ed Millard 2002-11-07 11:58:20 PST
I'm afraid the window is closing to get wmode in the Flash 6 Linux player.  I'm still waiting for the hooks in Mozilla to implement this in X11. 
Comment 34 bmartin 2002-11-07 20:35:04 PST
Testing latest branch and trunk with Flash 6.0 r60 public beta2 passes on WinXP Pro

http://www.gadgetscope.com/tests/trans.html displays "Trans" floating over
background image, no white box is present.
Comment 35 André Dahlqvist 2002-11-10 04:00:20 PST
*** Bug 179015 has been marked as a duplicate of this bug. ***
Comment 36 Nick Konstadoglou 2002-11-12 08:53:10 PST
I uninstalled my previous version of flash and downloaded Macromedia Flash
Player 6 for Netscape and compatibles. The wmode still doesn't work for me.
Mozilla Build ID: 2002101612. Windows98se.
Comment 37 Nick Konstadoglou 2002-11-12 09:46:13 PST
Should be reading the comments more careful. I install the latest open Beta and
wmode works fine. Forget my last comment.
Comment 38 Jacek Piskozub 2002-12-01 19:06:51 PST
*** Bug 181930 has been marked as a duplicate of this bug. ***
Comment 39 Henrik Gemal 2002-12-03 08:37:16 PST
*** Bug 183164 has been marked as a duplicate of this bug. ***
Comment 40 Henrik Gemal 2002-12-03 08:39:39 PST
a better test case is available at:
http://www.macromedia.com/support/flash/ts/documents/wmode.htm

where it can be seen that "Flash 6.0r61" which is the latest beta doesn't
support WMODE in latest nightly build 20021202 on WindowsXP
Comment 41 David Brittain 2002-12-03 08:54:20 PST
It doesn't look like a good example to me as wmode="transparent" isn't set for
the embed tag. So, it won't be windowless.
Comment 42 Doron Rosenberg (IBM) 2002-12-12 16:41:14 PST
new flash has been released with wmode for windows, testing linux right now!
Comment 43 Henrik Gemal 2002-12-13 01:11:23 PST
http://www.teledanmark.dk/html/forsider/forsiden.html is a good example.
using "Shockwave Flash 6.0 r65" I cant click any of the links since the flash
plugin seems to take over.

The flash on the site is written in:
http://www.teledanmark.dk/js/flashWrite.js
which has "wmode=transparent" on the embed tag.
Comment 44 David Brittain 2002-12-13 01:46:06 PST
Henrik - the problem you are referring to is covered by bug 182299 as you know.
This bug is about evangelising Macromedia to support windowless mode. With the
latest release of Flash they have done that. It is debatable how the problem in
bug 182299 should be fixed, but it is probably a Mozilla problem not a Flash
problem.

Doron - You don't need to test the Unix version, it won't work. Windowless mode
is not supported under Unix by Mozilla. See bug 137189.
Comment 45 Doron Rosenberg (IBM) 2002-12-13 10:16:20 PST
I mean macosx :)
Comment 46 /\/\arcio Galli 2002-12-19 12:22:04 PST
I would like to point out one behavior with Z-inde, I belive is a bug, please
input. I found this case in one of the many wmode bugs on the Tech evangelism
court. I simplified the testecase and it's online: 

http://taboca.com/worlds/gek/testcases/wmode/wmode-globo.html

What happens: 

1) Table elelement with FLash using wmode. 
2) After the table, DIV element with the GLOBE icon (GIF) and position:absolute;

Expected behavior: the globe icon appearing on top of the flash. Note that if
you embed the table+flash inside a DIV with position:absolute, then it works as
expected.
Comment 47 Jo Hermans 2002-12-29 09:58:52 PST
*** Bug 187072 has been marked as a duplicate of this bug. ***
Comment 48 Shoshannah Forbes 2003-01-06 02:01:12 PST
Another example of this problem:
http://www.yellowsubmarine.org.il/shows.asp
Really annoying.
Comment 49 bmartin 2003-02-14 13:23:57 PST
Testing with Flash 6 r65 with branch.

"Trans" is floating over background image, no white box is present:
http://www.macromedia.com/support/flash/ts/documents/wmode.htm
Comment 50 bmartin 2003-02-14 13:27:46 PST
correction to previous comment(wrong URL) ...

testing Flash 6r65 with trunk and branch on Win2k

"Trans" is floating over background image, no white box is present
http://www.gadgetscope.com/tests/trans.html
Comment 51 Chris Casciano 2003-02-15 09:13:48 PST
*** Bug 193389 has been marked as a duplicate of this bug. ***
Comment 52 R.K.Aa. 2003-02-19 01:48:04 PST
*** Bug 193999 has been marked as a duplicate of this bug. ***
Comment 53 Doron Rosenberg (IBM) 2003-02-25 16:31:15 PST
fixed. mmm, the smell of success.
Comment 54 SR 2003-04-27 11:36:33 PDT
comment #48 : on addition to have a "<param NAME=bgcolor VALUE=#5E87A6>" and a
"bgcolor=#5E87A6" in the object tag, if you fetch directly your swf file, you'll
see that there is a non transparent background in it.

Example #50 work well with :
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4b) Gecko/20030426
Shockwave Flash 6.0 r79
Comment 55 Nick Bebout 2003-06-12 20:03:36 PDT
SPAM: New Components
Comment 56 Edwin Wong 2003-06-13 12:26:58 PDT
comment #48: wmode=transparent attribute must be set for the <embed> tag in 
order for the submarine to float over the page without a background.  Currently 
the page is only has wmode set for the object tag.
Comment 57 Alfonso Martinez 2003-11-21 13:08:17 PST
*** Bug 226463 has been marked as a duplicate of this bug. ***
Comment 58 Kevin Ar18 2003-12-10 11:15:22 PST
I have a question regarding this flash issue.

Do I understand it correctly, in that flash images/movies should always appear
above other page contents (such as an asbsolute div tag) UNLESS, the
wmode="transparent" attribute is added?
Comment 59 Doron Rosenberg (IBM) 2003-12-11 06:27:16 PST
correct, flash movies without the wmode="transparent" will be above everything,
IE have the highest z-index.
Comment 60 Nick Dixon 2004-07-05 08:32:23 PDT
What should the behaviour be when the plugin is not installed?

If I visit some of these test pages with Konqueror 3.1 (no Flash plugin) on Red
Hat 9, ie:

http://www.gadgetscope.com/tests/trans.html
http://taboca.com/worlds/gek/testcases/wmode/wmode-globo.html

...the blank area occupied by the embedded object *is* transparent.

Viewing these same sites using Firefox (also without the Flash plugin) shows a
blank rectangle containing the plugin icon, obscuring the background.

Note You need to log in before you can comment on or make changes to this bug.